Article View: pl.comp.mail.mta
Article #242Re: Przepisywanie naglowkow
From: Tomasz R. Surmacz
Date: Fri, 13 Feb 1998 16:44
Date: Fri, 13 Feb 1998 16:44
67 lines
3734 bytes
3734 bytes
Artur Skawina <linux@base.org> wrote: : Tomasz Surmacz wrote: : > >> AS> Uzywanie aliasow w smtp jest nielegalne; niektore (wiekszosc) MTA : > >> : > >> Wiesz że dzwonią, ale nie wiesz w którym kościele :-) : > : > AS> RTFRFC : > : > Oświeć mnie, dyletanta, dlaczegóż to pisanie na adres tsurmacz@news.ict.- : > pwr.wroc.pl (CNAME okapi.ict.pwr.wroc.pl), które jakby nie było, *jest* : > używaniem aliasów w smtp, ma być nielegalne? : "Pisanie" na adres <tsurmacz@ news.ict.pwr.wroc.pl> i dostarczenie emaila : do <tsurmacz@ okapi.ict.pwr.wroc.pl> to sa dwie rozne rzeczy. Jesli uzyty Owszem. : jest SMTP to <tsurmacz@ news.ict.pwr.wroc.pl> nie moze [1] wystapic jako : argument MAIL FROM lub RCPT TO. Może. Tyle, że pierwszy MTA, jaki taki list przetwarza, poprzerabia wszystkie CNAME na 'the only one true name', czyli w tym przypadku ts@news.ict... na ts@okapi.ict... : Jesli to rzeczywiscie sendmail przepisywal te naglowki (a nie jakis : FE/MUA), to wymiana MTA na taki, ktory nie modyfikuje _tresci_ emaila : (a tylko ew. 'poprawia' koperte) moze pomoc w przyszlosci [2]. każdy MTA to robi, bo tak właśnie to musi działać. Jakby tak nie było, to poczta mogłaby sobie krążyć do upadłego, a p rzy najmniejszych problemach z DNS (który na skutek keszowania wcale nie musi wszędzie dawać identycznych danych) hosty docelowe nie rozpoznawałyby swoich własnych (CNAME-owanych) nazw. : [1] przynajmniej nie powinien :) nic nie stoi na przeszkodzie. : [2] _formalnie_ [3] uzywanie aliasow w naglowkach tez jest : nielegalne, ale w tym przypadku nie ma to zadnego znaczenia Niby dlaczego? Poproszę dokładny numerek RFC i numer linii lub rozdziału. : (naglowki nie sa uzywane podczas dostarczania poczty, a maja : znaczenie tylko dla MUAs); zreszta <tsurmacz@okapi.ict.pwr.wroc.pl> : tez jest nielegalnym adresem w/g [3] :) Coś ci się z okazji 13. w piątek poprzestawiało czy co? Że niby jak? To jaki powinien być poprawny? tsurmacz@[156.17.42.30]? : [3] RFC0821 Simple Mail Transfer Protocol. J. Postel. Aug-01-1982. : (Also STD0010) (Status: STANDARD) RFC 821 nic nie mówi na temat tego co jest, a co nie jest poprawnym adresem w RCPT TO: ani w MAIL FROM:, a już w szczególności *dokładnie nic* w nim nie ma na temat CNAME... Nie mówi też nic o nagłówkach -- tego dotyczy RFC822. Szczerze ubawiony, Tomek -- _________ (_ _' __) Tomasz R. Surmacz *--* Work:(071)320-2752 tsurmacz@ict.pwr,wroc.pl | (__ \ http://www.ict.pwr.wroc.pl/~tsurmacz/ *---* Home: ts @wroc,apk,net |__(____/ For PGP key finger tsurmacz@asic.ict,pwr,wroc.pl *---* irc: TomekS
Technical Details
Message-ID:
<6c1t9d$fva$2@okapi.ict.pwr.wroc.pl>Path:
mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!ict.pwr.wroc.pl!tsurmaczReferences:
<19980210194344.59432@pooh.cs.net.pl> <34E124E4.45AD5779@usa.net> <6bsmrc$14e$1@papaja.wroc.apk.net> <34E220CE.5E01DD92@usa.net> <6c0283$124$1@papaja.wroc.apk.net> <34E3B46F.20D18D1E@usa.net>Show Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!ict.pwr.wroc.pl!tsurmacz From: Tomasz R. Surmacz <tsurmacz@spamfilter.ict.pwr.wroc.pl> Newsgroups: pl.comp.mail.mta Subject: Re: Przepisywanie naglowkow Date: 13 Feb 1998 16:44:29 GMT Organization: Technical University of Wroclaw, Poland Lines: 67 Message-ID: <6c1t9d$fva$2@okapi.ict.pwr.wroc.pl> References: <19980210194344.59432@pooh.cs.net.pl> <34E124E4.45AD5779@usa.net> <6bsmrc$14e$1@papaja.wroc.apk.net> <34E220CE.5E01DD92@usa.net> <6c0283$124$1@papaja.wroc.apk.net> <34E3B46F.20D18D1E@usa.net> Reply-To: tsx-9801@okapi.ict.pwr.wroc.pl NNTP-Posting-Host: okapi.ict.pwr.wroc.pl Mime-Version: 1.0 X-Info0: The lifetime of this reply-to address is about a month or so, so if X-Info1: you just reply and it bounces -- use the address from signature. X-Archive: no X-No: yes X-Confused: maybe X-Newsreader: TIN [UNIX 1.3 unoff BETA 970304; sun4m SunOS 5.4] Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit