Article View: pl.listserv.polip
Article #11284Znak underscore w DNS
From: Marek Baczek
Date: Sat, 31 May 1997 11:36
Date: Sat, 31 May 1997 11:36
20 lines
1409 bytes
1409 bytes
Zgodnie z RFC1035 oraz RFC1912 w nazwach domenowych nie powinno się używać znaku podkreślenia "_" (underscore). Zaczynam podejrzewać, że coś się zmieniło w tym temacie gdyż coraz częściej napotykam się na takie nazwy (np. BXSOFT_OL.BTI.PL, w domenie *.com też można coś znaleźć ). Używanie znaku "_" w nazwie hosta uniemożliwia mi wysyłanie listów na takie adresy. Co gorsza, Linuxowy DNS chyba dopuszcza stosowanie underscore w nazwach domenowych (BXSOFT_OL.BTI.PL chodzi na Linuxie), Bind dla AIX 4.1.4 i HP-UX 9.04 też (chyba, mam takie info) dopuszcza underscore. Wprawdzie RFC1033 (z 1987 roku!) dopuszcza stosowanie underscore w nazwach hostów pocztowych, ale nie stanowi on standardu (RFC1035 i 1912 są ważniejsze, tak myślę). Any idea? -- Marek Baczek mailto:mgb@qdnet.pl http://www.qdnet.pl/~mgb/
Technical Details
Message-ID:
<5mp2iu$q8t$1@sunsite.icm.edu.pl>Path:
mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!not-for-mailShow Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!not-for-mail From: "Marek Baczek" <mgb@qdnet.pl> Newsgroups: pl.listserv.polip Subject: Znak underscore w DNS Date: Sat, 31 May 1997 13:36:13 +0200 Organization: QDnet ISP Lines: 21 Message-ID: <5mp2iu$q8t$1@sunsite.icm.edu.pl> NNTP-Posting-Host: kasjopeja.qdnet.pl Mime-Version: 1.0 X-Newsreader: Microsoft Outlook Express 4.71.0544.0 X-MimeOLE: Produced By Microsoft MimeOLE Engine V4.71.0544.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit