🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.listserv.polip
Article #11285

Re: Znak underscore w DNS

#11285
From: Rafal Maszkowski
Date: Sun, 01 Jun 1997 23:02
24 lines
1877 bytes
Marek Baczek <mgb@qdnet.pl> wrote:
> Zgodnie z RFC1035 oraz RFC1912 w nazwach domenowych nie
> powinno się używać znaku podkreślenia "_" (underscore).
> Zaczynam podejrzewać, że coś się zmieniło w tym temacie
> gdyż coraz częściej napotykam się na takie nazwy (np.
> BXSOFT_OL.BTI.PL, w domenie *.com też można coś znaleźć ).
> Używanie znaku "_" w nazwie hosta uniemożliwia mi wysyłanie
> listów na takie adresy. Co gorsza, Linuxowy DNS chyba
> dopuszcza stosowanie underscore w nazwach domenowych
> (BXSOFT_OL.BTI.PL chodzi na Linuxie), Bind dla AIX 4.1.4 i
> HP-UX 9.04 też (chyba, mam takie info) dopuszcza
> underscore.
> Wprawdzie RFC1033 (z 1987 roku!) dopuszcza stosowanie
> underscore w nazwach hostów pocztowych, ale nie stanowi on
> standardu (RFC1035 i 1912 są ważniejsze, tak myślę).

IMHO prawidłowa implementacja powinna krzyczeć głośno jeżeli dostrzeże
nielegalne znaki we własnym DNSie, ale przyjmować z pokorą takie znaki u
różnych dziwnych obcych. Napisz do hostmasterow stosujacych bledne znaki.

R.
-- 
Rafal Maszkowski rzm@torun.pdi.net           http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID: <5msv31$s34$2@rymunda.torun.pdi.net>
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!uw.edu.pl!mat.uni.torun.pl!torun.pdi.net!rymunda.torun.pdi.net!rzm
References: <5mp2iu$q8t$1@sunsite.icm.edu.pl>

Show Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!uw.edu.pl!mat.uni.torun.pl!torun.pdi.net!rymunda.torun.pdi.net!rzm
From: Rafal Maszkowski <rzm@rymunda.torun.pdi.net>
Newsgroups: pl.listserv.polip
Subject: Re: Znak underscore w DNS
Date: 1 Jun 1997 23:02:57 GMT
Organization: Publiczny Dostep do Internetu
Lines: 24
Message-ID: <5msv31$s34$2@rymunda.torun.pdi.net>
References: <5mp2iu$q8t$1@sunsite.icm.edu.pl>
NNTP-Posting-Host: rymunda.torun.pdi.net
Mime-Version: 1.0
X-Newsreader: TIN [UNIX 1.3 unoff BETA 970424; i586 Linux 2.0.29]
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit