Article View: pl.comp.mail
Article #69403Re: Minimalne kodowanie w mailu - które RFC?
From: Andrzej P. Wozniak
Date: Sun, 21 Mar 2021 17:37
Date: Sun, 21 Mar 2021 17:37
56 lines
4015 bytes
4015 bytes
Osoba podpisana jako Rafal Jankowski <jankowsr@oceanic.wsisiz.edu.pl>
w artykule <news:684067f8-86cf-2834-ba74-ac1ed9cab3ff@wsisiz.edu.pl>
pisze:
> On Sat, 20 Mar 2021, Andrzej P. Wozniak wrote:
>
>> RFC 2046 pochodzi z czasów, kiedy UTF-8 nie był kodowaniem zalecanym.
>> W XXI wieku wszystkie standardy zostały dostosowane do UTF-8 i obecnie
>> zalecenia są takie:
>> Deklarowany i kodowany 8-bitowo UTF-8 albo nic (czyli niedeklarowany
>> 7-bitowy US-ASCII).
>> Pozostałe zestawy znaków, w tym cała seria iso-8859-x, poszły w
>> odstawkę.
>
> Ale skoro zmieniło się zalecenie i przestało to być obowiązujące to w
> nagłówku tego RFC nie powinna się znaleźć informacja: "obsoleted by..."
Jest przecież rfc-index, a w nim masz wszystko opisane (według bieżących
danych):
2045 Multipurpose Internet Mail Extensions (MIME) Part One: Format of
Internet Message Bodies. N. Freed, N. Borenstein. November 1996.
(Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Updated
by RFC2184, RFC2231, RFC5335, RFC6532) (Status: DRAFT STANDARD)
(DOI: 10.17487/RFC2045)
2046 Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types.
N. Freed, N. Borenstein. November 1996. (Format: TXT, HTML)
(Obsoletes RFC1521, RFC1522, RFC1590) (Updated by RFC2646, RFC3798,
RFC5147, RFC6657, RFC8098) (Status: DRAFT STANDARD) (DOI:
10.17487/RFC2046)
2047 MIME (Multipurpose Internet Mail Extensions) Part Three: Message
Header Extensions for Non-ASCII Text. K. Moore. November 1996.
(Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Updated
by RFC2184, RFC2231) (Status: DRAFT STANDARD) (DOI:
10.17487/RFC2047)
2048 Multipurpose Internet Mail Extensions (MIME) Part Four: Registration
Procedures. N. Freed, J. Klensin, J. Postel. November 1996. (Format:
TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Obsoleted by
RFC4288, RFC4289) (Updated by RFC3023) (Status: BEST CURRENT
PRACTICE) (DOI: 10.17487/RFC2048)
2049 Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance
Criteria and Examples. N. Freed, N. Borenstein. November 1996.
(Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Status:
DRAFT STANDARD) (DOI: 10.17487/RFC2049)
Jest też plik RFCs_for_errata.txt, gdzie jest lista dokumentów z
poprawkami. Są w nim RFC2045, 2046, 2047 i 2049. Poprawki z wyjaśnieniem
są w podkatalogu inline-errata.
--
Andrzej P. Woźniak uszer@pochta.onet.pl (zamień miejscami z⇔h w adresie)
Technical Details
Message-ID:
<605785e5$0$501$65785112@news.neostrada.pl>Path:
mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!news.icm.edu.pl!newsfeed.pionier.net.pl!3.eu.feeder.erje.net!feeder.erje.net!newsreader4.netcologne.de!news.netcologne.de!peer03.ams1!peer.ams1.xlned.com!news.xlned.com!peer01.ams4!peer.am4.highwinds-media.com!news.highwinds-media.com!newsfeed.neostrada.pl!unt-exc-02.news.neostrada.pl!unt-spo-b-01.news.neostrada.pl!news.neostrada.pl.POSTED!not-for-mailReferences:
<174f8ca1-2ca2-3438-742a-57cc16adda3d@wsisiz.edu.pl> <9a59debd-2900-db6d-bce5-ef4183d7edb9@komp.wujka.marcina> <60554013$0$549$65785112@news.neostrada.pl> <684067f8-86cf-2834-ba74-ac1ed9cab3ff@wsisiz.edu.pl>Show Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!news.icm.edu.pl!newsfeed.pionier.net.pl!3.eu.feeder.erje.net!feeder.erje.net!newsreader4.netcologne.de!news.netcologne.de!peer03.ams1!peer.ams1.xlned.com!news.xlned.com!peer01.ams4!peer.am4.highwinds-media.com!news.highwinds-media.com!newsfeed.neostrada.pl!unt-exc-02.news.neostrada.pl!unt-spo-b-01.news.neostrada.pl!news.neostrada.pl.POSTED!not-for-mail From: "Andrzej P. Wozniak" <uszer@poczta.onet.pl.invalid> Newsgroups: pl.comp.mail References: <174f8ca1-2ca2-3438-742a-57cc16adda3d@wsisiz.edu.pl> <9a59debd-2900-db6d-bce5-ef4183d7edb9@komp.wujka.marcina> <60554013$0$549$65785112@news.neostrada.pl> <684067f8-86cf-2834-ba74-ac1ed9cab3ff@wsisiz.edu.pl> Subject: Re: Minimalne kodowanie w mailu - które RFC? Date: Sun, 21 Mar 2021 18:37:08 +0100 Organization: <news.tpi.pl> MIME-Version: 1.0 X-Priority: 3 X-MSMail-Priority: Normal X-Newsreader: Microsoft Outlook Express 6.00.2900.5931 User-Agent: OE PowerTool 4.5.4 X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.7681 X-Operating-System: Windows XP Home PL / POSReady 2009 Lines: 57 Message-ID: <605785e5$0$501$65785112@news.neostrada.pl> NNTP-Posting-Host: 84.10.60.130 X-Trace: 1616348646 unt-rea-b-01.news.neostrada.pl 501 84.10.60.130:1673 X-Complaints-To: abuse@news.neostrada.pl X-Received-Bytes: 3888 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit