🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.comp.mail
Article #69402

Re: Minimalne kodowanie w mailu - które RFC?

#69402
From: Rafal Jankowski
Date: Sun, 21 Mar 2021 19:16
45 lines
3202 bytes
On Sun, 21 Mar 2021, Andrzej P. Wozniak wrote:

>>  Ale skoro zmieniło się zalecenie i przestało to być obowiązujące to w
>>  nagłówku tego RFC nie powinna się znaleźć informacja: "obsoleted by..."
>
> Jest przecież rfc-index, a w nim masz wszystko opisane (według bieżących 
> danych):
>
> 2045 Multipurpose Internet Mail Extensions (MIME) Part One: Format of
>     Internet Message Bodies. N. Freed, N. Borenstein. November 1996.
>     (Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Updated
>     by RFC2184, RFC2231, RFC5335, RFC6532) (Status: DRAFT STANDARD)
>     (DOI: 10.17487/RFC2045)
>
> 2046 Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types.
>     N. Freed, N. Borenstein. November 1996. (Format: TXT, HTML)
>     (Obsoletes RFC1521, RFC1522, RFC1590) (Updated by RFC2646, RFC3798,
>     RFC5147, RFC6657, RFC8098) (Status: DRAFT STANDARD) (DOI:
>     10.17487/RFC2046)
>
> 2047 MIME (Multipurpose Internet Mail Extensions) Part Three: Message
>     Header Extensions for Non-ASCII Text. K. Moore. November 1996.
>     (Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Updated
>     by RFC2184, RFC2231) (Status: DRAFT STANDARD) (DOI:
>     10.17487/RFC2047)
>
> 2048 Multipurpose Internet Mail Extensions (MIME) Part Four: Registration
>     Procedures. N. Freed, J. Klensin, J. Postel. November 1996. (Format:
>     TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Obsoleted by
>     RFC4288, RFC4289) (Updated by RFC3023) (Status: BEST CURRENT
>     PRACTICE) (DOI: 10.17487/RFC2048)
>
> 2049 Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance
>     Criteria and Examples. N. Freed, N. Borenstein. November 1996.
>     (Format: TXT, HTML) (Obsoletes RFC1521, RFC1522, RFC1590) (Status:
>     DRAFT STANDARD) (DOI: 10.17487/RFC2049)
>
>
> Jest też plik RFCs_for_errata.txt, gdzie jest lista dokumentów z poprawkami. 
> Są w nim RFC2045, 2046, 2047 i 2049. Poprawki z wyjaśnieniem są w podkatalogu 
> inline-errata.

No dobrze, ale ja w dalszym ciągu nie rozumiem, który z ww dokumentów i w 
którym miejscu unieważnia RFC 2046 w całości lub choćby w części p. 4.1.2.
Technical Details
Message-ID: <4be2b023-2118-399-825-d3e6bf6c8a1e@wsisiz.edu.pl>
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!news.icm.edu.pl!wsisiz.edu.pl!.POSTED.oceanic.wsisiz.edu.pl!oceanic.wsisiz.edu.pl!jankowsr
References: <174f8ca1-2ca2-3438-742a-57cc16adda3d@wsisiz.edu.pl> <9a59debd-2900-db6d-bce5-ef4183d7edb9@komp.wujka.marcina> <60554013$0$549$65785112@news.neostrada.pl> <684067f8-86cf-2834-ba74-ac1ed9cab3ff@wsisiz.edu.pl> <605785e5$0$501$65785112@news.neostrada.pl>

Show Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!news.icm.edu.pl!wsisiz.edu.pl!.POSTED.oceanic.wsisiz.edu.pl!oceanic.wsisiz.edu.pl!jankowsr
From: Rafal Jankowski <jankowsr@oceanic.wsisiz.edu.pl>
Newsgroups: pl.comp.mail
Subject: Re: Minimalne kodowanie w mailu - które RFC?
Date: Sun, 21 Mar 2021 20:16:14 +0100
Organization: Mafia Pruszkowska
Message-ID: <4be2b023-2118-399-825-d3e6bf6c8a1e@wsisiz.edu.pl>
References: <174f8ca1-2ca2-3438-742a-57cc16adda3d@wsisiz.edu.pl> <9a59debd-2900-db6d-bce5-ef4183d7edb9@komp.wujka.marcina> <60554013$0$549$65785112@news.neostrada.pl> <684067f8-86cf-2834-ba74-ac1ed9cab3ff@wsisiz.edu.pl> <605785e5$0$501$65785112@news.neostrada.pl>
Mime-Version: 1.0
Injection-Info: portraits.wsisiz.edu.pl; posting-host="oceanic.wsisiz.edu.pl:2001:1a68:a::33"; logging-data="4117519"; mail-complaints-to="abuse@wsisiz.edu.pl"
In-Reply-To: <605785e5$0$501$65785112@news.neostrada.pl>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit