Article View: pl.answers
Article #169pl.comp.www FAQ
From: Ziemek Borowski
Date: Fri, 25 Apr 1997 00:00
Date: Fri, 25 Apr 1997 00:00
5572 lines
119116 bytes
119116 bytes
Posted-By: auto-faq 3.1.1.2
Archive-name: pl.comp.www
pl.comp.www FAQ $Id: faq.sgml,v 0.5 1997/04/09 18:00:13
ziembor Exp ziembor $
Ziemek Borowski
,,WWW w Polsce i po polsku'' - ,,przegl�d pyta� pospolitych'', lub
takich
kt�re powinny pa�� a nie pad�y ;-) w grupie pl.comp.www z uwgl�dnie
niem
zagadnie� publikacji elektronicznych wykraczaj�cych poza paj�czyn�.
______________________________________________________________________
Table of Contents:
1. Zasady, deklaracje
1.1. Dost�pno��
1.2. O tym dokumencie
1.3. Czy ta grupa ma swoje archiwum?
1.4. Czy mog� zaprenumerowa� t� grup� tak jak normaln� list�
dyskusyjn�?
1.5. W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?
1.5.1. Zanim zadasz pytanie:
1.5.2. Gdy nie masz innego wyj�cia...
1.6. Co wywo�uje powszechny (i uzasadniony) gniew i irytacj�?
2. Definicje
2.1. Internet
2.2. Intranet
2.3. Infostrada
2.4. WWW
2.5. HTML
2.6. SGML
2.7. HTTP
2.8. Netscape-HTML i MS-HTML
2.9. URI, URL, URN
2.10. CGI
2.11. VRML
2.12. Java
2.13. JavaScript
2.14. ActiveX
2.15. SSI
2.16. SSL, S-HTTP, Shen (z CERN)
2.17. ONE i plug-in
2.18. PERL, awk, C
2.19. HyperG, HyperWave
2.20. HyTime
2.21. DSSSL, CSS
2.22. XML
2.23. Broadway
2.24. LDAP
2.25. Unicode
3. Standardy i informacje dla Internetu
3.1. Dokumenty og�lne - procedury, definicje, zasady zachowania si�
w sieci.
3.2. HTML
3.3. URL, URI
3.4. HTTP
3.5. MIME
3.6. Gopher
3.7. VRML
3.8. Java
3.9. CGI
3.10. UsenetNews i E-Mail
3.11. Grafika
3.12. Wieloj�zyczno�� Sieci
4. Nawigacja
4.1. Paj�czarki
4.1.1. DOS
4.1.2. MS-Windows i OS/2
4.1.3. Unix
4.1.4. Apple
4.1.5. Inne
4.2. Poszukiwanie informacji
4.2.1. Katalogi tematyczne
4.2.2. Przeszukiwarki
4.2.3. Przypominacze, serwisy informacyjne
4.3. Wieloj�zyczno�� sieci - dlaczego widz� krzaczki?
4.4. Przy�pieszanie pracy (W3cache)
4.5. Praca off-line
4.5.1. Eksploracja cache dyskowego
4.5.2. Roboty gromadz�ce drzewo dokument�w
4.5.3. Wsp�lny W3cache
4.6. Niebezpiecze�stwa - wirusy i inne
5. Tworzenie og�lnie
5.1. Warunki publikowania
5.2. Prawa autorskie
5.3. Terminologia
5.4. Wieloj�czyna paj�czyna - polskie znaki diakrytyczne
5.5. Jakie formaty plik�w?
5.6. Dostawca us�ug internetowych
6. Tworzenie - HTML
6.1. Zasady sk�adni HTML
6.2. Najkr�tszy dokument
6.3. Podstawowe znaczniki
6.4. Przydatne wskaz�wki
6.5. Wsp�praca z przeszukiwarkami
6.6. Dlaczego standardy s� istotne?
6.7. Jak kontrolowa� poprawno�� kodu?
6.8. Ramki? Nie stosowa�!!!
6.9. Pytania r�ne
6.9.1. Czy mog� ukry� kod �r�d�owy dokumentu?
6.10. Narz�dzia
6.10.1. MS-Windows
6.10.2. Unix
7. Tworzenie - grafika
7.1. Istniej�ce formaty graficzne
7.2. Zasady umieszczania grafiki
7.3. Efekty specjalne
7.3.1. ,,Prze�roczyste grafiki''
7.3.2. Animacje
7.4. Pytania r�ne
8. Tworzenie - Java, JavaScript, CGI, SSI
8.1. Po co stosowa� programy w przekazie informacji
8.2. Statyczne - dynamiczne
8.3. Bazy danych
8.4. Przeszukiwanie
8.4.1. instalowa� search-engine
8.4.2. zmusi� publicznie dost�pne roboty do indeksowania naszych
zasob�w
8.5. Lataj�ce spodki
8.6. W jaki spos�b mog� zainstalowa� licznik na stronie?
9. Serwery
9.1. Jakie serwery WWW (HTTP) s� dost�pne?
9.2. Platforma sprz�towa
9.3. Obs�uga b��d�w
9.4. Implementacja SSL (by KravietZ)
9.4.1. Q: Jak nawi�zuje si� po��czenie SSL?
9.4.2. Q: Kt�re przegl�darki obs�uguj� SSL?
9.4.3. Q: Jak postawi� bezpieczny serwer WWW?
9.4.4. Q: Czy wszystkie przegl�darki akceptuj� wszystkie certyfikaty?
9.5. Strony na has�o
9.6. Wirtualny serwer
9.7. Robot exlusion
10. Bezpiecze�stwo WWW
10.1. Java
10.2. CGI
10.3. Serwery
11. Dzi�kuj�:
______________________________________________________________________
1. Zasady, deklaracje
1.1. Dost�pno��
Dokument ten jest osi�galny za pomoc� nast�puj�cych URLi:
� <http://www.digilab.com.pl/pl.comp.www/>
w wersji ,,do przegl�dania''
(mirror:
<http://www.QDnet.pl/~ZiemBor/pl.comp.www/>
)
� <http://www.digilab.com.pl/pl.comp.www/faq.html>
wersja ,,jednostronnicowa'' (wszystko w jednym dokumencie - cho� na
razie
bez spisu tre�ci)
� <http://www.digilab.com.pl/pl.comp.www/www.txt>
wersja tekstowa (bez polskich liter):
� <ftp://ftp.digilab.com.pl/pub/www.tgz>
wersja skompresowana
(do dekompresji wymaga w DOSie programu UNTGZ (GNU)):
� pe�na skompresowana wersja (ZIP)
<ftp://ftp.digilab.com.pl/pub/tar.gz/untgz094.zip>
(148kb)
� dla uog�lninego DOSa
<ftp://ftp.digilab.com.pl/pub/tar.gz/untgz_.exe>
(67kb)
� dla Windows z d�ugimi nazwami plik�w
<ftp://ftp.digilab.com.pl/pub/tar.gz/untgz32_.exe>
(76kb)
� dla IBM OS/2 <ftp://ftp.digilab.com.pl/pub/tar.gz/untgzos2_.exe>
� dokumentacja do untgz
<ftp://ftp.digilab.com.pl/pub/tar.gz/untgz.doc>
1.2. O tym dokumencie
� Je�li nie znalaz�e� tu odpowiedzi na swoje pytanie
przepraszam... I
mam pro�b�: jak znajdziesz, prze�lij uzupe�nienie do odpowiedzi na
istniej�ce pytanie, b�d�
napisz <maito:...@digilab.com.pl>
(wraz z odpowiedzi�) nowe.
� Dokument ten
b�dzie wysy�any do grup
pl.comp.www
oraz
pl.anwsers
raz na dwa tygodnie,
pierwszego i pi�tnastego dnia ka�dego miesi�ca.
� B�d� dok�ada� stara�, aby dokument ten by� w miar� systematycznie
uzupe�niany i w miar� pojawiania
si� nowych pyta� publikowane by�y jego kolejne wydania.
� Autorzy nie ponosz� �adnej odpowiedzialno�ci za efekty dzia�ania
spowodowane stosowaniem si� do zalece� zawartych w dokumencie.
� Wszystkie zastrze�one znaki firmowe zosta�y u�yte jedynie w celach
informacyjnych.
� Dokument nie ma �adnej mocy prawnej b�d� administracyjnej i
powo�ywanie si� na udzielone w nim odpowiedzi oraz porady jest
bezpodstawne.
� Dokument mo�e by� dowolnie u�ywany i rozpowszechniany, jednak w
wypadku publikacji prosz� o poinformowanie o tym fakcie, a w
wypadku
zamieszczenia w Internecie, t�umacze� itp. prosz� ponadto o
zobowi�zanie
si� do systematycznego uaktualniania.
� Dokonywanie zmian bez zgody i wiedzy autora dokumentu jest
niewskazane, cho� dopuszczalne, przy zachowaniu praw autoskich i
zaznaczeniu jakie fragmenty uleg�y zmianie.
� Wi�kszo�� tekst�w jest autorstwa Ziemka Borowskiego, cho� bardzo
cz�sto oparte s� na lekturze, np. artyku��w w grupie
pl.comp.www
Je�li autorem danego fragmentu jest kto� inny, jest to zaznaczone
przez podanie inicja��w autora tego fragmentu (*), lub uzupe�nienia
(+*) poni�ej tre�ci.
Tym nie mniej Ziemek Borowski bierze na siebie odpowiedzialno��
za ca�o�� tekstu.
� Zawarto��
pl.comp.www FAQ
opiera si� g��wnie na
listach z grupy
usenetowej
pl.comp.www <news:pl.comp.www>
oraz ew.
pl.comp.java
pl.listserv.polip
pl.comp.ogonki
,
je�li tylko maj� zwi�zek z tematem.
1.3. Czy ta grupa ma swoje archiwum?
Nie... (ewentualnie mo�esz szuka� w DejaNews
<http://www.DejaNews.com/>
;-) Ale trzeba uwa�a�:
jest tam ustawiony nag��wek
Pragma: NoCache
i blokada dla robot�w
(wi�c
nie mo�na �ci�gn�� ca�ego archiwum ,,do domu'').
1.4. Czy mog� zaprenumerowa� t� grup� tak jak normaln� list�
dyskusyjn�?
Nie i bardzo dobrze... ;-) (sprz�enie z list� to tylko niepotrzebne
k�opoty z polskimi literkami oraz g�upie pytania:
jak si� wypisa�?
;-)
1.5. W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?
Daleki jestem od ods�dzania od czci wszystkich, kt�rzy zadaj� pytania
nie konkretne, b�d� takie na kt�re odpowied� znajduje si� na drugiej
stronie manuala, podr�cznika b�d� FAQ. Ale prosz�...
1.5.1. Zanim zadasz pytanie:
� zastan�w si�, czy to co ci� trapi jest rzeczywi�cie problemem. By�
mo�e spotka�e� si� ju� z podobn� sytuacj� i tylko co� Ci na chwil�
rozum za�mi�o :-)
� przejrzyj dost�pn� lokalnie dokumentacj�... (pliki
*.htm
,
*.html
*.hlp
,
i
man *
od posiadanych program�w, zawarto�� katalog�w w
/usr/doc
na Unixach).
Po to si� j� tworzy.
� poszukaj FAQ (czyli zbioru najcz�ciej zadawanych pyta� wraz z
odpowiedziami) zwi�zanego z nurtuj�cymi ci� problemami... w Polsce
znajdziesz je pod adresem
<http://sunsite.icm.edu.pl/pub/usenet/>
� Sprawd� archiwa:
<http://web1.dejanews.com/forms/dnsetfilter.html>
i tam wpisuj�c w filtrze grup�:
pl.comp.www
� spytaj lokalnego administratora... chyba, �e ma Ci� ju� do��, b�d�
sam
nim jeste�
<SMIESZEK TYP="�yczliwie ironiczny"> ;-))))
</SMIESZEK>
� poszukaj przy pomocy katalogu
``tematycznego''
b�d�
``wyszukiwarki''
1.5.2. Gdy nie masz innego wyj�cia...
to pytaj... Ale pami�taj, �e zadawanie pyta�
te� jest sztuk�. Tutaj, w grupie
<news:pl.comp.www>
ograniczymy si� do wskaz�wek raczej technicznych.
� napisz dok�adnie: jaki masz problem... (np.
jakiego systemu operacyjnego u�ywasz
i z
jakim programem (i jak� jego wersj�) masz k�opoty
).
I nie my�l, �e istniej� jedynie M$ Windbloze (Lufciki ;-).
� je�li szukasz jakiego� narz�dzia, napis jakie wymagania ma
spe�nia�
i co najwa�niejsze w jakim systemie operacyjnym ma dzia�a�...
� nie zaszkodzi poda� gdzie szuka�e�, najwy�ej
inni si� czego� naucz�.
� pomy�l, czy tematyka Twojego pytania jest dostosowana do tematyki
grupy (np. nie pisz o jakim� zasobie nie zwi�zanym z TECHNOLOGI�
World Wide Web tylko dlatego, �e znajduje si� on w Paj�czynie
- od tego typu og�osze� s� inne grupy np.
pl.internet.nowosci
(moderowana),
inna grupa bli�ej zwi�zana z tematyk� witryny, zasobu).
I pami�taj: to, �e kto� Ci odpowie to tylko i wy��cznie jego dobra
wola.
I nie obra�aj si�, jesli kto� Ci odpisze np.
RTFM <http://zeus.pols.gliwice.pl:9999/FAQ/polip.html>
podaj�c jakiego�
``URLa''
, b�d� tyty� ;-).
1.6. Co wywo�uje powszechny (i uzasadniony) gniew i irytacj�?
Wiele rzeczy.... Na przyk�ad:
� wysy�anie
spamu <http://www.vixie.com/spam/>
� wysy�anie plik�w binarnych (zw�aszcza wielkich i to takich kt�re
mo�naby
umie�ci� gdzie� w paj�czynie, b�d� anonFTP i poda� URL)
� pytanie po raz n-ty jak zrobi� co� co jest opisane w ka�dym
`` kursie HTMLa ''
� pisanie, �e obowi�zuj�cym standardem kodowania polskich liter
powinno
by� ANSI CP-1250 (bo ,,tak jest pro�ciej'', i ,,dla ludzi'').
� skar�enie si� na jako�� darmowych us�ug i pytania ich dotycz�ce.
� ci�gle pro�by
oce�cie moj� stron�
b�d�ce zakamuflowan�
reklam�
I m.in. dlatego pisz� to FAQ, aby unikn�� powtarzania zawsze
tych samych, nie posuwaj�ch do przodu dyskusji, pyta�.
2. Definicje
Co to jest: * ?
2.1. Internet
RFC 1462
Internet zosta� zdefiniowany jako:
� sie� sieci komputerowych oparta na protoko�ach IP i TCP, UDP oraz
ICMP
(TCP/IP)
� zasoby dost�pne na komputerach po��czonych z sieci� (tzw. hostach)
� spo�eczno��, wsp�lnota (community) ludzi u�ywaj�cych i
rozwijaj�cych
t� sie�
Nie jest to wi�c, jakby ludzie Microfotu chcieli ,,taka ikonka
na pulpicie'' ani te� �adna z dominuj�cych w danej chwili us�ug
sieciowych.
Dla niekt�rych jest to potworna wizja porozumiewania si� ludzi za
po�rednictwem maszyn. Dla innych jest to przedsionek
``infostrady''
, czy og�lniej m�wi�c spo�ecze�stwa informacyjnego.
Patrz te�:
� Internet Society <http://www.isoc.org/>
� Polska Spo�eczno�� Internetu <http://www.psi.org.pl/>
� InterNIC <http://www.internic.net/>
� Elementarz Internetu <http://www.cto.us.edu.pl/eleminte/ei.html>
Macieja Uhliga
� Podstawowe us�ugi Internetu
<http://www.ict.pwr.wroc.pl/doc/iwpl/>
Tomasza Surmacza
� R�ne po�yteczne dokumenty w/g AGH
<http://www.agh.edu.pl/opisy.html>
� Wirtualna Akademia - Katedra Teleinformatyki
<http://www.gumbeers.elka.pg.gda.pl/WA/KTI/>
� Narz�dzia sieciowe
<http://www.immt.pwr.wroc.pl/export_hp/tool/tool.html>
Wojciecha Myszki (jeden z lepszych TECHNICZNYCH
przewodnik�w po sieci).
� EFFu Przewodnik po Internecie
<http://www.eff.org/pub/Net_info/EFF_Net_Guide/Other_versions/Polish/>
2.2. Intranet
Jest pr�b� zastosowania technologii internetowych z poziomu
prezentacji i
aplikacji (czyli przede wszystkim HTTP/HTML, poczty elektronicznej i
Usenet
news)
do sieci lokalnych i firmowych. (Ma to zwi�zek koncepcj�
odchudzenia stacji roboczych do wszechstronnie zorientowanego
(przegl�darka, edytor, poczta) acz odchudzonego klienta i zwi�zanym
z tym pomys�em na obni�anie koszt�w).
Patrz te�:
� Panorama Intranetu (Projekt Winter)
<http://winter.it.com.pl/intranet.htm>
�
IntranetJournal <http://www.intranetjournal.com/>
� Intranet Reference Site <http://intrack.com/intranet/>
� Netscape: Full Service Intranet
<http://home.netscape.com/comprod/at_work/white_paper/intranet/>
2.3. Infostrada
Jest to jedna z nazw utopii (programu spo�ecznego, ideologii)
nazywanej te� czasem spo�ecze�stwem
informacyjnym, g�osz�cej �e podstawowym towarem staje si� wiedza i
dost�p do niej. W tak sformu�owany program spo�eczny doskonale
wpisuje si� Internet
``(w swej warstwie aplikacyjnej)''
b�d�c jednym
z mo�liwych medi�w przekazu.
Patrz te�:
� Michael Sullivan-Trainor
Infostrada
ReadMe,
IDGBooks, ProgramersPress: Warszawa 1995 (ISBN 83-85769-95-1)
� Ziemek Borowski
Ideologia spo�ecze�stwa informacyjnego a Internet
<http://www.QDnet.pl/~Ziembor/internet.htm>
Warszawa 1996
(praca semestralna z EPC w
Instytucie Socjologii UW
2.4. WWW
WWW
(World Wide Web)
, zwana inaczej Paj�czyn�, Webem jest
hipertekstowym, multimedialnym, sieciowym, opartym na TCP/IP systemem
informacyjnym.
hipertekstowym "
czyli takim gdzie istniej� zdefiniowane zale�no�ci miedzy
poszczeg�lnymi dokumentami, mo�liwo�ci dowolnego przemieszczania
si�
pomi�dzy nimi, oraz zdefinowane znaczeniowo wyr�niki tekstu.
multimedialnym "
czyli dopuszczaj�cym stosowanie r�nych �rodk�w przekazu:
tradycyjnych
tekst�w, d�wi�k�w, grafiki.
sieciowym "
bo opartym na warstwie prezentacyjne/aplikacyjnej
sieci rozleg�ej Internet, a wi�c o zasi�gu praktycznie
globalnym.
Patrz te�:
� World Wide Web Corporation <http://www.w3.org/>
� WWW FAQ Boutella <http://www.boutell.com/faq/>
� Entering the World-Wide Web: A Guide to Cyberspace
<http://www.eit.com/goodies/www.guide/>
Kevina Hungesa
2.5. HTML
HTML
czyli
Hypertext Markup Language
jest (a w�a�ciwie by�) napisanym w
``SGML''
hipertekstowym j�zykiem
kodowania dokument�w. Od roku 1990 (gdy zosta� zaprojektowany przez
Tima Berners-Lee
w
CERN <http://www.cern.ch/hypertext/>
) w celu
szybszej i �atwiejszej wymiany dokument�w
przeszed� d�ug� i kr�t� drog�
od prostego (w praktyce zawieraj�cego kilkana�cie wyra�e�) j�zyka
znakowania ZNACZE� dokument�w do j�zyka (a w�a�ciwie slangu ze wzgl�du
na zanik kluczowych elemnt�w gramatyki) opisu strony.
Podstawowe za�o�enia przy�wiecaj�ce powstaniu i rozwijaniu j�zyka:
� prostota (tak w sensie nauczenia si�, jak i realizacji przez
klient�w)
� niezale�no�� od platformy
� mo�liwo�� roszerzania o wsp�prac� z bazami danych i
niestandardowymi
obiektami.
� elementy zale�no�ci mi�dzy dokumentami (i poszczeg�lnymi ich
fragmentami)
� r�ne poziomy ,,znaczeniowe'' j�zyka
� poziom 0
podstawowy - nag��wki, listy, odniesienia
� poziom 1
rysynki, podkre�lenia, wyr�znienia tekstu
� poziom 2
formularze, definicje znak�w (SGML entries)
� poziom 3
tabele,
� poziom 4
formu�y matematyczne
Patrz te�:
� Sekcja HTML na W3C <http://www.w3.org/pub/MarkUp/HTML/>
� The Web Design Group <http://www.htmlhelp.com/>
(opisy HTML 3.2, CSS, Style Guide, spis wa�nych odno�nik�w)
� ``Sekcja: Tworzenie HTML''
� HTML Writers Guild <http://www.hwg.org/>
2.6. SGML
SGML
czyli
Standard Generalized Markup Language
jest metaj�zykiem (opisanym w standardzie mi�dzynarodowym
(ISO 8879:1986)
)
s�u��cym do projektowania opisu dokument�w wed�ug okre�lonego
zapotrzebowania informacyjnego z u�yciem dowolnie dobranego
zestawu znacznik�w i ich sk�adni.
Dokument SGML sk�ada si� z kilku cz�ci:
deklaracji SGMLa " gdzie opisuje si� klas� dokumentu,
podstawowe paramenty jego budowy i przetwarzania: u�ywane
zestawy znak�w,
dopuszczalne d�ugo�ci litera��w (np. nazwy znacznik�w czy
d�ugo�� atrybut�w),
opcje minimalizacji (np. czy mo�liwe jest i w jakiej postaci
pomijanie
znacznik�w ko�cz�cych element).
Definicji Typu Dokumentu "
(DTD, Document Type Definition)
gdzie jest zakodowana hierarchia element�w wraz z dopuszczalnymi
atrybutami,
ich dopuszczalnymi i domy�lnymi warto�ciami, mo�liw�
zawatro�ci�. DTD
jednoznacznie okre�la sk�adnie danego typu dokumentu.
zawarto�ci dokumentu " czyli tzw.
DOCUMENT INSTANCE
(w
wypadku wielu typ�w dokument�w zawieraj�ce tak�e ,,zewn�trzne''
elementy steruj�ce (np. <?date>))
W wielu wypadkach deklaracj� stosuje si� domy�ln�, a zamiast
ca�ego DTD umieszcza si� Formal Public Indentifier (rozwi�zywany
zwykle
przez parsery na w�a�ciwie DTD przy pomocy pliku
catalog
zawieraj�cego zbi�r dopuszczalnych deklaracji wraz z ody�aczami
do poszczeg�lnych plik�w).
Przy czym istnieje rozr�nienie na identyfikatory publiczne:
<!DOCTYPE PUBLIC HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
czyli
zarejestrowane <http://www.sgmlopen.org/>
i systemowe np:
<!doctype linuxdoc system>
Parser SGML (jak sama nazwa wskazuje) jest programem analizuj�cym
sk�adni�
dokumentu i to (je�li mowa o tzw.
validating parsers
)
nie tylko sam� jednorazow� dawk� informacji ale r�wnie� deklaracj�
SGML
i DTD (wraz z jego sk�adni�). Wyj�cie z parsera (
ESIS,
czyli
Element Structure
Information Set
)
mo�e stanowi� podstaw� konwersji czy jakiejkolwiek
obr�bki dokumentu (��cznie z (re)formatowaniem, przy wykorzystaniu
arkuszy stylistycznych
``DSSSL''
).
(GS + ZMB)
Patrz te�:
� C. F. Goldfarb <http://www.sgmlsource.com/>
The SGML Handbook
, Y. Rubinsky, Ed.
Oxford University Press, 1990
� SGML HomePage (SIL) <http://www.sil.org/sgml/>
� Getting Started with SGML (SGMLopen)
<http://www.sgmlopen.org/sgml/docs/getstart.htm>
� SGML Introduction
<http://itrc.uwaterloo.ca/~engl210e/BookShelf/Tutorials/SGML/> -
Paul Prescod <papr...@calum.csclub.uwaterloo.ca>
�
Understanding the SGML declaration (Omnimark)
<http://www.omnimark.com/reference/white/decl/>
� Gentle Introduction to SGML (TEI)
<http://sable.ox.ac.uk/ota/teip3sg>
� SGML in Poland <http://info.fuw.edu.pl/~ksiezyk/sgml.html>
Rafa�a Ksi�yka (z WN PWN)
� Litterae. Dokumenty Elektroniczne s.c.
<mailto:M.O...@Litterae.com.pl>
(polska
firma produkuj�ca m.im. ,,Edytor Sterowany Szablonem''
a dostosowalny
do ka�dego DTD).
� comp.text.sgml <news:comp.text.sgml>
� sg...@camk.edu.pl <mailto:sgml-r...@camk.edu.pl>
polskoj�zyczna
lista dyskusyjna po�wi�cona zastosowaniom SGMLa
2.7. HTTP
HTTP
czyli
HyperText Transfer Protocol
jest protoko�em typu klient-serwer warstwy aplikacyjnej
(dzia�aj�cym w oparciu o protok� TCP)
s�u��cym do pobierania (i przy
u�yciu niekt�rych (w pe�ni realizuj�cych standard) serwer�w
dostarczania)
dokument�w hipertekstowych (najcz�ciej w postaci HTML) a tak�e
zbior�w binarnych takich jak programy albo dokumenty pochodz�ce
ze specjalizowanych edytor�w tekst�w.
Procedura nawi�zywania po��czenia przebiega nast�puj�co:
� Klient przedstawia ��danie pobrania oke�lonego
zasobu
(w formie:
POLECENIE �cie�ka_do_zasobu protok�
$ telnet www 80
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
GET /faq.htm HTTP/1.0
(po ��daniu nast�puje linijka wolna -
wszystkie przyk�ady s� w pokazywane w a) wersji HTTP/1.0
b) z niepe�nymi (jeszcze) nag��wkami klienckimi)
� Na to serwer odpowiada: (o ile ��danie jest realizowalne)
HTTP/1.0 200 OK
Date: Sat, 05 Apr 1997 16:20:50 GMT
Server: Apache/1.1.1
Content-type: text/html
<HEAD><TITLE> Witajcie ;-) </TITLE></HEAD><BODY>
(........ i tak dalej ;-))
� nie zawsze wszystko przebiega tak pomy�lnie.
Czasem pomylili�my URI i zamiast potwierdzenia wys�ania strony,
serwer odpowiada:
HTTP/1.0 404 Not found
Date: Sat, 05 Apr 1997 16:29:10 GMT
Server: Apache/1.1.1
Content-type: text/html
<HEAD><TITLE>File Not found</TITLE></HEAD>
<HEAD><H1>File Not found</H1>
The requested URL /pp was not found on this server.
</BODY>
(chyba wszystkie serwery pozwalaj� zmienia� zawarto��
p�l ``wy�wietlanych w wypadku b��d�w''
Patrz te�:
� ``Sekcja: Standardy: HTTP''
� ``Sekcja: Tworzenie: HTTP''
� WebCompare <http://webcompare.iworld.com/>
� Sekcja: HTTP na W3 <http://www.w3.com/pub/WWW/Protocol/>
� HTTP Made Really Easy <http://www.jmarshall.com/easy/http/>
James Marchall <mailto:ja...@jmarshall.com?subject=HTTP Made Really
Easy>
� HTTP WG w <http://www.ics.uci.edu/pub/ietf/http/>
IETF <http://www.ietf.org/>
2.8. Netscape-HTML i MS-HTML
S� to dialekty (slangi) HTMLa cechuj�ce si� z jednej strony
rozmaitymi
rozszerzeniami
(extensions) a z drugiej
ignorowaniem proponowanych przez innych (np. cia�a standaryzacyjne,
konkurencj�) nowych mo�liwo�ci np. proponowanych w szkicach
dotycz�cych
� obs�ugi r�wna� matematycznych w HTML 3.0
� tabel w RFC 1942
Problem z tymi swoistymi
rozszerzeniami
polega na tym, �e przez tworzenie nieprzemy�lanych fakt�w blokuj�
one rozw�j j�zyka (trudno zachowa� sp�jno�� logiczn� struktury
dokumentu je�li w ka�dym jego miejscu mo�e wyst�pi� jakie�
polecenie (w tym wypadku chodzi o nikomu w tej formie
nie potrzebny znacznik <CENTER>).
Patrz te�:
� AntiNetscape HomePage <htttp://server.berkeley.edu/sprawd�>
� Netscape Comunictation <http://www.netscape.com/>
� Microsoft Corporation <http://www.microsoft.com/>
2.9. URI, URL, URN
W sieci (zwaszcza przekszta�caj�cej si� z systemu menu (Gopher)
do heterogenicznego hipertekstu), zaistnia�a potrzeba jednoznacznego
identyfikowania zasob�w. Wychodz� temu naprzeciw rozmaitej mocy
,,uniwersanlne wska�niki'' (cho� wymieniam je musz� przyzna� �e nie do
ko�ca rozumiem czym si� r�ni� ;-() :
�
URL
Uniform Resource Locator
�
URI
Uniform Resource Indentificator
�
URN
Uniform Resource Name
�
URC
Uniform Resource Citation
Tutaj bli�ej
om�wi�
URL
URL sk�ada si� z w swej pe�nej wersji:
nazwy protoko�u " (a w�a�ciwie odpowiedniego mnemonika)
adresu w�z�a sieci " (czyli nazyw hosta, komputera w sieci)
portu przypisanego danej us�udze " standardowe numery
port�w opisane s� w
``innych dokumentach.''
�cie�ki do pliku " (mo�e by� wirtualnej czyli
okre�lanej w ustawieniach serwera, nie za� w fizycznie
istniej�cej)
paramentr�w pliku " (wymienianych po znaku " ; " -
np. typ pliku w FTP)
opcji zapytania " (przekazywanych jako parametry do program�w,
a wymienianych po znaku zapytania " ? ")
fragmentu, w�z�a w pliku " wymienianych po znaku ,,hasha'' " #
")
czyli:
protok�://u�ytkownik:has�o@host:nr_portu/�cie�ka;parametr_obiektu?zapytan
ie#w�ze�
Wida� wi�c, �e w bezpo�rednio w URLu mog� by� u�yte jedynie znaki ze
alfanumeryczne z zestawu ASCII (dost�pno�� wprowadzania)
(czyli {a-Z}{0-9} a tak�e znaki
"+",
"&", (wykorzystywane przez CGI)
"-" i "%" s�u��cy do zapisywania potrzebych
znak�w w notacji szesnastowej np. %7E znaczy ~ czyli tyld� stosowan�
cz�sto jako skr�t dla kont u�ytkownik�w).
Dost�pne us�ugi opatrzone s� nast�puj�cymi mnemonikami:
file:// " odno�nik do zasob�w lokalnych komputera (nie nale�y
chyba
u�ywa� w sieci :-) (zalecane je�li chcemy pokaza� jaki� plik
kt�ry
musi
istnie� na komputerze kilenta (np.
file://localhost/etc/resolv.conf
ftp:// " odno�nik do zasob�w dost�pnych za pomoc� protoko�u FTP,
z
wariantem
ftp://u�ytkownik@...
lub
ftp://u�ytkownik:has�o@...
(cho� tej ostatniej wersji nie polecam)
gopher:// " odno�nik do zasob�w
``Gopher`a''
(standardowy port: 70)
http:// " zas�b obs�ugiwany przez serwer
``httpd''
(HTTPd) (standardowy port: 80)
maito: " odno�nik powoduj�cy wys�anie listu pod podany adres
(bez
// po dwukropku!!!)
(dla wyspecyfikowania tematu listu mo�na spr�bowa� doda� do
komendy <A
atrybut TITLE=" Tytu� listu " )
news:
nazwa.grupy
news: " odno�nik powoduj�cy uruchomienie przegl�darki USENETU
(news) u�ywaj�c domy�lnego serwera, i podanej grupy
(ew. okre�lony artyku� w/g identyfikatora).
telnet: " odno�nik do zdalnego komputera, zazwyczaj u�ywaj�c
terminala VT100 (bez // po dwukropku!!!) (standardowy port: 23)
tn3270: " odno�nik do zdalnego komputera IBM (np. 3090 na
plearn.edu.pl) terminala IBM-3270 (bez // po dwukropku!!!)
wais: " odwo�anie do systemu wyszukiwawczego
WAIS
newsrc: " odno�nik do okre�lonego pliku newsrc (jak rozumiem
lokalnego)
nntp:// " okre�la inny ni� domy�lnie u�ywany serwer news�w (port
116)
Adres komputera mo�e by� podany tak przy u�yciu
nazwy zdefiniowanej w DNS
jak i jako numer IP. Numer portu o ile
standardowy
czyli opisany w odpowiednim
RFC -
STD2 <http://sunsite.icm.edu.pl/pub/rfc/rfc1700.tgz.gz>
mo�e by� pomini�ty. �cie�ka dost�pu do pliku mo�e ko�czy� si�
na nazwie katalogu (o ile w katalogu tym jest (zdefiniowany w ustaw
ieniach
serwera) plik ,,domy�lny'' zwykle o nazwie:
� index.html
� index.htm
� default.htm (to z MS)
jednak wtedy (aby nieco przy�pieszy� operacje - podw�jne
odwo�ywanie si� serweranajpierw do pliku, a potem do katalogu)
warto zako�czy� �cie�k� znakiem / (tzw. slash, ciach).
Parametr pliku jest (w tej chwili) istotny jedynie dla HTTPd:
�
(+PT)
Patrz te�:
�
``Sekcja: Standardy: URL''
� Beginner's Guide to HTML
<http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html>
� URL Schemes Supported in Lynx
<http://www.crl.com/~subir/lynx/lynx_help/lynx_url_support.html>
2.10. CGI
CGI
czyli
Common Gateway Interface
jest specyfikacj� (
API
-
Aplication Program Interface
)
umo�liwiaj�c� komunikacj�
przegl�darki z programami uruchamianymi przez serwer.
Pocz�tkowo tworzona przez zesp� z NCSA, nie doczeka�a si�
opisu jeszcze opisu w RFC.
W tej chwili b�d�c nieoficjalnym standardem (pochodz�cym
z NSCA httpd, a implementowanym przez wi�kszo��
dost�pnych serwer�w (nawet tych nie-Unixowych w postaci tzw. WinCGI))
jest
powoli wypierana przez rozmaite specyfikacje programistyczne
poszczeg�lnych
serwer�w (firm produkuj�cych) takie jak
NetscapeAPI,
MS IIS API, czy Apache CGI/PHF
Patrz te�:
� ``Sekcja: Interacja''
� ``Sekcja: Bezpiecze�stwo: CGI''
� CGI Overview <http://hoohoo.ncsa.uiuc.edu/cgi/>
� CGI reference <http://www.vservers.com/reference/cgi.html>
� CGI Programmer`s Reference (FAQ)
<http://www.best.com/%7Ehedlund/cgi-faq/>
�
CGI FAQ (www.htmlhelp.com) <http://www.htmlhelp.com/faq/cgi.html>
� CGI-references <http://www.CGI-references.com/>
wi�kszo�� rzczy potrzebnych do tworzenia program�w
zgodnych z CGI
� <news:comp.infosystems.www.authoring.cgi>
2.11. VRML
VRML
czyli
Vitual Reality Modeling Language
jest to, wykorzystuj�cy niekt�re mechanizmy WWW
(takie jak httpd, czy URL), j�zyk opisu scen tr�jwymiarowych oparty na
formacie Open Inventor stworzonym przez Silicon Graphics.
Niekt�rzy wi��� z nim du�e nadzieje, uwa�aj�c �e przekaz graficzny
jest
�atwiej przyswajalny, ale (przynajmniej dla mnie) poziom
skomplikowania
j�zyka, wielko�� plik�w (i brak wyobra�ni plastycznej) powoduj�, �e
jest
to raczej przysz�o�� ni� tera�niejszo��.
Patrz te�:
� VRML 2.0 - Specyfikacja (vag.vrml.org)
<http://vag.vrml.org/VRML2.0/FINAL/>
� <news:comp.lang.vrml>
� VRML Forum (Wired) <http://vrml.wired.com/>
� VRML Repository (SDSC) <http://www.sdsc.edu/vrml/>
� Silicon Graphics <http://www.sq.com/>
� Piotr Gawrysiak
VRML. Wirtualna rzeczywisto�� w Internecie
Warszawa 1995, 1996;
Zak�ad Nauczania Informatyki MIKOM <http://www.pol.pl/MICOM/>
Wygl�da przyzwoicie - przy czym raczej jako podr�czna �ci�gawka
przy pisaniu skrypt�w (z dyskietk�)
� VRML w Polsce (Instytut Studi�w Spo�ecznych UW)
<http://andante.iss.uw.edu.pl/obuz/vrmlp/index.html>
� AMU-NET's VRML Repository (Administrator: Klaudiusz Modrzewski)
<http://math.amu.edu.pl/ftp/windows/vrml/00_index.html>
2.12. Java
Java
jest obiektowym j�zykiem programowania
stworzonym przez Sun INC. (zesp� pod kierunkiem Jamesa Goslinga)
do sterowania urz�dzeniami elektronicznymi (,,niekomputerowymi'').
Jednym z podstawowych za�o�e� projektu by�o stworzenie przeno�nego
kodu, nie wymagaj�cego powt�rnej rekompilacji, przy zmianie
architektury
maszyny na kt�rej program ma dzia�a�.
Powsta�a w ten spos�b tzw. wirtualna maszyny javy - czyli sztuczne
�rodowisko,
w jakim dzia�aj� programy, jest
(powinnien by� by�) niezale�na od platformy systemowej,
stosowanego systemu operacyjnego). Dzi�ki przeno�no�ci, wzgl�dnej
prostocie,
oraz oczywi�cie promocji ze strony Suna (np. darmowa przegl�darka WWW
HotJava)
zyska� sobie do�� powszechny odzew.
Pomimo kr�tkiego cyklu rozwojowego j�zyka (rozpocz�cie realizacji
projektu
,,Green''to kwiecie� 1991, za� �wiatowa premiera Javy i HotJavy to maj
1995 r.) jest wykorzystywana do wielu r�nych zastosowa�: pocz�wszy od
prostych
applet�w (czyli kr�tkich programik�w
realizuj�cych pojedy�cze zadania - zazwyczaj zagnie�d�one w HTMLu)
przewijaj�cych tekst u do�u strony, poprzez stosowanie jako interface
do baz
danych (
``poprzez JBCD''
,
do pot�nych aplikacji takich jak
Corell Office for Java. <http://officeforjava.corel.com/>
Patrz te�:
� <http://www.javasoft.com/>
� <http://java.sun.com/>
� Java na SunSite ICM UW <http://SunSite.icm.edu.pl/java/>
� Artur van Hoff, Sami Shaio, Orcha Starkbuck
Sun Microsystems INC
Hooked on JAVA <http://www.javasoft.com/hooked/>
(ISBN 0-201-48837-X)
(polskie wydanie:
Java
Wydawnictwo HELION <http://www.helion.gliwice.pl>
(ISBN 83-86718-30-7)
�
Addison-Wesley Java Series <http://www.aw.com/devpress/>
� Java na UCI AGH <http://arrow.uci.agh.edu.pl/%7Ejava/index-p.html>
� Linux: Java CGI HOWTO
<http://www.orbits.com/software/Java_CGI.html>
David H. Silber <mailto:d...@orbits.com>
2.13. JavaScript
JavaScript
(primo voto: Mocha ze stajni
Netscape Communication <http://home.netscape.com/>
)
jest prostym j�zykiem podobnym do
MS <http://www.microsoft.com/>
VisualBasica
, i
interpretowanym bezpo�rednio prze przegl�dark� WWW.
Teoretycznie zyska� akcepta Suna, jednak AFAIK ma tyle wsp�lnego z
``JAV�''
co pierwsze cztery literki w nazwie ;-))).
Patrz te�:
� JavaScript Authoring Guide (Netscape)
<http://home.netscape.com/eng/mozilla/Gold/handbook/javascript/index.html>
� polskie t�umaczenie <http://www.polbox.com.pl/lupus/html/>
(Paw�a Wimmera <mailto:pawel....@lupus.waw.pl>
i
W�odzimierza Wypycha) <http://epublica.pol.pl/>
kursu JavaScript Stefana Kocha <http://rummelplatz.uni-
mannheim.de/~skoch/js/script.htm>
2.14. ActiveX
Jest wymy�lon� przez
NetManage <http://www.netmanage.com/>
a usilnie promowan� przez
MicroSoft <http://www.microsoft.com/activeplatform/default.asp>
technologi� pozwalaj�ca na stosowanie obiekt�w OLE w zastosowaniach
sieciowych.
Ale poniewa�:
� OLE jest stosowalne jedynie w
MS Windows [TM]
� MS nie dotrzyma� obietnicy wypszczenia na rynek technologii
pozwalaj�cej na u�ycie obiekt�w ActiveX na Unixach (to znaczy:
ja niestety nie mam ani w domu, ani w pracy �adnego Suna, a
implementacja
A. powsta�a jedynie na t� platform�.)
� ``Broadway ''
jest pi�kny i wspania�y,
ale jeszcze nie stosowany (a pono� obs�uguje A.)
�
nie posiada tych mo�liwo�ci wsp�pracy z bazami danych co
``JAVA''
nie nale�y stosowa�
Patrz te�:
�
<http://www.microsoft.com/wwlive/>
� NetManage <http://www.netmanage.com/>
� <http://www.X.org/>
� ActiveX Journal <http://www.folkarts.com/journals/activex/>
� Active X unoffical Guide <http://www.shorrock.u-
net.com/index.html>
2.15. SSI
SSI
czyli
Serwer Side Included
Jest prostym mechanizmem dynamicznego tworzenia dokument�w opracowanym
(jak wiele innych, istotnych w paj�czynie technologii) w NSCA.
Pozwala m.in. na:
� do��cznie nag��wk�w i stopek dokument�w
� wprowadzanie daty utworzenia, modyfikacji, wielko�ci pliku
�
w��czaniu standardowego wyj�cia z program�w do dokument�w
Wszystkie zlecenia dla dokument�w sk�adanych przez serwer znajduj�
si� w
komentarzu SGMLa, tak wi�c w wypadku b��dnego wykonania zlecenia,
pozostaje nam puste miejsce.
Patrz te�:
� NCSA httpd server side includes
<http://hohoo.nsca.uiuc.edu/docs/tutorials/includes.html>
� @internet -- What's Included in Server Side Includes?
<http://www.dnai.com/%7Ethomst/@inet030.html>
� Parsed Text and Server Side Includes
<http://hopf.math.nwu.edu/docs/parse.html>
� Server Side Includes Page <http://www.sigma.net/tdunn/ssi/>
2.16. SSL, S-HTTP, Shen (z CERN)
SSL
(Secure Socket Layer)
- stworzony przez Netscape protok� bezpiecznej
komunikacji mi�dzy klientem a serwerem. Istniej�ce implementacje:
telnet,
FTP i - najbardziej rozpowszechnione - HTTP. SSL zapewnia trzy rzeczy:
prywatno�� (po��czenie jest szyfrowane), autoryzacj� (klient i serwer
okre�la swoj� to�samo��) i niezmienno�� (przez sumy kontrolne).
Innymi implementacjami ,,bezpiecznego HTTP serwera'' sa:
S-HTTP <http://www.commerce.net/software/Shttpd/> (stworzony przez
EIT <http://www.eit.com/>, Terisa Systems, i
ComerceNet <http://www.comercenet.com/>
u�ywaj�cy szyfrowania danych, nie za� jak w wypadku SSL tworzenia
szyfrowanego kana�u przey�u danych wi�c wymagaj�cy dedykowanego
klienta) i Shen (CERN).
(KravietZ+ZMB)
Patrz te�:
� ``Sekcja: Serwery: SSL''
� SSL Home Page (Netscape)
<http://home.netscape.com/newsref/std/SSL.html>
�
Terisa Systems <http://www.terisa.com/>
2.17.
ONE i plug-in
ONE
czyli
Open Network Environment
Netscape
jest technologi� (�rodowiskiem programistycznym) pozwalaj�c�
�atwiejsze
i szybsze tworzenie dynamicznych,
wieloplatformowych aplikacji sieciowych.
W swoich dokumentach NC pisze o tym, �e bazuj� na ,,otwartych,
publicznych
standardach dost�pnych na ka�d� platform�''. (Je�li to s� standardy
internetu,
to zazwyczaj do�� pokracznie interpretowane... - jak cho�by rozmaite
,,extentions'' HTMLa).
Plug-In (wtyczka)
jest technologi� pozwalaj�c� na rozszerzenie
mo�liwo�ci przegl�darki czytania rozmaitych format�w dokument�w - np.:
Anobe PDF, CorelDraw, rysunki wektorowe, pliki r�nych dziwnych
,,procesor�w tekst�w'', animacje.
Patrz te�:
� <http://developer.netscape.com/library/one/>
�
lista plug-in�w wg firmy CC <http://www.medianet.com.pl/~cc/>
2.18.
PERL, awk, C
Practical Extraction and Report Language
czasem nazywany jest te�
The Pathologically Eclectic Rubbish Lister
jest skryptowym j�zykiem rozwijanym przez Larrego Walla pozwalaj�cym
na
�atwe, szybkie operacje na tekstach, a tak�e (co stanowi jego
przewag�
nad tak wspania�ym narz�dziem jakim jest
awk
(lub
gawk
))
na dost�p do wszelkich fukcji systemu.
Pozwala nie tylko na rozmaite dzia�ania na dokumentach w trakcie ich
przygotowywania, ale tak�e �atwe i wydajne tworzenie program�w
``uruchamianych przez serwer HTTPd''
AWK a zw�aszcza
gawk s� o wiele prostsze (a zastosowaniach typu
przetwarzanie tekst�w co najmniej r�wnie wydajne).
Dodatkow� zalet� jest to �e nale�y do standardowego wyposa�enia Unixa,
a i DOSowe implementacje s� �adne i szybkie ;-)
C
jest pi�knym, g�upim narz�dziem... do wyszystkiego,
a zw�aszcza przetwarzania tekst�w.
Patrz te�:
� CPAN <http://SunSite.icm.edu.pl/pub/CPAN/>
� Perl Institute <http://www.perl.org/>
� Krzysio Leszczy�ski <mailto:ch...@camk.edu.pl>
PERL
{w:}
Linux+ <http://www.linux.com.pl/>
2/ 3/1997
(ISSN 1427-55-62)
� Programming Perl (the Camel Book) <http://www.ora.com/>
� Learning Perl (the Lama Book) <http://www.ora.com/>
� Thomas Boutell
CGI Programing in C & Perl <http://www.boutell.com/cgi/>
Addison-Wesley Publishing Comp.INC <http://www.aw.com/devpres/>
(ISBN 0-201-42219-0)
�
<news:pl.comp.lang.perl>
�
<news:comp.lang.awk>
�
man perl, man awk
2.19.
HyperG, HyperWave
HyperG
, a tak�e
HyperWave
s� pomys�em na rozszerzenie mo�liwo�ci HTTP o:
� pe�n� (przeszukiwaln�) baz� serwowanych dokument�w (z
,,kolekcji'')
(.htz) (wraz z mo�liwo�ci� podzielenia tej bazy na wiele maszyn)
� wielowariantowo�� dokument�w (po to by wst�pnie zapozna� si� z
tre�ci�
serwowany jed dokument tekstowy, do wydruku idzie DVI, lub
PostScript)
� okre�lona stuktura (hierarchia) dokument�w
� serwowanie i pobieranie dokument�w tak w ramach standardu HyperG
jak i
standard�w okre�laj�cych WWW.
Patrz te�:
� Kurs Hyper-G <http://www.iicm.edu/hgcourse/>
Keitha Andrewsa <mailto:kand...@iicm.edu>
� archiwa HyperG na Sunsite.ICM.edu.pl
<http://SunSite.icm.edu.pl/pub/HyperG/>
� <news:comp.infosystems.hyper-g>
2.20.
HyTime
HyTime
czyli
Hypermedia/Time-based Structuring
Language.
jest przemys�owym, mi�dzynarodowym
(ISO/IEC 10744:1992) <http://www.iso.ch/>
standardem dystrybucji i
tworzenia dokument�w multimedialnych.
Patrz te�:
� Eliot Kimber's HyTime Course <http://www.drmacro.com/>
� HyMinder:
TechnoTeacher, Inc <http://www.Techno.com/>
� SoftQuad Panorama <http://www.sq.com/panorama/>
2.21.
DSSSL, CSS
DSSSL
czyli
Document Style Semantics and Specification Language
jest specyfikacj� s�u��c� formatowaniu dokument�w SGML. Mo�na w ten
spos�b
rozdzieli� ,,znaczeniowe'' ,,tagowanie'' tekstu, od projektowania jego
wygl�du.
Z DSSSL wywodzi si� koncepcja CSS1 czyli
Cascading Style Sheets b�d�cego (jak dla mnie)
pr�b� opanowania rozwoju stosowanego przez niekt�rych producent�w
,,znakowania
typograficznego'' czyli np <CENTER>, <BODY BACKGROUND="red.gif">.
Patrz te�:
� DSSSL Tutorial
<http://itrc.uwaterloo.ca/~papresco/dsssl/tutorial.html>
Paul Prescod <mailto:papr...@calum.csclub.uwaterloo.ca>
� JADE J. Clarka <http://www.jclark.com/jade/>
�
Cascading Style Sheets, level 1 - W3C Recommendation 17 Dec 1996
<http://www.w3.org/pub/WWW/TR/REC-CSS1>
H�kon Wium Lie <mailto:how...@w3.org>
Bert Bos <mailto:be...@w3.org>
� Positioning HTML Elements with Cascading Style Sheets
<http://www.w3.org/pub/WWW/TR/WD-positioning-970131.html>
� WDG CSS1 Reference <http://www.htmlhelp.com/reference/css/>
2.22.
XML
XML
czyli
eXtensible Markup Language
jest uproszczon� specyfikacj�
``SGMLa''
umo�liwiaj�c� tworzenie i dodawanie w�asnych znacznik�w do dokument�w.
Pojajawi�y si� ju� pierwsze incjatywy jego wykorzystania:
� Microsoft <http://www.microsoft.com/standards/>
-
Channel Definition Format
maj�cy (we wsp�pracy ze ,,standardowym''
HTMLem) s�u�y� tworzeniu cz�sto uaktualniach kolekcji dokument�w,
lub kana��w
informacyjnych pomi�dzy serwerami HTTPd a stacjami klienckimi.
Patrz te�:
� W3C XML Working Draft <http://www.w3.org/pub/WWW/TR/WD-
xml-961114.html>
2.23.
Broadway
Broadway jest opart� na X-Windows technlogi� zdalnego dost�pu do
aplikacji.
Jest (w przeciwie�stwie do poprzednich wersji X11) optymalizowane do
pracy w sieciach o niskiej przepustowo�ci, wi�c mo�liwa jest praca
zdalna
(w sieciach rozleg�ych).
Patrz te�:
� BroadWay na X.org <http://www.x.org/consortium/broadway.html>
2.24.
LDAP
Jest uproszczon� wersj� us�ugi s�ownikowej
X.500 <http://x500.itm.edu.pl/> pozwalaj�cej lokalizowa� osoby,
obiekty w sieci
rozproszonej.
Patrz te�:
�
RFC 1777 <http://SunSite.cim.edu.pl/pub/rfc/rfc1777.txt.gz>
�
Netscape Communication
<http://home.netscape.com/references/std.html>
2.25.
Unicode
Jest 16 bitowym (z przeciwie�stwie do powszechnie dzi� stosowanych
8 bitowych) systemem kodowania znak�w diakrytycznych maj�cym umo�liwi�
u�ywanie w ramach jednego zestawu znak�w wielu r�nych zestaw�w.
Patrz te�:
� <http://www.unicode.org/>
� <news:pl.comp.ogonki>
� <news:comp.text>
� The Unicode Standard Ver. 2.0
The Unicode Consortium
Addison Wesley DevelopersPress <http://www.aw.com/developers/>
(ISBN 0-201-48395-9)
3.
Standardy i informacje dla Internetu
Internet nie posiada scentralizowanej stuktury. Jednak posiada do��
dobrze
udokumentowan� stron� techniczn�. Paradoks? Oczywi�cie. Jak ca�a sie�.
Odpowiednie informacje na temat zasad tworzenia standard�w, cia� nad
nimi (standardami) debatuj�cych itd. mo�na znale�� w dokumentach
wymienionych
w cz�ci pierwszej
tego rozdzia�u. W kolejnych paragrafach wymieniam te standardy i
specyfikacje
kt�re wydaj� mi si� wa�ne dla rozwoju paj�czyny, pomijaj�c istotne
kwestie
np. DNSu, czy szyfrowania.
3.1. Dokumenty og�lne - procedury, definicje, zasady zachowania si� w
sieci.
�
RFC 2000
S
J. Postel,
"INTERNET OFFICIAL PROTOCOL STANDARDS"
, 02/24/1997.
(Liczba stron - 56) (STD 1)
�
RFC 1983
I
G. Malkin,
Internet Users' Glossary
08/16/1996. (Liczba stron - 62)
(FYI 18) (Obsoletes RFC1392)
�
RFC 1935
I
J. Quarterman, S. Carl-Mitchell,
What is the Internet, Anyway?
,
04/10/1996. (Liczba stron - 11)
�
RFC 1855
I
S. Hambridge
Netiquette Guidelines
10/20/1995. (Liczba stron - 21)
(FYI 28)
�
RFC 2028
BC
R. Hovey, S. Bradner,
The Organizations Involved in the IETF
Standards Process
10/29/1996.
(Liczba stron - 7)
�
RFC 2027
BC
J. Galvin,
IAB and IESG Selection, Confirmation, and Recall
Process: Operation of the Nominating and Recall Committees
10/29/1996.
(Liczba stron - 11)
�
RFC 2026
BC
S. Bradner,
The Internet Standards Process -- Revision 3
10/29/1996.
(Liczba stron - 36)
(Updates RFC1602)
(Obsoletes RFC1602)
�
RFC 1796
BC
Huitema, C., J. Postel, and S. Crocker
Not All RFCs are Standards
10/04/1995.
3.2.
HTML
�
HTML 3.2 Reference Specification <http://www.w3.org/pub/WWW/TR/REC-
html32.html>
W3C Recommendation 14-Jan-1997
Dave Raggett
<mailto:d...@w3.org>
�
RFC 1866
PS
T. Berners-Lee, D. Connolly,
Hypertext Markup Language - 2.0
,
11/03/1995.
(Liczba stron - 77)
�
RFC 1867
E
E. Nebel, L. Masinter,
Form-based File Upload in HTML
,
11/07/1995.
(Liczba stron - 13)
�
RFC 1942
E
D. Raggett
HTML Tables
05/15/1996.
(Liczba stron - 30)
�
RFC 1980
I
J. Seidman
A Proposed Extension to HTML: Client-Side Image Maps
08/14/1996.
(Liczba stron - 7)
3.3.
URL, URI
�
RFC 1738
PS
T. Berners-Lee, L. Masinter, M. McCahill
Uniform Resource Locators (URL)
12/20/1994.
(Liczba stron - 25)
�
RFC 1808
PS
R. Fielding,
Relative Uniform Resource Locators
06/14/1995.
(Liczba stron - 16)
�
RFC 1700
S
J. Reynolds, J. Postel
ASSIGNED NUMBERS
10/20/1994.
(Liczba stron - 230)
(Obsoletes RFC1340)
(STD 2)
�
RFC 1630
I
T. Berners-Lee,
Universal Resource Identifiers in WWW: A Unifying
Syntax for the Expression of Names and Addresses of Objects on the
Network as used in the World-Wide Web
06/09/1994.
(Liczba stron - 28)
�
RFC 2017
PS
N. Freed, K. Moore, A. Cargille,
Definition of the URL MIME
External-Body Access-Type
10/14/1996.
(Liczba stron - 5)
3.4.
HTTP
�
RFC 2068
PS
R. Fielding, J. Gettys, J. Mogul,
H. Frystyk, T. Berners-Lee,
Hypertext Transfer Protocol -- HTTP/1.1
01/03/1997.
(Liczba stron - 162)
�
RFC 1945
I
T. Berners-Lee, R. Fielding, H. Nielsen,
Hypertext Transfer Protocol -- HTTP/1.0
05/17/1996.
(Liczba stron - 60)
3.5.
MIME
�
� RFC 2077
PS
S. Nelson, C. Parks, Mitra,
The Model Primary Content Type for Multipurpose
Internet Mail Extensions
,
01/10/1997.
(Liczba stron - 13)
�
RFC 2045
DS
N. Freed, N. Borenstein
Multipurpose Internet Mail Extensions
(MIME) Part One: Format of Internet Message Bodies
12/02/1996.
(Liczba stron - 31)
(Obsoletes RFC1521)
�
RFC 2046
DS
N. Freed, N. Borenstein,
Multipurpose Internet Mail Extensions
(MIME) Part Two: Media Types
12/02/1996.
(Liczba stron - 44)
(Obsoletes RFC1521)
�
RFC 2047
DS
K. Moore,
MIME (Multipurpose Internet Mail Extensions) Part Three:
Message Header Extensions for Non-ASCII Text
12/02/1996.
(Liczba stron - 15)
(Obsoletes RFC1522)
�
RFC 2048
BC
N. Freed, J. Klensin, J. Postel
Multipurpose Internet Mail
Extensions (MIME) Part Four: Registration Procedures
01/28/1997.
(Liczba stron - 21)
(Obsoletes RFC1590)
�
RFC 2049
DS
N. Freed, N. Borenstein,
Multipurpose Internet Mail Extensions
(MIME) Part Five: Conformance Criteria and Examples
12/02/1996.
(Liczba stron - 24)
(Obsoletes RFC1521)
�
RFC 2110
MIME E-mail Encapsulatin of Aggregate Documents, such as HTML
(MHTML)
�
RFC 2112
The MIME Multipart/Related Content/type
3.6.
Gopher
�
RFC 1436
I
F. Anklesaria, M. McCahill, P. Lindner, D. Johnson, D. John,
D. Torrey, B. Alberti,
The Internet Gopher Protocol (a distributed document search
and retrieval protocol)
03/18/1993.
(Liczba stron - 16)
3.7.
VRML
� VRML 2.0 - Specyfikacja <http://vag.vrml.org/VRML2.0/FINAL/>
3.8.
Java
� James Gosling, Bill Joy, Guy Stele
The Java Language Specification
(ISBN 0-201063451-1)
� Tim Lindholm, Frank Yellin,
The Java Virtual Machine Specification
(ISBN 0-20163452-X)
3.9.
CGI
� D.R.T.Robinson
draft-robinson-www-interface-01.html
<http://SunSite.icm.edu.pl/pub/internet-drafts/>
The WWW Common Gateway Interface Version 1.1
(15.02.1996)
3.10.
UsenetNews i E-Mail
�
RFC 822
S
D. Crocker,
Standard for the format of ARPA Internet text
messages
, 08/13/1982. (Pages=47) (Format=.txt) (Obsoletes
RFC0733) (STD 11) (Updated by RFC1327, RFC0987)
�
RFC 822
S
J. Postel,
Simple Mail Transfer Protocol
, 08/01/1982. (Pages=58)
(Format=.txt) (Obsoletes RFC0788) (STD 10)
�
RFC 1123
S
R. Braden
Requirements for Internet hosts - application and
support
, 10/01/1989. (Pages=98) (Format=.txt) (STD 3)
�
RFC 1036
M. Horton, R. Adams,
Standard for interchange of USENET messages
,
12/01/1987. (Pages=19) (Format=.txt) (Obsoletes RFC0850)
�
RFC 2076
I
J. Palme
Common Internet Message Headers
02/00/1997. (stron 26) (Format=.txt)
3.11.
Grafika
� GIF Specification
� JPEG Specification
�
RFC 2083
I
T. Boutell,
PNG (Portable Network Graphics) Specification Version 1.0
,
01/16/1997.
(Liczba stron - 102)
3.12.
Wieloj�zyczno�� Sieci
�
ISO 639 <http://www.sil.org/sgml/iso639a.html>
Language Codes
�
ISO 3166 <http://www.sil.org/sgml/iso3166.html>
Country Codes
�
RFC 1766
PS
H. Alvestrand,
Tags for the Identification of Languages
,
03/02/1995. (Pages=9) (Format=.txt)
�
RFC 2070
PS
F. Yergeau, G. Nicol, G. Adams, M. Duerst,
Internationalization of the Hypertext Markup Language
01/06/1997.
(Liczba stron - 43)
�
RFC 1815
I
M. Ohta
Character Sets ISO-10646 and ISO-10646-J-1
08/01/1995.
(Liczba stron - 6)
Patrz te�:
�
The Official Documents Defining the Web
<http://www.utoronto.ca/webdocs/Official/overview.html> Iana
Grahama
� IETF Working Groups <http://www.ics.uci.edu/pub/ietf/>
4.
Nawigacja
4.1.
Paj�czarki
4.1.1.
DOS
Wbrew temu co mog�oby si� wydawa� jest ca�kiem du�o przegl�darek
dzia�aj�cych w ,,go�ym'' DOSie (przypominam �e poza MS-DOSem istniej�
i inne systemy dzia�aj�ce w tym trybie, np.
Caldera OpenDOS
(nb. nied�ugo ma by� wyposa�ony nie
tylko w klienta
NetWare,
ale i w stos
TCP/IP)).
Dost�pne dla DOSa przegl�darki wymienione zosta�y pod adresem
<http://www.fdisk.com/doslynx/>.
4.1.2.
MS-Windows i OS/2
Najprostsz� form� zaopatrzenia si� w przegl�dark� jest zajrzenie do
jednego z archiw�w oprogramowania Winsock:
� The Ultimate Collection of Winsock Software
<http://www.tucows.com/>
(mirrory: SunSite.ICM <http://sunsite.icm.edu.pl/pub/tucows/>
i
IT.PWaw) <http://alfa2.it.pw.edu.pl/tucows/>
� The CWSApps List
Indeks Aplikacji Sieciowych dla Windows
� Papa's Anonymous FTP
i tam mo�na znale�� tak Netscape Navigatora,
MS IExplorera, jak i NSCA Mosaics i wiele, wiele innych.
4.1.3.
Unix
O ile UNIX i pochodne do tej pory dominuj� na rynku serwer�w, to
systemem przegl�darek sta� si�
MS Windows. <http://www.microsoft.com/>
Tym nie mniej jest kilka
warto�ciowych produkt�w. Takich jak:
� Arena (W3C i Yggdrasil)
� Amaya (W3C)
(mirror na SunSite ICM) <http://sunsite.icm.edu.pl/pub/amaya/>
� Netscape Navigator (mirror na SunSite.ICM)
� Netscape Communicator (mirror na SunSite.ICM)
(istniej� te� plki pozwalaj�ce stworzy� ,,polsk�'' wersj� produkt�w
Netscape <http://disneyland.mif.pw.gda.pl/~abagi/Netscape_pl/>
autorstwa
Andrzeja Bagi�skiego)
<http://disneyland.mif.pw.gda.pl/~abagi/Netscape_pl/>
� niezast�piony Lynx
(mirror na SunSite.ICM) <http://SunSite.icm.edu.pl/pub/www/lynx/>
� NSCA Mosaic
� Chimera
� MNEMONIC
{ Multilithic, Non-dependant, Extensible, Modular,
Objective, Network-aware, Internet Client }: w trakcie powstawania.
W Polsce podstawowym archiwum jest ,,sansajt''
Patrz te�:
<http://sunsite.unc.edu/pub/Linux/Documentation/HOWTO/WWW-HOWTO.html>
4.1.4.
Apple
To Do ;-)
Patrz te�:
� <http://www.tucows.com/>
� <http://www.boutell.com/faq/>
4.1.5.
Inne
To Do
Patrz te�:
� <http://www.boutell.com/faq/>
4.2.
Poszukiwanie informacji
Wyszukiwanie w informacji w paj�czynie nadal jest koszmarem z
reklamy Novella:
zalew papierem i danymi... Pomagaj� w tym katalogi tematyczne,
przeszukiwarki czy te� specializowane us�ugi dostarczania informacji.
4.2.1.
Katalogi tematyczne
� Wirtualna Polska <http://wp.cnt.pl/>
� WOW! <http://www.waw.wow.pl/>
� Onet <http://www.optimusnet.pl/>
� PolishWorld <http://www.polishworld.com/>
� NASK <http://www.nask.pl/resources/>
� oficjalna Polska Strona <http://www.polska.pl/>
(po angielsku) <http://www.poland.pl/>
� oryginalna (i pierwsza) Polska Strona na info.fuw.edu.pl
<http://info.fuw.edu.pl/PolandHomepage.html>
i �wiatowe
� Yahoo <http://www.yahoo.com/>
� WWW Virtual Library
<http://www.w3.org/hypertext/DataSources/bySubject/Overview.html>
� WebCrawler <http://www.webcrawler.com/> (skromny obj�to�ciowo,
za to bardzo starannie opracowany)
� Galaxy EINET <http://www.einet.net/galaxy>
4.2.2.
Przeszukiwarki
� ICMowy serwer archie (PL) <http://archie.icm.edu.pl/>
� InfoSeek na ICM (PL) <http://infoseek.icm.edu.pl:8000>
� AltaVista w TPnet (PL) <http://www.altavista.tpnet.pl:8000>
� Sieciowid (PL) <http://sieciowid.pol.pl>
Polski OnLine
� Netoscop (PL) <http://netscop.chip.pl>
istniej�cy w ramach serwisu sieciowego
CHiPa <http://www.chip.pl/>
� DEC Alta Vista <http://www.altavista.digital.com/> (patrz te�:
Telia (PL) <http://www.altavista.telia.com/>
� Lycos <http://fuzine.mt.cs.cmu.edu/mlm/lycos-home.html>
� WebCrawler <http://webcrawler.com/>
� World Wide Web Worm
<http://www.cs.colorado.edu/home/mcbryan/WWWW.html>
� InfoSeek <http://infoseek.com/>
� OpenText <http://www.opentext.com/>
�
Exite <http://www.exite.com/>
� HotBot <http://www.HotBot.com/search.html>
� i inne ... :-) wi�kszo�� dostawc�w us�ug Iternetowych dostarcza
odp.
formularzy do wyszukiwania na najpopularniejszych przeszukiwarkach.
Patrz te�:
� Panorama wyszukiwania w Internecie
<http://winter.it.com.pl/wyszukiwanie.htm>
w Projekcie Winter
4.2.3.
Przypominacze, serwisy informacyjne
Istnieje ju� kilkana�cie r�nych specjalizowanych w wyszukiwaniu i
�ledzeniu
informacji serwis�w. Cz�sto s� one dost�pne za darmo (czyli za
przeczytanie
za��czonych reklam ;-). Nale�� do nich np.:
� <http://www.pointcast.com/>
� <http://www.urlminder.com/>
Patrz te�:
� <http://www.yahoo.com>
4.3.
Wieloj�zyczno�� sieci - dlaczego widz� krzaczki?
Dlaczego cz�sto widz� ,,krzaczki'' zamiast polskich liter?
Jest kilka mo�liwo�ci rozwi�zania tego problemu:
� Masz niew�a�ciw� przegl�dark�, tj. nie obs�uguj�c� polskich liter
w
standardzie ISO-8859-2. W miar� mo�liwo�ci wymie� j� na co� innego
lub sprawd� czy nie mo�na tego jako� poprawi�:
<http://www.agh.edu.pl/ogonki/>
� Twoja przegl�darka obs�uguje polskie literki, ale ty nic o tym nie
wiesz. Np. nie ustawi�e� w Netscape Navigatorze 3.0 opcji:
Options|Document Ecoding|Central European (ISO-8859-2)
i odpowiedniej czcionki w
Options|General_Preferences|Fonts|Latin-2
� Wina le�y po stronie autora strony:
� ani w nag��wku http:
"text/html charset=8859-2" html htm
w pliku mime.types
� ani w nag��wku strony przy pomocy komendy
<meta http-equiv="content-type"
content="text/html; charset=iso-8859-2">
� ani nawet nie u�y� atrybutu
LANG=PL
w wyra�eniu
<BODY ...
nie zadeklarowa� polsko�ci
dokumentu, ani nawet u�ywanej strony kodowej
� po ostatnich poprawkach poczynionych przy pomocy jakiego� dziwnego
edytora (najcz�ciej typu: Zobaczysz_Co�_Innego_Ni�_Inni) wszytkie
polskie
literki zosta�y zamienione na tzw.
latin-1 entries
(np. ó czyli � - jednakowe w obu standardach) kt�re s�
siedmiobitowymi mnemonikami dla znak�w
z zakresu 128-255 zestawu znak�w ISO-8859-1 (czyli
zachodnioeuropejskiego).
� wina le�y po stronie autora strony: u�ywa CP 1250 :-(
Patrz te�:
� ``Tworzenie wieloj�zyczno��''
� Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/>
� W jaki spos�b poprawnie serwowa� polskie dokumenty?
<http://la.ists.pwr.wroc.pl/%7Ecoven/tech/langtech.html>
Paw�a Wi�cka
4.4.
Przy�pieszanie pracy (W3cache)
Co to jest i dlaczego nale�y u�ywa� W3cache-proxy?
Dlaczego? Przecie� to oczywiste... ;-)
Jednym ze skutk�w coraz gwa�towniejszego rozwoju us�ug WWW jest
saturacja ��cz sieci rozleg�ych. O ile przepustowo�ci ��cz sieci
lokalnych
i miejskich s� zwykle nadmiarowe, to ��cza mi�dzynarodowe (znacznie
bardziej kosztowne) stanowi� zazwyczaj w�skie gard�a Internetu.
Szybko�� wzrostu zapotrzebowania na pasmo znacznie przekracza wszelkie
mo�liwo�ci inwestycyjne. Analiza ruchu wskazuje przy tym, �e
procentowo
coraz wi�kszy udzia� stanowi� w nim transmisje WWW.
Polska, jako jeden z pierwszych kraj�w zbudowa�a struktur� tzw. cache
WWW, kt�ra pozwala na lokalne buforowanie najcz�ciej ��danych
dokument�w
WWW, a tym samym:
� zmniejszenie obci��enia ��cz mi�dzynarodowych,
� skr�cenie �redniego czasu dost�pu do informacji,
� zoptymalizowanie wykorzystania ��cz krajowych.
Hierarchia W3cache <http://w3cache.icm.edu.pl/sites_pl.html/>
obejmuje
wszystkie wa�niejsze sieci miejskie oraz dzia�a w bezpo�redniej
wsp�pracy
z podobnymi projektami poza Polsk�. W3cache wymienia tak�e
informacje z
pojedynczymi serwerami cache tam, gdzie nie istniej� jeszcze
struktury
og�lnokrajowe.
Przy czym u�ytkownicy takich og�lnopolskich sieci jak TPnet, lub
Telebank powinni ustawi� parametry swojego proxy cache na lokalny
cache, a
je�li nie ma (a nie ma) to na w3cache.icm.edu.pl:8080 jako
najbli�szy
sieciowo ich sieciom, nie za� na cache np. krakowskie. (cho�
ostatnio w
zwi�zku z zaistnieniem
<http://w3cache.icm.edu.pl>
w TPnecie, powstawaniem ,,lokalnych'' po�acze� TPnetu z
NASKnetem (np. w Krakowie) sytuacja si� zmienia).
(WojSyl+ZMB)
Patrz te�:
� Replication <http://www.w3.org/>
� <http://w3cache.icm.edu.pl/>
4.5.
Praca off-line
W naszej sytuacji, gdy ��cz�c si� lini� telefoniczn�
za ka�de trzy minuty po��czenia trzeba zap�aci� (bagatela)
17 groszy coraz istotniejsze staj� si� metody zmnieszania koszt�w,
przez gromadzenie dokument�w na dyskach lokalnych.
4.5.1.
Eksploracja cache dyskowego
Jest to najprostsza (koncepcyjne ;-) metoda pracy.
Mo�a specjalizowanym programem kopiowa� pliki gromadzone przez
przegl�dark� (w NN w katalogu
Cache lub ~/.netscape/cache/, w IE`95 w
c:600les)
do innych katalog�w (tworz�c przy okazji indeksy).
� Unmozify <http://www.evolve.co.uk/unmozify/> na
Windowsowej Netszkapy (tak 3.1 jak i 32bit).
� IE lub NN Cache Explorer
<http://ourworld.compuserve.com/homepages/M_Wolf/> Marcusa Wolfa
dla Windows 95.
� <about:cache> w prawie ka�dym Netscape Navigatorze.
� NSCA Mosaic <http://hohoo.nsca.uinc.edu/>
potrafi prawie wszystko co przegl�darka powinna robi�, ma wi�c i
wbudowane narz�dzia do eksploracji chache.
4.5.2.
Roboty gromadz�ce drzewo dokument�w
Na pierwszy rzut oka jest to wy�mienity pomys�:
zatrudni� kogo�, co� do odwalenia za nas w roboty w czasie
najmniejszego
obci��enia sieci, pozwalaj�c nam przej�e� wyniki szukania w wolnej
chwili.
Ale (o ile u�ywa si� robota stosuj�cego si� do
``konwencji '' - a innych nie warto nawet
uruchania�) rozwi�zanie to ma swoj� wad�: do wielu cz�ci nie
rozmaitych
serwer�w masz dost�pu (np. do wyniku dzia�ania katalogu /cgi-bin/ )
� wget <ftp://gnjilux.cc.fer.hr/pub/unix/util/wget/wget.tar.gz> dla
Unix�w i Linuxa
(z Chorwacji,
ale serwer jest do�� s�aby wi�c trasmisja potrafi d�ugo trwa�)
(mirror: <http://sunsite.auc.dk/ftp/pub/infosystems/wget/>
�
Lynx powy�ej 2.6 <http://lynx.browsers.org/> pono� to
potrafi... ale jak... nie wiem (zapewne przy pomocy kombinacji
opcji
lynx -source -traversal lub lynx -crawl -traversal
� SurfBot <http://www.surflogic.com/products.html> dla Windows
� Teleport Pro Version 1.13 for Windows 95/NT
<http://www.tenmax.com/>
� WebWracker < >
� Mosaic <http://hohoo.ncsa.uic.edu/> potrafi wszystko.
4.5.3.
Wsp�lny W3cache
Rozwi�zanie to nale�y do wymagaj�cych troch� wi�kszego doswiadczenia,
ale te� daje (zw�aszcza w powi�zaniu z przeszukiwaniem dokument�w)
najwi�ksze mo�liwo�ci tak wzbogacenia form pracy (np WWWOFLE mo�e
pe�ni� i
rol� robota) jak i zaoszcz�dzenia (wp�lne zasoby dla wszystkich
komputer�w,
mo�liwo�� monitorowania najcz�ciej uszcz�czanych miejsc,
w przeciwie�stwie do cz�ci robot�w zachowuje (i utrzymuje)
powi�zania mi�dzy dokumentami w sieci i na dysku.
� WWWOFFLE - World Wide Web Offline Explorer
<http://www.gedanken.demon.co.uk/>
dedykowany dla wsp�u�ytkowania ini telefonicznej (wraz z diald)
przez kilka komputer�w w sieci.
� Squid <http://squid.nlanr.net/Squid/>
� Harvest Project <http://harvest.transarc.com/>
4.6.
Niebezpiecze�stwa - wirusy i inne
Czy u�ywaj�c WWW mog� narazi� si� na zniszecznie zawarto�ci dysku,
b�d� inn� form� destabilizacji pracy komputera?
Oczywi�cie :-(.
A powa�nie: o ile masz wy��czon� JAVA, JavaScript, ActiveX
i nie �adujesz plik�w z danymi zawieraj�cymi makroinstrukcje,
PostScript oraz wykonywalnych - nie mo�esz. W pozosta�ych wypadkach:
� pliki MS Worda, MS Excella (i innych program�w mog�cych
zawiera� makroinstrukcje) i wykonywalne - wiadomo - mog� by�
zaka�one i to nie zale�y od medium przesy�owego.
� w Javie i JavaScript znaleziono (w niekt�rych wersjach
implementacjach np.: Netscape Navigatorze 2.0.0) jakie� usterki na
tyle powa�ne, �e pono� zagra�aj�ce bezpiecze�stwu system�w.
� PostScript, TeX i inne programy/dokumenty - mog� zawiera�
niebezpieczne operacje, kt�re pewne przegl�darki mog� pr�bowa�
wykona�: kasowanie plik�w albo ustawienie/zmiana has�a drukarki.
� W wypadku Lynxa istnieje co� takiego (tzw. trusted hosts) co
pozwala
wykonywa� polecenia wydawane ze zdalnego komputera na lokalnym.
Patrz te�:
``Sekcja: Bezpiecze�stwo WWW''
5.
Tworzenie og�lnie
5.1.
Warunki publikowania
Aby m�c publikowa� potrzeba odpowiedniego typu konta: najlepiej na
komputerze gdzie jest zainstalowany serwer httpd.
W wypadku dostawc�w
komercyjnych nale�y wykupi� odpowiedni rodzaj konta. Na wi�kszo�ci
uczelni
istnieje mo�liwo�� za�o�enia w�asnej strony w ramach normalnego konta,
i to
cz�sto nawet bez ingerencji administratora (zazwyczaj nale�y za�o�y� w
swoim katalogu domowym katalogu
public_html
lub
www
(zwykle jest to ustawialne w pliku
srm.conf
dyrektyw�
UserDir
lub podobn�.
. Istnieje tak�e
kilka serwer�w komercyjnych umo�liwiaj�cych publikowanie materia��w
niekomercyjnych bez wnoszenia op�at. Istniej� te� serwery
umo�liwiaj�ce
,,darmowe'' us�ugi: e-mail i niekomercyjne publikowanie na WWW.
Darmowe tzn. nie p�acisz firmie, ale za to firma mo�e
udost�pnia� (lub w inny spos�b wykorzystywa�) Tw�j adres innym
(co powoduje zalew �mieciem reklamowym).
� <http://free.polbox.pl/>
� <http://www.pocketpress.com.pl/free/>
� <http://www.hotmail.com/>
� <http://www.geocities.com/>
i na troch� innych zasadach:
QDnet <http://www.QDnet.pl/>
Patrz te�:
� Darmowe us�ugi w/g Paw�a Wi�cka
<http://la.ists.pwr.wroc.pl/~coven/tech/freenet.html.po>
�
lista dostawc�w Internetu Jarka Rafy
<http://www.wsp.krakow.pl/providers/providers.htm>
5.2.
Prawa autorskie
Nale�y przyj��, �e (przynajmniej w wypadku polskich stron) obowi�zuj�
przepisy
Ustawy o prawie autorskim i prawach pokrewnych z 04.02.1995
<http://www.pocketpres.com/>
Przy czym (na podstawie art. 1 punkt 1 i punkt 2 ustawy), o ile autor
nie
zaznaczy� inaczej wszystkie strony s� domy�lnie oznaczone jako �
b�d� (C) i mo�na podawa� do nich odniesienie, nie mo�na natomiast
ich wykorzystywa� we w�asnej pracy (tj. tre�ci powi�zanej z form�,
poniewa� czystej informacji to ju� nie dotyczy) bez zgody (najlepiej
pisemnej) autora (w�a�ciciela (C)). Ochronie podlegaj� r�wnie� znaki
firmowe (lecz mo�na ich u�y� w celach informacyjnych).
Nie mo�na jednak popada� w przesad�: ze wgl�du na rodzaj medium
nie mo�na domaga� si� pe�nej integralno�ci i nienaruszalno�ci dzie�a.
� Nie mo�na zakaza� kopiowania dokumentu w
jakiejkolwiek
formie. (wystarczy �e przegl�darka musi
�ci�gn�� dokument na komputer lokalny)
� Nie mo�na domaga� si� by dokument zachowa� sw� integralno�� i
identyczno�� graficzn� (bo nie mo�emy wymaga� by� przegl�dany w
zadanych ustawieniach przegl�darki je�li np. zosta� przeskanowany
przez
``robota''
, albo jest interpretowany
przez przegl�dark� dla niewidomych (np. z syntezatorem mowy).
Patrz te�:
�
�wiat Wiedzy
9/96
5.3.
Terminologia
WWW "
Wszechnica Wiedzy Wszelakiej
{Marka Cara},
paj�czyna
,
site "
miejsce w Internecie
{Microsoftu}
o�rodek w Webie
{PC Magazine PL}
w�ze� sieci
,
serwer
link "
odno�nik
,
odwo�anie
{s� te� stanowczo przeze mnie odradzane:
hiperpo��czenie
,
��cznik
,
skr�t
service "
us�uga
download "
za�aduj
,
�ci�gnij
,
zapami�taj
upload "
za�aduj na serwer
serwer "
serwer
,
sztafarz
browser "
przegl�darka
,
paj�czarka
applet " ?
bookmark "
zak�adka
Patrz te�:
� ???
5.4.
Wieloj�czyna paj�czyna - polskie znaki diakrytyczne
W jaki spos�b mog� tworzy� poprawne strony z polskimi
znakami diakrytycznymi?
Przede wszystkim nale�y u�ywa� kodowania w ISO-8859-2. Poza tym je�li
nie jeste� administratorem i nie mo�esz spowodowa�, �eby serwer
dodawa� do
nag��wka stron z polskimi literami deklaracji typu dokumentu:
text/html; charset=iso-8859-2
nale�y doda� w nag��wku strony
(pomi�dzy <HEAD> i </HEAD>, a przed <TITLE> )
nast�puj�c� instrukcj�:
<META HTTP-EQUIV="content-type"
CONTENT="text/html; charset=iso-8859-2">
nie jest to rozwi�zanie najbardziej eleganckie: powoduje (na
niekt�rych serwerach i z niekt�rymi przegl�darkami (np. Netscape Navi
gator)
dwukrotne interpretowanie zawarto�ci dokumentu, nie jest w pe�ni
uwzgl�dnione w specyfikacji HTML. Tym nie mniej dop�ki nie doczekamy
si�
(b�d�, sami nie przyczynimy si� ;-) do uznania przez grona normaliza
cyjne i
producent�w oprogramowania faktu, �e w WWW stosuje si� i inne, poza
anglosaskim zestawy znak�w, pozostaje nam stosowanie p�rodk�w.
Patrz te�:
� ``Sekcja: Standardy: Wieloj�zyczno��''
� Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/>
� Apache - wieloj�zyczny serwer w/g Paw�a Wi�cka
<http://la.ists.pwr.wroc.pl/%7Ecoven/tech/langtech.html>
5.5.
Czy mog� w Paj�czynie umieszcza� dokumenty w
innym formacie ni� HTML?
Jakie formaty plik�w?
Tak. Ale trzeba pami�ta� o tym, aby nie by�y ograniczone tylko do
jednej platformy sprz�towej/systemowej. I dlatego nie nale�y u�ywa�
surowych plik�w MS Worda czy QuattroPro. Warto je prze�o�y� na jaki�
powszechnie uznany standard taki jak PostScript, RichTextFormat,
CVS, PDF, HTML.
Je�li nie jest to mo�liwe?
W takim razie nale�y doda� odpowiednie deklaracje
MIME types
serwera.
Oznaczenia typ�w plik�w znajduj� si� w
comp.mail.mime FAQ
<http://sunsite.icm.edu.pl/pub/usenet/comp.mail.mime/>
5.6.
Dostawca us�ug internetowych
Czy na publikowanie czego� w Sieci musz� mie� jak�� koncesj�
O ile nie �wiadczysz telekomunikacyjnych us�ug powszechnych, nie
sprzedajesz dost�pu do sieci, ani nie ��czysz sieci w budynkach
mieszkalnych
- nie potrzebujesz. Ale to temat na inn� grup�
<news:pl.listserv.polip>.
6.
Tworzenie - HTML
6.1.
Zasady sk�adni HTML
HTML jest aplikacj�
``SGMLa''
Sk�adnia dokumentu HTML jest definiowana przez kombinacj�
deklaracji SGML
(definuj�cej m.in. zakres dopuszczalnych znak�w)
oraz
DTD
. Wyra�enia znakuj�ce sk�adaj� si� z
cz�ciej otwieraj�cej a zamykaj�cej.
W pierwszej cz�ci jest to sekwencja
<znacznik>
za� w drugiej
jest to
</znacznik>
(< to znak mniejszo�ci za� > to znak wi�kszo�ci i s� to
HTML (i w wi�kszo�ci j�zyk�w opartych na SGMLu) znaki zastrze�one
do znakowania).
Po w�a�ciwym poleceniu mog� nast�powa�
jego atrybuty (wraz z warto�ciami)
<znacznik atrybut=wartosc>
Nie s� istotne typowe elementy steruj�ce: spacje, tabulatory,
znaki ko�ca linii (og�lnie znaki o kodzie ASCII poni�ej 32)
(s� one zbijane w jeden).
W niekt�rych przypadkach nie jest wymagane zamki�cie polecenia
znakuj�cego.(np.<P>, <LI>) cho� czasem
mo�e si� to nieciekawie sko�czy� (zw�aszcza nie-ko�czenie polece�
,,wymieniaj�cych'' takich jak <UL>, <OL>).
Cz�� przydatnych na codzie� znak�w u�ywanych przez polecenia
znakuj�ce zosta�a zast�piona przez tzw.
entries
rozpoczynaj�cych
si� od znaczka & (Ampersand):
� < - < - znak mniejszo�ci
� > - > - znak wi�kszo�ci
� " - " - znak cala
(stosowany powszechnie jako cudzys��w)
� " " - - znak kr�tkiej spacji
� & - &
� oraz znaki z zakresu powy�ej 127 w tablicy ISO-8859-2 (Latin-1)
W parametrach atrybut�w mog� (bez uj�cia w " lub ') wyst�powa�
jedynie
znaki z zakresu a-Z, poza tym kropki, znak my�lnika
(przeniesienia).
(wyst�puj� przy tym problemy zwi�zane z literk� � w atrybutach
(nawet uj�t�
w cudzys�owy np.
<IMG SRC="foo" ALT="���">). Istotna jest kolejno�� zagnie�dze�
znacznik�w (ew. patrz
przegl�d sk�adni Coguara <http://www.digilab.com.pl/dtd/Coguar/DTD-
HOME.html>
by� mo�e rozwin� z tego kurs HTMLa ;-)
6.2.
Najkr�tszy dokument
Wed�ug specyfikacji HTML 3.2 najkr�tszy dokument
wygl�da w tak:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<TITLE>Tytu� dokumentu</TITLE>
cho� zwykle stosuje si�:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=ISO-8859-2">
<!--komentarz: to polski dodatek, niezyt elegancki -->
<TITLE>Tytu� dokumentu</TITLE>
</HEAD>
<BODY>
zawarto�� dokumentu
</BODY>
</HTML>
6.3.
Podstawowe znaczniki
<HTML> " oznaczenie pocz�tku dokumentu HTML
<HEAD> " sekcja nag��wkowa (definicje dotycz�ce
ca�ego dokumentu, miejsce na wsadzenie informacji o stosowanych
stylach,
relacjach mi�dzy dokumentami itd).
<BODY> " sekcja g��wna dokumentu (ca�a reszta ;-)
<TITLE> " tytu� dokumentu
<A> " (od ANCHOR) wymaga co najmniej jednego z dw�ch
atrybut�w: HREF="
``URL''
" lub
name="punkt"
oraz zako�czenia (to co znajduje si� pomi�dzy pocz�tkiem a
ko�cem
wyra�enia stanowi obszar aktywny po��czenia (czyli trzeba
klikn�� myszk�
na tek�cie z wyra�enia aby uruchomi� odno�nik i przenie�� si� do
innego dokumentu).
<LINK> " pozwala na zdefiniowanie zale�no�ci mi�dzy
dokumentami.
<META> " wnosi dodatkowe informacje na temat dokumentu.
<STONG> " wyr�nienie
<EM> " wyr�nienie
<H1> " nag��wek 1 stopnia
Patrz te�:
� ``rekomendacja dla HTML 3.2''
� ``RFC 1886''
� opis Wilbura czyli HTML 3.2
<http://www.htmlhelp.com/reference/wilbur/>
autorstwa Gallacusa
a tak�e wersja offline
<http://www.htmlhelp.com/reference/wilbur/wilbur.zip>
� WWW FAQ Thomasa Boutella <http://www.boutell.com/faq/>
� Kurs HTML Paw�a Wimmera z Wydawnictwa Lupus
<http://www.polbox.com.pl/lupus/html/>
� Panorama HTML <http://winter.it.com.pl/html/>
z
Projektu Winter
� WWWhowto - Jak zrobi� swoja strone WWW? Tomasza Pi�ata
<http://ajax.umcs.lublin.pl/%7Eponcjusz/WWWhowto/>
(jest tam te� dzia�aj�cy on-line validating parser HTML Wilbur
SWAT <http://ajax.umcs.lublin.pl/%7Eponcjusz/SWAT/>
� Jak stworzy� w�asn� stron� WWW (Grzegorza W�jcika)
<http://www.ia.pw.edu.pl/pl-iso/homepage-info.html>
� Jak zrobi� w�asn� stron� WWW
<http://www.pk.edu.pl/sysdocs/howto.html>
(wskaz�wki dla u�ytkownik�w z PK)
(Szymona Soko�a i Grzegorza Muchy)
� Opis polece� j�zyka HTML z przyk�adami
<http://www.wibro.agh.edu.pl/info/www/html/reference/>
Roberta Paj�ka
� KROTKI KURS HTML
<http://panda.bg.univ.gda.pl:80/%7Ekrabek/kurs.html>
� Jak zrobi� swoja w�asn� HomePage ?
<http://zeus.polsl.gliwice.pl/%7Ebort/local/how-to.html> Andrzeja
Borta
� Opis HTML autostwa ,,Statoma''
<http://www.polsl.gliwice.pl/~statom/HTML/HTML.html>
czyli Tomasza Stankiewicza
� The Bare Bones Guide to HTML <http://werbach.com/barebones/>
kr�tki
(15kb) spis wszystkich komend HTML wraz z netscapizmami
(zaznaczonymi)
�
Beginner's Guide to HTML
<http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html> z
NCSA
�
Creating HTML Documents
<http://www.ncsa.uiuc.edu/SDG/Software/Mosaic/Docs/d2-htmlinfo.html>
(te� NCSA)
�
HTML Charter <http://www.ietf.cnri.reston.va.us/html.charters/html-
charter.html> - po�wi�cona HTMLowi grupa robocza
IETF <http://www.ietf.org/>
6.4.
Przydatne wskaz�wki
� gdy tworzysz wi�kszy zestaw dokument�w warto najpierw
stworzy� projekt (w tym graficzny), szablon dokumentu. Nie od
rzeczy jest
tutaj u�ycie technologii CSS1 (w celu zapewnienia sp�jnej szaty
graficznej serwisu - a to �e jeszcze nie obs�uguj� jej niekt�re
przegl�darki -
nie szkodzi
nied�ugo b�d�)
� staraj si� tworzy� dokumenty ,,znaczeniowe''
a ,,wygl�dowe''.
� pami�taj o tym by w dokumencie (niekoniecznie w jego jawnej
cz�ci)
znalaz�a si� informacja o:
� adresie pocztowym autora
(<link REV="MADE" HREF="mailto:zie...@digilab.com.pl">
� dacie aktualizacji,
� miejscu planowanej publikacji
(cho� nie koniecznie trzeba do tego celu u�ywa� kontrukcji
<BASE *>),
� prawach autorskich (zw�aszcza nie swoich)
Patrz te�:
�
6.5.
Wsp�praca z przeszukiwarkami
Warto dostosowa� swoje dokumenty do istnienia przeszukiwarek i innych
robot�w przez zdefiniowanie dodatkowej informacji o dokumencie:
kr�tki opis " <META
name="Description" CONTENT=" To jest kr�tki opis ">
s�owa kluczowe " <META
name="Keywords" CONTENT=" WWW, FAQ ">
informacja o prawch autorskich " <META
name="CopyRight" CONTENT=" Ziemek Borowski (GNU v.2.0) ">
informacja o autorze " <META
name="Author" CONTENT=" Ziemek Borowski ">
informacja o adresie pocztowym autora " <LINK REV="MADE"
HREF="mailto:zie...@digilab.com.pl">
data powstania dokument�w " <META
name="Create" CONTENT=" Sat 15 Mar 1997 19:26:58 ">
data ostatniej modyfikacji dokumentu " <META
name="Modification" CONTENT="Sat 15 Mar 1997 19:26:58 ">
Patrz te�:
� Opis META <>
6.6.
Dlaczego standardy s� istotne?
Netscapizmami
zwie si� popularnie te rozszerzenia akceptowane tylko i
wy��cznie przez przegl�darki firmy Netscape Communications Corporation
, i
ostatnio przez MS Internet Explorer, nie zarejestrowane w oficjalnej
specyfikacji (b�d� jej propozycji) j�zyka HTML.
Nie nale�y ich u�ywa� poniewa�:
� nie ma mo�liwo�ci sensownego sprawdzenia parserem/validatorem
SGML takiego
dokumentu (zazwyczaj brak jest oficjalnych DTD (i nawet
nieoficjalnych, np. dla IE 3.0, lub NN 3.0) dla takich rozszerze�)
� dokumenty te nie zawsze mog� by� poprawnie
wy�wietlane w przegl�darkach innych
producent�w. A HTML b�d�cy (zw�aszcza w wersjach 2.0 i Wilbur)
bardzo
ubogim znaczeniowo zastosowaniem SGML-a, zosta� stworzony po to, by
istnia�a wsp�lna, niezale�na od sprz�tu i systemu platforma
informacyjna.
� niekt�re rozszerzenia nie mieszcz� si� w �aden spos�b w sk�adni
istniej�cych DTD HTMLowych
;-) np. te zwi�zane z ramkami... (FRAMES)
Patrz te�:
�
6.7.
Jak kontrolowa� poprawno�� kodu?
Dlaczego: to chyba oczywiste ka�dy chyba chce �eby rzeczywisty efekt
pokrywa� si� z planowanym, tak treraz jak i w przysz�o�ci, gdy
przegl�darki
b�d� np. �ci�lej trzyma� si� standardu.
Powszechnie stosowan� metod� jest ,,r�czne'' sprawdzanie za pomoc�
wybranej dowolnie ,,przegl�darki testowej'' takiej jak np. Lynx,
Netscape,
lub MS IE. Jest to dzia�anie co najmniej w�tpliwe: przegl�darka
powinna
wy�wietla� wszystkie (nawet z b��dami sk�adniowymi) strony poprawnie,
cho�
niekoniecznie zgodnie z intencjami jej autor�w. Poprawn� form�
sprawdzania
strony jest raczej u�ycie parsera/validatora
SGML takiego jak na przyk�ad
SP <http://www.jclark.com/sp/>
Jamesa Clarka (dost�pny tak dla DOS (32-ext.) Win32,
jak i UNIXa wraz z odpowiednim
DTD dla stosowanego dialektu HTMLa
<http://www.w3.org/pub/WWW/MarkUp/html-pubtext/>
W wyniku kontroli np.
nsgmls -m /usr/lib/pubtext/catalog -f nazwa.err -o nazwa.out nazwa.htm
powstaje lista b��d�w (przez skierowanie potoku b��d�w do
pliku) na podstawie, kt�rej nale�y ,,r�cznie'' poprawi� dokument.
Dopiero
potem warto sprawdzi� w przegl�dace, czy przypadkiem czego� istotnego
nie
przeoczyli�my...
Dobr� metod� jest u�ycie jednego z wielu zdalnych weryfikator�w kodu
HTMLa (patrz ni�ej), lub jednego z dost�pnych weryfikator�w
,,lokalnych'':
� weblint (PERL) <http://www.cre.canon.co.uk/~neilb/weblint/>
� SQ Panorama <http://www.sq.com/> dla MS Windows
Odradza�bym stanowczo u�ywnie rozmaitych wynalazk�w przyjaznych ale
nie do
ko�ca wiedz�cych co to s� na przyk�ad opcje minimalizacji.
Patrz te�:
� Validation-HTML
<http://sunsite.umc/mdw/Documentation/HOWTO/mini/Validation-HTML>
� Validations Services (WDG)
<http://www.htmlhelp.com/lins/validation.html>
� oparty na nsgmls J. Clarka KJV <http://*/KVC/>
- klasyka gatunku.
� SWAT Tomasza (Ponckiego) Pi�ata
<http://ajacs.umcs.lublin.pl/%E7poncjusz/SWAT/> - bardzo dobre
narz�dzie dla tych
kt�rzy tworz� w HTML 3.2
6.8.
Ramki? Nie stosowa�!!!
Dlaczego?
� nie odpowiedniego DTD,
� nadal bardzo trudno umie�ci� jak�� stron� w zak�adkach,
� starsze przegl�darki nie akceptuj�,
� �atwo zapomnie� o poleceniu <NOFAMES>
6.9.
Pytania r�ne
6.9.1.
Czy mog� ukry� kod �r�d�owy dokumentu?
Nie. I bardzo dobrze. Po prostu kod �r�d�owy dokumentu w HTML musi
by� zakodowany bez �adnych ogranicze�, aby mo�na by�o czyta� dokumenty
nie do
ko�ca sprowadzone na lokalny komputer.
6.10.
Narz�dzia
Gdy mowa o narz�dziach s�u��cych do kreowania dokument�w
w HTMLu cz�sto trudno doj�� do porozumienia. Cz�� ludzi twierdzi,
�e najlepszym narz�dziem jest... Windowsowy
Notatnik
Inni twierdz�, �e ma za ma�e mo�liwo�ci wyszukiwania i zamiany
wi�c zalecaj� Vi;-) S� to zwolennicy
edytor�w poziomu
,,r�cznego''
. S� tacy kt�rzy chcieli by jednak mie�
jak�� form� spomagania tworzenia dokument�w przez pod�wietlanie
sk�adni i mo�liwo�c wybrania z listy dobranych znacznik�w. Ci
s� zwolennikami
,,edytor�w niskiego poziomu''
. S�
jednak te� zwolennicy edytor�w graficznych tzw.
WYSIWYG
czyli ,,wysokiego poziomu''. Lecz bardzo cz�sto zapomina si� o innego
typu narz�dziach np. konwerterach z innych format�w (w tym SGMLowych)
rozmaitych preprocesorach (zwykle pisanych ,,wieloplatformowo'' w C
lub perlu)
u�atwiaj�ch tworzenie du�ych o�rodk�w:
� Orb <http://www.cinenet.net/users/cberry/orbinfo.html>
� HTXP <http://www.mcs.anl.gov/home/kwong/htxp1.htm>
� DocuGen <http://www.sil.org/> czyli ,,Document Preparation Aids
for Non-Major Languages''
� CVS i RCS <http://www.loria.fr/~molli/cvs-index.html>
;-)
6.10.1.
MS-Windows
Gdy mowa o narz�dziach pomagaj�cych tworzy� dokumenty hipertekstowe
w �rodowisku MS Windows (TM) zawsze mam ochot� stwierdzi�, �e mo�na
u�y�
Emacsa <http://www.Xemacs.org/>
lub
``ViMa''
Ale nie tego si� po mnie oczekuje. Niestety ;-).
To co osobi�cie mog� zaleci� to:
� SQ HoToMetaL PRO 3.0 <http://www.sq.com/>
ew. je�li mamy mniej pieni�dzy:
SQ HoToMetaL Free 2.0 <http://www.sq.com/>
� do pewnego typu prac, i ze sporymi zastrze�eniami (natury, mhyyy,
sk�adniowej)
MS FrontPage <http://www.microsot.com/poland/>
� TextEdita <http://www.textedit.com>
jako dobry, i ,,czysty''
a jednocze�nie dostosowywalny edytor czysto tekstowy.
� ReSoLV Worker <http://gdzie�/>
Odradzam natomiast (zw�aszcza do szybkich poprawek)
dobr� przegl�dark�, ale gorszy edytor:
Netscape Navigatora Gold <http://www.netscape.com/>
(zostawia za du�o w�asnego, niepoprawnego,
kodu przy ka�dym zapami�taniu).
Patrz te�:
� The Ultimate Collection Of Winsock Software
<http://www.tucows.com/>
(bli�ej s� mirory:
Tucows na SunSite <http://sunsite.icm.edu.pl/pub/tucows/>
i
Tucows na PW <http://alfa2.it.pw.edu.pl/tucows/>
)
� The CWSApps List
<http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html>
-
Indeks Aplikacji Sieciowych dla Windows (mirror w Poznaniu)
� Papa's Anonymous FTP <ftp://ftp.man.poznan.pl/pub/winsock-l/>
(w Poznaniu)
� www.Windows95.com shareware and freeware
<http://www.windows95.com/>
6.10.2.
Unix
Wbrew temu co niekt�rzy m�wi� dla Unixie jest mn�stwo cennych narz�dzi
do edycji HTML (i generalnie SGMLa). Poczynaj�c od spreparowanych pod
k�tem HTML plik�w startowych
Vi
,
ViMa <http://www.math.fu-berlin.de/%7Eguckes/vim/>
,
joe
,
Emacsa <http://www.santafe.edu/%7Enelson/tools/>
i
XEmacsa, <http://www.XEmacs.org/>
dochodz�c do dedykowanych HTMLowi
asWedita <http://SunSite.icm.edu.pl/pub/www/asWedit/>
i edytora z
Ayamayi (W3C) <http://www.w3.org/>
Istotne s� te� liczne narz�dzia skryptowe takie jak na przyk�ad
WebLint <http://www.cre.canon.co.uk/~neilb/weblint/> (do kontroli
poprawno�ci),
Latex2HTML
<http://cbl.leeds.ac.uk/nikos/tex2html/doc/latex2html/latex2html.html>,
SGML-Tools <http://web.inter.nl.net/users/C.deGroot/sgmltools/>,
perlSGML, <http://www.oac.uci.edu/indiv/ehood/perlSGML.html>
sdc, <ftp://ftp.inria.fr/INRIA/Projects/icsla/Implementations>
oraz preprocesory takie jak
Orb <http://www.cinenet.net/users/cberry/orbinfo.html>
lub
HTXp <http://www.mcs.anl.gov/home/kwong/htxp1.htm>
7.
Tworzenie - grafika
7.1.
Istniej�ce formaty graficzne
Istnieje kilka uznanych format�w grafiki s�u��cych do prezentacji
w paj�czynie:
� GIF
� JPEG
� PNG
� nieoficjalnie: XBM, XPM
� i inne, ale ju� tylko przy pomocy
``wtyczek (plug-in�w)''
Patrz te�:
�
7.2.
Zasady umieszczania grafiki
� Pami�taj o tym by nie zamieszcza� na stronie startowej
wielkich (tj. razem powy�ej 20 kb) element�w graficznych.
Mo�esz tym odstraszy� (wolne/prze�nione ��cza)
� Pami�taj o atrybucie ALT poleczenia IMG
� Niech grafiki stanowi� drobne urozaicenie tekstu, immanetn� ca�o��
jako ilustracje a nie jako�� sam� w sobie:
Patrzcie co potrafi� zrobi� PhotoShopem
� Staraj si� nie robi� element�w zawieraj�cych napisy jako grafik�.
A nu� kto� to b�dzie chcia� obejrze� na monitorze 21 calowym ;-)
Pomijaj�c fakt, �e to uniemo�liwia normalne indeksowanie
takich napis�w (niekt�re roboty nie czytuj� tego co jest
zamieszczone jako
ALT
).
Patrz te�:
�
7.3.
Efekty specjalne
7.3.1.
,,Prze�roczyste grafiki''
Aby przygotowa� prze�roczyste grafiki, tj. w kolorze dowolnie
definiowanego t�a lub podk�adu, nale�y zapami�ta� je w formacie GIF
89a
przy pomocy np.
LView Pro 1.0 dla Windows <http://world.std.com/%7Emmedia/lviewp.html>
(lub z mirrora:
<http://alfa2.ia.pw.edu.pl/tucows/>
)
albo
giftrans
dla DOSa
<http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.exe>
i/lub
UNIX <http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.1.gz>
7.3.2. Animacje
Do tworzenia animowanych rysunk�w mog� s�u�y�:
Gif Construction Set dla Windows
<ftp://ftp.dtp.std.com/ftp/vendors/mmedia/gifcon.exe>
WebPaint - shareware dla W95 <http://www.barentsnett.no/webpaint/>
GifMerge dla UNIXa <http://www.iis.ee.ethz.ch/%7Ekiwi/GIFMerge/>
Patrz te�:
�
7.4.
Pytania r�ne
Patrz te�:
�
8.
Tworzenie - Java, JavaScript, CGI, SSI
8.1. Po co stosowa� programy w przekazie informacji
Czasem trzeba. I to nie po to by
uatrakcyjny� statyczne strony Web
a po to by
� zapewni� dost�p do danych z bazy
� umo�liwi� wyszukiwanie
� zapewni� informacj� zwrotn�
� u�atwi� autentyfikacj�
Patrz te�:
�
8.2.
Statyczne - dynamiczne
Nie wiem czemu wszelkie pisma m�wi�c o Paj�czynie i Javie pisz�
o statycznych dokumentach HTML i wnoszeniu ruchu do nich...
Uwa�am za haniebn� praktyk� tworzenie lataj�cych ramek, spodk�w i
napis�w.
Uwa�am, �e wszelkie stosowanie oprogramowania powinno dotyczy�
systuacji, gdy dane s� po prostu oprawiane w form� HTMLow�.
Patrz te�:
�
8.3.
Bazy danych
Jakie s� dost�pne bazy danych mo�liwe do stosowania w Paj�czynie?
Odpowied� brzmni pewnie:
wszystkie
. Ale trzeba
wybra� jeden produkt.
Ja osobi�cie poleca�bym
Postgres <http://www.postgresql.org/>
na Unixie (a zw�aszcza
Linuxie <http://www.Linux.org.pl/>
). Dlaczego?
� d�uga historia (10 lat - pocz�tek prac na zlecenia DARPA i NSF)
� relacyjna
� rozszerzalna
� cechy obiektowe
� dost�p przy pomocy podzbioru SQL
� istnieje interface do WWW
Poza tym niekt�rzy zalecaj�:
� mSQL <http://hunges.com.au/>
(cho� baza ta dost�pna jest za darmo jedynie dla instytucji
edukacyjnych),
�
miniSQL - T.c.X. Data Konsult <http://tcx.se/>
� dost�pny teoretycznie za darmo cho� na dziwnych zasadach
MICRO/CDS/ISIS <http://www.medianet.com.pl/~cc/>
rodem z UNESCO.
� Oracle <http://www.oracle.com.pl/>
� Essentia <http://www.inter-soft.com/produkts/essentia/>
Patrz te�:
� Micha� Mosiewicz
Linux i bazy danych
{w:}
Linux+ <http://www.linux.com.pl/>
3/1997 (ISSN 1427-55-62)
8.4.
Przeszukiwanie
Aby udost�pni� przeszukiwanie swojego serwera mo�na:
8.4.1. instalowa� search-engine
oczywi�cie taka czynno�� wi��e si� z ryzykiem doci��enia maszyny. Ale
czego si� nie robi dla odbiorc�w naszej informacji ;-).
Z czego mo�na wybiera�?
� SWISH <http://www.eit.com/software/swish/>
� GlimpseHTTPd <http://glimpse.cs.arizona.edu/ghttp/>
(kopia na SunSite.ICM)
<http://Sunsite.icm.edu.pl/pub/unix/glimpse/>
� ht:/dig <http://htdig/>
(RPM na SunSite.ICM) <ftp://ftp.icm.edu.pl/pub/Linux/redhat-
contrib/RPMS/>
8.4.2. zmusi� publicznie dost�pne roboty do indeksowania naszych
zasob�w
W wypdaku niekt�rych publicznie dost�pnych us�ug przeszukiwawczych
mo�liwe jest zaw�enie poszukiwa� okre�lonej klasy URL. Nic (poza
zdrowym
rozs�dkiem i potencjalnym protestem ich w�a�cicieli) nie stoi na
przeszkodzie
napisaniu odpowiedniej formatki
wyszukuj�cej u�ywaj�cej np.
<http://www.hotbot.com/>
lub
<http://infoseek.icm.edu.pl:8000>
8.5.
Lataj�ce spodki
W jaki spos�b mam spowodowa� by odbiorcy mojej strony mogli
na niej pogra� w k�ko i krzy�yk?
Nie wiem. Najlepiej by�oby chyba zaprz�c do tego celu Jav�.
Patrz te�:
� ????
8.6.
W jaki spos�b mog� zainstalowa� licznik na stronie?
Nie nale�y tego robi� poniewa�, zazwyczaj, liczniki k�ami�, nie
uwzgl�dniaj�c odwo�a� do strony przez Proxy-Cache, powoduj�
niepotrzebne
obci��enie serwera (graficzne), i jest przejawem niepotrzebnego
efekciarstwa. Je�li jednak te argumenty s� nieprzekonuj�ce polecam:
� <http://www.webtools.org/counter/>
� <http://www.w4.nl/software/counter/>
� <ftp://ftp.ibspan.waw.pl/pub/unix/html-counter/>
albo skorzystanie z opisu autorstwa Tomasza Pi�ata (sprawdzony jedynie
z
NSCA HTTPd 1.4. i dzia�aj�cy na bazie
Server Side Include
):
nale�y za�o�y� w katalogu gdzie mamy stron�, do kt�rej chcemy
liczy� dost�py plik
AddType text/x-server-parsed-html index.html
AddType application/x-httpd-cgi count.cgi
- gdzie
index.html
to nazwa tej strony,
a
count.cgi
nazwa pliku programu
licznika (obie linijki powinny by� zako�czone Enterem). Oto zawarto��
tego
drugiego:
#!/usr/bin/perl
open (COUNT,"count") ;
$counter =<COUNT>;
close (COUNT) ;
open (COUNT, ">count") ;
print COUNT +($counter+1) ;
close (COUNT) ;
print $counter;
exit(0) ;
mo�e zaistnie� potrzeba zmiany �cie�ki do PERLa (to jest
#!/usr/bin/perl).
Naj�atwiej sprawdzi�, gdzie jest PERL pisz�c:
whereis perl
lub
which perl
Wykonujemy co nast�puje:
touch count
chmod 777 count
chmod 505 .htaccess
chmod 505 count.cgi
W pliku
count
znajdowa� si� b�dzie liczba odwiedzin.
Umieszczamy na stronie cos takiego:
Te strone odwiedzilo juz
<!-#exec cmd="/usr/bin/perl count.cgi"->
gosci!
Uwaga cenzora: powinno by�:
Te strone pobrano juz <!-#exec cmd="/usr/bin/perl count.cgi"-> razy od dnia
zainstalowania licznika lub jego resetowania.
(TP)
9.
Serwery
9.1.
Jaki serwer wybra�?
Jakie serwery WWW (HTTP) s� dost�pne?
Pytanie rzeka... najlepiej spojrze� na stron�
WebCompare <http://webcompare.iworld.com/>
gdzie szczeg�owo opisano (i por�wnano)
wi�kszo�� dost�pnych serwer�w WWW.
Ja osobi�cie u�ywam
boa <http://www.boa.org/>
-
ma�ego, taniego (GNU) i chodz�cego (niezale�nie od ustawie�) jako
nobody nie
za� jako root.
Inni preferuj�
Apache 1.2 <http://sunsite.icm.edu.pl/pub/www/apache/>
i wcale si� im nie dziwi� - pot�ne narz�dzie, z do��
�atw� integracj� z bazami danych, opcjami takimi jak: wirtualny serwer
i
u�ywane na tyle powszechnie (podobnie jest z
sendmailem <http://www.senmail.org/>
), �e skutecznie
przetestowane
(
Netcraft <http://www.netcraft.com/>
donosi
�e Apache stanowi ponad 40% wszystkich u�ywanych w Internecie serwer�w
HTTPd -
a nast�pny developer, Microsoft, ma tylko 10% udzia��w w rynku ;-).
A potencjalne niebezpiecze�stwa mo�na zwalcza� przez zainstalowanie
,,wrapper�w'' i �cian ognia.
Wartym uwagi produktem (cho� po cz�ci testowym)
jest napisany przez zesp� z
W3C
serwer
Jigsaw <http://www.w3.org/pub/WWW/Jigsaw/>
(w Javie wi�c
naprawd� wieloplatformowy, a w dodatku jako jeden z pierwszych prawie
w
pe�ni realizuj�cy HTTP/1.1).
S� wreszcie tacy, kt�rzy lubi� p�aci� za... co� co mog� otrzyma�
niemal za
darmo... Tym polecam { ;-)))) } produkty firm:
� Microsoft <http://www.mirosoft.com/poland/>
(gdy mowa o
serwerach mamy do wyboru
Personal Web Serwer
,
albo
Internet Information Serwer
)
� NetScape Comunication <http://home.netscape.com/>
� Lotus/IBM <http://www.notes.net>
i
Lotus Notes wraz serwerem HTTP
Domino <http://domino.lotus.com>
Patrz te�:
� <http://www.webcompare.com/>
9.2.
Platforma sprz�towa
Oboj�tna... Na pytanie:
Jak� platform� sprz�tow� wybra�?
odpowied� brzmi:
Nie Unixa, nie MacIntosha, nie MS Windows,
a t� na kt�rej si� najlepiej znasz i kt�rej ufasz...
Patrz te�:
� <http://www.webcompare.com/>
9.3.
Obs�uga b��d�w
O klasie danego serwisu (serwera) decyduje nie tylko to
jakie us�ugi proponuje, ale tak�e to jak sobie radzi z sytuacjami
nietypowymi - czy gdy u�ytkownik �le wpisze adres krzyczy na niego
Bad URL
, czy te� stwierdza
Chyba si� pomyli�e�. Masz oto skr�cony spis mojej zawaro�ci,
i wybierz prosz�, to czego szuka�e�. Mo�esz tak�e skorzysta� z moich
us�ug wyszukiwawczych
Spos�b reakcji na najbardziej podstawowe b��dy (typu
404: file not found
lub
403: Forbiden
mo�na ustawi� w pliku
srm.conf
(w rodzinie serwer�w z NSCA).
Patrz te�:
� NCSA httpd
<http://hoohoo.ncsa.uiuc.edu/docs/setup/ConfigureInfo.html#Directive>
9.4.
Implementacja SSL (by KravietZ)
9.4.1. Q: Jak nawi�zuje si� po��czenie SSL?
Podaj�c w URLu protok� "https". Np.
<https://www.verisign.com/>
Oczywi�cie, nie z ka�dym serwerem WWW mo�na si� po��czy� przez SSL.
Jednak praktycznie wszystkie serwery maj�ce co� wsp�lnego z zakupami
przez Internet na to pozwalaj�. W Netscape i MSIE bezpieczne
po��czenie
jest oznaczane przez z��czenie z�amanego kluczyka w lewym dolnym rogu
ekranu.
9.4.2. Q: Kt�re przegl�darki obs�uguj� SSL?
Z najpopularniejszych: Netscape, MSIE i Lynx 2.7 (od niedawna).
Niestety ameryka�skie prawo nak�ada ograniczenia (ITAR) na eksport
program�w zawieraj�cych zaawansowane algorytmy kryptograficzne,
wobec czego Netscape i MSIE s� rozpowszechniane w dw�ch wersjach:
eksportowej (klucz 40-to bitowy) i ameryka�skiej (128-mio bitowy).
Ostatnimi
czasy klucze 40-bitowe kilkukrotnie z�amano dla wykazania
nies�uszno�ci
ITAR i nale�y je uznawa� za niepewne.
Oficjalnie wersji 128-mio bitowych nie wolno eksportowa� ze Stan�w,
ale
oczywi�cie ju� dawno zosta�o to zrobione i mo�na je sobie �ci�gn��
z Europy.
Lynx-SSL (v2.7) jest dost�pny na razie tylko w postaci RPM�w pod
Redhata
(Linux) i u�ywa kluczy 128-mio bitowych. Obs�uga SSL w Lynxie
jest w tej chwili bardzo ograniczona (brak zarz�dzania certyfikatami
lub
jakiejkolwiek konfiguracji SSL).
Jest jeszcze jeden program z kluczem 128-mio bitowym - WorkHorse
(pod MS Windows), przeznaczony z za�o�enia do home-bankingu. Z tego
powodu
ma s�abo rozbudowane wodotryski i obs�ug� HTMLa, za to bardzo bogate
funkcje
zabezpieczania transakcji (PGP, PEM, ECheque, SSL) i inne, r�wnie
interesuj�ce.
Wszystkie wymienione programy mo�na �ci�gn�� z
<ftp://ftp.replay.com/pub/replay/pub/browsers/>
(Holandia) lub z mirrora na
<ftp://pipeta.chemia.pk.edu.pl/pub/replay/browsers/>
Na obu serwerach mo�na
te� sobie wypr�bowa� po��czenie SSL.
9.4.3. Q: Jak postawi� bezpieczny serwer WWW?
Trzeba uruchomi� serwer WWW z wbudowan� obs�ug� SSL, wygenerowa�
klucze
dla serwera i kupi� (lub wygenerowa� sobie) dla nich certyfikat od
jednej
z zajmuj�cych si� tym firm CA (certyfying authorities). Koszt tej
operacji
zaczyna si� od ok. 100 USD.
Je�li chodzi o serwer, to poza kilkunastoma komercyjnymi istnieje
darmowe
Apache-SSL, opieraj�ce si� o tak�e darmow� implementacj� SSL - SSLeay.
SSLeay obs�uguje klucze 128-mio bitowe i ma wszystkie funkcje
generowania oraz
certyfikacji kluczy tak, �e mo�na zosta� swoim w�asnym CA.
Na Apache-SSL jest oparte s� popularne komercyjne serwery Stronghold
oraz Sioux.
Certyfikat dla serwera mo�na sobie wygenerowa� samemu przy u�yciu
SSLeay
(czyli zosta� swoim w�asnym CA), ale wi��� si� z tym niedogodno��
opisana
w nast�pnym pytaniu.
Decyduj�c si� na komercyjny serwer nale�y si� dok�adnie dowiedzie�
czy nie jest on obj�ty ograniczeniami eksportowymi, �eby nie kupi�
kota w worku (czyli serwera obs�uguj�cego klucze max. 40-to bitowe).
9.4.4. Q: Czy wszystkie przegl�darki akceptuj� wszystkie certyfikaty?
Nie. Najpopularniejszym - i jednym z najdro�szych CA - jest
Verisign <http://www.verisign.com/>
Jego certyfikaty akceptuj� wszystkie wersje Netscape i MSIE. Netscape
od wersji 2.0 przyjmuje certyfikaty nieznanych sobie CA, po
zatwierdzeniu
przez u�ytkownika. MSIE 3.0 jest ,,m�drzejsze'' i czego� takiego nie
pozwala
robi�.
Obecnie najta�szym CA jest
Thawte Consulting <http://ww.thawte.com/>
,
kt�ra bierze za to 100 USD i jej certyfikaty s� rozpoznawane
przez wszystkie przegl�darki. Thawte certyfikuje tak�e Apache-SSL.
9.5.
Strony na has�o
W danym katalogu nale�y umie�ci� plik
o zawarto�ci:
AuthName this page
AuthType basic
AuthUserFile /home/looser/.htpasswd
AuthGroupFile /dev/null
<Limit GET PUT>
require user secret
</Limit>
opis do kodu:
� tekst ,,this page'' mo�na zast�pi� czymkolwiek.
�
/dev/null
z
AuthGroupFile
nale�y zast�pi� nazw�
pliku (o ile chcemu stworzy� grup�)
� plik wymieniony w
AuthUserFile
powinien znajdowa� si� w katalogu domowym u�ytkownika,
nie za� w
public_html
lub innym powszechnie dost�pnym.
Has�a dodaje si� odpowiednim programem:
htpasswd -c /home/looser/.htpasswd secret
(-c je�li tworzymy nowy plik)
htpasswd
jest w dystrybucji NCSA i Apache, w katalogu
support
W przypadku gdy u�ytkownik�w ma by� wi�cej ni� kilkudziesi�ciu, nale�y
przej�� na format DB lub DBM. Przeszukiwanie plik�w DB i DBM jest
znacznie
szybsze ni� zwyk�ego tekstowego
. Ustawienia s� analogiczne,
tylko
�e zamiast zbioru funkcji Auth* mamy AuthDB* lub AuthDBM* i do
zarz�dzania
9.6.
Wirtualny serwer
Po to aby m�c utworzy� wirtualny serwer (czyli u�ywaj�c tej
samej maszyny m�c serwowa� dokumenty pod r�nymi nazwami i u�ywaj�c
r�nych katalog�w wystarczy jedynie odpowiednio skonfigurowa� serwer,
(tj. doda� odpowiednie dyrektywy w plikach konfiguracyjnych serwera,
oraz -
co jest zalecane ale pono� nie niezb�dne - doda� now� form� interface
sieciowego - w wypadku
linuxa <http://www.linux.org.pl/>
z odpowiednio skompilowanym j�drem wystarczy wyda� jedynie odpowiednie
polecenie:
/sbin/ifconfig eth0 alias www.domain1.com ;-)
oraz doda� wirtualn� nazw� dla naszej maszyny do DNS.
Patrz te�:
� <http://sunsite.unc.edu/mdw/HOWTO/mini/Virtual-Web>
�
<http://hohoo.ncsa.uiuc.edu/>
9.7.
Robot exlusion
Nale�y pogodzi� si� z istnieniem rozmaitych robot�w w paj�czynie ;-).
To dzi�ki nim mo�na przeszukiwa� paj�czyn�, to dzi�ki nim mo�liwe jest
tworzenie indywidualizowanych us�ug dostarczaj�cych informacje a nie
dane,
wreszcie sprawdzanie powprawno�ci powi�za� pomi�dzy dokumentami.
A to �e czasem maj� ochot� �cign��, dynamicznie tworzone strony, albo
rozmaite
niepowo�ane zasoby (jak na przyk�ad nieopatrznie ,,ods�oni�ty''
katalog z wszystkimi RFC?
Jest na to rada.
Ju� w pocz�tkach WWW (czyli w lipcu 1994 r. ;-) zosta� opracowany
nieformalny
standard for Robot Exclusion
do kt�re stosuj� si� wszystkie ,,przyzwoite <***>'' roboty.
Opiera si� on na sprawdzaniu przez robota istnienia pliku
/robots.txt <http://www.webcrawler.com/robots.txt>
zawieraj�cego polecenia:
� User-agent: (jako parametr
nazwa robota
<http://info.webcrawler.com/mak/projects/robots/active.html> *
znaczy - wszystkie)
� Disallow: /nazwa/zasobu (je�li bez nazwy znaczy, �e robot mo�e
indeksowa�
wszystko) .
Poza tym istniej� (jeszcze niezbyt powszechnie uznane) zakl�cia
<META
takie jak np <META
name="robots" CONTENT="NOINDEX">
Patrz te�:
�
<http://info.webcrawler.com/mak/projects/robots/norobots.html>
� The Standard for Robot Exclusion
<http://www.archive.org/robotexclusion.html>
� Standard for Robot Exclusion Revised
<http://www.kollar.com/robots.html>
�
Hypertext Links in HTML - W3C Working Draft
<http://www.w3.org/pub/WWW/TR/WD-htmllink>
10.
Bezpiecze�stwo WWW
Trzy podstawowe rady:
� czytaj
CERT Adisories <http://www.cert.org/Adivsory/>
� uruchamiaj jedynie tu us�ugi kt�re s� niezb�dne
� staraj si� uruchamia� daemony z jak najmniejszymi uprawnieniami
(najlepiej jako
nobody
)
� The World Wide Web Security FAQ
<http://www.genome.wi.mit.edu/WWW/faqs/www-security-faq.html>
Lincoln D. Stein <mailto:lst...@genome.wi.mit.edu>
� security FAQ <gdzie�>
� CERT/CC <http://www.cert.org/>
� NASK CERT <http://www.nask.pl/CERT/>
;-)
10.1.
Java
Teoretycznie w
Jav� <http://www.javasoft.com/>
(podobnie jak w
ActiveX <http://www.AcitiveX.com>
wbudowane s� mechanizmy ograniczaj�ce mo�liwo�ci
destabilizacji pracy systemu. Jednak
nie ma oprogramowania bez
b��d�w
. Wi�c najlepiej (na codzie�) wy��czy� we w�asnej
przegl�darce mo�liwo�� interpretowania obiekt�w
JAVY
i
ActiveX
Patrz te�:
� The World Wide Web Security FAQ
<http://www.genome.wi.mit.edu/WWW/faqs/www-security-faq.html>
Lincoln D. Stein <mailto:lst...@genome.wi.mit.edu>
�
10.2.
CGI
Patrz te�:
�
10.3.
Serwery
Patrz te�:
�
11.
Dzi�kuj�:
� Rafa�owi Maszkowskiemu <http://www.torun.pdi.net/%7Erzm/>
za uwagi i zapuszczenie robota wysy�aj�cego tekst na grup�
pl.comp.www
� Markowi B�czkowi <http://www.QDnet.pl/%7Emgb/>
za miejsce w paj�czynie
� Grzegorzowi Staniakowi <mailto:gsta...@golem.umcs.lublin.pl>
za cenne uwagi (zw�aszcza o SGMLu)
� Piotrowi T�czy�skiemu <http://hum.amu.edu.pl/%7Epteczyn/>
za tropienie b��d�w i b��dzik�w (nie tylko merytorycznych)
� Wojciechowi Myszce <mailto:W.My...@immt.pwr.wroc.pl>
za uwagi i podej�cie do problem�w polskiej Sieci ;-)
� Paw�owi Wi�ckowi <http://www.ists.pwr.wroc.pl/%7Ecoven/>
za informacje o serwerach, ViMie i
Linux Denian/GNU <http://www.debian.org/>...
� Wojtkowi Sylwestrzakowi <mailto:woj...@icm.edu.pl>
za W3 cache i fragmenty tekstu mu po�wi�cone.
� Jerzemu Pankiewiczowi <mailto:panki...@pwr.wroc.pl>
za uwagi
� Tomaszowi (Ponckiemu) Pi�atowi
<http://ajax.umcs.lublin.pl/%7Eponcjusz/>
za fragment o licznikach, URLe i wiele innych rzeczy ;-)
� Marcinowi Cie�lakowi <mailto:sa...@sgh.waw.pl>
za uwagi
� Bogus�awowi Friesowi <mailto:fr...@digilab.com.pl>
� Jaros�awowi Zieli�skiemu <mailto:j...@it.com.pl>
za cenne uwagi i
<http://winter.it.com.pl>
� Pawe� Krawczyk <http://www.ceti.com.pl/~kravietz/>
za fragmenty tekstu po�wi�cone SSL i
ograniczniu dost�pu do serwera.
� Linus Torvalds <mailto:li...@linux.helsinki.fi>
:-) za Linuxa
� Free Software Foundation <http://www.gnu.ai.mit.edu/>
za GNU Public Licence (GPL) v. 2.0
� Charles F. Goldfarb <http://www.SGMLsource.com/>
za SGML
� Tim Berners-Lee
za pomys� paj�czyny...
�
� Tees A. de Groot <mailto:C.de...@Inter.nl.net>
� Ulrich Windl <mailto:ulrich...@rz.uni-regensburg.de>
� Tom Gordon <mailto:thomas...@gmd.de>
� Matt Welsh <mailto:m...@sunsite.unc.edu>
� Greg Hankins <mailto:gr...@linux.org>
i innym kt�rzy wnie�li sw�j wk�ad w stworzenie pakietu
SGML-Tools <http://web.inter.NL.net/users/C.deGroot/sgmltools/>
� Bramowi Moolenaarowi
za ViMa a zw�aszcza wersj� 4.x.
� Jimowi Clarkowi <mailto:jcl...@jclark.com>
za
SP
� Tillmannowi Steinbrechergowi
za
UNTGZ <http://privat.schlund.de/tst/untgz.htm>
--
Rafal Maszkowski r...@torun.pdi.net http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID:
<pl.comp.www-1-862008438@torun.pdi.net>Path:
mbox-mo1.pugleaf.net!unknown!not-for-mailShow Full Headers
Complete Article Headers
From: Ziemek Borowski <zie...@qdnet.pl> Subject: pl.comp.www FAQ Date: 1997/04/25 Message-ID: <pl.comp.www-1-862008438@torun.pdi.net> X-Deja-AN: 238364652 Distribution: world Sender: r...@rymunda.torun.pdi.net Supersedes: <pl.comp.www...@torun.pdi.net> X-Posting-Frequency: Posted on 1st and 15th day of each month Followup-To: poster Organization: Rafal Maszkowski Keywords: WWW World Wide Web Reply-To: zie...@qdnet.pl (Ziemek Borowski) Newsgroups: pl.comp.www,pl.answers MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit