Article View: pl.comp.os.advocacy
Article #5962blokada portu 25 (fwd)
From: Qrczak
Date: Thu, 07 May 1998 17:50
Date: Thu, 07 May 1998 17:50
129 lines
6776 bytes
6776 bytes
Przesyłam na odpowiedniejszą grupę...
--
QRCZAK
__("< Marcin Kowalczyk
\__/ qrczak@knm.org.pl
^^ http://qrczak.home.ml.org/
---------- Forwarded message ----------
Date: 7 May 1998 13:38:34 +0200
From: Szymon Sokol <szymon@galaxy.uci.agh.edu.pl>
Newsgroups: pl.pregierz
Subject: Re: blokada portu 25
[ Article reposted from pl.comp.security ]
[ Author was Artur Urbanowicz <artur@apollo.umcs.lublin.pl> ]
[ Posted on 7 May 1998 09:04:40 GMT ]
Witam,
Musze poinformowac, ze przewijajacy sie w Waszej dyskusji
pomysl nie przyjmowania poczty od programow firmy Microsoft jest
nieco spozniony. Kto by pomyslal? Zdziwicie sie, bo to Microsoft
wykonal pierwszy ruch!
Zglosila sie do mnie osoba, ktora otrzymywala uporczywe zwroty
poczty wysylanej do domeny eragsm.com.pl (bez obrazy, ERA GSM)
z zadziwiajacym komentarzem:
<smtp eragsm.com.pl xxxx@eragsm.com.pl -1>: ...\
<<- RCPT To:<xxxx@eragsm.com.pl> \
ORCPT=rfc822;xxxx@eragsm.com.pl
->> 501 Syntax Error (this is abnormal, investigate!)
Poniewaz w sieci, z ktorej korzysta wysylajacy listy osobiscie
instalowalem hosta linuxowego z programem 'zmailer'
(www.zmailer.org), poczulem sie w obowiazku rzecz cala sprawdzic.
Na wszelki wypadek przygotowalem nieco popiolu na moja glowe
- bardzo nie lubie fuszerki, rowniez wtedy, gdy to ja cos spartacze.
W koncu to sam program nakazal: investigate, zas administrator
www.eragsm.com.pl poinformowal uzytkownika, ze "[...] nasz mail
exchanger podlaczony jest do sieci przez filtr protokolu SMTP
i ten nie przepuszcze niektorych niezestandaryzowanych nowinek [...]"
doradzajac jednoczesnie, by slac poczte zgodnie z RFC, tak jak
Microsoft.
Sprawdzilem, ze program przyjmujacy poczte na hoscie
mail.eragsm.com.pl ('Microsoft Exchange Internet Mail Service
5.5.1960.3') zglasza sie jako serwer obslugujacy rozszerzenia
ESMTP, na ostrozne 'EHLO' odpowiada ich dumna lista, w ktorej
znajduje sie rowniez DSN (Delivery Status Notification).
Po takiej zachecie 'zmailer' kontynuuje konwersacje, dodajac
do 'RCPT' dodatkowy parametr 'ORCPT', a kto ciekaw, po co tak
czyni, niech siegnie do RFC1891. Niestety - Microsoftowy partner
w tej konwersacji zapomina nagle jezyka w gebie i reaguje
calkiem niedobrze, odsylajac '501 Syntax Error'.
Rzecz sama w sobie warta jest co najwyzej wzmianki w kolejnym
Service Pack, gdybym szukajac w archiwach firmy Microsoft rady
na nieprawidlowe dzialanie ich produktu nie znalazl komentarza
do innej poprawki, mowiacego co nieco o podejsciu firmy Microsoft
do standardow RFC:
When a connection begins for the Microsoft Mail Gateway to SMTP,
the first thing that occurs is a greeting exchange between the
TCP/IP host and the SMTP gateway computer. RFC 822 specifies that
these greeting replies include host names. However, the SMTP
gateway does not include the host names in its greeting replies.
Most hosts ignore this particular piece of the 822 RFC.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^!!!!!!!!
When communicating with an IBM VM host running IBM VM SMTP V2R2, an
error may occur because IBM VM requires that the host name be
included. As a result, the gateway log file, SMTPGATE.LOG, will
record the following error message:
ERROR Network_read: Lost network connection
Rady na problem eragsm.com.pl (upieram sie to tak nazywac)
co prawda nie znalazlem, ale wiem przynajmniej, ze firma Microsoft
w podobnie rozbrajajacy sposob zignorowala sekcje 5.2 dokumentu
RFC1891 przy implementacji opisanych tam funkcji w swoim produkcie.
Rozwiazania s(m)ieciowe firmy Microsoft mam zreszta w glebokim
niepowazaniu od czasu natkniecia sie na problemy ze wspolpraca
UNIX-owego serwera DHCP z klientem w Win95. Dla koneserow
dyplomacji proponuje lekture dokumentu 2929694 z Knowledgebase
firmy Novell, ktory rzecz ostroznie wyjasnia. Wybitny przyklad
chodzenia po szkle w wykonaniu solidnej, moim zdaniem, firmy Novell:
We do not intend to say that the Win95 TCPIP is totally at fault
but this TID was produced to point out issues we have noticed with
using the Win95 TCPIP. There are areas where the Win95 TCPIP is NOT
compliant with RFC 1541. Out of the 3 points that are mentioned
in the Causes section, the ARP issue and the DHCPDECLINE issue
have been fixed in the NT4.0 client and it appears that the patch
mentioned above DOES fix these issues for Win95.
It has been said that using the NT Server DHCP will resolve some
of these issues and that is a true statement because the Win95
TCPIP and the NT server are "designed" to work best with each other
(from our observation). If the customer were to use the Novell
DOS/Windows Client32 TCPIP with the Novell DHCP Server they would
not have these issues either. We continue to make Novell's Client
TCPIP and Server DHCP comply fully with the RFC. The client side
is very compliant at this time. The new DHCP server will be
compliant with RFC 2131. We will continue to ensure that our
DHCP server works as well with the WIN 95 TCP/IP as we possibly
can, within the guidelines of the applicable RFCs.
It is NOT our intention to get into a "finger pointing" situation
with MS. There are areas where the Novell DHCP server needs to be
changed and we are doing or have done that. At the same time
there are issues with the Win95 TCPIP that we need to make our
customers aware of so they can work with the appropriate entity
to resolve the problems.
Byc moze ktos mi podpowie, ktore jeszcze RFC zostaly przez
firme Microsoft pogwalcone - przez pomylke programisty lub
dla utrzymania okienkowego monopolu. Ja w kazdym razie
NIE POLECAM NIKOMU STOSOWANIA PRODUKTOW FIRMY MICROSOFT DO
CELOW LACZNOSCI INTERNETOWEJ.
Pozdrawiam: Artur Urbanowicz
--
A GGGG H H Szymon Sokół -- administrator sieci
A A G H H Uczelniane Centrum Informatyki Akademii Górniczo-Hutniczej
AAAAA G GGG HHHHH al. Mickiewicza 30, 30-059 Kraków. FAX +48 12 6338907
A A GGGG H H http://galaxy.uci.agh.edu.pl/~szymon/ TEL +48 12 6172894
Technical Details
Message-ID:
<Pine.LNX.3.96.980507194903.306C-100000@qrnik.knm.org.pl>Path:
mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!news.task.gda.pl!qrnik.knm.org.pl!qrnik.knm.org.pl!qrczakShow Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!news.task.gda.pl!qrnik.knm.org.pl!qrnik.knm.org.pl!qrczak From: Qrczak <qrczak@knm.org.pl> Newsgroups: pl.comp.os.advocacy Subject: blokada portu 25 (fwd) Date: Thu, 7 May 1998 19:50:26 +0200 Organization: Klub Nieszkodliwych Manjaków Lines: 131 Message-ID: <Pine.LNX.3.96.980507194903.306C-100000@qrnik.knm.org.pl> NNTP-Posting-Host: ppp4-79.warszawa.tpnet.pl Mime-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit