Article View: pl.answers
Article #98pl.comp.www FAQ
From: Ziemek Borowski
Date: Fri, 15 Nov 1996 00:00
Date: Fri, 15 Nov 1996 00:00
1458 lines
62238 bytes
62238 bytes
Posted-By: auto-faq 3.1.1.2
Archive-name: pl.comp.www
pl.comp.www FAQ czyli NZPiO
Ziemek Borowski & inni.
Wersja 0.6.0.15 - 21.10.96 godzina 23:59:59
Zawsze dost�pne pod adresem
<http://www.qdnet.pl/~Ziembor/pl.comp.www/> oraz wersja tekstowa (bez
polskich liter). <http://www.qdnet.pl/~Ziembor/wwwfaqpl.txt> Wersja
skompresowana: <http://www.qdnet.pl/~Ziembor/wwwfaqpl.tgz> (czasem
mo�e by� potrzebny program untgz (GNU - 211kb)
<http://www.qdnet.pl/~Ziembor/untgz_.exe>) Chwilowo pod adresem:
<http://www.qdnet.pl/~Ziembor/pl.comp.www/cr/> znajduje si� wersja bez
polskich liter... (i b�dzie dop�ki na IBM 3090 z VM/CMS i w b�ednie
administrowanych sieciach nie da si� uzyska� przybli�enia polskich
znak�w).
______________________________________________________________________
Table of Contents:
1. Autorzy, deklaracje, kwestie porz�dkowe.
1.1. Koordynator i (w charakterze sklejacza) autor :-)
1.2. komentuj�, wsp�pracuj� i/lub pomagaj�
1.3. Czy ta grupa ma swoje archiwum?
1.4. Czy mog� zaprenumerowa� t� grup� tak jak normaln� list�
dyskusyjn�?
1.5. W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?
2. Wst�p, og�lny opis WWW.
2.1. Co to jest Internet?
2.2. Co to jest Web, WWW?
2.3. Kto wyznacza standardy dla Internetu i WWW???
2.4. Co to jest
2.5. Co to jest HTML?
2.6. Co to jest URL?
2.7. Co to jest CGI?
2.8. Co to jest VRML?
2.9. Co to jest Java i JavaScript?
2.10. Co to jest plug-in?
2.11. Co to jest ActiveX?
2.12. Co to jest Broadway?
2.13. Co to jest SSI?
2.14. Co to jest SSL?
2.15. Co to jest ONE?
2.16. Kto u�ywa WWW i Internetu?
3. Jakich narz�dzi u�ywa� do pracy z WWW.
3.1. Jakie przegl�darki s� dost�pne dla DOSa?
3.2. Jakie przegl�darki s� dost�pne dla MS Windows 3.x i MS Windows
95/NT?
3.3. Jakie s� dost�pne przegl�darki dla
4. U�ytkowanie WWW.
4.1. Czy jest jaki� katalog tematyczny WWW?
4.2. Jak mog� znale�� jaki� tekst na stronie Web?
4.3. Dlaczego cz�sto widz� ,,krzaczki'' zamiast polskich liter?
4.4. Czy u�ywaj�c WWW mo�na z�apa� wirusa?
4.5. W jaki spos�b nawigowa� po Paj�czynie ?
4.6. Jak jest z prawami autorskimi w Internecie?
4.7. W jaki spos�b pracowa� z WWW bez bezpo�redniego po��czenia?
4.8. Co to jest i dlaczego nale�y u�ywa� W3cache-proxy?
5. Tworzenie - og�lne.
5.1. Jak mog� publikowa� w WWW?
6. HTML
6.1. Jak wygl�da dokument WWW?
6.2. Co jest standardem w
6.3. Jakie narz�dzia wspomagaj�ce tworzenie dokument�w WWW s�
dost�pne dla DOSa/Win i MS Windows 95/NT?
6.4. Jakie narz�dzia wspomagaj�ce tworzenie dokument�w WWW s�
dost�pne dla
6.5. Co to s� netscapizmy oraz inne rozszerzenia? I dlaczego nie
nale�y ich stosowa�?
6.6. W jaki spos�b mog� tworzy� poprawne strony z polskimi znakami
diakrytycznymi?
6.7. Dlaczego i w jaki spos�b sprawdza� poprawno�� sk�adniow�
dokument�w?
7. Grafika na stronach WWW?
8. CGI i programowanie w WWW.
8.1. W jaki spos�b mog� zainstalowa� licznik na stronie?
8.2. Czy mog� w Paj�czynie umieszcza� dokumenty w innym formacie
ni�
8.3. Jakich polskich termin�w u�ywa� przy tworzeniu stron?
9. Serwery WWW
9.1. Jakie serwery WWW (HTTP) s� dost�pne i kt�ry wybra� (i pod
jakim systemem powinien pracowa�)?
9.2. Gdzie mog� znale�� opis protoko�u serwera WWW (HTTP)?
9.3. W jaki spos�b mog� na moim serwerze obs�ugiwa� jego b��dy?
9.4. W jaki spos�b poprawnie serwowa� polskie dokumenty?
9.5. Jak stworzy� stron� na has�o?
9.6. W jaki spos�b mog� udost�pni� przeszukiwanie mojego serwera?
9.7. Jak mo�na udost�pnia� baz� danych przez WWW?
10. Standardy
11. Og�lne wprowadzenia do sieci.
12. �r�d�a
12.1. �rod�a
12.2. drukowane �r�d�a
12.3. �r�d�a
12.4. �r�d�a
12.5. �r�d�a dotycz�ce innych, zwi�zanych z WWW j�zyk�w
programowania
13. Dokumenty dotycz�ce tworzenia WWW po polsku.
13.1. Dokumenty dotycz�ce tworzenia WWW w polskiej sieci.
14. Dokumenty dotycz�ce WWW w �wiatowej sieci
______________________________________________________________________
1. Autorzy, deklaracje, kwestie porz�dkowe.
1.1. Koordynator i (w charakterze sklejacza) autor :-)
Ziemek Borowski (ZMB) <mailto:zie...@qdnet.pl>
<http://www.qdnet.pl/~Ziembor/>
1.2. komentuj�, wsp�pracuj� i/lub pomagaj�
za co serdecznie im dzi�kuj� (kolejno�� quasi-losowa ;-)
� Rafa� Maszkowski (RM) <mailto:r...@torun.pdi.net>
<http://www.torun.pdi.net/~rzm/>
� Marek B�czek (MGB) <mailto:m...@qdnet.pl>
<http://www.qdnet.pl/~mgb/>
� Grzegorz Staniak (GS) <mailto:gsta...@golem.umcs.lublin.pl>
� Piotr T�czy�ski (PT) <mailto:pte...@hum.amu.edu.pl>
<http://hum.amu.edu.pl/~pteczyn/>
� Wojciech Myszka (WM) <mailto:W.My...@immt.pwr.wroc.pl>
� Pawe� Wi�cek (cov) <mailto:co...@pwr.wroc.pl>
<http://www.ists.pwr.wroc.pl/~coven/>
� Wojtek Sylwestrzak (WojSyl) <mailto:woj...@icm.edu.pl>
� Jerzy Pankiewicz (JP) <mailto:panki...@pwr.wroc.pl>
� Tomasz Pi�at (TP) <mailto:ponc...@ajax.umcs.lublin.pl>
<http://ajax.umcs.lublin.pl/~poncjusz/>
� Marcin Cie�lak (Saper) <mailto:sa...@sgh.waw.pl>
� inni, kt�rzy zg�osz� swoj� ofert� pomocy :-)
� wszyscy pisuj�cy na pl.comp.www
Deklaracje
� Je�li nie znalaz�e� tu odpowiedzi na swoje pytanie przepraszam... I
mam pro�b�: jak znajdziesz, prze�lij uzupe�nienie do odpowiedzi na
istniej�ce pytanie, b�d� napisz (wraz z odpowiedzi�) nowe.
� Gdy niniejszy dokument zostanie dopracowany (tj. osi�gnie wersj� >
1.0) b�dzie wysy�any do grupy pl.comp.www raz na dwa tygodnie,
pierwszego i pi�tnastego dnia ka�dego miesi�ca.
� Dokument ten b�dzie systematycznie uzupe�niany i w miar� pojawiania
si� nowych pyta� publikowane b�d� jego kolejne wydania.
� Autorzy nie ponosz� �adnej odpowiedzialno�ci za efekty dzia�ania
spowodowane stosowaniem si� do zalece� zawartych w dokumencie.
� Wszystkie zastrze�one znaki firmowe zosta�y u�yte jedynie w celach
informacyjnych.
� Dokument nie ma �adnej mocy prawnej b�d� administracyjnej i
powo�ywanie si� na udzielone w nim odpowiedzi oraz porady jest
bezpodstawne.
� Dokument mo�e by� dowolnie u�ywany i rozpowszechniany, jednak w
wypadku publikacji prosz� o poinformowanie o tym fakcie, a w
wypadku zamieszczenia w Internecie prosz� ponadto o zobowi�zanie
si� do systematycznego uaktualniania.
� Dokonywanie zmian bez zgody i wiedzy autora dokumentu jest
niewskazane. cho� dopuszczalne, przy zachowaniu praw autoskich i
zaznaczeniu jakie fragmenty uleg�y zmianie.
� Wi�kszo�� tekst�w jest autorstwa Ziemka Borowskiego, cho� bardzo
cz�sto oparte s� na lekturze, np. artyku��w w grupie
<news:pl.comp.www>. Je�li autorem danego fragmentu jest kto� inny,
jest to zaznaczone przez podanie inicja��w autora tego fragmentu
(*), lub uzupe�nienia (+*). Tym nie mniej Ziemek Borowski bierze na
siebie odpowiedzialno�� za ca�o�� tekstu.
� Zawarto�� pl.comp.www FAQ opiera si� g��wnie na listach z grupy
usenetowej pl.comp.www oraz ew. pl.comp.lang.java ,
pl.listserv.polip , pl.comp.ogonki , je�li tylko maj� zwi�zek z
tematem.
Kwestie porz�dkowe
1.3. Czy ta grupa ma swoje archiwum?
Nie... (ewentualnie mo�esz szuka� w DejaNews
<http://www.dejanews.com/forms/dns.html> ;-) Ale trzeba uwa���: jest
tam ustawiony nag��wek Pragma: NoCache, i blokada dla robot�w (wi�c
nie mo�na �ci�gn�� ca�ego archiwum ,,do domu'').
1.4. Czy mog� zaprenumerowa� t� grup� tak jak normaln� list�
dyskusyjn�?
Nie i bardzo dobrze... ;-) (sprz�enie z list� to tylko niepotrzebne
k�opoty z polskimi literkami oraz g�upie pytania: jak si� wypisa�? .
;-)
1.5. W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?
Daleki jestem od ods�dzania od czci wszystkich, kt�rzy zadaj� pytania
nie konkretne, b�d� takie na kt�re odpowied� znajduje si� na drugiej
stronie manuala, podr�cznika b�d� FAQ. Ale prosz�... Zanim zadasz
jakie� pytanie:
� zastan�w si�, czy to co ci� trapi jest rzeczywi�cie problemem. By�
mo�e spotka�e� si� ju� z podobn� sytuacj� i tylko co� Ci na chwil�
rozum za�mi�o :-)
� przejrzyj dost�pn� lokalnie dokumentacj�... Po to si� j� tworzy.
� poszukaj FAQ (czyli zbioru najcz�ciej zadawanych pyta� wraz z
odpowiedziami) zwi�zanego z nurtuj�cymi ci� problemami... w Polsce
znajdziesz je pod adresem <http://sunsite.icm.edu.pl/pub/usenet/>
� Sprawd� archiwa: <http://www.dejanews.com/forms/dnq.html> i tam
wpisz grup�: pl.comp.www
� spytaj lokalnego administratora... chyba, �e ma Ci� ju� do��, b�d�
sam nim jeste� :-)
� poszukaj przy pomocy katalogu tematycznego b�d� wyszukiwarki
A je�li to nie pomo�e... to pytaj... Ale pami�taj, �e zadawanie
pyta� te� jest sztuk�. Tutaj, w grupie pl.comp.www ograniczymy si�
do wskaz�wek raczej technicznych.
� napisz dok�adnie: jaki masz problem... (jakiego systemu u�ywasz i z
jakim programem (i jak� jego wersj�) masz k�opoty)
� je�li szukasz jakiego� programu, napisz jak si� nazywa, jakie
wymagania ma spe�nia� i co najwa�niejsze w jakim systemie
operacyjnym ma dzia�a�...
� nie zaszkodzi poda� gdzie szuka�e�
I pami�taj: to, �e kto� Ci odpowie to tylko i wy��cznie jego dobra
wola.
2. Wst�p, og�lny opis WWW.
Poni�ej przedstawiam og�lne informacje dotycz�ce World Wide Web.
2.1. Co to jest Internet?
W RFC 1462, lub FYI 20 Internet zosta� zdefiniowany jako:
� sie� komputerowa oparta na protoko�ach TCP i IP (tzw. TCP/IP),
� zasoby dost�pne na komputerach po��czonych z sieci� (tzw. hostach)
� spo�eczno��, wsp�lnota (community) ludzi u�ywaj�cych i
rozwijaj�cych t� sie�,
2.2. Co to jest Web, WWW?
WWW (World Wide Web), zwana inaczej Paj�czyn� , Webem jest
hipertekstowym, multimedialnym, sieciowym, opartym na TCP/IP systemem
informacyjnym.
hipertekstowym
czyli takim gdzie istniej� zdefiniowane zale�no�ci miedzy
poszczeg�lnymi dokumentami, i mo�liwo�ci dowolnego
przemieszczania si� pomi�dzy nimi.
multimedialnym
czyli dopuszczaj�cym stosowanie r�nych �rodk�w przekazu:
tradycyjnych tekst�w, d�wi�k�w, grafiki.
sieciowym
opartym na sieci rozleg�ej Internet, a wi�c o zasi�gu
praktycznie globalnym.
2.3. Kto wyznacza standardy dla Internetu i WWW???
Ostateczn� instancj� zatwierdzaj�c� dan� propozycj� standardu jest
Internet Engineering Task Force czyli w skr�cie IETF.
<http://www.ietf.org/> Swoje propozycje w zakresie WWW przedstawia mu
The World Wide Web Consortium (W3C) b�d�ca organizacj� skupiaj�c�
producent�w oprogramowania.
2.4. Co to jest SGML i HTML? I jakie s� ich wzajemne zwi�zki?
Standard Generalized Markup Language oraz HyperText Markup Language
:-) SGML to j�zyk tworzenia j�zyk�w oznacze�. HTML i inne podobne
j�zyki opisane w r�nych DTDs s� jego zastosowaniem, aplikacj�. Ka�dy
dokument SGML w zasadzie sk�ada si� z trzech cz�ci:
� deklaracja SGML, opisuj�ca zestawy znak�w, mechanizmy sk�adniowe i
pewne pocz�tkowe warto�ci stosowane w dokumentach danego typu;
� DTD czyli definicja typu dokumentu opisuj�ca struktur� j�zyka
oznacze� czyli zestaw element�w, model zawarto�ci ka�dego z nich,
dopuszczalne i domy�lne warto�ci atrybut�w etc;
� sam dokument, czyli document instance , np. konkretna strona HTML.
W przypadku aplikacji zorientowanej na jeden tylko typ dokumentu,
deklaracja sk�adni mo�e by� stosowana domy�lnie (+ opcje zmiany)
lub wszyta w kod, do wariant�w DTD nast�puje odwo�anie przez
deklarowanie typu dokumentu (DOCTYPE) z publicznym identyfikatorem,
po czym idzie ju� sam dokument. Tak powinno by� te� w
przegl�darkach HTML, ale jak wiadomo znajomo�� SGML ich autor�w
jest nik�a, wiec deklaracja SGML jest po prostu ignorowana, w
najlepszym razie stosowana na oko. Edytory HTML (zazwyczaj
operuj�ce rozmaitymi rozszerzeniami HTML dla kt�rych zazwyczaj nie
ma odpowiednich DTD) wstawiaj� deklaracje DOCTYPE w zasadzie tylko
w celu wywarcia wra�enia na klientach.
(GS+ZMB)
2.5. Co to jest HTML?
HTML jest, a w�a�ciwie powinien by�, konkretn� aplikacj�
(zastosowaniem) SGML opisan� w odpowiednim DTD. Niestety najcz�ciej
jest to (w praktyce) oddzielny j�zyk, maj�cy tylko pewne elementy
wsp�lne z SGML... Rozwijany przede wszystkim przez The World Wide Web
Consortium (W3C) (tam te� mo�na znale�� specyfikacje i odsy�acze do
podr�cznik�w)
2.6. Co to jest URL?
Uniform Resource Locator Wygl�da mniej wi�cej tak
<http://www.cos.tam.pl:80/jakis/katalog/jakis.plik.html> I jest
z�o�ony z nazwy us�ugi:
� file://... - odno�nik do zasob�w lokalnych komputera (nie nale�y
chyba u�ywa� w sieci :-)
� ftp://... - odno�nik do zasob�w dost�pnych za pomoc� protoko�u
FTP, z wariantem ftp://u�ytkownik@... lub
ftp://u�ytkownik:has�o@...
� gopher://... - odno�nik do zasob�w Gopher
� http://... - zbi�r obs�ugiwany bezpo�ednio przez serwer httpd
(WWW)
� maito:... - odno�nik powoduj�cy wys�anie listu pod podany adres
(bez // po dwukropku!!!)
� news:... - odno�nik powoduj�cy uruchomienie przegl�darki USENETU
(news) u�ywaj�c domy�lnego serwera, i podanej grupy
� telnet:... - odno�nik do zdalnego komputera, zazwyczaj u�ywaj�c
terminala VT100 (bez // po dwukropku!!!)
� tn3270:... - odno�nik do zdalnego komputera IBM (np. 3090 na
plearn.edu.pl) terminala IBM-3270 (bez // po dwukropku!!!)
� wais: - odwo�anie do systemu wyszukiwawczego WAIS:
<http://www.ict.pwr.wroc.pl/cgi-bin/tswais>
� newsrc:... - Odno�nik do okre�lonego pliku newsrc
� nntp://... - Okre�la inny ni� domy�lnie u�ywany serwer news�w
oraz:
� adresu (mo�e by� IP lub s�owny typu www.my.computer)
� numeru portu pod kt�rym jest dost�pna dana us�uga - o ile
standardowy (tj. wg. RFC 1738 ) niepotrzebny.
� �cie�ki dost�pu do pliku ((zako�czonej - cho� nie jest to
bezwzgl�dny (tj. wg. specyfikacji) wym�g) znaczkiem / o ile nie
jest to pe�na �cie�ka, a tylko nazwa katalogu) Je�li podajemy
jedynie katalog na serwerze wy�wietlany jest jedynie plik
zdefiniowany w ustawieniach serwera jako domy�lny. Zazwyczaj jest
to index.html , index.htm lub .
� nazwy pliku
(+PT)
2.7. Co to jest CGI?
Common Gateway Interface jest specyfikacj� umo�liwiaj�c� komunikacj�
przegl�darki z programami uruchamianymi przez serwer. Opisana zosta�a
na powszechnie znanym serwerze W3C:
<http://www.w3.org/pub/WWW/Daemon/User/CGI/Overview.html> oraz
<http://hoohoo.ncsa.uiuc.edu/cgi/> a tak�e
<http://www.vservers.com/reference/> i CGI Programmer`s Reference
2.8. Co to jest VRML?
Vitual Reality Modeling Language jest to, wykorzystuj�cy niekt�re
mechanizmy WWW (takie jak httpd, czy URL), j�zyk opisu scen
tr�jwymiarowych oparty na formacie Open Inventor stworzonym przez
Silicon Graphics. Istnieje ju� wersja 2.0:
<http://vag.vrml.org/VRML2.0/FINAL/> (plik PS - 1.2Mb, po rozpakowaniu
17Mb - s� tam te� inne wersje)
2.9. Co to jest Java i JavaScript?
JAVA ma by� w za�o�eniach obiektowym j�zykiem programowania
niezale�nym od systemu operacyjnego i sprz�tu stworzonym przez Sun
INC. JavaScript jest jego uproszczon� wersj�.
2.10. Co to jest plug-in?
Plug-in`em nazwano programy wspomagaj�ce przegl�darki WWW,
umo�liwiaj�ce np. czytanie niestandardowych format�w plik�w.
2.11. Co to jest ActiveX?
ActiveX jest technologi� opracowan� przez NetManage, umo�liwiaj�c�
wstawianie obiekt�w OLE w strony WWW. Moim zdaniem nie nale�y stosowa�
tej technologii, chyba, �e nie chcemy, �eby wi�kszo�� u�ytkownik�w WWW
to zobaczy�a.
2.12. Co to jest Broadway?
,,Uniwersalny dost�p za po�rednictwem Paj�czyny do interaktywnych
aplikacji'' -- taki jest slogan reklamowy. Ze znaczkiem X na masce,
rzecz jasna. <http://www.x.org/consortium/broadway.html> Wi�cej
szczeg��w: Piotr T�czy�ski Premiera na Broadway`u . UNIXForum,
4/1996 s.13-15.
2.13. Co to jest SSI?
Server-Side Include
2.14. Co to jest SSL?
Secure Socket Layer
2.15. Co to jest ONE?
2.16. Kto u�ywa WWW i Internetu?
W �wiecie powszechnie uznawany jest GVU Survey
<http://www.cc.gatech.edu/gvu/user_surveys/User_Survey_Home.html>
Natomiast w Polsce... Prowadzi si� wprawdzie r�nego rodzaju badania
ankietowe. Ale moje mniemanie o nich jest ... takie, �e lepiej
przemilcz�. Dlaczego?
� nikt nigdzie nie opisuje metody przeprowadzenia sonda�u.
� jak ju� opisuje to okazuje si�, �e tak naprawd� nie ma metody tj.
badania by�y robione tylko nie wiadomo na jakiej populacji, na ile
sk�ad respondent�w by� reprezentatywny, i jak dok�adnie brzmia�y
pytania.
� nawet gdy by�a jaka� metoda to... zadano niejednoznaczne pytania,
lub zostawiono w pytaniach z za�o�enia wielo-odpowiedziowych
mo�liwo�� wyboru tylko jednej opcji :-) . Je�li kto� zna dobrze
zrobione (tj. nie takie jak wy�ej opisane) badania w polskiej
cz�ci Internetu prosz� o informacj�.
3. Jakich narz�dzi u�ywa� do pracy z WWW.
Na razie wskazuj� �r�d�a pozyskania paj�czarek jedynie dla dw�ch
dominuj�cych rodzin system�w operacyjnych. P�niej obiecuj� to
rozszerzy� o inne takie jak: IBM OS/2, Amig�, i co tam jeszcze Boutell
wymienia :-) I zalecam zajrzenie do iWorld
<http://browserwatch.iworld.com/> do przegl�du paj�czarek...
3.1. Jakie przegl�darki s� dost�pne dla DOSa?
Nietety niewiele... Jest DOSLynx (uaktualniona wersja:
<http://www.fdisk.com/doslynx/> ) s� jakie� przegl�darki plik�w
tekstowych uwgl�dniaj�ce i HTML:
<ftp://ftp.pwr.wroc.pl/pub/pc/sac/utiltext/view114.zip>
3.2. Jakie przegl�darki s� dost�pne dla MS Windows 3.x i MS Windows
95/NT?
Niestety multum :-). I nie spos�b ich wszystkich wymieni� w tym
kr�tkim przegl�dzie. Na razie ogranicz� si� do wskazania g��wnych
archiw�w:
� Netscape Communications Corporation - Mirror na
<http://sunsite.icm.edu.pl/www/netscape/>
� Microsoft. - Mirror w Lupusie:
<ftp://ftp.polbox.com.pl/library/!lupus/>
� Tucows - The Ultimate Collection of Winsock Software
<http://alfa2.it.pw.edu.pl/tucows/>
� The CWSApps List - Indeks Aplikacji Sieciowych dla Windows
<http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html>
� Papa's Anonymous FTP <ftp://ftp.man.poznan.pl/pub/winsock-l/>
3.3. Jakie s� dost�pne przegl�darki dla UNIXa?
O ile UNIX i pochodne do tej pory dominuj� na rynku serwer�w, to
systemem przegl�darek sta� si� MS Windows. Tym nie mniej jest kilka
warto�ciowych produkt�w. Takich jak Arena, Netscape Navigator
<http://sunsite.icm.edu.pl/pub/netscape/navigator/3.0/unix/>
niezast�piony Lynx <ftp://ftp.pwr.wroc.pl/pub/infosystems/www/lynx/> W
Polsce podstawowym archiwum jest ,,sansajt''
<http://sunsite.icm.edu.pl/pub/www/> (cho� czasem, ,,dzi�ki''
Warmanowi bardzo powolnym).
4. U�ytkowanie WWW.
Poni�ej opisz� istotne aspekty u�ytkowania WWW.
4.1. Czy jest jaki� katalog tematyczny WWW?
� Wirtualna Polska: <http://wp.cnt.pl/>
� WOW!: <http://www.wow.pl/>
� OptimusNET: <http://www.optimusnet.pl/>
i �wiatowe
� Yahoo: <http://www.yahoo.com/>
� WWW Virtual Library:
<http://www.w3.org/hypertext/DataSources/bySubject/Overview.html>
4.2. Jak mog� znale�� jaki� tekst na stronie Web?
� Z tego co zrozumia�em to (w Polsce) dobrym rozwi�zaniem jest u�ycie
ICMowego serwera archie: <http://archie.icm.edu.pl/>
� DEC Alta Vista: <http://www.altavista.digital.com/>
� Yahoo: <http://www.yahoo.com/>
� Lycos: <http://fuzine.mt.cs.cmu.edu/mlm/lycos-home.html>
� WebCrawler: <http://webcrawler.com/>
� World Wide Web Worm:
<http://www.cs.colorado.edu/home/mcbryan/WWWW.html>
� InfoSeek: <http://www2.infoseek.com/>
� OpenText: <http://www.opentext.com>
� HotBot: <http://www.HotBot.com/search.html>
� i inne ... :-) wi�kszo�� dostawc�w us�ug I*netowych dostarcza odp.
formularzy do wyszukiwania na najpopularniejszych przeszukiwarkach.
4.3. Dlaczego cz�sto widz� ,,krzaczki'' zamiast polskich liter?
Jest kilka mo�liwo�ci rozwi�zania tego problemu:
� Masz niew�a�ciw� przegl�dark�, tj. nie obs�uguj�c� polskich liter w
standardzie ISO-8859-2. W miar� mo�liwo�ci wymie� j� na co� innego
(lub sprawd� czy nie mo�na tego jako� poprawi�:
<http://www.agh.edu.pl/ogonki/>)
� Twoja przegl�darka obs�uguje polskie literki, ale ty nic o tym nie
wiesz. np. nie ustawi�e� w Netscape Navigatorze 3.0 opcji:
Options|Document Ecoding|Central European (ISO-8859-2) i
odpowiedniej czcionki w Options|General_Preferences|Fonts|Latin-2
� Wina le�y po stronie autora strony: Ani w nag��wku http, (
"text/html charset=8859-2" html htm w pliku mime.types) ani w
nag��wku strony (przy pomocy komendy <meta http-equiv="content-
type" content="text/html; charset=iso-8859-2"> ) nie zadeklarowa�
polsko�ci dokumentu, ani nawet u�ywanej strony kodowej
� Wina le�y po stronie autora strony: u�ywa CP 1250 :-(
4.4. Czy u�ywaj�c WWW mo�na z�apa� wirusa?
Oczywi�cie :-) Zw�aszcza wirusa g�upoty. A powa�nie: o ile masz
wy��czon� JAVA, JavaScript, ActiveX, i nie �adujesz plik�w Worda,
PostScript oraz wykonywalnych - nie mo�esz. W pozosta�ych wypadkach:
� Pliki Worda i wykonywalne - wiadomo - mog� by� zaka�one i to nie
zale�y od medium.
� w Javie, i JavaScript znaleziono (np. w niekt�rych wersjach
Netscape Navigatora 2.0.) jakie� usterki na tyle powa�ne, �e pono�
zagra�aj�ce bezpiecze�stwu system�w.
� PostScript - mo�e zawiera� niebezpieczne operacje, kt�re pewne
przegl�darki mog� pr�bowa� wykona�: kasowanie plik�w albo
ustawienie/zmiana has�a drukarki.
� W wypadku Lynxa istnieje co� takiego (tzw. trusted hosts) co
pozwala wykonywa� polecenia wydawane ze zdalnego komputera na
lokalnym.
4.5. W jaki spos�b nawigowa� po Paj�czynie ?
Jak najmniej chaotycznie :-0. Najlepiej u�ywaj�c do poszukiwa�
katalog�w zasob�w i przeszukiwarek, i odznaczaj�c ciekawe miejsca w
,,zak�adkach'', lub ,,bookmark`ach''
4.6. Jak jest z prawami autorskimi w Internecie?
Nale�y przyj��, �e (przynajmniej w wypadku polskich stron) obowi�zuj�
przepisy Ustawy o prawie autorskim i prawach pokrewnych z 04.02.1995
Przy czym (na podstawie art. 1 punkt 1 i punkt 2 ustawy), o ile autor
nie zaznaczy� inaczej wszystkie strony s� domy�lnie oznaczone jako �
b�d� (C) i mo�na podawa� do nich odniesienie, nie mo�na natomiast ich
wykorzystywa� we w�asnej pracy (tj. tre�ci powi�zanej z form�,
poniewa� czystej informacji to ju� nie dotyczy) bez zgody (najlepiej
pisemnej) autora (w�a�ciciela (C)). Ochronie podlegaj� r�wnie� znaki
firmowe (lecz mo�na ich u�y� w celach informacyjnych).
4.7. W jaki spos�b pracowa� z WWW bez bezpo�redniego po��czenia?
Tak zupe�nie bez po��czenia si� nie da... Ale mo�na �ci�gn��
potrzebne strony (u�ywaj�c tzw. robota, albo normalnej przegl�darki z
w��czonym cache dyskowym, lub zainstalowanym serwerem proxy cache) a
nast�pnie je lokalnie przegl�da�. Wi�kszo�� dost�pnych w tej chwili
przegl�darek dzia�a bez po��czenia z sieci�. Poza tym istnieje bardzo
�adnie dzia�aj�cy viewer: view114.zip pozwalaj�cy m.in. ogl�da� pliki
MS Word, HTML, i innych...
<ftp://ftp.pwr.wroc.pl/pub/pc/sac/utiltext/view114.zip>
Mo�na te� u�y� us�ugi nazywanej www2mail. W Polsce taki serwer
uruchomi� Jaros�aw Strza�kowski . Wystarczy wys�a� pod adresem:
www2...@arrow.uci.agh.edu.pl list zawieraj�cy w ciele URLe ��danych
dokument�w. (ZMB+WM)
4.8. Co to jest i dlaczego nale�y u�ywa� W3cache-proxy?
Dlaczego? Przecie� to oczywiste... Jednym ze skutk�w coraz
gwa�towniejszego rozwoju us�ug WWW jest saturacja ��cz sieci
rozleg�ych. O ile przepustowo�ci ��cz sieci lokalnych i miejskich s�
zwykle nadmiarowe, to ��cza mi�dzynarodowe (znacznie bardziej
kosztowne) stanowi� zazwyczaj w�skie gard�a Internetu. Szybko��
wzrostu zapotrzebowania na pasmo znacznie przekracza wszelkie
mo�liwo�ci inwestycyjne. Analiza ruchu wskazuje przy tym, �e
procentowo coraz wi�kszy udzia� stanowi� w nim transmisje WWW.
Polska, jako jeden z pierwszych kraj�w zbudowa�a struktur� tzw. cache
WWW, kt�ra pozwala na lokalne buforowanie najcz�ciej ��danych
dokument�w WWW, a tym samym:
� zmniejszenie obci��enia ��cz mi�dzynarodowych,
� skr�cenie �redniego czasu dost�pu do informacji,
� zoptymalizowanie wykorzystania ��cz krajowych.
Hierarchia W3cache <http://w3cache.icm.edu.pl/sites_pl.html/>
obejmuje wszystkie wa�niejsze sieci miejskie oraz dzia�a w
bezpo�redniej wsp�pracy z podobnymi projektami poza Polsk�.
W3cache wymienia tak�e informacje z pojedynczymi serwerami cache
tam, gdzie nie istniej� jeszcze struktury og�lnokrajowe. Przy czym
u�ytkownicy takich og�lnopolskich sieci jak TPnet, lub Telebank
powinni ustawi� parametry swojego proxy cache na lokalny cache, a
je�li nie ma (a nie ma) to na w3cache.icm.edu.pl:8080 jako
najbli�szy sieciowo ich sieciom, nie za� na cache np. krakowskie.
(WojSyl+ZMB)
5. Tworzenie - og�lne.
Tworzenie stron i prezentacji WWW to nie tylko kodowanie w HTML, ale
tak�e przygotowywanie grafik, dba�o�� o poprawno�� sk�adniow� kodu
HTML i mn�stwo innych zagadnie�.
5.1. Jak mog� publikowa� w WWW?
Aby m�c publikowa� potrzeba odpowiedniego typu konta: najlepiej na
komputerze gdzie jest zainstalowany serwer httpd. W wypadku dostawc�w
komercyjnych nale�y wykupi� odpowiedni rodzaj konta. Na wi�kszo�ci
uczelni istnieje mo�liwo�� za�o�enia w�asnej strony w ramach
normalnego konta, i to cz�sto nawet bez ingerencji administratora
(zazwyczaj nale�y za�o�y� w swoim katalogu domowym katalogu
public_html lub .home . Istnieje tak�e kilka serwer�w komercyjnych
umo�liwiaj�cych publikowanie materia��w niekomercyjnych bez wnoszenia
op�at. Np. Marek B�czek z�o�y� deklaracj�, �e jest got�w przyj��
strony na nast�puj�cych warunkach:
� strona musi by� niekomercyjna.
� strona musi by� co najmniej ciekawa.
� strona musi by� robiona w ISO-8859-2 lub CP1250; (w �adnym wypadku
bez ogonk�w, mo�e by� po angielsku).
� strony nie powinny przekroczy� 10 MB i nie powinny zawiera� zbyt
du�o plik�w do za�adowania.
� URL do tej strony by�by taki: <http://www.qdnet.pl/~jaka�nazwa/>
� Prosz� przys�a� kilka stron dla przyk�adu e-mail na adres (Marek
B�czek <mailto:m...@qdnet.pl> (do 500kB)).
W poza tym w �wiecie istnieje kilka serwer�w oferuj�cych podbne
us�ugi: np. Geocites lub spis :-) Paw�a Wi�cka
<http://la.ists.pwr.wroc.pl/~coven/tech/freenet.html>
6. HTML
6.1. Jak wygl�da dokument WWW?
Wi�kszo�� polece� jest dwucz�ciowa: cz�� otwieraj�ca <XXX> i
zamykaj�ca </XXX> . Cz�� polece� nie wymaga zamkni�cia. Oto jest kod
najprostszego dokumentu w HTMLu <HTML> <HEAD> <TITLE> Tytu� dokumentu
</TITLE> </HEAD> <BODY> Zawarto�� dokumentu </BODY> </HTML> A teraz
opis: <HTML> deklaracja, �e jest to pocz�tek dokumentu HTML <HEAD>
nag��wek (zawieraj�cy definicje dla ca�ego dokumentu) <TITLE> tytu�
dokumentu <BODY> w�a�ciwa tre�� dokumentu. Znaki specjalne pozwalaj�
wstawi� graficzny obraz znak�w b�d�cych cz�ci� polece�: wi�kszo�ci (
<- < ) i mniejszo�� (> - > ), cudzys�owu (" - " ) oraz
spacji (&160;; - ), i stanowi�cy sk�adnik tych poprzednich
ampersand ( & - & ). Przy czym wobec pomini�cia deklaracji typu
dokumentu nie powinni�my stosowa� niczego poza najprostszym
,,poziomem'' HTML. W przeciwnym wypadku na pocz�tku dokumentu powinno
si� zale�� na przyk�ad co� takiego:
<!DOCTYPE HTML PUBLIC "-
Wi�cej informacji mo�na znale�� w dost�pnych w sieci i realnym �wiecie
kursach i podr�cznikach HTML.
6.2. Co jest standardem w HTML?
Aktualnie obowi�zuj�cy standard HTML zosta� zdefiniowany w dokumencie
IETF: RFC 1866 autorstwa T. Berners-Lee i D. Connolly Hypertext Markup
Language - 2.0 z listopada 1995 r. oraz RFC 1867 E. Nebela i L.
Masinter Form-based File Upload in HTML . Poza tym w dyskusji znajduje
si� propozycja standardu HTML 3.2. Jedna z propozycji nosi nazw�
Wilbur a druga, powracaj�ca w cz�ci do rzeczy porzuconych w Wilburze
<http://www.w3.org/hypertext/WWW/MarkUp/Wilbur/> nazywa si� Cougar
<http://www.w3.org/hypertext/WWW/MarkUp/Cougar/HTML.dtd>. Poza
istniej� rozmaite ,,rozszerzenia'' r�nych firm. Pawe� Wi�cek
zaproponowa� (w tek�cie umieszczonym pod adresem
<http://www.ists.pwr.wroc.pl/~coven/tech/mbc.html> ) program
MuliBrowser Compatibility: Wszystkie strony WWW powinny dobrze
wygl�da� na ka�dej przegl�darce. Przede wszystkim kompatybilno�� z
wszystkimi przegl�darkami wcale nie musi oznacza� ograniczania si� do
wsp�lnego podzbioru HTML-a (co w praktyce oznacza� by mog�o nawet co�
oko�o HTML 2.0 - jako wystarczaj�cy standard...). Idea przy�wiecaj�ca
programowi MultiBrowser Compability jest taka, �eby korzysta� z
rozszerze� w taki spos�b, �eby nie przeszkadza�o to innym
przegl�darkom. Oto kilka przyk�ad�w (ta lista b�dzie ros�a):
Tabele - stosowanie tabel takie, �eby nie zak��ca� pracy przegl�darek
ich nie obs�uguj�cych (z nowszych wersji - Lynx) nie jest �atw�
sztuk�. O ile w przypadku prostych tabel mo�na to osi�gn�� bez
wi�kszych k�opot�w, przy bardziej wymy�lnych konstrukcjach
korzystaj�cych z atrybut�w typu rowspan mo�e to by� trudniejsze.
Podstawowa idea polega tu na wstawianiu do kom�rek odpowiednio
dobranych kombinacji odst�p�w i przej�� do nowej linii (znacznik <br>
). Przyk�adowo tabela zawieraj�ca kilka wielokom�rkowych wierszy mo�e
mie� porozmieszczane w nich dodatkowe odst�py zapewniaj�ce odst�py
mi�dzy zawarto�ciami poszczeg�lnych kom�rek oraz przej�cia do nowych
linii wstawiane na ko�cu kom�rek ko�cz�cych wiersze. Dzi�ki temu tekst
kt�ry w przegl�darce obs�uguj�cej tabele b�dzie w jednym wierszu
tabeli, na Lynx-ie znajdzie si� r�wnie� w jednym wierszu. Mo�liwe s�
r�wnie� machinacje korzystaj�ce z obs�ugiwanego przez Lynx-a 2.5, a
nie obs�ugiwanego przez Netscape czy Internet Explorera znacznika
<tab> , jednak�e mo�e to wywo�a� przykre efekty na jakiej� mniej
znanej przegl�darce (Arena?), lub na nowszej wersji kt�rej� z
przegl�darek.
Ramki - w przypadku ramek sprawa jest prosta - nale�y skorzysta� z
istnienia znacznika <noframes> , i umie�ci� w jego wn�trzu wersje
strony przeznaczon� dla przegl�darki nie obs�uguj�cej ramek. Konkretne
rozwi�zania mog� by� r�ne - ja umieszczam tam tylko troch�
zmodyfikowan� wersje dokumentu, kt�ry w wersji ramkowej zajmuje g��wn�
ramk�, inni (niezbyt elegancko) umieszczaj� tam tylko odno�nik do tego
dokumentu. Mo�na si� r�wnie� pokusi� o przygotowanie znacznie
zmienionej wersji dokumentu, w kt�rej funkcje wykorzystuj�ce ramki
zostaj� zast�pione innymi.
Obrazki - nie powinny sprawia� k�opot�w. Nale�y tylko pami�ta� o
u�ywaniu atrybutu alt, umieszczaj�c w nim tekst dobrze zast�puj�cy
obrazek (mo�na si� nawet pokusi� o ascii art), a je�li obrazek s�u�y
wy��cznie jako ozdobnik - pozostawienie go pustego (alt=""), albo gdy
jest to linia w formie obrazka warto mo�e zastosowa� <IMG
SRC="linia.gif" ALT=dquot;--------------------------"
(ZMB, cov )
6.3. Jakie narz�dzia wspomagaj�ce tworzenie dokument�w WWW s�
dost�pne dla DOSa/Win i MS Windows 95/NT?
Z powodu ogromnej dynamiki powstawania nowych program�w mog� jedynie
wskaza� dost�pne archiwa oprogramowania:
� Tucows - The Ultimate Collection of Winsock Software
<http://alfa2.it.pw.edu.pl/tucows/> coraz lepsze: zawiera wi�kszo��
oprogramowania dla Intenetowego stosowania MS Windows, zwi�z�e
recenzje i archiwa bezpo�rednio na Politechnice Warszawskiej
� The CWSApps List - Indeks Aplikacji Sieciowych dla Windows
<http://www.man.poznan.pl/hypertext/cwsa/cwsapps.>> zawiera
wi�kszo�� oprogramowania dla Intenetowego stosowania MS Windows,
recenzje. Archiwa prowadz� niestety w �wiat, cho� mo�na po
wynotowaniu nazw program�w, �ci�gn�� je z Papa AFTP.
� Papa's Anonymous FTP <ftp://ftp.man.poznan.pl/pub/winsock-l/> jedno
z lepiej wyposa�onych archiw�w na FTP.
6.4. Jakie narz�dzia wspomagaj�ce tworzenie dokument�w WWW s�
dost�pne dla UNIXa?
Jest to dla mnie niewygodne pytanie: dopiero zaczynam u�ywa� Linuxa.
Ale jest co� takiego jak asWedit
<ftp://sunsite.icm.edu.pl/pub/www/asWedit/>, s� tryby HTML dla ViMa
<http://www.math.fu-berlin.de/~guckes/vim/>, i Emacsa
<http://www.santafe.edu/~nelson/tools/>. S� te� (skryptowe) narz�dzia
do weryfikacji odniesie�, sprawdzania poprawno�ci kodu itp. S�
wreszcie narz�dzia pozwalaj�ce na konwersj� popularnych w U*xie
format�w: LaTeX, LinuxDOC-SGML
<http://sunsite.icm.edu.pl/pub/Linux/sunsite/utill/text/linuxdoc-
sgml-1.5.tar.gz> na HTML. Wi�kszo�� ze wspomnianych narz�dzi mo�na
znale�� na ,,sansjacie'' <http://sunsite.icm.edu.pl/pub/www/>
6.5. Co to s� netscapizmy oraz inne rozszerzenia? I dlaczego nie
nale�y ich stosowa�?
Netscapizmami zwie si� popularnie te rozszerzenia akceptowane tylko i
wy��cznie przez przegl�darki firmy Netscape Communications Corporation
, i ostatnio przez MS Internet Explorer nie zarejestrowane w
oficjalnej specyfikacji (b�d� jej propozycji) j�zyka HTML. Nie nale�y
ich u�ywa� poniewa�:
� nie ma mo�liwo�ci sensownego sprawdzenia parserem/validatorem
takiego dokumentu (zazwyczaj brak jest oficjalnych DTD (i nawet
nieoficjalnych, np. dla IE 3.0, lub NN 3.0) dla takich rozszerze�)
� dokumenty te nie zawsze mog� by� wy�wietlane w przegl�darkach
innych producent�w. A HTML b�d�cy (zw�aszcza w wersjach 2.0 i
Wilbur) bardzo ubogim znaczeniowo zastosowaniem SGML-a, zosta�
stworzony po to, by istnia�a wsp�lna, niezale�na od sprz�tu i
systemu platforma informacyjna.
� niekt�re rozszerzenia nie mieszcz� si� w �aden spos�b w logice SGML
;-) np. te zwi�zane z ramkami... (FRAMES)
6.6. W jaki spos�b mog� tworzy� poprawne strony z polskimi znakami
diakrytycznymi?
Przede wszystkim nale�y u�ywa� kodowania w ISO-8859-2. Poza tym je�li
nie jeste� administratorem i nie mo�esz spowodowa�, �eby serwer
dodawa� do nag��wka stron z polskimi literami deklaracji typu
dokumentu: text/html; charset=ISO-8859-2 nale�y doda� w nag��wku
strony (pomi�dzy <HEAD> i </HEAD> , a i raczej przed <TITLE> )
nast�puj�c� instrukcj�: <META HTTP-EQUIV="content-type"
CONTENT="text/html; charset=iso-8859-2"> nie jest to rozwi�zanie
najbardziej eleganckie: powoduje (na niekt�rych serwerach) dwukrotne
interpretowanie zawarto�ci dokumentu, nie jest w pe�ni uwzgl�dnione w
specyfikacji HTML. Tym nie mniej dop�ki nie doczekamy si� (b�d�, sami
nie przyczynimy si� ;-) do uznania przez grona normalizacyjne i
producent�w oprogramowania faktu, �e w WWW stosuje si� i inne, poza
anglosaskim zestawy znak�w, pozostaje nam stosowanie p�rodk�w.
6.7. Dlaczego i w jaki spos�b sprawdza� poprawno�� sk�adniow� doku
ment�w?
Dlaczego: to chyba oczywiste ka�dy chyba chce �eby rzeczywisty efekt
pokrywa� si� z planowanym, tak treraz jak i w przysz�o�ci, gdy
przegl�darki b�d� np. �ci�lej trzyma� si� standardu. Powszechnie
stosowan� metod� jest ,,r�czne'' sprawdzanie za pomoc� wybranej
dowolnie ,,przegl�darki testowej'' takiej jak np. Lynx, Netscape, lub
MS IE. Jest to dzia�anie co najmniej w�tpliwe: przegl�darka powinna
wy�wietla� wszystkie (nawet z b��dami sk�adniowymi) strony poprawnie,
cho� niekoniecznie zgodnie z intencjami jej autor�w. Poprawn� form�
sprawdzania strony jest raczej u�ycie parsera/validatora SGML takiego
jak na przyk�ad SP Jamesa Clarka (dost�pny tak dla DOS (32-ext.)
Win32, jak i UNIXa) <http://www.jclark.com/sp/> wraz z odpowiednim DTD
dla stosowanego dialektu HTMLa.
<http://www.w3.org/pub/WWW/MarkUp/html-pubtext/> W wyniku kontroli
powstaje lista b��d�w (przez skierowanie potoku b��d�w do pliku) na
podstawie, kt�rej nale�y ,,r�cznie'' poprawi� dokument. Dopiero potem
mo�na sprawdzi� w przegl�dace, czy przypadkiem czego� istotnego nie
przeoczyli�my...
7. Grafika na stronach WWW?
Dopuszczalnymi formatami grafik dla WWW s�: GIF, JPEG, i PNG, oraz
XMB. Nie nale�y, bez ostrze�enia kierowa� do stron zawieraj�cych du�e
(tj. powy�ej 20 kb) grafiki. Aby przygotowa� prze�roczyste grafiki,
tj. w kolorze dowolnie definiowanego t�a lub podk�adu, nale�y
zapami�ta� je w formacie GIF 89a przy pomocy np. LView Pro 1.0 dla
Windows, <http://world.std.com/~mmedia/lviewp.html> lub z mirrora:
<http://alfa2.ia.pw.edu.pl/tucows/> albo giftrans dla DOS
<http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.exe> i/lub
UNIX.
<http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.1.gz> Do
tworzenia animowanych rysunk�w mo�e s�u�y� program Gif Construction
Set dla Windows <ftp://ftp.dtp.std.com/ftp/vendors/mmedia/gifcon.exe>
WebPaint - shareware dla W95 <http://www.barentsnett.no/webpaint/>
GifMerge dla UNIXa <http://www.iis.ee.ethz.ch/~kiwi/GIFMerge/> Wi�cej
informacji zawieraj� nast�puj�ce strony:
<http://www.best.com/~adamb/GIFpage.html>
<http://dragon.jpl.nasa.gov/~adam/transparent.html>
<http://www.boutell.com/faq/tinter.htm> Standard formatu graficznego
GIF 89a jest opisany pod adresem
<http://members.aol.com/royalef/gifanim.htm>
8. CGI i programowanie w WWW.
8.1. W jaki spos�b mog� zainstalowa� licznik na stronie?
Nie nale�y tego robi� poniewa�, zazwyczaj, liczniki k�ami�, nie
uwzgl�dniaj�c odwo�a� do strony przez Proxy-Cache, powoduje
niepotrzebne obci��enie serwera (graficzne), i jest przejawem
niepotrzebnego efekciarstwa. Je�li jednak te argumenty s�
nieprzekonuj�ce polecam <http://www.webtools.org/counter/>
<http://www.w4.nl/software/counter/> lub Yahoo
<http://www.yahoo.com/>, czy wreszcie
<ftp://ftp.ibspan.waw.pl/pub/unix/html-counter/>
albo skorzystaj z opisu Tomasza Pi�ata (sprawdzony jedynie z NSCA
HTTPd 1.4. i dzia�aj�cy na bazie Server Side Include ): nale�y za�o�y�
w katalogu gdzie mamy strone, do kt�rej chcemy liczy� dost�py plik
.htaccess . Oto jego zawarto��:
AddType text/x-server-parsed-html index.html
AddType application/x-httpd-cgi count.cgi
- gdzie index.html to nazwa tej strony, a count.cgi nazwa pliku pro
gramu licznika (obie liniki powinny by� zako�czone Enterem). Oto
zawarto�� tego drugiego:
#!/usr/bin/perl
open (COUNT,"count") ;
$counter =<COUNT>;
close (COUNT) ;
open (COUNT, ">count") ;
print COUNT +($counter+1) ;
close (COUNT) ;
print $counter;
exit(0) ;
mo�e zaistnie� potrzeba zmiany �cie�ki do PERLa (to jest
#!/usr/bin/perl). Naj�atwiej sprawdzi�, gdzie jest PERL pisz�c:
whereis perl lub which perl Wykonujemy co nast�puje:
touch count
chmod 777 count
chmod 505 \.htaccess
chmod 505 count.cgi
W pliku count znajdowa� si� b�dzie liczba odwiedzin. Umieszczamy na
stronie cos takiego: T� strone odwiedzilo juz <!-#exec
cmd="/usr/bin/perl count.cgi"-> go�ci!
Uwaga cenzora: powinno by�: Te strone pobrano juz <!-#exec
cmd="/usr/bin/perl count.cgi"-> razy od dnia zainstalowania licznika
lub jego resetowania.
(TP+ZMB)
8.2. Czy mog� w Paj�czynie umieszcza� dokumenty w innym formacie ni�
HTML?
Tak. Ale trzeba pami�ta� o tym, aby nie by�y ograniczone tylko do
jednej platformy sprz�towej/systemowej. I dlatego nie nale�y u�ywa�
surowych plik�w MS Word`a czy QuattroPro. Warto je prze�o�y� na jaki�
powszechnie uznany standard taki jak PostScript, RichTextFormat, CVS,
TeX, lub HTML. Je�li nie jest to mo�liwe? W takim razie nale�y doda�
odpowiednie deklaracje MIME types serwera. Oznaczenia typ�w plik�w
znajduj� si� w comp.mail.mime FAQ
<http://sunsite.icm.edu.pl/pub/usenet/comp.mail.mime/>
8.3. Jakich polskich termin�w u�ywa� przy tworzeniu stron?
Temat jest problematyczny... My�l�, �e zamiast link powinien pojawi�
si� odno�nik , odwo�anie , za� zamiast Microsoftowego miejsca w
Internecie lub site`a : serwer �wiatowej Paj�czyny - cho� i ten,
serwer brzmi nie-po-polsku . Zamiast: service us�uga .
9. Serwery WWW
9.1. systemem powinien pracowa�)? Jakie serwery WWW (HTTP) s�
dost�pne i kt�ry wybra� (i pod jakim
Pytanie rzeka... najlepiej spojrze� na stron� Web Compare
<http://webcompare.iworld.com/> gdzie szczeg�owo opisano (i
por�wnano) wi�kszo�� dost�pnych serwer�w WWW.
9.2. Gdzie mog� znale�� opis protoko�u serwera WWW (HTTP)?
Aktualnie obowi�zuj�cy standard (realizowany w ca�o�ci przez wi�kszo��
dost�pnych serwer�w) zosta� opisany w RFC 1945
9.3. W jaki spos�b mog� na moim serwerze obs�ugiwa� jego b��dy?
Przede wszystkim zajrzyj do dokumentacji swojego serwera. Zazwyczaj w
dostarczanych zbiorach konfiguracyjnych serwer�w dost�pne s�
odpowiednie opcje (cho� zwykle skomentowane , aby je uaktywni�
wystarczy skasowa� znak komentarza). Opis b��d�w znajduje si� w
specyfikacji http.
9.4. W jaki spos�b poprawnie serwowa� polskie dokumenty?
na podstawie: <http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html>
Nale�y wykorzysta� mo�liwo�ci serwera Apache-Httpd, a mianowicie
technologi� MultiViews. Dzi�ki temu wykorzystywane s� preferencje
j�zykowe u�ytkownika. Generuje to nast�puj�ce rozszerzenia dla wersji
j�zykowych dokument�w:
Charset, HTML, HTML z SSI CGI u�ytkownika
Jedyna: .html; .shtml; .cgi;
ASCII: .html.pn; .shtml.pn; .cgi.pn;
ISO 8859-2: .html.po; .shtml.po; .cgi.po;
Angielska: .html.en; .shtml.en; .cgi.en;
Dla skrypt�w CGI umieszczonych w katalogu /cgi-bin/ warto stosowa�
nazwy takie jak dla CGI u�ytkownika (rozpoznawanych po rozszerzeniu).
Aby m�c skorzysta� z tej technologii nale�y w ka�dym katalogu umie�ci�
plik .htaccess o np. nast�puj�cej zawarto�ci (dyrektywy te mog� si�
te� znale�� w plikach konfiguracyjnych serwera - access.conf i
srm.conf):
Options All MultiViews
AddLanguage pl .po
AddLanguage pn .pn
AddLanguage pw .pw
LanguagePriority pl pn pw en
DirectoryIndex index.shtml index.html
Dyrektywa deklaruj�ca rozszerzenie .en znajduje si� domy�lnie w pliku
srm.conf. Powy�szy plik
.htaccess w��cza MultiViews, aby mo�na by�o korzysta� z tej tech
nologii, definiuje rozszerzenia j�zykowe u�ywane przez ni�, ustala
domy�lne preferencje j�zykowe i pozwala u�ywa� plik�w index z Server-
Side Includes. Do automatycznego tworzenia na podstawie dokument�w z
polskimi literami w standardzie ISO 8859-2 wersji bez polskich znak�w
i ewentualnie CP 1250 z zachowaniem wymog�w tej technologii mo�na u�y�
programu HtmlConv (patrz ni�ej). Przygotowywanie dokument�w pod DOS-
em Z w�asnego do�wiadczenia wiem, �e przygotowywanie dokument�w HTML-
owych pod DOS-em jest do�� popularne. Jednak�e napotykamy tam na
drobny problem - DOS-owy limit d�ugo�ci nazw plik�w, a dok�adniej
limit d�ugo�ci rozszerzenia do trzech znak�w. Sugeruj� u�ywanie
nast�puj�cych rozszerze� zast�pczych:
UNIX DOS
*.html *.htm
*.ihtml *.iht
*.whtml *.wht
*.ehtml *.eht
*.shtml *.sht
*.html.po *.htp
*.html.pn *.htn
*.html.en *.hte
*.shtml.po *.shp
*.shtml.pn *.shn
*.shtml.en *.she
Dodatkowo plik .htaccess powinien pod DOS-em nosi� nazw� _htacces.
T�umaczenia nazw plik�w z wersji DOS-owych na wersje UNIX-owe (obie
technologie) wykonuje program Reh (ten i inne opisane w tej odpowiedzi
programy opisane s� na stronie:
<http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html>).
(cov)
9.5. Jak stworzy� stron� na has�o?
W UNIXie, na Apache, b�d� NSCA nale�y za�o�y� w katalogu w kt�rym ma
si� znajdowa� chroniony zas�b plik .htaccess w kt�rym nale�y wpisa�
klauzul� (podobn� do wyst�puj�cej w zbiorze access.conf)
AuthUserFile /home/dir/foo/public_html/.htpasswd
AuthGoupFile /home/dir/foo/public_html/.htgroup
i wymienionych zbiorach nazwy u�ytkownik�w i has�a.
Pod NT te� jest to mo�liwe pod warunkiem, �e korzysta si� z NTFS.
Nadaje si� na katalog lub konkretny plik odpowiednie uprawnienia do
czytania (jednemu lub grupie u�ytkownik�w), po czym odbiera si�
uprawnienia pozosta�ym.
9.6. W jaki spos�b mog� udost�pni� przeszukiwanie mojego serwera?
Temat czeka na opracowanie. :-)
9.7. Jak mo�na udost�pnia� baz� danych przez WWW?
Jest cos takiego, do WWW nadaje si� doskonale, daje tylko podzbi�r SQL
- i to wszystko za darmo (cho� jedynie dla uniwersytet�w i organizacji
non-profit). Nazywa si� miniSQL (ostatnia wersja - 1.0.13).
Dokumentacje do niego znajduje si� pod adresem
<http://www.sgh.waw.pl/guides/db/mSQL/> Tam te� jest link do
�ci�gni�cia kt�rej� z wersji przez FTP. Innym rozwi�zaniem jest
Apache z CGI / modu�em PHP/FI i mSQL.
(CS+Saper+PT)
10. Standardy
dost�pne w r�nych miejscach:
� <ftp://ftp.nask.pl/pub/rfc/>
� <ftp://ftp.icm.edu.pl/pub/rfc/>
� <ftp://ftp.cyf-kr.edu.pl/pub/mirror/rfc/>
� <ftp://ftp.man.lodz.pl/pub/doc/>
� <ftp://ftp.pwr.wroc.pl/pub/doc/rfc/>
� <ftp://ds.internic.net/rfc/>
� <ftp://nic.nordu.net/>
� <ftp://ftp.nis.garr.it/>
HTML
� RFC 1590 - The text/html Internet Media type
� RFC 1866 - Official Specification of HTML 2.0
� RFC 1867 - FORM-based file uploads (Experimental)
� RFC 1942 - dotycz�cy tabel w HTML
HTTP
� RFC 1945 - Official Specification of HTTP 1.0
E-Mail and MIME
� RFC 822 - Standard for Internet E-mail
� RFC 1123 - Update to RFC 822
� RFC 1521 - MIME Mail standard (1/1) - message format
� RFC 1522 - MIME Mail standard (2/2) - extended header field data
� RFC 1590 - The text/html Internet Media type
USEnet News
� RFC 1036 - USENET news messages protocol
Uniform Resource Locators
� RFC 1738 - Uniform Resource Locators
� RFC 1808 - Relative Uniform Resource Locators
� RFC 1630 - Overview of Resource Naming Schemes for the Internet
� RFC 1700 - Assigned Numbers - numery port�w w I*necie
Language and Country Specifications
� RFC 1766 - Language Tags for use on the Internet
� ISO 639 - Language Codes
<http://www.ics.uci.edu/pub/ietf/http/related/iso639.txt>
� ISO 3166 - Country Codes
<http://www.ics.uci.edu/pub/ietf/http/related/iso3166.txt>
11. Og�lne wprowadzenia do sieci.
Jako�e WWW jest dla wielu podstawow� us�ug� Internetu, a na pewno
wielu ludzi zaczyna sw�j kontakt z sieci� od niego, pozwalam sobie
zamie�ci� odniesienia do podstawowych przewodnik�w po Sieci.
� Elementarz Internetu Macieja Uhliga
<http://www.cto.us.edu.pl/eleminte/ei.html>
� Podstawowe us�ugi Internetu <http://www.ict.pwr.wroc.pl/doc/iwpl/>
� R�ne po�yteczne dokumenty w/g AGH
<http://www.agh.edu.pl/opisy.html>
� Wirtualna Akademia - Katedra Teleinformatyki
<http://www.gumbeers.elka.pg.gda.pl/WA/KTI/>
� Narz�dzia sieciowe Wojciecha Myszki.
<http://www.immt.pwr.wroc.pl/export_hp/tool/tool.html>
� EFFu Przewodnik po Internecie, w.3.1
<ftp://www.peryt.waw.pl/pub/doc/netguide-ascii-polish.eff> . Jest
te� wersja skompresowana
<ftp://www.peryt.waw.pl/pub/doc/netguipl.zip>
12. �r�d�a HTML
O HTML mo�na d�ugo. Postaram si� jednak przedstawi� przede wszystkim
polskie (tj. tak polsko-j�zyczne, jak i tylko si� w Polsce znajduj�ce)
zasoby.
12.1. �rod�a HTML po polsku w sieci.
Mam nadziej�, �e poni�sza lista jest w miar� pe�na.... Nie
uwzgl�dni�em licznych (zdaje si�, �e na po�y pirackich) kopii dzie�
autorskich np. Kursu HTML Paw�a Wimmera. By� mo�e cz�� tych �r�de�
nie istnieje, w mi�dzyczasie powsta�y inne... Prosz� o sprostowania
:-)
� Kurs HTML Paw�a Wimmera <http://www.polbox.com.pl/html/glowny.htm>
Jest te� wersja offline
<ftp://polbox.com.pl/library/!lupus/html.zip>
� WWWhowto - Jak zrobi� swoja strone WWW? Tomasza Pi�ata (Chwilowo
nieczynny) http:://ajax.umcs.lublin.pl/~poncjusz/
� Jak stworzy� w�asn� stron� WWW (Grzegorza W�jcika)
<http://www.ia.pw.edu.pl/pl-iso/homepage-info.html>
� Jak zrobi� w�asn� stron� WWW (wskaz�wki dla u�ytkownik�w z PK)
(Szymona Soko�a i Grzegorza Muchy)
<http://www.pk.edu.pl/sysdocs/howto.html> )
� Opis polece� j�zyka HTML z przyk�adami Roberta Paj�ka
� KROTKI KURS HTML <http://panda.bg.univ.gda.pl:80/~krabek/kurs.html>
� Jak zrobi� swoja w�asn� HomePage ?
<http://zeus.polsl.gliwice.pl/~bort/local/how-to.html>
12.2. drukowane �r�d�a HTML po polsku
� W�odzimierz Macewicz HTML. J�zyk opisu dokumentu hipertekstowego
HTML Warszawa 1996; Zak�ad Nauczania Informatyki MIKOM (kiedy� w I
wyd.(1995) nazywa�o si� to J�zyk sk�adu dokumentu hipertekstowego
HTML i HTML + ) �ci�ga; porz�dnie opisuje HTML. Pisze o polskich
literach. Dobre zestawienie znak�w (��cznie z nie obs�ugiwanymi
jeszcze sekwencjami matematycznymi) i notacj� co do, jakiej
przegl�darki (a zw�aszcza specyfikacji j�zyka) nale�y. Jedyne czego
brakuje (jako �ci�dze, nie tylko podr�cznikowi) to odes�a� do
standard�w (RFC) i stwierdzenia dlaczego nale�y u�ywa� HTML 2.0 aby
by� powszechnie zrozumianym. Stosunkowo tania: 182 strony za 10 z�.
� Elisabeth Castro Po prostu HTML Gliwice 1996; Helion, Peachpit
Press Ksi��ka kucharska. Wygl�da na wart� swej ceny :-) Bardzo
rozbudowany spis tre�ci + przyk�ady graficzne obok konkretnych
konstrukcji j�zyka. (cho� ja i tak wol� ksi��k� Macewicza :-) cena
co� ko�o 19 z�.
� J�zyk HTML. Tworzenie w�asnych dokument�w WWW (w:) CHIP Special.
Internet dla ka�dego. s. 50-80 Wroc�aw 1996; Vogel Publishing maj-
czerwiec 1996 jest te� CD-ROM ze FAQ i RFC (do RFC 1814, 60 Mb) i
jakimi� dwoma kursami: Sunila Gupty i dost�pnym w sieci (Wroc�aw) A
Beginner's Guide to HTML . Cena 20 z�. (uwa�am, �e dla widziarzy
(zw�aszcza tych 3.1) warto)
� Piotr T�czy�ski (1995). Quo vadis, Internecie? (w:) Informacja
Profesjonalna , 5:42-46. ISSN 1233-0329.
� Piotr T�czy�ski (1996). HTML - uniwersalny j�zyk Paj�k�w? (..)
Informacja Profesjonalna , (w druku). ISSN 1233-0329.
� Rafa� Wiosna Ka�dy chce mie� w�asn� stron� , cykl publikacji w
numerach 26/95, 3/96 dwutygodnika PCkurier jak wida� ukaza�y si�
dwa odcinki, a obiecywano 3 :-) . By�o to, wst�pne, przedstawienie
mo�liwo�ci j�zyka i jako takie ca�kiem dobre. Ale chyba nie warto
kupowa� numer�w archiwalnych :-)
� Asha Dornfest Tworzenie stron WWW za pomoc� Worda ; Gliwice 1996;
Helion
� Dave Taylor Tworzenie stron WWW. HTML Warszawa 1996; IDG Books,
ReadME
� Artur van Hoff, Sami Shaio, Orca Starbuck JAVA ; Gliwice 1996;
Helion (2 dyskietki z przyk�adami)
� Piotr Gawrysiak VRML. Wirtualna rzeczywisto�� w Internecie Warszawa
1995, 1996; Zak�ad Nauczania Informatyki MIKOM Wygl�da przyzwoicie
- przy czym raczej jako podr�czna �ci�gawka przy pisaniu skrypt�w
(z dyskietk�)
12.3. �r�d�a HTML po angielsku w sieci
� Yahoo <http://www.yahoo.com/Computers/World_Wide_Web/HTML/>
� A Beginner's Guide to HTML (na Politechnice Wroc�awskiej) i na ATM
<http://www.immt.pwr.wroc.pl/export_hp/html-primer-080693.html>
� Introduction to HTML Iana S. Grahama (Peryt - Warszawa)
<http://whisky.peryt.waw.pl/tools/webdoc/HTML/docs/NewHTML/htmlindex.html>
i na Uniwersytecie Gda�skim
<http://www.univ.gda.pl/owner/ktem/newhtml/html_intro.html>
� HTML Documentation Iana S. Grahama (Politechnika Krakowska)
<http://www.pk.edu.pl/sysdocs/jezyk_html/>
� Interaktywny kurs HTML (w oryginale autorstwa Yuriko Ienaga
zmodyfikowany przez Jana Peszko <mailto:jp...@ip.krakow.pl>)
<http://www.ip.krakow.pl/~jpesz/html/html.html>
� The other HTML FAQ Galactusa
<http://www.stack.urc.tue.nl/~galactus/html/other-faq.html>
� World Wide Web FAQ Thomasa Boutella (w pozna�skim MANie).
<http://www.put.Poznan.pl/hypertext/Internet/faq/www/www_faq.html>
Jest te� wersja offline WWW-FAQ.
� HTML 3.0 Specification Instytut Fizyki UJ - Krak�w
<http://www.if.uj.edu.pl/UJ/IF/PTO/HTML_3.0/Contents.html>
Tr�jmiejska Akademicka Sie� Komputerowa
<http://www.task.gda.pl/help/HTML_3.0/Contents.html> Introduction
to HTML 3.0 (UCI AGH Krak�w)
<http://rexio.uci.agh.edu.pl/~dot/man/1.html>
� Welcome to HotJAVA SGGW Warszawa <http://alpha.sggw.waw.pl/java/>
� Dokumentacja do NCSA Mosaic we Wroc�awiu
http:://www.immt.pwr.wroc.pl/mosaic-docs/
12.4. �r�d�a HTML po angielsku drukowane
� Ian S. Graham HTML Documentation and Style Guide Torontto 1994
12.5. �r�d�a dotycz�ce innych, zwi�zanych z WWW j�zyk�w programowania
� VRML w Polsce <http://andante.iss.uw.edu.pl/obuz/vrmlp/index.html>
� AMU-NET's VRML Repository (Administrator: Klaudiusz Modrzewski) dla
Win 3.x: <http://math.amu.edu.pl/ftp/windows/vrml/00_index.html> i
dla Win95 <http://math.amu.edu.pl/ftp/windows/win95/vrlm/00.html>.
� JAVA na UCI AH <http://arrow.uci.agh.edu.pl/~java/index-p.html>
� JAVA na SunSite ICM UW <http://sunsite.icm.edu.pl/java/>
13. Dokumenty dotycz�ce tworzenia WWW po polsku.
� Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/>
� Strony testowe ISO-8859-? Wojciecha Myszki
<http://www.immt.pwr.wroc.pl/export_hp/test/>
� Instalacja i konfiguracja serwera WWW <http://info.fuw.edu.pl/tech-
doc/serwery.html>
� test polskich liter <http://www.ch.uj.edu.pl/pl/testpl.html>
� Winter Jaros�awa Zieli�skiego <http://winter.it.com.pl/> ciekawy
serwis semi-komercyjny, zawieraj�cy sporo ciekawych, cho� jeszcze
cz�sto og�lnikowych materia��w na temat HTML i Lotus Notes.
13.1. Dokumenty dotycz�ce tworzenia WWW w polskiej sieci.
� Przewodniki po WWW na SGH w Warszawie
<http://www.sgh.waw.pl/guides/>
� NSCA Tutorial <http://www.lublin.pl/docs-1.4/tutorials/index.html>
� Running A WWW Service Briana Kelly (Gliwice)
<http://www.polsl.gliwice.pl/e-books/HTML/handbook.html>
14. Dokumenty dotycz�ce WWW w �wiatowej sieci
I znow b�dzie to jedynie m�j subiektywny wyb�r:
� The World Wide Web Consortium (W3C) <http://www.w3.org/> serwer
organizacji proponuj�cej standardy dla WWW. tam mi�dzy innymi
Style Guide for Online Hypertext
<http://www.w3.org/pub/WWW/Provider/Style/>
� Gallacusowy opis Wilbura
<http://www.htmlhelp.com/reference/wilbur/> a tak�e wersja offline
<http://www.htmlhelp.com/reference/wilbur/wilbur.zip>
� The WDVL: The Virtual Library of WWW Development
<http://WWW.Stars.com/Vlib/>
� Top 10 Things NOT to do
� The Multilingual World Wide Web
<http://www.ebt.com:8080/docs/multilingual-www.html>
� Lynx Optimized Pages!
<http://www.nyu.edu/pages/wsn/subir/lynx.html>
� WWW Viewer Test Page <http://www-
dsed.llnl.gov/documents/WWWtest.html>
� Yale C/AIM WWW Style Manual
<http://info.med.yale.edu/caim/StyleManual_Top.<tt/HTML/>
� WWW Authoring Information <http://www.netspace.org/~dwb/www-
authoring.html>
� HTML resouces in WWW by SQ <http://www.sq.com/htmlsgml/html/h-
sites.htm>
� The Bare Bones Guide to HTML <http://werbach.com/barebones/> kr�tki
(15kb) spis wszystkich komend HTML wraz z netscapizmami
(zaznaczonymi)
--
Rafal Maszkowski r...@torun.pdi.net http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID:
<pl.comp.www-1-848027421@torun.pdi.net>Path:
mbox-mo1.pugleaf.net!unknown!not-for-mailShow Full Headers
Complete Article Headers
From: Ziemek Borowski <zie...@qdnet.pl> Subject: pl.comp.www FAQ Date: 1996/11/15 Message-ID: <pl.comp.www-1-848027421@torun.pdi.net> X-Deja-AN: 196569871 distribution: world sender: r...@rymunda.torun.pdi.net supersedes: <pl.comp.www...@torun.pdi.net> x-posting-frequency: Posted on 1st and 15th day of each month followup-to: poster organization: Rafal Maszkowski keywords: WWW World Wide Web reply-to: zie...@qdnet.pl (Ziemek Borowski) newsgroups: pl.comp.www,pl.answers MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit