🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.answers
Article #84

pl.comp.www FAQ

#84
From: Ziemek Borowski
Date: Wed, 02 Oct 1996 00:00
981 lines
57130 bytes
Posted-By: auto-faq 3.1.1.2
Archive-name: pl.comp.www


Najczesciej zadawane pytania na pl.comp.www
wraz z odpowiedziami

Wersja 0.6.0 HTML - 26.09.96
Autorzy

   * Ziemek Borowski koordynator   <URL:mailto:zie...@qdnet.pl>
     <URL:http://www.qdnet.pl/~Ziembor/>
   * Marek Baczek   <URL:mailto:m...@qdnet.pl>
     <URL:http://www.qdnet.pl/~mgb/>
   * Grzegorz Staniak   <URL:mailto:gsta...@golem.umcs.lublin.pl>
   * Piotr Teczynski   <URL:mailto:pte...@hum.amu.edu.pl>
     <URL:http://hum.amu.edu.pl/~pteczyn/>
   * Wojciech Myszka   <URL:mailto:W.My...@immt.pwr.wroc.pl>
   * Piotr Wiecek   <URL:mailto:co...@i17linuxb.ists.pwr.wroc.pl>
     <URL:http://www.ists.pwr.wroc.pl/~coven/>
   * Tomasz Pilat <URL:mailto:ponc...@ajax.umcs.lublin.pl>
     <URL:http://ajax.umcs.lublin.pl/~poncjusz/>
   * inni, ktorzy zglosza swoja oferte pomocy :-)
   * wszyscy pisujacy na pl.comp.www

   * Gdy niniejszy dokument zostanie dopracowany (tj. osiagnie wersje >
     1.0) bedzie wysylany do grupy pl.comp.www raz na dwa tygodnie,
     piewszego i pietnastego dnia kazdego miesiaca.
   * Dokument ten bedzie systematycznie uzupelniany i w miare pojawiania
     sie nowych pytan publikowane beda jego kolejne wydania.
   * Autorzy nie ponosza zadnej odpowiedzialnosci za efekty dzialania
     spowodowane stosowaniem sie do zalecen zawartych w dokumencie.
   * Wszystkie zastrzezone znaki firmowe zostaly uzyte jedynie w celach
     informacyjnych.
   * Dokument nie ma zadnej mocy prawnej badz administracyjnej i
     powolywanie sie na udzielone w nim odpowiedzi oraz porady jest
     bezpodstawne.
   * Dokonywanie zmian bez zgody i wiedzy autora dokumentu jest
     niewskazane.
   * Dokument bedzie dystrybuowany w postaci archiwow o nazwach-
        o wwwfaqpl.htm oraz
        o pl.comp.www lub pl_comp_www w archiwach FAQ.
   * Zawartosc WWW_FAQ opiera sie glownie na listach z grupy usenetowej
     pl.comp.www oraz ew. pl.comp.lang.java, pl.listserv.polip,
     pl.comp.ogonki jesli tylko maja zwiazek z tematem.

    Spis tresci
odpowiedzi

  1.     W jaki sposob zadawac pytania, aby uzyskac odpowiedz?
         Daleki jestem od odsadzania od czci wszystkich, ktorzy zadaja
     pytania niekonkretne, badz takie na ktore odpowiedz znajduje sie na
     drugiej stronie manuala, podrecznika badz FAQ. Ale prosze... Zanim
     zadasz jakies pytanie:
        o zastanow sie, czy to co cie trapi jest rzeczywiscie problemem.
          Byc moze spotkales sie juz z podobna sytuacja i tylko cos Ci na
          chwile rozum zacmilo :-)
        o przejrzyj dostepna lokalnie dokumentacje... Po to sie ja tworzy.
        o poszukaj FAQ (czyli zbioru najczesciej zadawanych pytan wraz z
          odpowiedziami) zwiazanego z nurtujacymi cie problemami... w
          Polsce znajdziesz je pod adresem
          <URL:http://sunsite.icm.edu.pl/pub/usenet/>
        o spytaj lokalnego administratora... chyba, ze ma Cie juz dosc,
          badz nim jestes :-)
        o poszukaj przy pomocy katalogu tematycznego
          badz wyszukiwarki
     A jesli to nie pomoze... to pytaj... Ale pamietaj, ze zadawanie pytan
     tez jest sztuka. Tutaj, w grupie raczej technicznej ograniczymy sie do
     wskazowek raczej technicznych.
        o napisz dokladnie jaki masz problem... (jakiego systemu uzywasz i
          z jakim programem masz klopoty)
        o jesli szukasz jakiegos programu, napisz jak sie nazywa, jakie
          wymagania ma spelniac i co najwazniejsze w jakim sytemie
          operacyjnym ma dzialac
        o nie zaszkodzi podac gdzie szukales
     I pamietaj: to, ze ktos Ci odpowie to tylko i wylacznie jego dobra
     wola.
  2.     Wstep, ogolny opis WWW.
             Ponizej przedstawiam ogolne infomacje dotyczace World-Wide
     Web.
       1.     Co to jest Internet?
              W RFC 1462 , lub FYI 20 Internet zostal zdefiniowany jako:
             + siec komputerow oparta na protokole TCP/IP,
             + zasoby dostepne na komputerach polaczonych z siecia (tzw.
               hostach)
             + spolecznosc, wspolnota (community) ludzi uzywajacych i
               rozwijajacych te siec,
       2.     Co to jest Web, WWW?
              WWW (World-Wide Web), zwana inaczej Pajeczyna, Webem jest
          hypertektowym, multimedialnym, sieciowym, opartym na TCP/IP
          systemem informacyjnym .
              hypertekstowym - czyli takim gdzie istnieja zdefiniowane
          zaleznosci miedzy poszczegolnymi dokumentami.
              multimedialnym - czyli dospuszczajacym stosowanie roznych
          srodkow przekazu: tradycyjnych tekstow, muzyki, grafiki.
              sieciowym - opartym na sieci rozleglej Internet a wiec o
          zasiegu praktycznie globalnym.
       3.     Kto wyznacza standardy dla Internetu i WWW???
              Ostateczna instancja zatwierdzajaca dana propozycje Internet
          Engenering Task Force IETF . Swoje propozycje w zakresie WWW
          przedstawia mu W3 Corporation bedaca organizacja skupiajaca
          producentow oprogramowania.
       4.     Co to jest SGML i HTML? I jakie sa ich wzajemne zwiazki?
              Hyper Text Markup Language
          oraz Standard Generalized Markup Language :-)
          SGML to jezyk tworzenia jezykow oznaczen. HTML i inne podobne
          jezyki opisane w roznych DTDs sa jego zastosowaniem, aplikacja.
          Kazdy dokument SGML w zasadzie sklada sie z trzech czesci:
          * deklaracja SGML, opisujaca zestawy znakow, mechanizmy
          skladniowe i pewne poczatkowe wartosci stosowane w dokumentach
          danego typu;
          * DTD czyli definicja typu dokumentu opisujaca strukture jezyka
          oznaczen czyli zestaw elementow, model zawartosci kazdego z nich,
          dopuszczalne i domyslne wartosci atrybutow etc;
          * sam dokument, czyli "document instance ", np. konkretna strona
          HTML.
          W przypadku aplikacji zorientowanej na jeden tylko typ dokumentu,
          deklaracja skladni moze byc stosowana domyslnie (+ opcje zmiany)
          lub wszyta w kod, do wariantow DTD nastepuje odwolanie przez
          deklarowanie typu dokumentu (DOCTYPE) z publicznym
          identyfikatorem, po czym idzie juz sam dokument. Tak powinno byc
          tez w przegladarkach HTML, ale jak wiadomo znajomosc SGML ich
          autorow jest nikla, wiec deklaracja SGML jest po prostu
          ignorowana, w najlepszym razie stosowana "na oko". Edytory HTML
          (zazwyczaj operujace rozmaitymi rozszerzeniami HTML dla ktorych
          zazwyczaj nie ma odpowiednich DTD) wstawiaja DOCTYPEs w zasadzie
          tylko w celu wywarcia wrazenia na klientach.
       5.     Co to jest HTML?
              HTML jest, a wlasciwie powinien byc, konkretna aplikacja
          (zastosowaniem) opisana w odpowiednim DTD. Niestety najczesciej
          jest to (w praktyce) odzielny jezyk, majacy tylko pewne elementy
          wpolne z SGML...
       6.     Co to jest URL? Universal Resouce Locator
          Wyglada mniej wiecej tak
          http://www.cos.tam.pl:80/jakis/katalog/jakis.plik.html
          I jest zlozony z nazwy uslugi:
             + file://... -- odnosnik do zasobow lokalnych komputera (nie
               nalezy chyba uzywac w sieci :-)
             + ftp://... -- odnosnik do zasobow dostepnych za pomoca
               protokolu FTP
             + gopher://... -- odnosnik do zasobow Gopher
             + http://... -- zbior obslugiwany bezposednio przez serwer
               HTTP (WWW)
             + maito:... -- odnosnik powodujacy wyslanie listu pod podany
               adres (bez // po dwukropku!!!)
             + news:... -- odnosnik powodujacy uruchomienie przegladarki
               USENETU (news) uzywajac domyslnego serwera, i podanej grupy
             + telnet:... -- odnosnik do zdalnego komputera, zazwyczaj
               uzywajac terminala VT100 (bez // po dwukropku!!!)
             + tn3270:... -- odnosnik do zdalnego komputera IBM (np. 3090
               na plearn.edu.pl) terminala IBM-3270 (bez // po
               dwukropku!!!)
             + wais: -- odwolanie do sytemu wyszukiwawczego WAIS:
               http://www.ict.pwr.wroc.pl/cgi-bin/tswais
             + newsrc: ... -- Odnosnik do okreslonego pliku newsrc (bez //
               po dwukropku!!!)
             + nntp:// ... -- Okresla inny niz domyslnie uzywany serwer
               newsow
          oraz:
             + adresu (moze byc IP lub slowny typu www.my.computer)
             + numeru portu pod ktorym jest dostepna dana usluga - o ile
               standardowy (tj. wg RFC 1700 ) niepotrzebny.
             + sciezki dostepu do pliku ((zakonczonej - choc nie jest to
               bezwzgledny (tj. wg. specyfikacji) wymog) znaczkiem / o ile
               nie jest to pelna sciezka, a tylko nazwa katalogu)
             + nazwy pliku
          (PT)
       7.     Co to jest CGI? Common Gateway Interface
          Specyfikacja umozliwiajaca komunikacje przegladarki z sewerem.
          Opisana zostala na powszechnie znanym serwerze
          <URL:http://hoohoo.nsca.edu/cgi/> , a takze
          <URL:http://www.vservers.com/reference/>
       8.     Co to jest VRML?     Vitual Reality Modeling Langue
          Wykorzystujacy niektore mechanizmy WWW (takie jak HTTP, czy URL)
          jezyk opisu scen trojwymiaowych opaty na formacie Open Inventor
          stworzonym przez Silicon Graphics.
       9.     Co to jest Java i JavaScript     JAVA ma byc w zalozeniach
          obiektowym jezykiem programowania niezaleznym od sytemu
          operacyjnego i sprzetu stworzonym pzez Sun INS.
          JavaScript jest jego uproszczona wersja
      10.     Co to jest plug-in     Plug-in`em nazwano programy
          wspomagajace przegladarki WWW, umozliwiajace np. czytanie
          niestandardowych formatow plikow.
      11.     Co to jest ActiveX     ActiveX jest technologia opracowana
          przez NetManage, umozliwiajaca wstawianie przez obiektow OLE w
          strony WWW. Moim zdaniem nie nalezy stososowac tej technologii,
          chyba, ze nie chcemy, zeby wiekszosc uzytkownikow WWW to
          zobaczyla.
      12.     Kto uzywa WWW i Internetu?     W swiecie powszechnie uznawany
          jest GVU Survey
          <URL:http://www.cc.gatech.edu/gvu/user_surveys/User_Survey_Home.html>
          Natomiast w Polsce... Prowadzi sie wprawdzie roznego rodzaju
          badania ankietowe. Ale moje mniemanie o nich jest ... takie, ze
          lepiej przemilcze. Dlaczego?
             + nikt nigdzie nie opisuje metody przeprowadzenia sondazu.
             + jak juz opisuje to okazuje sie, ze tak naprawde nie ma
               metody tj. badania byly robione tylko nie wiadomo na jakiej
               populacji, na ile sklad respondentow byl reprezentatywny, i
               jak dokladnie brzmialy pytania.
             + nawet gdy byla jakas metoda to... zadano niejednoznaczne
               pytania, lub zostawiono w pytaniach wielo-odpowiedziowych
               mozliwosc wyboru tylko jednej opcji :-) . Jesli ktos zna
               dobrze zrobione (tj. nie takie jak wyzej opisane) badania w
               polskiej czesci Internetu prosze o informacje
  3.     Jakich narzedzi uzywac do pracy z WWW.
         Na razie wskazuje zrodla pozyskania "pajeczarek" jeynie dla dwoch
     dominujacych rodzin systemow operacyjnych. Pozniej obiecuje to
     rozszerzyc o inne takie jak: IBM OS/2, Amige, i co tam jeszcze Boutell
     wymienia :-)
       1.     Jakie przegladarki sa dostepne dla MS Window 3.x i MS Windows
          95/NT 3.x?
              Niestety mutum :-). I nie sposob ich wszytkich wymienic w tym
          krotkim przegladzie. Na razie ogranicze sie do wskazania glownych
          archiwow:
          * Netscape Communication Ltd. - Mirror na
          <:URL:http://sunsite.icm.edu.pl/www/netscape/>
          * Microsoft. - Mirror na <:URL:ftp://ftp.poznan.optimus.pl/>
          * Tucows - The Ultimate Collection of Winsock Software
          <:URL:http://alfa2.it.pw.edu.pl/tucows/>
          * The CWSApps List - Indek s Aplikacji Sieciowych dla Windows
          <:URL:http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html>
          * Papa's Anonymous FTP
          <:URL:ftp://ftp.man.poznan.pl/pub/winsock-l/>
       2.     Jakie sa dostepne przegladarki dla Unixa
              O ile Unix i pochodne do tej pory dominuja na rynku serwerow,
          to sytemem przegladarek stal MS Windows. Tym nie mniej jest kilka
          watosciowych produktow. Takich jak Arena , Netscape Navigator 3.0
          ,
          <URL:http://sunsite.icm.edu.pl/pub/www/netscape/navigator/Unix/>
          niezastapiony Lynx
          <URL:ftp://ftp.pwr.wroc.pl/pub/infosystems/www/lynx/> W Polsce
          podstawowym archiwum jest
          <URL:http://sunsite.icm.edu.pl/pub/www/>
  4.     Uzytkowanie WWW.
         Ponizej opisze istotne aspekty uzytkowania WWW.
       1.     Czy jest jakis katalog tematyczny WWW?

             + Wirtualna Polska <URL:http://wp.cnt.pl/>
             + WOW! <URL:http://www.wow.pl/>
             + OptimusNET <URL:http://www.optimusnet.pl/>
               i swiatowe
             + Yahoo <URL:http://www.yahoo.com/>
             + WWW Virtual Library
               <URL:http://www.w3.org/hypertext/DataSources/bySubject/Overview.
html>
       2.     Jak moge znalezc jakis tekst na stonie Web?

             + Z tego co zrozumialem to (w Polsce) dobrym rozwiazaniem jest
               uzycie ICMowego serwera archie
               <URL:http://archie.icm.edu.pl/>.
             + DEC Alta Vista <URL:http://www.altavista.digital.com/>
             + Yahoo <URL:http://www.yahoo.com/>
             + Lycos <URL:http://fuzine.mt.cs.cmu.edu/mlm/lycos-home.html>
             + WebCrawler <URL:http://webcrawler.com/>
             + World Wide Web Worm
               <URL:http://www.cs.colorado.edu/home/mcbryan/WWWW.html>
             + InfoSeek <URL:http://www2.infoseek.com/>
             + OpenText <URL:http://www.opentext.com>
             + HotBot <URL:http://www.HotBot.com/search.html>
             + i inne ... :-) wiekszosc dostawcow uslug I*netowych
               dostarcza odp. formularzy do wyszukiwania na
               najpopularniejszych przeszukiwarkach.
       3.     Dlaczego czesto widze "krzaczki" zamiast polskich liter?
              Jest kilka mozliwosci rozwiazania tego poblemu:
             + Masz niewlasciwa przegladarke, tj. nie obslugujaca polskich
               liter w standardzie ISO-8859-2. W miare mozliwosci wymien ja
               na cos innego (lub sprawdz czy nie mozna tego jakos poprawic
               <URL:http://www.agh.edu.pl/ogonki/> )
             + Twoja przegladarka obsluguje polskie literki, ale ty nic o
               tym nie wiesz. np. nie ustawiles w Netscape Navigatorze 3.0
               opcji: Options|Document Ecoding|Central European
               (ISO-8859-2) i odpowiedniej czcionki w
               Options|General_Preferences|Fonts|Latin-2
             + Wina lezy po stronie autora strony: Ani w naglowku HTTP, ani
               w naglowku strony (przy pomocy komendy
               <meta http-equiv="content-type" content="text/html;
               charset=iso-8859-2"> ) nie zadeklarowal "polskosci"
               dokumentu, ani nawet uzywanej strony kodowej
             + Wina lezy po stronie autora strony: uzywa CP 1250 :-(
       4.     Czy uzywajac WWW mozna "zlapac" wirusa?
              Oczywiscie :-) Zwlaszcza wirusa glupoty. A powaznie: o ile
          masz wylaczona JAVA, JavaScript, M$ ActiveX, i nie ladujesz
          plikow Worda oraz wykonywalnych - nie mozesz. W pozostalych
          wypadkach:
             + Pliki Worda i wykonywalne - wiadomo - moga byc zakazone i to
               nie zalezy od medium.
             + w Javie, i JavaSripcie znaleziono jakies usterki na tyle
               powazne, ze ponoc zagrazajace bezpieczenstwu systemow.
             + PostScript - moze zawierac niebezpieczne operacje, ktore
               pewne przegladarki moga probowac wykonac: kasowanie plikow
               albo ustawienie/zmiana hasla drukarki.
             + Bylo tez cos takiego (pamietam z dawnych instalacji lynxa)
               co pozwalalo wykonywac polecenia na lokalnym komputerze,
               (trusted hosts).
       5.  W jaki sposob nawigowac po WebSpace
              Jak najmniej chaotycznie :-0. Najlepiej uzywajac do
          poszukiwan katalogow zasobow i przeszukiwarek, i odznaczajac
          ciekawe miejsca w "zakladkach", lub "bookmark`ach"
       6.  Jak jest z prawami autorskimi w Internecie
              Nalezy przyjac, ze (przynajmniej w wypadku polskich stron)
          obowiazuja przepisy "Ustawy o prawie autorskim i prawach
          pokrewnych". Przy czym nalezy przyjac, ze o ile autor nie
          zaznaczyl inaczej (np. Public Domain, lub GNU Public Licence)
          wszystkie strony sa domyslnie oznaczone jako � badz dla NN (C) i
          mozna podawac do nich odniesienie, nie mozna natomiast ich
          wykorzystywac we wlasnej pracy (tj. tresci powiazanej z forma,
          poniewaz "czystej informacji" to juz nie dotyczy). Ochronie
          podlegaja rowniez znaki firmowe (lecz mozna ich uzyc w celach
          informacyjnych).
       7.     W jaki sposob pracowac z WWW bez bezposredniego polaczenia?
              Tak zupelnie bez polaczenia sie nie da...
          Ale mozna sciagnac potrzebne strony (uzywajac tzw. robota, albo
          normalnej przegladarki z wlaczonym cache dyskowym, lub
          zainstalowanym lokalnie serwerem proxy cache) a nastepnie je
          lokalnie przegladajac. Wiekszosc dostepnych w tej chwili
          przegladarek dziala bez polaczenia z siecia. Poza tym istnieje
          bardzo ladnie dzialajacy viewer
       8.     Co to jest i dlaczego nalezy uzywac W3chache-proxy?
              Dlaczego? Przeciez to oczywiste...
              Jednym ze skutkow coraz gwaltowniejszego rozwoju uslug WWW
          jest saturacja lacz sieci rozleglych. O ile przepustowosci lacz
          sieci lokalnych i miejskich sa zwykle nadmiarowe, to lacza
          miedzynarodowe (znacznie bardziej kosztowne) stanowia zazwyczaj
          waskie gardla Internetu.
              Szybkosc wzrostu zapotrzebowania na pasmo znacznie przekracza
          wszelkie mozliwosci inwestycyjne. Analiza ruchu wskazuje przy
          tym, ze procentowo coraz wiekszy udzial stanowia w nim transmisje
          WWW.
              Polska, jako jeden z pierwszych krajow zbudowala strukture
          tzw. cache WWW, ktora pozwala na lokalne buforowanie najczesciej
          zadanych dokumentow WWW, a tym samym:
             + zmniejszenie obciazenia lacz miedzynarodowych,
             + skrocenie sredniego czasu dostepu do informacji,
             + zoptymalizowanie wykorzystania lacz krajowych.
              Hierarchia W3cache
          <URL:http://w3cache.icm.edu.pl/sites_pl.html/> obejmuje wszystkie
          wazniejsze sieci miejskie oraz dziala w bezposredniej wspolpracy
          z podobnymi projektami poza Polska. W3cache wymienia takze
          informacje z pojedynczymi serwerami cache tam, gdzie nie istnieja
          jeszcze struktury ogolnokrajowe.
              Przy czym uzytkownicy takich ogolnopolskich sieci jak TPnet,
          lub Telebank powinni ustawic parametry swojego proxy cache na
          w3cache.icm.edu.pl jako najblizszy ich sieciom, nie zas na cache
          np. krakowskie.
  5.
         Tworzenie stron WWW
         Tworzenie stron i prezentacji WWW to nie tylko kodowanie w HTML,
     ale takze przygotowywanie grafik, dbalosc o poprawnosc skladniowa kodu
     HTML i mnowstwo innych zagadnien.
       1.     Jak moge publikowac w WWW?
              Aby moc publikowac potrzeba odpowiedniego typu konta:
          najlepiej na komputerze gdzie jest zainstalowany serwer HTTPd. W
          wypadku dostawcow komecyjnych nalezy wykupic odpowiedni rodzaj
          konta. Na wiekszosci uczelni istnieje mozliwosc zalozenia wlasnej
          stony w ramach nomalnego konta, i to czesto nawet bez ingerencji
          administratora (zazwyczaj nalezy zalozyc w swoim katalogu
          "domowym" katalogu "public_html" lub ".home"). Istnieje takze
          kilka serwerow komercyjnych umozliwiajacych publikowanie
          materialow niekomercyjnych bez wnoszenia oplat. Np. Marek Baczek
          zlozyl nastepuja deklaracje, ze jest gotow przyjac strony na
          nastepujacych warunkach:
             + strona musi byc niekomercyjna.
             + strona musi byc co najmniej ciekawa.
             + strona musi byc robiona w ISO-8859-2 lub CP1250; bez ogonkow
               stron nie przyjmujemy, moze byc po angielsku.
             + strony nie powinny przekroczyc 10 MB i nie powinny zawierac
               zbyt duzo plikow do zaladowania.
             + URL do tej strony bylby taki:
               <URL:http://www.qdnet.pl/~jakasnazwa/>
             + Prosze przyslac kilka stron dla przykladu e-mail na adres
               (Marek Baczek <URL:mailto:m...@qdnet.pl> (do 500kB).
          W poza tym w swiecie istnieje kilka serwerow oferujacych podbne
          uslugi: np. Geocites
       2.     Jak wyglada dokument WWW?
              Wiekszosc polecen jest dwuczesciowa: czesc otwierajaca <XXX>
          i zamykajaca </XXX>. Czesc polecen nie wymaga zamkniecia. Oto
          jest kod najprostszego dokumentu w HTML <HTML> <HEAD> <TITLE>
          Tytul dokumentu </TITLE> </HEAD> <BODY> Zawartosc dokumentu
          </BODY> </HTML> A teraz opis:
          <HTML> deklaracja, ze jest to poczatek dokumentu HTML
          <HEAD> naglowek (zawierajacy definicje dla calego dokumentu)
          <TITLE> tytul dokumentu
          <BODY> wlasciwa tresc dokumentu.
          Znaki specjalne pozwalaja wstawic graficzny obraz znakow bedacych
          czescia polecen: wiekszosci (< - &lt;) i mniejszosc (> - &gt;),
          cudzyslowu (" - &quot;) oraz spacji (  - &nbsp;), i stanowiacy
          skladnik tych poprzednich ampersand (& - &amp;). Wiecej
          informacji mozna znalezc w dostepnych w sieci i realnym swiecie
          kursach i podrecznikach HTML.
       3.     Co jest standardem w HTML?
              Aktualnie obowiazujacy standard HTML zostal zdefiniowany w
          dokumencie IETF: RFC 1866 autorstwa T. Berners-Lee i D. Connolly
          Hypertext Markup Language - 2.0 z listopada 1995 r. oraz FC 1867
          E. Nebela i L. Masinter Form-based File Upload in HTML . Poza tym
          "w dyskusji" znajduje sie propozycja standadu HTML 3.2. Jedna z
          wariantow nosi nazwe Wilbur druga, powracajaca w czesci do rzeczy
          porzuconych w Wilburze nazywa sie Coguar . Poza istnieja rozmaite
          "rozszerzenia" roznych firm.
              Tym niemniej wszystkie strony WWW powinny dobrze wygladac na
          kazdej przegladarce.
              Przede wszystkim kompatybilnosc z wszystkimi przegladarkami
          wcale nie musi oznaczac ograniczania sie do wspolnego podzbioru
          HTML-a (co w praktyce oznaczac by moglo nawet cos okolo HTML
          2.0). Idea przyswiecajaca programowi MBC jest taka, zeby
          korzystac z rozszerzen w taki sposob, zeby nie przeszkadzalo to
          innym przegladarkom. Oto kilka przykladow (ta lista bedzie
          rosla):

              Tabele - stosowanie tabel takie, zeby nie zaklocac pracy
          przegladarek ich nie obslugujacych (z nowszych wersji - Lynx) nie
          jest latwa sztuka. O ile w przypadku prostych tabel mozna to
          osiagnac bez wiekszych klopotow, przy bardziej wymyslnych
          konstrukcjach korzystajacych z atrybutow typu rowspan moze to byc
          trudniejsze. Podstawowa idea polega tu na wstawianiu do komorek
          odpowiednio dobranych kombinacji odstepow i przejsc do nowej
          linii (tag <br>). Przykladowo tabela zawierajaca kilka
          kilkukomorkowych wierszy moze miec porozmieszczane w nich
          dodatkowe odstepy zapewniajace odstepy miedzy zawartosciami
          poszczegolnych komorek oraz przejscia do nowych linii wstawiane
          na koncu komorek konczacych wiersze. Dzieki temu tekst ktory w
          przegladarce obslugujacej tabele bedzie w jednym wierszu tabeli,
          na Lynx-ie znajdzie sie rowniez w jednym wierszu. Mozliwe sa
          rowniez machinacje korzystajace z obslugiwanego przez Lynx-a 2.5,
          a nie obslugiwanego przez Netscape czy Internet Explorera taga
          <tab>, jednakze moze to wywolac przykre efekty na jakiejs mniej
          znanej przegladarce (Arena?), lub na nowszej wersji ktorejs z
          przegladarek.

              Ramki - w przypadku ramek sprawa jest prosta - nalezy
          skorzystac z istnienia tagu <noframes>, i umiescic w jego wnetrzu
          wersje strony przeznaczona dla przegladarki nie obslugujacej
          ramek. Konkretne rozwiazania moga byc rozne - ja umieszczam tam
          tylko troche zmodyfikowana wersje dokumentu, ktory w wersji
          ramkowej zajmuje glowna ramke, inni (niezbyt elegancko)
          umieszczaja tam tylko link do tego dokumentu. Mozna sie rowniez
          pokusic o przygotowanie znacznie zmienionej wersji dokumentu, w
          ktorej funkcje wykorzystujace ramki zostaja zastapione innymi.

              Obrazki - nie powinny sprawiac klopotow. Nalezy tylko
          pamietac o uzywaniu atrybutu alt, umieszczajac w nim tekst dobrze
          zastepujacy obrazek (mozna sie nawet pokusic o ascii art), a
          jesli obrazek sluzy wylacznie jako ozdobnik - pozostawienie go
          pustego (alt=""). cov
       4.     Jakie narzedzia wspomagajace tworzenie dokumentow WWW sa
          dostepne dla DOS/Win i MS Windows 95/NT?
              Z powodu ogromnej dynamiki powstawania nowych programow moge
          jedynie wskazac dostepne archiwa oprogramowania:
             + Tucows - The Ultimate Collection of Winsock Software
                   <URL:http://alfa2.it.pw.edu.pl/tucows/> coraz lepsze:
               zawiera wiekszosc oprogramowania dla Intenetowego stosowania
               MS Windows, zwiezle recenzje i archiwa bezposrednio na
               Politechnice Warszawskiej
             + The CWSApps List - Indek s Aplikacji Sieciowych dla Windows

               <URL:http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html >
               zawiera wiekszosc oprogramowania dla Intenetowego stosowania
               MS Windows, recenzje. Archiwa prowadza niestety w swiat
             + Papa's Anonymous FTP
                   <URL:ftp://ftp.man.poznan.pl/pub/winsock-l> jedno z
               lepiej wyposazonych archiwow na FTP.
       5.     Jakie narzedzia wspomagajace tworzenie dokumentow WWW sa
          dostepne dla Unixa?
              Jest to dla mnie niewygodne pytanie: dopiero zaczynam uzywac
          Linuxa. Ale jest cos takiego jak asWedit, sa tryby HTML dla VI i
          Emacsa. Sa tez (skryptowe) narzedzia do weryfikacji odniesien,
          sprawdzania poprawnosci kodu itp. Sa wreszcie narzedzia
          pozwalajace na konwersje popularnych w U*xie formatow: LATEX,
          LinuxDOC-SGML na HTML. Wiekszosc ze wspomnianych narzedzi mozna
          znalezc na "sansjacie" <URL:http://sunsite.icm.edu.pl/pub/www/>
       6.     Co to sa "netscapizmy" oraz inne rozszerzenia? I dlaczego nie
          nalezy ich stosowac?
              "Netscapizmami" zwie sie popularnie te rozszerzenia
          akceptowane tylko i wylacznie przez przegladarki Netscape
          Comunication , i ostatnio przez MS Internet Explorer nie
          zarejestrowane w oficjalnej specyfikacji (badz jej propozycji)
          jezyka HTML.
          Nie nalezy ich uzywac poniewaz:
             + nie ma mozliwosci sensownego sprawdzenia
               parserem/validatorem takiego dokumentu (zazwyczaj brak jest
               oficjalnych DTD dla takich rozszerzen)
             + dokumenty te nie zawsze moga byc wyswietlane w
               przegladarkach innych producentow. A HTML bedacy (w sumie)
               bardzo ubogim znaczeniowo zastosowaniem SGML-a, zostal
               stworzony po to by istniala wspolna, niezalezna od sprzetu i
               systemu platforma informacyjna.
             + niektore rozszerzenia nie mieszcza sie w zaden sposob w
               logice SGML :-)
       7.     W jaki sposob umieszczac grafike na stronach WWW?     Nie
          nalezy, bez ostrzezenia kierowac do stron zawierajacych duze (tj.
          powyzej 20 kb) grafiki.
              Aby przygotowac "przezroczyste" grafiki, tj. w kolorze
          dowolnie definiowanego tla lub podkladu, nalezy zapamietac je w
          formacie GIF 89a przy pomocy np.
          LView Pro 1.a. dla Windows, albo
          giftrans dla DOS i/lub Unix.
          Do tworzenia animowanych rysunkow moze sluzyc program Gif
          Construction dla Windows
          <URL:ftp://ftp.dtp.std.com/ftp/vendors/mmedia/gifcon.exe>
          WebPaint - shareware dla W95
          <URL:http://www.barentsnett.no/webpaint/>
          GifMerge <URL:http://www.iis.ee.ethz.ch/~kiwi/GIFMerge/>
              Wiecej informacji zawieraja nastepujace strony:
          <URL:http://dragon.jpl.nasa.gov/~adam/transparent.html>
          <URL:ftp://csi.jpl.nasa.gov/pub/graphics/transparent.faq>
          <URL:http://www.boutell.com/faq/tinter.html>
          Standard formatu graficznego GIF 89a jest opisany pod adresem
          <URL:http://members.aol.com/royalef/gifanim.htm>
       8.     W jaki sposob moge tworzyc poprawne strony z polskimi znakami
          diakrytycznymi?
              Przede wszystkim nalezy uzywac kodowania w ISO-8859-2. Poza
          tym jesli nie jestes administratorem i nie mozesz spowodowac,
          zeby serwer dodawal do naglowka ston z polskimi literami
          deklaracji typu dokumentu: text/html; charset=ISO-8859-2 nalezy
          dodac w naglowku strony (pomiedzy <HEAD> i </HEAD>, a i raczej
          przed <TITLE>) nastepujacej instrukcji: <META
          HTTP-EQUIV="content-type" CONTENT="text/html;
          charset=iso-8859-2"> nie jest to rozwiazanie najbardziej
          eleganckie: powoduje (na niektorych serwerach) dwukrotne
          interpretowanie zawartosci dokumentu, nie jest w pelni
          uwzglednione w specyfikacji HTML. Tym nie mniej dopoki nie
          doczekamy sie (badz, sami nie przyczynimy sie:-) do uznania przez
          grona normalizacyjne i producentow oprogamowania faktu, ze w WWW
          stosuje sie i inne, poza anglosaskim zestawy znakow, pozostaje
          nam stosowanie polsrodkow.
       9.     Dlaczego i w jaki sposob sprawdzac poprawnosc skladniowa
          dokumentow?
              Dlaczego: to chyba oczywiste kazdy chyba chce zeby
          rzeczywisty efekt pokywal sie z planowanym.
              Powszechnie stosowana metoda jest "reczne" sprawdzanie za
          pomoca wybranej dowolnie "przegladarki testowej" takiej jak np.
          Lynx, Netscape, lub MS IE. Jest to dzialanie co najmniej
          watpliwe: przegladarka powinna wyswietlac wszystkie (nawet z
          bledami skladniowymi) strony poprawnie, choc niekoniecznie
          zgodnie z intencjami jej autorow. Poprawna forma sprawdzania
          strony jest raczej uzycie parsera SGML takiego jak na przyklad SP
          Jamesa Clarka (dostepny tak dla DOS (32-ext.) Win32, jak i Unixa)
          <URL:"http://www.jclark.com/sp/"> wraz z odpowiednim dla
          stosowanego dialektu HTML DTD . W wyniku kontroli powstaje lista
          bledow (przez skieowanie potoku bledow do pliku) na podstawie
          ktorej nalezy "recznie" poprawic dokument.
      10.     W jaki sposob moge zainstalowac licznik na stronie?
              Nie nalezy tego robic poniewaz, zazwyczaj, liczniki klamia ,
          nie uwzgledniajac odwolan do strony przez Proxy-Cache, powoduje
          niepotrzebne obciazenie serwera (graficzne), i jest przejawem
          niepotrzebnego efekciarstwa. Jesli jednak te argumenty sa
          nieprzekonujace polecam <URL:http://www.webtools.com/counter/>,
          albo Yahoo
          Czy wreszcie <URL:ftp://ftp.ibspan.waw.pl/pub/unix/html-counter/>

          albo skorzystaj z opisu Tomasza Pilata: nalezy zalozyc w katalogu
          gdzie mamy strone, do ktorej chcemy liczyc dostepy plik
          .htaccess. Oto jego zawartosc:
          AddType text/x-server-parsed-html index.html
          ---- gdzie index.html to nazwa tej strony
          Oto glowny licznik. Powiedzmy ze sie nazywa count.cgi. Oto jego
          zawartosc:

          #!/usr/bin/perl
          open (COUNT, "count") ;
          $counter = <COUNT> ;
          close (COUNT) ;
          open (COUNT, "> count") ;
          print COUNT +($counter+1) ;
          close (COUNT) ;
          print $counter;
          exit(0) ;

          moze zaistniec potrzeba zmiany sciezki do perla (to
          #!/usr/bin/perl). Najlatwiej sprawdzic, gdzie jest perl piszac:
          whereis perl lub which perl
      11. Wykonujemy co nastepuje:
          touch count
          chmod 777 count
          chmod 505 .htaccess
          chmod 505 count.cgi
          W pliku count znajdowac sie bedzie liczba odwiedzin.
      12. Umieszczamy na stronie cos takiego: Ta strone odwiedzilo juz
          <!--#exec cmd="/usr/bin/perl count.cgi"--> gosci!
          Uwaga cenzora: powinno byc:
          Te strone pobrano juz <!--#exec cmd="/usr/bin/perl count.cgi"-->
          razy od dnia zainstalowania licznika lub jego resetowania
          Pamietajac czy sciezka do perla jest odpowiednia...
          To wszystko. Powinno dzialac... Jak nie to napiszcie!
          (TP)
      13.     Czy moge w WebSpace umieszczac dokumenty w innym formacie niz
          HTML?
              Tak. Ale trzeba pamietac o tym, aby nie byly ograniczone
          tylko do jednej platformy sprzetowej/systemowej. I dlatego nie
          nalezy uzywac "surowych"plikow MS Word`a czy QuattroPro. Warto je
          przelozyc na jakis powszechnie uznay standard taki jak
          PostScript, RichTextFormat, CVS, TEX, lub HTML.
              Jesli jest to niemozliwe?
              W takim razie nalezy dodac odpowiednie deklaracje MIME types
          serwera. Oznaczenia typow plikow znajduja sie w comp.mail.mime
          FAQ <URL:http://sunsite.icm.edu.pl/pub/usenet/comp.mail.mime/>
      14.     Jakich polskich terminow uzywac przy tworzeniu stron?
              Temat jest problematyczny... Na pewno odwolanie lub odnosnik
          jest lepszy niz hypereference...
  6.     Co warto wiedziec o serwerach WWW?
         Jak najwiecej :-)
       1.     Jakie serwery WWW (HTTP) sa dostepne i ktory wybrac (i pod
          jakim system systemem powinien pracowac)?
              Pytanie rzeka... najlepiej spojrzec na strone Web Compare
          <URL:http://webcompare.iworld.com/> gdzie szczegolowo opisano (i
          porownano) wiekszosc dostepnych sewerow WWW.
       2.     Gdzie moge znalezc opis protokolu sewera WWW (HTTP)
              Aktualnie obowiazujacy standard (realizowany w calosci przez
          wiekszosc dostepnych sewerow) zostal opisany w RFC 1945
       3.     W jaki sposob moge na moim serwerze obslugiwac jego bledy?
              Przede wszystkim zajrzyj do dokumentacji swojego serwera.
          Zazwyczaj w dostarcznych zbiorach konfiguracyjnych serwerow
          dostepne sa odpowiednie opcje (choc zwykle "skomentowane", aby je
          uaktywnic wystaczy skasowac znak komentarza). Opis bledow
          znajduje sie w specyfikacji HTTP.
       4.     W jaki sposob poprawnie serwowac polskie dokumenty?
              Nalezy wykorzystac mozliwosci serwera Apache-Httpd, a
          mianowicie technologie MultiViews. Dzieki temu wykorzystywane sa
          preferencje jezykowe uzytkownika.
              Generuje to nastepujace rozszerzenia dla wersji jezykowych
          dokumentow:

              Wersja       Rozszerzenie    Rozszerzenie  Rozszerzenie (CGI
            dokumentu    (HTML bez SSI)   (HTML z SSI)     uzytkownika)
           Jedyna        .html           .shtml          .cgi
           Polska - bez
           polskich      .html.pn        .shtml.pn       .cgi.pn
           znakow
           Polska - ISO
           8859-2        .html.po        .shtml.po       .cgi.po
           Polska - Win
           CP 1250       .html.pw        .shtml.pw       .cgi.pw
           Angielska     .html.en        .shtml.en       .cgi.en
          Uwaga: Odradza sie stosowanie wersji Win CP 1250.
              Dla skryptow CGI umieszczonych w katalogu /cgi-bin/ warto
          stosowac nazwy takie jak dla CGI uzytkownika (rozpoznawanych po
          rozszerzeniu).
              Aby moc skorzystac z tej technologii nalezy w kazdym katalogu
          umiescic plik .htaccess o np. nastepujacej zawartosci (dyrektywy
          te moga sie tez znalezc w plikach konfiguracyjnych serwera -
          access.conf i srm.conf):

          Options All MultiViews
          AddLanguage         pl .po
          AddLanguage         pn .pn
          AddLanguage         pw .pw
          LanguagePriority    pl pn pw en
          DirectoryIndex index.shtml index.html

          Dyrektywa deklarujaca rozszerzenie .en znajduje sie domyslnie w
          pliku srm.conf.
              Powyzszy plik .htaccess wlacza MultiViews, aby mozna bylo
          korzystac z tej technologii, definiuje rozszerzenia jezykowe
          uzywane przez nia, ustala domyslne preferencje jezykowe i pozwala
          uzywac plikow index z Server-Side Includes.
              Do automatycznego tworzenia na podstawie dokumentow z
          polskimi literami w standardzie ISO 8859-2 wersji bez polskich
          znakow i ewentualnie CP 1250 z zachowaniem wymogow tej
          technologii mozna uzyc programu HtmlConv (patrz nizej).

          -----------------------------------------------------------------
          Przygotowywanie dokumentow pod DOS-em Z wlasnego doswiadczenia
          wiem, ze przygotowywanie dokumentow HTML-owych pod DOS-em jest
          dosc popularne. Jednakze napotykamy tam na drobny problem -
          DOS-owy limit dlugosci nazw plikow, a dokladniej limit dlugosci
          rozszerzenia do trzech znakow.
              Sugeruje uzywanie nastepujacych rozszerzen zastepczych:

           Rozszerzenie - Unix Rozszerzenie - DOS
           .html               .htm
           .ihtml              .iht
           .whtml              .wht
           .ehtml              .eht
           .shtml              .sht
           .html.po            .htp
           .html.pn            .htn
           .html.pw            .htw
           .html.en            .hte
           .shtml.po           .shp
           .shtml.pn           .shn
           .shtml.pw           .shw
           .shtml.en           .she

              Dodatkowo plik .htaccess powinien pod DOS-em nosic nazwe
          _htacces. Tlumaczenia nazw plikow z wersji DOS-owych na wersje
          Unix-owe (obie technologie) wykonuje program Reh (patrz nizej).
              Jezeli chcemy nie tylko tworzyc, ale i testowac tworzone
          strony, mozemy zrobic to dowolna przegladarka, np. Netscape.
          Jesli stosujemy pierwsza technologie to proby ladowania
          dokumentow z odpowiednimi dlugimi rozszerzeniami automatycznie
          spowoduja zaladowanie pliku z odpowiednim krotkim rozszerzeniem.
          Jesli stosujemy druga technologie, to niezbedny bedzie program
          ExtFake (patrz nizej) dokonujacy tlumaczenia nazw plikow.
              Program HtmlConv (patrz nizej) jest dostepny rowniez w wersji
          DOS-owej.
              Poniewaz program HtmlConv wymaga, aby wersje zrodlowe
          dokumentow zawieraly polskie litery w standardzie ISO 8859-2,
          nalezy poslugiwac sie edytorami pozwalajacymi na ich wprowadzanie
          - ja osobiscie polecam dowolny edytor tekstowy (np. TvEdit, Vim)
          i program Ogonki (autorstwa Andrzeja Gorbiela), dostepny na
          Polskiej Stronie Ogonkowej .

          -----------------------------------------------------------------
          Programy narzedziowe Ponizej wymienione jest kilka programow
          narzedziowych (mojego autorstwa) ulatwiajacych przygotowywanie
          dokumentow zgodnie z dowolna z powyzszych technologii.
              Kazde archiwum zawiera krotka dokumentacje.
          HtmlConv - Linux
               Program do konwersji dokumentow HTML-owych z polskimi
               literami w standardzie ISO 8859-2 do dokumentow bez polskich
               liter i ewentualnie z polskimi literami w standardzie CP
               1250. Zmienia polskie litery, URL-e w linkach, deklaracje
               stosowanego zestawu znakow. Mozna go stosowac do dokumentow
               korzystajacych z dowolnej z wymienionych tu technologii, a
               takze do dokumentow laczacych technologie. Powyzsze archiwum
               zawiera binaria dla Linux-a (a.out).
          HtmlConv - DOS
               Program do konwersji dokumentow HTML-owych z polskimi
               literami w standardzie ISO 8859-2 do dokumentow bez polskich
               liter i ewentualnie z polskimi literami w standardzie CP
               1250. Zmienia polskie litery, URL-e w linkach, deklaracje
               stosowanego zestawu znakow. Mozna go stosowac do dokumentow
               korzystajacych z dowolnej z wymienionych tu technologii, a
               takze do dokumentow laczacych technologie. Powyzsze archiwum
               zawiera binaria dla MS-DOS-a.
          HtmlConv - zrodla
               Program do konwersji dokumentow HTML-owych z polskimi
               literami w standardzie ISO 8859-2 do dokumentow bez polskich
               liter i ewentualnie z polskimi literami w standardzie CP
               1250. Zmienia polskie litery, URL-e w linkach, deklaracje
               stosowanego zestawu znakow. Mozna go stosowac do dokumentow
               korzystajacych z dowolnej z wymienionych tu technologii, a
               takze do dokumentow laczacych technologie. Powyzsze archiwum
               zawiera zrodla z przeznaczeniem dla systemow Unixopodobnych.
               Wymaga biblioteki Coven (patrz nizej).
          Reh
               Skrypt (a wlasciwie pakiet skryptow) shellowych
               zamieniajacych rozszerzenia w wersji DOS-owej na
               rozszerzenia w wersji Unix-owej, a takze nazwe pliku
               _htacces na .htaccess. Dostosowane do obu wymienionych
               technologii. Wymagaja dostepnosci programow sh, find, sed,
               mv (a wiec powinny dzialac na dowolnym systemi
               Unixopodobnym. Uwaga! Wykorzystanie find moze nie byc w
               pelni przenosne).
          ExtFake
               Rezydentny (224 bajty) program tlumaczacy dlugie wersje
               rozszerzen stosowanych w nowej technologii na ich krotkie
               odpowiedniki, co umozliwia bezproblemowe testowanie
               dokumentow korzystajacych z nowej technologii.
          Biblioteka Coven - Linux
               Biblioteka zawierajaca szereg uzytecznych funkcji, m. in. do
               tworzenia skryptow CGI o kilku wersjach jezykowych (zgodne z
               oboma wymienionymi wyzej technologiami), konwersji polskich
               liter, ulatwiajace pisanie skryptow CGI i inne. Powyzsze
               archiwum zawiera skompilowana biblioteke dla Linux-a (a.out)
               i pliki naglowkowe.
          Biblioteka Coven - zrodla
               Biblioteka zawierajaca szereg uzytecznych funkcji, m. in. do
               tworzenia skryptow CGI o kilku wersjach jezykowych (zgodne z
               oboma wymienionymi wyzej technologiami), konwersji polskich
               liter, ulatwiajace pisanie skryptow CGI i inne. Powyzsze
               archiwum zawiera zrodla biblioteki i pliki naglowkowe.
          Cov
       5.     Jak mozna udostepniac baze danych przez WWW?
              Jest cos takiego, do WWW nadaje sie doskonale, daje tylko
          podzbior SQL - i to wszystko za darmo. Nazywa sie miniSQL
          (ostatnia wersja - 1.0.13). Dokumentacje do niego zanjduje sie
          pod adresem <URL:http://www.sgh.waw.pl/guides/db/mSQL/> Tam tez
          jest link do sciagniecia ktorejs z wersji przez FTP.
  7.     Adninistrowanie WWW

       1.     Jak stworzyc strone na haslo?
              W Unixie, na Apache , badz NSCA nalezy zalozyc w kalalogu w
          ktoym ma sie znajdowac choniony zasob plik .htaccess w ktoym
          nalezy wpisac klauzule (podobna do wystepujacej w zbioze
          access.conf) AuthUserFile /home/dir/foo/public_html/.htpasswd
          AuthGoupFile /home/dir/foo/public_html/.htgroup
          i wymienionych zbioach nazwy uzytkownikow i hasla.
              Pod NT tez jest to mozliwe pod warunkiem, ze korzysta sie z
          NTFS. Nadaje sie na katalog lub konkretny plik odpowiednie
          uprawnienia do czytania (jednemu lub grupie uzytkownikow) , po
          czym odbiera sie uprawnienia pozostalym.
       2.     W jaki sposob moge udostepnic przeszukiwanie mojego serwera?
              Temat czeka na opracowanie. :-)
  8.     Zrodla wiedzy
  9.     Jakoze WWW jest dla wielu podstawowa usluga Internetu, a na pewno
     wielu ludzi zaczyna swoj kontakt z siecia od niego, pozwalam sobie
     zamiescic odniesienia do podstawowych przewodnikow po Sieci.
 10.     Elementarz Internetu Macieja Uhliga.
     <URL:http://www.cto.us.edu.pl/>
 11.     Zrodla HTML
         O HTML mozna dlugo. Postaram sie jednak przedstawic przede
     wszystkim polskie (tj. tak polsko-jezyczne, jak i tylko sie w polsce
     znajdujace) zasoby.
        o     zrodla HTML po polsku w sieci.

             + Kurs HTML Pawla Wimmera
               http://www.polbox.com.pl/cgi-bin/ssis/lupus/html/glowny.htm
               Jest tez wersja offline (html.zip)
             + WWWhowto - Jak zrobic swoja strone WWW? Tomasza Pilata
               (Chwilowo nieczynny) http://ajax.umcs.lublin.pl/~poncjusz/
             + Jak stworzyc wlasna strone WWW (Grzegorza Wojcika)
               http://www.ia.pw.edu.pl/pl-iso/homepage-info.html
             + Jak zrobic wlasna strone WWW (wskazowki dla uzytkownikow z
               PK) (Szymona Sokola i Grzegorza Muchy)
               http://www.pk.edu.pl/sysdocs/howto.html)
             + KROTKI KURS HTML
               http://panda.bg.univ.gda.pl:80/~krabek/kurs.html
             + Jak zrobic swoja wlasna HomePage ?
               http://zeus.polsl.gliwice.pl/~bort/local/how-to.html
             + VRML w Polsce
               http://andante.iss.uw.edu.pl/obuz/vrmlp/index.html
             + AMU-NET's VRML Repository (Maintainer: Klaudiusz Modrzewski
               )
             + JAVA na UCI AH
               http://arrow.uci.agh.edu.pl/~java/index-p.html
             + JAVA na SunSite ICM UW http://sunsite.icm.edu.pl/java/
        o
        o Wlodzimierz Macewicz
          HTML. Jezyk opisu dokumentu hipertektowego HTML
              Warszawa 1996; Zaklad Nauczania Informatyki MIKOM (kiedys w I
          wyd.(19 95) nazywalo sie to Jezyk skladu dokumentu hipertektowego
          HTML i HTML + ) Porzadnie opisuje HTML. Pisze o polskich
          literach. Dobre zestawienie znakow (lacznie z nie obslugiwanymi
          jeszcze sekwencjami matematycznymi) i notacja co do jakiej
          przegladarki (specyfikacji jezyka) nalezy. Moim skromnym zdaniem
          tak pierwsze jak i d rugie wydanie ma pewna drobna wade: wiele
          razy powtarza sie w niej polecenie: "patrz strona.15/18/19,".
          Poza tym swietna, i pierwsza polska na rynku. I stosunkowo tania
          182 strony za 10 zl.
        o Elisabeth Castro Po prostu HTML Gliwice 1996; Helion, Peachpit
          Press
              Wyglada na warta swej ceny. B. rozbudowny spis tresci +
          przyklady graficzne obok konkretnych konstrukcji jezyka. (choc ja
          i tak wole ksiazke Macewicza :-) cena cos kolo 19 zl.
        o Jezyk HTML. Tworzenie wlasnych dokumentow WWW (w:) CHIP Special.
          Internet dla kazdego. s. 50-80 Wroclaw 1996; Vogel Publishing
              jest tez CD-ROM ze FAQ i jakimis dwoma kursami: Sunila Gupty
          i dostepnym w sieci (Wroclaw) A Beginner's Guide to HTML Poza tym
          katalog z RFC (60 Mb) cena 20 zl. (uwazam, ze dla widziarzy
          (zwlaszcza tych 3.1) warto)
        o Piotr Teczynski (1995). Quo vadis, Internecie? (w:) Informacja
          Profesjonalna , 5:42-46. ISSN 1233-0329.
        o Piotr Teczynski (1996). HTML - uniwersalny jezyk Pajakow? (..)
          Informacja Profesjonalna , (w druku). ISSN 1233-0329.
        o Piotr Gawrysiak VRML. Wirtualna rzeczywistosc w Internecie
          Warszawa 1995, 1996; Zaklad Nauczania Informatyki MIKOM
              Wyglada przyzwoicie - przy czym raczej jako podreczna
          sciagawka przy pisaniu skryptow (z dyskietka)
        o Rafal Wiosna Kazdy chce miec wlasna strone , cykl publikacji w
          numerach 26/95, 3/96 dwutygodnika PCkurier
              jak widac ukazaly sie dwa odcinki, a obiecywano 3 :-) . Bylo
          to, wstepne, przedstawienie mozliwosci jezyka i jako takie
          calkiem dobre. Ale chyba nie warto kupowac numerow archiwalnych
          :-)
        o Asha Dornfest Tworzenie stron WWW przy pomocy Worda ; Gliwice
          1996; Helion
        o Dave Taylor Tworzenie stron WWW. HTML Warszawa 1996; IDG Books,
          ReadME

        o

             + A Beginner's Guide to HTML (na Politechnice Wroclawskiej) i
               na ATM htt
               p://www.immt.pwr.wroc.pl/export_hp/html-primer-080693.html
             + Introduction to HTML Iana S. Grahama (Peryt - Warszawa)
               http://whisky.peryt.waw.pl/tools/webdoc/HTMLdocs/NewHTML/htmlind
ex.html
               i na Uniwersytecie Gdanskim
               http://www.univ.gda.pl/owner/ktem/newhtml/html_intro.html
             + HTML Documentation Iana S. Grahama (Politechnika Krakowska)
               http://www.pk.edu.pl/sysdocs/jezyk_html/
             + Interaktywny kurs HTML (w oryginale autorstwa Yuriko Ienaga
               zmodyfikowany przez: Jana Peszko) h
               ttp://www.ip.krakow.pl/~jpesz/html/html.html
             + World Wide Web FAQ Thomasa Boutella (w poznanskim MANie.
               Jest tez wersja offline WWW-FAQ (*.zip ) )
               http://www.put.poznan.pl/hypertext/Internet/faq/www/www_faq.htm
             + HTML 3.0 Specification
               Instytut Fizyki UJ - Krakow
               http://www.if.uj.edu.pl/UJ/IF/PTO/HTML_3.0/Contents.html
               Wydzial Chemii UW - Warszawa
               http://zoolook.chem.uw.edu.pl/html_3.0/
               Tojmiejska Akademicka Siec Komputerowa
               http://www.task.gda.pl/help/HTML_3.0/Contents.html
             + Welcome to HotJAVA SGH Warszawa
               http://alpha.sggw.waw.pl/java/
             + Introduction to HTML 3.0 (UCI AGH Krakow)
               http://rexio.uci.agh.edu.pl/~dot/man/1.html
             + Dokumentacja do NCSA Mosaic we Wroclawiu
               http://www.immt.pwr.wroc.pl/mosaic-docs/
        o

             + Polska Strona Ogonkowa <URL;http://www.agh.edu.pl/ogonki/>
             + Ston testowe ISO-8859-2 Wojciecha Myszki
               <URL;http://www.immt.pwr.wroc.pl/export_hp/test/>
             + Instalacja i konfiguracja serwera WWW
               <URL;http://info.fuw.edu.pl/tech-doc/serwery.html>
             + test polskich liter
               <URL;http://www.ch.uj.edu.pl/pl/testpl.html>
             + Winter Jaka Zielinskiego <URL:http://winter.it.com.pl/>
               ciekawi sewis semi-komercyjny, zawierajacy sporo ciekawych,
               choc jeszcze czesto ogolnikowych materialow na temat HTML i
               Lotus Notes.
          w Polsce
             + NSCA Tutortial
               <URL:http://www.lublin.pl/docs-1.4/tutorials/index.html>
             + CERN Server User Guide
               <URL:http://vax.telbank.pl/dow_dir/guide.html>
             + Running A WWW Service Briana Kelly (Gliwice)
               <URL:http://www.polsl.gliwice.pl/e-books/HTML/handbook.html>
        o     Standardy - dostepne w roznych miejscach,
              <URL:ftp://ftp.nask.pl/pub/rfc/>
          <URL:ftp://ftp.icm.edu.pl/pub/rfc/>
          <URL:ftp://ds.internic.net/rfc/>
          <URL:ftp://nic.nordu.net/> (192.36.148.17)
          <URL:ftp://ftp.nis.garr.it/> (192.12.192.10) HTML
             + RFC 1590 - The text/html Internet Media type
             + RFC 1866 - Official Specification of HTML 2.0
             + RFC 1867 - FORM-based file uploads (Experimental)
          HTTP
             + RFC 1945 - Official Specification of HTTP 1.0
          E-Mail and MIME
             + RFC 822 - Standard for Internet E-mail
             + RFC 1123 - Update to RFC 822
             + RFC 1521 - MIME Mail standard (1/1) -- message format
             + RFC 1522 - MIME Mail standard (2/2) -- extended header field
               data
             + RFC 1590 - The text/html Internet Media type
          USEnet News
             + RFC 1036 - USENET news messages protocol
          Uniform Resource Locators
             + RFC 1738 - Uniform Resource Locators
             + RFC 1808 - Relative Uniform Resource Locators
             + RFC 1630 - Overview of Resource Naming Schemes for the
               Internet
             + RFC 1700 - Assigned Numbers - numery portow w I*necie
          Language and Country Specifications
             + RFC 1766 - Language Tags for use on the Internet
             + ISO 639 - Language Codes
               <URL:ftp://http://www.ics.uci.edu/pub/ietf/http/related/iso639.t
xt>
             + ISO 3166 - Country Codes
               <URL:ftp://http://www.ics.uci.edu/pub/ietf/http/related/iso3166.
txt>

        o

        o     Dokumenty dotyczace tworzenia serwisow WWW w sieci (polskiej)


        o     Dokumenty dotyczace tworzenia serwisow WWW w sieci
              I znow bedzie to jedynie moj subiektywny wybor:
             + W3 Corporation <URL:http://www.w3.org/> Sewer organizacji
               proponujacej standardy dla WWW.
                   tam miedzy innymi Style Guide for Online Hypertext
               <URL:http://www.w3.org/pub/WWW/Provider/Style/>
             +
             + The WDVL: The Virtual Library of WWW Development
               <URL:http://WWW.Stars.com/Vlib/>
             + Top 10 Things NOT to do
             + The Multilingual World Wide Web
               <URL:http://www.ebt.com:8080/docs/multilingual-www.html>
             + Lynx Optimized Pages!
               <URL:http://www.nyu.edu/pages/wsn/subir/lynx.html>
             + WWW Viewer Test Page
               <URL:http://www-dsed.llnl.gov/documents/WWWtest.html>
             + Yale C/AIM WWW Style Manual
               <URL:http://info.med.yale.edu/caim/StyleManual_Top.HTML>
             + WWW Authoring Information
               <URL:http://www.netspace.org/~dwb/www-authoring.html>
             + HTML resouces in WWW by SQ
               <URL:http://www.sq.com/htmlsgml/html/h-sites.htm>
             + The Bare Bones Guide to HTML
               <URL:http://werbach.com/barebones/> krotki (15kb) spis
               wszystkich komend HTML wraz z netscapizmami (zaznaczonymi)
               <URL:ftp://http://werbach.com/barebones/>

-- 
Rafal Maszkowski r...@torun.pdi.net           http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID: <pl.comp.www-1-844284664@torun.pdi.net>
Path: mbox-mo1.pugleaf.net!unknown!not-for-mail

Show Full Headers
Complete Article Headers
From: Ziemek Borowski <zie...@qdnet.pl>
Subject: pl.comp.www FAQ
Date: 1996/10/02
Message-ID: <pl.comp.www-1-844284664@torun.pdi.net>
X-Deja-AN: 186797004
distribution: world
sender: r...@rymunda.torun.pdi.net
supersedes: <pl.comp.www...@torun.pdi.net>
x-posting-frequency: Posted on 2nd day of each month
followup-to: poster
organization: Rafal Maszkowski
keywords: WWW World Wide Web
reply-to: zie...@qdnet.pl (Ziemek Borowski)
newsgroups: pl.comp.www,pl.answers
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit