🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.answers
Article #197

pl.comp.www FAQ - 2/5 - definicje

#197
From: Ziemek Borowski
Date: Mon, 14 Jul 1997 03:49
970 lines
46073 bytes
     _________________________________________________________________

  2. Definicje

   _Co to jest: ...?_

2.1 Internet

     RFC 1462 Internet zostal zdefiniowany jako:
     * siec sieci komputerowych oparta na protokolach IP i TCP, UDP oraz
       ICMP (TCP/IP)
     * zasoby dostepne na komputerach polaczonych z siecia (tzw. hostach)
     * spolecznosc, wspolnota (community) ludzi uzywajacych i
       rozwijajacych te siec

   Nie jest to wiec, jakby niektorzy chcieli ,,taka ikonka na pulpicie''
   ani tez zadna z dominujacych w danej chwili uslug sieciowych.

   Dla niektorych jest to potworna wizja porozumiewania sie ludzi za
   posrednictwem maszyn. Dla innych jest to przedsionek infostrady, czy
   ogolniej mowiac spoleczenstwa informacyjnego.

   _Patrz tez:_
     * Internet Society <http://www.isoc.org/>
     * Polska Spolecznosc Internetu <http://www.psi.org.pl/>
     * InterNIC <http://www.internic.net/>
     * Elementarz Internetu <http://www.cto.us.edu.pl/eleminte/ei.html>
       Macieja Uhliga
     * Podstawowe uslugi Internetu <http://www.ict.pwr.wroc.pl/doc/iwpl/>
       Tomasza Surmacza
     * Rozne pozyteczne dokumenty w/g AGH
       <http://www.agh.edu.pl/opisy.html>
     * Wirtualna Akademia - Katedra Teleinformatyki
       <http://www.gumbeers.elka.pg.gda.pl/WA/KTI/>
     * Narzedzia sieciowe
       <http://www.immt.pwr.wroc.pl/export_hp/tool/tool.html> Wojciecha
       Myszki (jeden z lepszych TECHNICZNYCH przewodnikow po sieci).
     * EFFu Przewodnik po Internecie
       <http://www.eff.org/pub/Net_info/EFF_Net_Guide/Other_versions/Poli
       sh/>
       (wersja ,,hipertestowa'') <http://alicja.ci.pwr.wroc.pl/internet/>
     * Geneza i rozwoj internetu <http://www.ccs.pl/~mkc/internet/> Marka
       Kuchiaka



2.2 Intranet

     Jest proba zastosowania technologii internetowych z poziomu
   prezentacji i aplikacji (czyli przede wszystkim HTTP/HTML, poczty
   elektronicznej i Usenet news) do sieci lokalnych i firmowych. Sieci
   intranetowe wspomagane sa przez indeksy dokumentow i uslugi
   wyszukiwawcze pozwalajace na tworzenie firmowej ,,bazy wiedzy''. (Ma
   to zwiazek koncepcja odchudzenia stacji roboczych do wszechstronnie
   zorientowanego (przegladarka, edytor, poczta) acz odchudzonego klienta
   i zwiazanym z tym pomyslem na obnizanie kosztow).

   _Patrz tez:_
     *
     * IntranetJournal <http://www.intranetjournal.com/>
     * Intranet Reference Site <http://intrack.com/intranet/>
     * Netscape: Full Service Intranet
       <http://home.netscape.com/comprod/at_work/white_paper/intranet/>

2.3 Infostrada

     Jest to jedna z nazw utopii (programu spolecznego, ideologii)
   nazywanej tez czasem spoleczenstwem informacyjnym, gloszacej ze
   podstawowym towarem staje sie wiedza i dostep do niej. W tak
   sformulowany program spoleczny doskonale wpisuje sie Internet (w swej
   warstwie aplikacyjnej) bedac jednym z mozliwych mediow przekazu.

   _Patrz tez:_
     * Michael Sullivan-Trainor _Infostrada_ ReadMe, IDGBooks,
       ProgramersPress: Warszawa 1995 (ISBN 83-85769-95-1)
     * Uzaleznienie od Internetu <http://winter.it.com.pl/2e1a.htm> J.
       Zielinski.
     * Pawel Bartuzi FidoNet. Komputerowa siec wymiany informacji.
       Studium Socjologiczne
       <http://free.polbox.pl/v/venglin2/pracamgr.txt>
     * Information Society Project Office <http://www.ispo.cec.be/> Unia
       Europejska.
     * Bibliography of Organizational Computer-Mediated Communication
       <http://shum.cc.huji.ac.il/jcmc/rudybib.html>
     * The Information Infrastructure Task Force (USA)
       <http://www.iitf.doc.gov/>

2.4 WWW

     _WWW_ _(World Wide Web)_ , zwana inaczej Pajeczyna, Webem jest
   hipertekstowym, multimedialnym, sieciowym, opartym na TCP/IP systemem
   informacyjnym.
     * _hipertekstowym_   czyli takim gdzie istnieja zdefiniowane
       zaleznosci miedzy poszczegolnymi dokumentami, mozliwosci dowolnego
       przemieszczania sie pomiedzy nimi, oraz zdefiniowane znaczeniowo
       wyrozniki tekstu.
     * _multimedialnym_   czyli dopuszczajacym stosowanie roznych srodkow
       przekazu: tradycyjnych tekstow, dzwiekow, grafiki.
     * _sieciowym_   bo opartym na warstwie prezentacyjne/aplikacyjnej
       sieci rozleglej Internet, a wiec o zasiegu praktycznie globalnym.

   _Patrz tez:_
     * World Wide Web Consortium <http://www.w3.org/pub/WWW/>
     * WWW FAQ Boutella <http://www.boutell.com/faq/>
     * Entering the World-Wide Web: A Guide to Cyberspace
       <http://www.eit.com/goodies/www.guide/> Kevina Hungesa

2.5 HTML

     _HTML_ czyli _Hypertext Markup Language_ jest (a wlasciwie byl)
   napisanym w SGML hipertekstowym jezykiem kodowania dokumentow. Od roku
   1990 (gdy zostal zaprojektowany przez Tima Berners-Lee w CERN
   <http://www.cern.ch/CERN/WorldWideWeb/WWWandCERN.html> ) w celu
   szybszej i latwiejszej wymiany dokumentow przeszedl dluga i kreta
   droge od prostego (w praktyce zawierajacego kilkanascie wyrazen)
   jezyka znakowania ZNACZEN dokumentow do jezyka (a wlasciwie slangu ze
   wzgledu na zanik kluczowych elementow gramatyki) opisu strony.
   Podstawowe zalozenia przyswiecajace powstaniu i rozwijaniu jezyka:
     * prostota (tak w sensie nauczenia sie, jak i realizacji przez
       klientow)
     * niezaleznosc od platformy
     * mozliwosc rozszerzania o wspolprace z bazami danych i
       niestandardowymi obiektami.
     * elementy zaleznosci miedzy dokumentami (i poszczegolnymi ich
       fragmentami)
     * rozne poziomy ,,znaczeniowe'' jezyka
          + poziom 0 podstawowy - naglowki, listy, odniesienia
          + poziom 1 rysunki, podkreslenia, wyroznienia tekstu
          + poziom 2 formularze, definicje znakow (SGML entity)
          + poziom 3 tabele
          + poziom 4 formuly matematyczne

   _Patrz tez:_
     * HTML na W3C <http://www.w3.org/pub/WWW/MarkUp/>
     * The Web Design Group <http://htmlhelp.com/> (opisy HTML 3.2, CSS,
       Style Guide, spis waznych odnosnikow)
     * Sekcja: Tworzenie HTML
     * HTML Writers Guild <http://www.hwg.org/>

2.6 SGML


     _________________________________________________________________

Date: Sat Oct 21 23:53:24 MET DST 1996
From: Grzegorz Staniak <GSTANIAK@golem.umcs.lublin.pl>
From: ziembor@qdnet.pl
Subject: SGML
     _________________________________________________________________

   _SGML_ czyli _Standard Generalized Markup Language_ jest metajezykiem
   - opisanym w miedzynarodowym standardzie (ISO 8879:1986) sluzacym do
   projektowania opisu dokumentow wedlug okreslonego zapotrzebowania
   informacyjnego z uzyciem dowolnie dobranego zestawu znacznikow i ich
   skladni.

   Dokument SGML sklada sie z kilku czesci:
     * _deklaracji SGMLa_ gdzie opisuje sie klase dokumentu, podstawowe
       parametry jego budowy i przetwarzania: uzywane zestawy znakow,
       dopuszczalne dlugosci literalow (np. nazwy znacznikow czy dlugosc
       atrybutow), opcje minimalizacji (np. czy mozliwe jest i w jakiej
       postaci pomijanie znacznikow konczacych element).
     * _Definicji Typu Dokumentu_ _(DTD, Document Type Definition)_ gdzie
       jest zakodowana hierarchia elementow wraz z dopuszczalnymi
       atrybutami, ich dopuszczalnymi i domyslnymi wartosciami, mozliwa
       zawartoscia DTD jednoznacznie okresla skladnie danego typu
       dokumentu.
     * _zawartosci dokumentu_ czyli tzw. _DOCUMENT INSTANCE_ (w wypadku
       wielu typow dokumentow zawierajace takze ,,zewnetrzne'' elementy
       sterujace (np. <?date>))

   W wielu wypadkach deklaracje stosuje sie domyslna, a zamiast calego
   DTD umieszcza sie Formal Public Indentifier (rozwiazywany zwykle przez
   parsery na wlasciwie DTD przy pomocy pliku catalog zawierajacego zbior
   dopuszczalnych deklaracji wraz z odsylaczami do poszczegolnych
   plikow). Przy czym istnieje rozroznienie na identyfikatory publiczne:
   <!DOCTYPE PUBLIC HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"> czyli
   zarejestrowane i systemowe np.: <!doctype linuxdoc system> tworzone ad
   hoc.

   Parser SGML (jak sama nazwa wskazuje) jest programem analizujacym
   skladnie dokumentu i to (jesli mowa o tzw. _validating parsers_ ) nie
   tylko sama jednorazowa dawke informacji ale rowniez deklaracje SGML i
   DTD (wraz z jego skladnia). Wyjscie z parsera ( _ESIS,_ czyli _Element
   Structure Information Set_ ) moze stanowic podstawe konwersji czy
   jakiejkolwiek obrobki dokumentu (lacznie z (re)formatowaniem, przy
   wykorzystaniu arkuszy stylistycznych DSSSL ).

   _Patrz tez:_
     * C. F. Goldfarb <http://www.SGMLsource.com/> _The SGML Handbook_ ,
       Y. Rubinsky, Ed. Oxford University Press, 1990
     * SGML HomePage (SIL) <http://www.sil.org/sgml/>
     * Getting Started with SGML (SGMLopen)
       <http://www.SGMLopen.org/sgml/docs/getstart.htm>
     * SGML Introduction
       <http://itrc.uwaterloo.ca/%7Eengl210e/BookShelf/Tutorials/SGML/> -
       Paul Prescod <mailto:papresco@calum.csclub.uwaterloo.ca>
     * Understanding the SGML declaration (Omnimark)
       <http://www.omnimark.com:80/resources/white/dec/>
     * Gentle Introduction to SGML (TEI)
       <http://ota.ahds.ac.uk/ota/teip3sg/>
     * SGML in Poland <http://info.fuw.edu.pl/%7Eksiezyk/sgml.html>
       Rafala Ksiezyka (z WN PWN)
     * Litterae. Dokumenty Elektroniczne s.c.
       <mailto:M.Olko@Litterae.com.pl> (polska firma produkujaca m.in.
       ,,Edytor Sterowany Szablonem'' a dostosowalny do kazdego DTD).
     * comp.text.sgml <news:comp.text.sgml>
     * sgml@camk.edu.pl <mailto:sgml-request@camk.edu.pl> polskojezyczna
       lista dyskusyjna poswiecona zastosowaniom SGMLa

2.7 HTTP

     _HTTP_ czyli _Hypertext Transfer Protocol_ jest protokolem typu
   klient-serwer warstwy aplikacyjnej (dzialajacym w oparciu o protokol
   TCP) sluzacym do pobierania (i przy uzyciu niektorych (w pelni
   realizujacych standard) serwerow dostarczania) dokumentow
   hipertekstowych (najczesciej w postaci HTML) a takze zbiorow binarnych
   takich jak programy albo dokumenty pochodzace ze specjalizowanych
   edytorow tekstow.

   Procedura nawiazywania polaczenia przebiega nastepujaco:
     * Klient przedstawia zadanie pobrania okreslonego _zasobu_ (w
       formie: _POLECENIE sciezka_do_zasobu protokol_

$ telnet www 80
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
GET /faq.htm HTTP/1.0
   (po zadaniu nastepuje linijka wolna - wszystkie przyklady sa w
       pokazywane w
     * wersji HTTP/1.0
     * z niepelnymi (jeszcze) naglowkami klienckimi)
     * Na to serwer odpowiada: (o ile zadanie jest realizowalne)

HTTP/1.0 200 OK
Date: Sat, 05 Apr 1997 16:20:50 GMT
Server: Apache/1.1.1
Content-type: text/html
<HEAD><TITLE> Witajcie ;-) </TITLE></HEAD><BODY>
(........ i tak dalej ;-))
     * nie zawsze wszystko przebiega tak pomyslnie. Czasem pomylilismy
       URI i zamiast potwierdzenia wyslania strony, serwer odpowiada:

HTTP/1.0 404 Not found
Date: Sat, 05 Apr 1997 16:29:10 GMT
Server: Apache/1.1.1
Content-type: text/html
<HEAD><TITLE>File Not found</TITLE></HEAD>
<HEAD><H1>File Not found</H1>
The requested URL /pp was not found on this server.
</BODY>

   (Chyba wszystkie serwery pozwalaja zmieniac zawartosc pol (stron)
   wyswietlanych w wypadku bledow.)

   _Patrz tez:_
     * Sekcja: Standardy: HTTP
     * Sekcja: Tworzenie: HTTP
     * WebCompare <http://webcompare.internet.com/>
     * Sekcja: HTTP na W3 <http://www.w3.org/pub/WWW/Protocols/>
     * HTTP Made Really Easy <http://www.jmarshall.com/easy/http/> James
       Marchall <mailto:james@jmarshall.com>
     * HTTP WG <http://www.ics.uci.edu/pub/ietf/http/> w IETF

  2.8 URI, URL, URN
     _________________________________________________________________

Date: Sun Jun 29 14:49:21 MET DST 1997
From: Ziemek Borowski <ziemek@ziembor.waw.pl>
From: Piotr Teczynski <pteczyn@hum.amu.edu.pl>
From: Marcin 'Chomik' Nowak <chomik@piast.t19.ds.pwr.wroc.pl>
Subject: URL
     _________________________________________________________________

   W sieci (zwlaszcza przeksztalcajacej sie z systemu menu (Gopher) do
   heterogenicznego hipertekstu), zaistniala potrzeba jednoznacznego
   identyfikowania zasobow. Wychodza temu naprzeciw rozmaitej mocy
   ,,uniwersalne wskazniki'' (choc wymieniam je musze przyznac, ze nie do
   konca rozumiem czym sie roznia ;-() :
     * _URL_ _Uniform Resource Locator_
     * _URI_ _Uniform Resource Indentificator_
     * _URN_ _Uniform Resource Name_
     * _URC_ _Uniform Resource Citation_

   Tutaj blizej omowie jedynie URL.

   URL sklada sie ze nazwy schematu i czesci dopelniajacej (wlasciwego
   adresu): URL == <scheme>:<scheme-specific-part>

   Czyli URL sklada sie ze schematu, _nazwy protokolu_ (a wlasciwie
   odpowiedniego mnemonika) oraz z czesci specyficznej dla danego
   schematu. Przy czym te czesc charakterystyczna mozna rozbic na
   nastepujace czesci:
     * _uzytkownik_
     * _haslo_
     * _adresu wezla sieci_ (czyli nazwy hosta, komputera w sieci)
     * _portu przypisanego danej usludze_ standardowe numery portow
       opisane sa w innych dokumentach.
     * _sciezki do pliku_ (moze byc wirtualnej czyli okreslanej w
       ustawieniach serwera, nie zas w fizycznie istniejacej)
     * _parametrow pliku_ (wymienianych po znaku " ; " - np. typ pliku w
       FTP)
     * _opcji zapytania_ (przekazywanych jako parametry do programow, a
       wymienianych po znaku zapytania " ? ")
     * _fragmentu, wezla w pliku_ wymienianego po znaku ,,hasha'' " # ")

   czyli:
protokol://uzytkownik:haslo@host:nr_portu/sciezka;parametr_obiektu?zapytanie#we
zel

   W nazwie uslugi (schemacie) moga byc uzyte litery lacinskie {a-z},
   cyfry, znak plusa (+), kropki (.) i przeniesienia (-). Przy czym
   program powinien dokonywac translacji z napisu wielkimi literami do
   malych. Widac wiec, ze w bezposrednio w URLu moga byc uzyte jedynie
   znaki ze alfanumeryczne z zestawu ASCII (dostepnosc wprowadzania)
   (czyli {a-Z}{0-9} a takze znaki "+", "&", (wykorzystywane przez CGI)
   "-" i "%" sluzacy do zapisywania potrzebnych znakow w notacji
   szesnastkowej np. %7E znaczy ~ czyli tylde stosowana czesto jako skrot
   dla kont uzytkownikow).

   Dostepne uslugi opatrzone sa nastepujacymi mnemonikami:
     * _file:_ odnosnik do zasobow lokalnych komputera (nie nalezy chyba
       uzywac w sieci :-) (zalecane jesli chcemy pokazac jakis plik ktory
       _musi_ istniec na komputerze klienta (np.
       file://localhost/etc/resolv.conf
     * _ftp:_ odnosnik do zasobow dostepnych za pomoca protokolu FTP, z
       wariantem ftp://uzytkownik@... lub ftp://uzytkownik:haslo@...
       (choc tej ostatniej wersji zdecydowanie nie polecam - o wiele
       latwiej ,,podsluchac'' tak przekazywane haslo)
     * _gopher:_ odnosnik do zasobow Gopher`a (standardowy port: 70)
     * _http:_ zasob obslugiwany przez serwer httpd (HTTPd) (standardowy
       port: 80)
     * _maito:_ odnosnik powodujacy wyslanie listu pod podany adres (bez
       // po dwukropku!!!) (dla wyspecyfikowania tematu listu mozna
       sprobowac dodac do komendy <A atrybut TITLE=" Tytul listu " )
     * _news: nazwa.grupy news:_ odnosnik powodujacy uruchomienie
       przegladarki USENETU (news) uzywajac domyslnego serwera, i podanej
       grupy (ew. okreslony artykul wg identyfikatora).
     * _telnet:_ odnosnik do zdalnego komputera, zazwyczaj uzywajac
       terminala VT100 (bez // po dwukropku!!!) (standardowy port: 23)
     * _tn3270:_ odnosnik do zdalnego komputera IBM (np. 3090 na
       plearn.edu.pl) terminala IBM-3270 (bez // po dwukropku!!!)
     * _wais:_ odwolanie do systemu wyszukiwawczego WAIS
     * _newsrc:_ odnosnik do okreslonego pliku newsrc (jak rozumiem
       lokalnego)
     * _nntp:_ okresla inny niz domyslnie uzywany serwer newsow (port
       119)

   Adres komputera moze byc podany tak przy uzyciu nazwy zdefiniowanej w
   DNS jak i jako numer IP. Numer portu o ile standardowy czyli opisany w
   odpowiednim RFC - STD 2 moze byc pominiety. Sciezka dostepu do pliku
   moze konczyc sie na nazwie katalogu (o ile w katalogu tym jest
   (zdefiniowany w ustawieniach serwera) plik ,,domyslny'' zwykle o
   nazwie:
     * index.html
     * index.htm
     * default.htm (to z MS)

   jednak wtedy (aby nieco przyspieszyc operacje - podwojne odwolywanie
   sie serwera najpierw do pliku, a potem do katalogu, wraz z generowanie
   przez serwer odpowiedzi o numerze np. 301 czyli Moved permanently nie
   rozpoznawanej przez niektore przegladarki). warto zakonczyc sciezke
   znakiem / (tzw. slash, ciach).

   _Patrz tez:_
     * Sekcja: Standardy: URL
     * Beginner's Guide to HTML
       <http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html>
       (Marka Andersena)
     * URL Schemes Supported in Lynx
       <http://www.crl.com/%7Esubir/lynx/lynx_help/lynx_url_support.html>

2.9 CGI

     _CGI_ czyli _Common Gateway Interface_ jest specyfikacja ( _API_ -
   _Aplication Program Interface_ ) umozliwiajaca komunikacje
   przegladarki z programami uruchamianymi przez serwer. Poczatkowo
   tworzona przez zespol z NCSA, nie doczekala sie opisu jeszcze opisu w
   RFC.

   W tej chwili bedac nieoficjalnym standardem (pochodzacym z NSCA HTTPd,
   a implementowanym przez wiekszosc dostepnych serwerow (nawet tych nie
   Unixowych w postaci tzw. WinCGI)) jest powoli wypierana przez rozmaite
   specyfikacje programistyczne poszczegolnych serwerow (firm
   produkujacych) takie jak _NetscapeAPI,_ _MS IIS API,_ czy Apache
   CGI/PHF

   _Patrz tez:_
     * Sekcja: Interacja
     * Sekcja: Bezpieczenstwo: CGI
     * CGI Overview <http://hoohoo.ncsa.uiuc.edu/cgi/>
     * CGI reference (VSerwers.com)
       <http://www.vservers.com/reference/cgi.html>
     * CGI Programmer`s Reference (FAQ) <http://www.best.com/%7Ehedlund/>
       Marca Hedlunda
     * CGI Programing FAQ (WDG - htmlhelp.com)
       <http://htmlhelp.com/faq/cgifaq.html> Nick Kew
     * CGI-resources <http://www.cgi-resources.com/> wiekszosc rzeczy
       potrzebnych do tworzenia programow zgodnych z CGI (odsylacze do
       specyfikacji, gotowych darmowych programow)
     * Perl/CGI programming FAQ
       <ftp://ftp.pk.edu.pl/pub/lang/perl/CPAN/doc/FAQs/perl-cgi-faq.html
       > Shishir Gundavaram and Tom Christiansen
     * news:comp.infosystems.www.authoring.cgi (moderowana)

2.10 VRML

     _VRML_ czyli _Vitual Reality Modeling Language_ jest to,
   wykorzystujacy niektore mechanizmy WWW (takie jak httpd, czy URL),
   jezyk opisu scen trojwymiarowych oparty na formacie Open Inventor
   stworzonym przez Silicon Graphics. Niektorzy wiaza z nim duze
   nadzieje, uwazajac ze przekaz graficzny jest latwiej przyswajalny, ale
   (przynajmniej dla mnie) poziom skomplikowania jezyka, wielkosc plikow
   (i brak wyobrazni plastycznej) powoduja, ze jest to raczej przyszlosc
   niz terazniejszosc.

   _Patrz tez:_
     * VRML 2.0 - Specyfikacja (VRML Architecture Group)
       <http://vag.vrml.org/VRML2.0/FINAL/>
     * news:comp.lang.vrml
     * VRML Forum (Wired) <http://vrml.wired.com/>
     * VRML Repository (SDSC) <http://www.sdsc.edu/vrml/>
     * VRML 97 <http://vrml.sgi.com/vrml97/courses/compel/> (w:) (Silicon
       Graphics) <http://www.sgi.com/>
     * Piotr Gawrysiak _VRML. Wirtualna rzeczywistosc w Internecie_
       Warszawa 1995, 1996; Zaklad Nauczania Informatyki MIKOM
       <http://www.pol.pl/witryna._p/mikom/> Wyglada przyzwoicie - przy
       czym raczej jako podreczna sciagawka przy pisaniu skryptow (z
       dyskietka)
     * VRML w Polsce (Instytut Studiow Spolecznych UW)
       <http://andante.iss.uw.edu.pl/obuz/vrmlp/index.html>
     * AMU-NET's VRML Repository (Administrator: Klaudiusz Modrzewski)
       <http://math.amu.edu.pl/ftp/windows/>

2.11 Java

     _Java_ jest obiektowym jezykiem programowania stworzonym przez Sun
   INC. (zespol pod kierunkiem Jamesa Goslinga) do sterowania
   urzadzeniami elektronicznymi (,,niekomputerowymi''). Jednym z
   podstawowych zalozen projektu bylo stworzenie przenosnego kodu, nie
   wymagajacego powtornej rekompilacji, przy zmianie architektury maszyny
   na ktorej program ma dzialac. Powstala w ten sposob tzw. wirtualna
   maszyny JAVA`y - czyli sztuczne srodowisko, w jakim dzialaja programy,
   jest (powinien byc) niezalezna od platformy systemowej, stosowanego
   systemu operacyjnego). Dzieki przenosnosci, wzglednej prostocie, oraz
   oczywiscie promocji ze strony Suna (np. darmowa przegladarka WWW
   HotJava) zyskal sobie dosc powszechny odzew. Pomimo krotkiego cyklu
   rozwojowego jezyka (rozpoczecie realizacji projektu ,,Green'' to
   kwiecien 1991, zas swiatowa premiera Java`y i HotJava to maj 1995 r.)
   jest wykorzystywana do wielu roznych zastosowan: poczawszy od prostych
   appletow (czyli krotkich programikow realizujacych pojedyncze zadania
   - zazwyczaj zagniezdzone w HTMLu) przewijajacych tekst u dolu strony,
   poprzez stosowanie jako interface do baz danych (poprzez Java DataBase
   Conetivity) , do poteznych aplikacji takich jak Corell Office for
   Java. <http://officeforjava.corel.com/>

   _Patrz tez:_
     * Java @ Sunie <http://java.sun.com/>
     * Java @ SunSite ICM UW <http://SunSite.ICM.edu.pl/java/>
     * Artur van Hoff, Sami Shaio, Orcha Starkbuck Sun Microsystems INC
       Hooked on JAVA <http://www.aw.com/devpress/java/> (ISBN
       0-201-48837-X) (polskie wydanie: _Java_ Wydawnictwo HELION
       <http://www.helion.com.pl/> (ISBN 83-86718-30-7)
     * Addison-Wesley Java Series <http://www.aw.com/devpress/>
     * Java na UCI AGH <http://arrow.uci.agh.edu.pl/%7Ejava/index-p.html>
     * Linux: Java CGI HOWTO
       <http://www.orbits.com/software/Java_CGI.html> David H. Silber
       <mailto:dhs@orbits.com>

2.12 JavaScript

     _JavaScript_ (primo voto: Mocha ze stajni Netscape Communication
   <http://home.netscape.com/> ) jest prostym jezykiem podobnym do MS
   <http://www.microsoft.com/> _VisualBasica,_ i interpretowanym
   bezposrednio prze przegladarke WWW. Teoretycznie zyskal akceptacje
   Suna, jednak AFAIK ma tyle wspolnego z JAVa co pierwsze cztery literki
   w nazwie ;-))).

   _Patrz tez:_
     * JavaScript Authoring Guide (Netscape)
       <http://home.netscape.com/eng/mozilla/Gold/handbook/javascript/ind
       ex.html>
     * polskie tlumaczenie
       <http://www.polbox.com.pl/lupus/html/index.htm> (Pawla Wimmera i
       Wlodzimierza Wypycha) kursu JavaScript Stefana Kocha
       <http://rummelplatz.uni-mannheim.de/%7Eskoch/js/script.htm>
     * JavaScript: the Definitive Guide, Beta Edition
       <http://www.ora.com/> stron 441, cena $30 O`Reily&Associates
       <http://www.ora.com/>

2.13 ActiveX

     Jest wymyslona przez NetManage <http://www.netmanage.com/> a usilnie
   promowana przez MicroSoft
   <http://www.microsoft.com/activeplatform/default.asp> technologia
   pozwalajaca na stosowanie obiektow OLE w zastosowaniach sieciowych.
   Wywodzi sie od ,,dynamicznej wymiany danych'' w MS Windows, poprzez
   OLE 1.0 i 2.0, komponenty VBX (16-bitowe w VisualBasic) przeksztalcone
   na 32 bity OCX. A handlowa nazwa OCX to wlasnie ActiveX. Ale poniewaz:
     * OLE jest stosowalne jedynie w MS Windows [TM]
     * MS nie dotrzymal obietnicy wyposzczenia na rynek technologii
       pozwalajacej na uzycie obiektow ActiveX na Unixach (to znaczy: ja
       niestety nie mam ani w domu, ani w pracy zadnego Suna, a Unixowa
       implementacja A. ponoc powstala i to jedynie na te platforme).
     * Broadway jest piekny i wspanialy, ale jeszcze nie stosowany (a
       ponoc obsluguje A.)
     * nie posiada tych mozliwosci wspolpracy z bazami danych co JAVA

   _nie nalezy uzywac. _

   _Patrz tez:_
     * What is ActiveX? (Microsoft)
       <http://www.microsoft.com/activex/actx-gen/awhatis.asp>
     * NetManage <http://www.netmanage.com/>
     * http://www.X.org/
     * ActiveX Journal <http://www.folkarts.com/journals/activex/>
     * Active X unoffical Guide <http://www.shorrock.u-net.com/>

2.14 SSI

     _SSI_ czyli _Serwer Side Include_

   Jest prostym mechanizmem dynamicznego tworzenia dokumentow opracowanym
   (jak wiele innych, istotnych w pajeczynie technologii) w NSCA. Pozwala
   m.in. na:
     * dolaczanie naglowkow i stopek dokumentow
     * wprowadzanie daty utworzenia, modyfikacji, wielkosci pliku
     * wlaczaniu standardowego wyjscia z programow do dokumentow

   Wszystkie zlecenia dla dokumentow skladanych przez serwer znajduja sie
   w komentarzu SGMLa, tak wiec w wypadku blednego wykonania zlecenia,
   pozostaje nam puste miejsce. Serwer Apache
   <http://sunsite.icm.edu.pl/pub/www/apache/> w wersji 1.2.0 znacznie
   rozszerza skladnie SSI, wprowadzajac m.in. polecenia warunkowe (if,
   else, endif).

   _Patrz tez:_
     * NCSA httpd server side includes
       <http://hoohoo.ncsa.uiuc.edu/docs/tutorials/includes.html>
     * @internet - What's Included in Server Side Includes?
       <http://www.dnai.com/%7Ethomst/>
     * Parsed Text and Server Side Includes
       <http://hopf.math.nwu.edu/docs/parse.html>
     * Server Side Includes Page <http://www.sigma.net/tdunn/ssi/>
     * Server-parsed HTML (server-side includes) and how to use it @
       Netscape <http://help.netscape.com/kb/server/960513-109.html>
     * XSSI
       <http://sunsite.icm.edu.pl/pub/www/apache/docs/mod/mod_include.htm
       l>

  2.15 SSL, S-HTTP, Shen (z CERN)
     _________________________________________________________________

Subject:  Sposoby bezpiecznego przesylu danych
From:     Pawel Krawczyk <kravietz@tau.ceti.com.pl>
Date:     Sun Jun 15 16:01:19 MET DST 1997
     _________________________________________________________________

   _SSL_ _(Secure Socket Layer)_ patrz: Sekcja: Bezpieczenstwo: SSL

  2.16 ONE i plug-in

   _ONE_ czyli _Open Network Environment_ Netscape jest technologia
   (srodowiskiem programistycznym) pozwalajaca latwiejsze i szybsze
   tworzenie dynamicznych, wieloplatformowych aplikacji sieciowych. W
   swoich dokumentach NC pisze o tym, ze bazuja na ,,otwartych,
   publicznych standardach dostepnych na kazda platforme''. (Jesli to sa
   standardy internetu, to zazwyczaj dosc pokracznie interpretowane... -
   jak chocby rozmaite ,,extentions'' HTMLa).

   _Plug-In (wtyczka)_ jest technologia pozwalajaca na rozszerzenie
   mozliwosci przegladarki czytania rozmaitych formatow dokumentow - np.:
   Anobe PDF, CorelDraw, rysunki wektorowe, pliki roznych dziwnych
   ,,procesorow tekstow'', animacje.

   _Patrz tez:_
     * Netscape ONE <http://developer.netscape.com/library/one/>
     * lista plug-inow wg firmy CC <http://www.medianet.com.pl/%7Ecc/>

  2.17 Cookie

   _Cookie_ jest mechanizmem (wymyslonym przez Netscape) przechowywania
   stanu klienta przy kolejnych zadaniach kierowanych do serwera.
   Powstala tez propozycja przechowywania stanu klienta firmowana przez
   IETF (RFC).

   _Patrz tez:_
     * Client Side State - HTTP Cookies
       <http://home.netscape.com/newsref/std/cookie_spec.html> - Netscape
     * RFC 2109 _PS_ D. Kristol, L. Montulli, _HTTP State Management
       Mechanism_ , 02/18/1997. (Stron=21) (Format=.txt)

  2.18 PERL, awk, C

   _Practical Extraction and Report Language_ czasem nazywany jest tez
   _The Pathologically Eclectic Rubbish Lister_ (z man perl ) jest
   skryptowym jezykiem rozwijanym przez Larrego Walla pozwalajacym na
   latwe, szybkie operacje na tekstach, a takze (co stanowi jego przewage
   nad tak wspanialym narzedziem jakim jest _awk_ (lub _gawk_ )) na
   dostep do wszelkich funkcji systemu. Pozwala nie tylko na rozmaite
   dzialania na dokumentach w trakcie ich przygotowywania, ale takze
   latwe i wydajne tworzenie programow uruchamianych przez serwer HTTPd.

     * CPAN <http://SunSite.ICM.edu.pl/pub/CPAN/> - Comprehensive Perl
       Archive (Network?)
     * Perl Institute <http://www.perl.org/>
     * The Perl Home Page <http://www.perl.com/perl/>
     * Krzysio Leszczynski <mailto:chris@camk.edu.pl> _PERL_ {w:} Linux+
       <http://www.Linux.com.pl/> 2/ 3/1997 (ISSN 1427-55-62)
     * Programming Perl (the Camel Book)
       <http://www.ora.com/catalog/pperl2/>
     * Learning Perl (the Lama Book) <http://www.ora.com/catalog/lperl/>
     * perlWWW <http://www.oac.uci.edu/indiv/ehood/perlWWW/>
     * news:pl.comp.lang.perl

   _AWK _a zwlaszcza _gawk _sa o wiele prostsze (a zastosowaniach typu
   przetwarzanie tekstow co najmniej rownie wydajne). Dodatkowa zaleta
   jest to ze nalezy do standardowego wyposazenia Unixa, a i DOSowe
   implementacje sa i ladne (jak na DOSa) i szybkie ;-)

   _C_ jest pieknym, glupim narzedziem... do wszystkiego, a zwlaszcza
   przetwarzania tekstow ;-).

   _Patrz tez:_
     * Thomas Boutell CGI Programing in C & Perl
       <http://www.boutell.com/cgibook/> Addison-Wesley Publishing
       Comp.INC <http://www.aw.com/devpress/> (ISBN 0-201-42219-0)
     * ISO/IEC 9899:1990 C Language <http://www.iso.ch/cate/d17782.html>
     * news:comp.lang.awk
     * man perl , man awk

  2.19 HyperG, HyperWave

   _HyperG_ , a takze _HyperWave_ sa pomyslem na rozszerzenie mozliwosci
   HTTP o:
     * pelna (przeszukiwalna) baze serwowanych dokumentow (z
       ,,kolekcji'') (.htz) (wraz z mozliwoscia podzielenia tej bazy na
       wiele maszyn)
     * wielowariantowosc dokumentow (po to by wstepnie zapoznac sie z
       trescia serwowany jed dokument tekstowy, do wydruku idzie DVI, lub
       PostScript)
     * okreslona struktura (hierarchia) dokumentow
     * serwowanie i pobieranie dokumentow tak w ramach standardu HyperG
       jak i standardow okreslajacych WWW.

   _Patrz tez:_
     * Kurs HyperG <http://www.iicm.edu/hgcourse/> Keitha Andrewsa
       <mailto:kandrews@iicm.edu>
     * news:comp.infosystems.hyper-g

  2.20 HyTime

   _HyTime_ czyli _Hypermedia/Time-based Structuring Language._ jest
   przemyslowym, miedzynarodowym (ISO/IEC 10744:1992)
   <http://www.iso.ch/cate/d18834.html> standardem dystrybucji i
   tworzenia dokumentow multimedialnych.

   _Patrz tez:_
     * Eliot Kimber's HyTime Course <http://www.drmacro.com/>
     * HyMinder: TechnoTeacher, Inc <http://www.Techno.com/>
     * SoftQuad Panorama <http://www.softquad.com/panorama/viewer/>

  2.21 DSSSL, CSS

   _DSSSL_ czyli _Document Style Semantics and Specification Language_
   jest specyfikacja sluzaca formatowaniu dokumentow SGML. Mozna w ten
   sposob rozdzielic ,,znaczeniowe'' ,,tagowanie'' tekstu, od
   projektowania jego wygladu.

     Z DSSSL wywodzi sie koncepcja _CSS1_ czyli _Cascading Style Sheets
   Level 1_ bedacego (jak dla mnie) proba opanowania rozwoju stosowanego
   przez niektorych producentow ,,znakowania typograficznego'' (wielce
   przy tym zawodnego bo zaleznego nie tylko od przegladarki, ale i
   systemu operacyjnego i innych czynnikow) czyli np <CENTER>, <BODY
   BACKGROUND="red.gif"> i powrotu do HTMLa znaczeniowego. Posiada przy
   tym tak prosta
     _________________________________________________________________

nazwa_odpowiedniego_znacznika_HTML { atrybut_1: wartosc, atrybut_2:
wartosc
/** komentarz jak z C **/}
     _________________________________________________________________

   skladnie, elastycznosc (np. o wiele dokladniejsze nizby to bylo
   mozliwe w HTMLu pozycjonowanie elementow, mozliwosc automatycznego
   dolaczania arkuszy z osobnych plikow), ze stanowi powazna konkurencje
   dla NHTMLa i innych wodotryskow.

   Warto tutaj zwrocic uwage na fakt, ze prawidlowo napisany dokument
   HTML/SGML+CSS/DSSSL w wypadku kontaktu z przegladarka nie uzywajaca
   ,,styli'' (-ow?) powinien byc w dalszym ciagu czytelny (choc moze
   mniej kolorowy i bez nadzwyczajnych efektow, zwlaszcza w wypadku
   drukowania).

   _Patrz tez:_
     * Sekcja: CSS
     * ISO/IEC 10179:1996
       <http://occam.sjf.Novell.com:8080/dsssl/dsssl96> _Information
       technology - Processing languages - Document Style Semantics and
       Specification Language (DSSSL)_ @ Novell
     * DSSSL Tutorial
       <http://itrc.uwaterloo.ca/%7Epapresco/dsssl/tutorial.html> Paul
       Prescod <mailto:papresco@calum.csclub.uwaterloo.ca> (DSSSL)
     * JADE J. Clarka <http://www.jclark.com/jade/> (DSSSL)
     * Cascading Style Sheets, level 1 - W3C Recommendation 17 Dec 1996
       <http://www.w3.org/pub/WWW/TR/REC-CSS1> Hakon Wium Lie
       <mailto:howcome@w3.org> Bert Bos <mailto:bert@w3.org>
     * Positioning HTML Elements with Cascading Style Sheets
       <http://www.w3.org/pub/WWW/TR/WD-positioning> @ W3C
     * WDG CSS1 Reference <http://htmlhelp.com/reference/css/>
     * The Evolution of Style Sheets @ webreference.com
       <http://webreference.com/dev/style/evolution.html>
     * Bert Bos' listing of historical SGML and HTML style proposals
       <http://grid.let.rug.nl/%7Ebert/Stylesheets/>
     * Cascading Style Sheets Gallery @ Microsoft
       <http://www.microsoft.com/opentype/css/gallery/>

  2.22 XML

   _XML_ czyli _eXtensible Markup Language_ jest uproszczona specyfikacja
   SGMLa umozliwiajaca tworzenie i dodawanie wlasnych znacznikow do
   dokumentow. Nie ma na celu zastapienia ani SGMLa ani HTML. Jest (ma
   byc) raczej etapem posrednim - rozszerzeniem mozliwosci o tworzone
   niemal _ad hoc_ zestawy znacznikow.

   Pojawily sie juz pierwsze incjatywy jego wykorzystania:
     * Microsoft <http://www.microsoft.com/standards/> _Channel
       Definition Format_ majacy (we wspolpracy ze ,,standardowym''
       HTMLem) sluzyc tworzeniu czesto uaktualniach kolekcji dokumentow,
       lub kanalow informacyjnych pomiedzy serwerami HTTPd a stacjami
       klienckimi - tak zwane kanaly tematyczne. (wiecej w Winter
       <http://winter.it.com.pl/channels.htm> )

   _Patrz tez:_
     * W3C XML Working Draft <http://www.w3.org/pub/WWW/TR/WD-xml>
     * XML @ textuality.com <http://www.textuality.com/xml/>

  2.23 Broadway

   Broadway (X11R6 ver.3) jest oparta na X-Windows technologia zdalnego
   dostepu do aplikacji. Jest (w przeciwienstwie do poprzednich wersji
   X11R6) optymalizowane do pracy w warunkach niskiej przepustowosci,
   wiec mozliwa jest praca zdalna w sieciach rozleglych, lub przez modem.

   _Patrz tez:_
     * BroadWay na X.org <http://www.X.org/consortium/broadway.html>

  2.24 LDAP

   Jest uproszczona wersja uslugi slownikowej X.500
   <http://x500.ICM.edu.pl/> pozwalajacej lokalizowac osoby, obiekty w
   sieci rozproszonej. Rozwijane na Uniwersytecie Michigan - UMICH
   <http://www.umich.edu/%7Ersug/ldap/>

   _Patrz tez:_
     * RFC 1777 <http://SunSite.ICM.edu.pl/pub/doc/rfc/rfc1777.txt> _DS_
       W. Yeong, T. Howes, S. Kille, _Lightweight Directory Access
       Protocol_ 03/28/1995. (stron=22) (Format=.txt) (Uniewaznia
       RFC1487)
     * LDAP @ Netscape Communication
       <http://home.netscape.com/newsref/ref/ldap.html>
     * LDAP FAQ @ Stanford
       <http://www-leland.stanford.edu/group/networking/directory/x500lda
       pfaq.html>

  2.25 Unicode

   Jest 16 bitowym (z przeciwienstwie do powszechnie dzis stosowanych 8
   bitowych) systemem kodowania znakow diakrytycznych majacym umozliwic
   uzywanie w ramach jednego zestawu znakow wielu roznych zestawow.
   Niektore nacje pokladaja w nim duze nadzieje (nareszcie narzucony
   standard wybawi nas od 18 ,,standardow''), inne nie wiedziec czemu
   ignoruja... ;-)))) A powaznie: Unicode jest w tej chwili obecny raczej
   w wewnetrznych (jadrze czy jakos tak) tablicach kodowania w Linuxie,
   ponoc w M$ NT, ale jeszcze na tereny pajeczyny nie wkroczylo (glownie
   z powodu slabej kompatybilnosci z innymi normami typu ASCII i
   pochodne).

   _Patrz tez:_
     * Unicode Consorium <http://www.unicode.org/>
     * news:pl.comp.ogonki
     * news:comp.text
     * _The Unicode Standard Ver. 2.0_ The Unicode Consortium Addison
       Wesley DevelopersPress <http://www.aw.com/devpress/> (ISBN
       0-201-48395-9)
     * Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/pl.html> -
       choc wiele tam nie, ma to wierze, ze sie cos pojawi. ;-)))
     * norma ISO/IEC 10646
     _________________________________________________________________

     _________________________________________________________________

    3. Standardy i informacje dla Internetu

   Internet nie posiada scentralizowanej struktury Jednak posiada dosc
   dobrze udokumentowana strone techniczna. Paradoks? Oczywiscie. Jak
   cala siec. Odpowiednie informacje na temat zasad tworzenia standardow,
   cial nad nimi (standardami) debatujacych itd. mozna znalezc w
   dokumentach wymienionych w czesci pierwszej tego rozdzialu. W
   kolejnych paragrafach wymieniam te standardy i specyfikacje ktore
   wydaja mi sie wazne dla rozwoju pajeczyny, pomijajac istotne kwestie
   np. DNSu, czy szyfrowania (ktore sa istotne i zamierzam dodac je w
   przyslosci), czy tez protokoly trasowania (routingu), zmiany adresow
   prezentowanych na IP (ktore sa istotne ale stanowia raczej wdzieczny
   temat dla FAQ grupy news:pl.comp.networking )

3.1 Dokumenty ogolne - procedury, definicje, zasady zachowania sie
w sieci.

     *   RFC 2200 _S_ J. Postel, _"INTERNET OFFICIAL PROTOCOL STANDARDS"_
       06/12/1997 (Liczba stron - 56) (STD 1)
     *   RFC 2151 _I_ G. Kessler, S. Shepard, _"A Primer On Internet and
       TCP/IP Tools and Utilities"_ 06/10/1997. (Liczba stron -52) (FYI
       30) (uniewaznia RFC1739)
     *   RFC 1983 _I_ G. Malkin, _Internet Users' Glossary_ 08/16/1996.
       (Liczba stron - 62) (FYI 18) (Uniewaznia RFC1392)
     *   RFC 1935 _I_ J. Quarterman, S. Carl-Mitchell, _What is the
       Internet, Anyway?_ , 04/10/1996. (Liczba stron - 11)
     *   RFC 1855 _I_ S. Hambridge _Netiquette Guidelines_ 10/20/1995.
       (Liczba stron - 21) (FYI 28)
     *   RFC 2028 _BC_ R. Hovey, S. Bradner, _The Organizations Involved
       in the IETF Standards Process_ 10/29/1996. (Liczba stron - 7)
     *   RFC 2027 _BC_ J. Galvin, _IAB and IESG Selection, Confirmation,
       and Recall Process: Operation of the Nominating and Recall
       Committees_ 10/29/1996. (Liczba stron - 11)
     *   RFC 2026 _BC_ S. Bradner, _The Internet Standards Process --
       Revision 3_ 10/29/1996. (Liczba stron - 36) (Uaktualnia RFC1602)
       (Uniewaznia RFC1602)
     *   RFC 1796 _BC_ Huitema, C., J. Postel, and S. Crocker _Not All
       RFCs are Standards_ 10/04/1995.

  3.2 HTML

     *   HTML 3.2 Reference Specification
       <http://www.w3.org/pub/WWW/TR/REC-html32.html> W3C Recommendation
       14-Jan-1997 Dave Raggett mailto:dsr@w3.org
     *   RFC 1866 _PS_ T. Berners-Lee, D. Connolly, _Hypertext Markup
       Language - 2.0_ , 11/03/1995. (Liczba stron - 77)
     *   RFC 1867 _E_ E. Nebel, L. Masinter, _Form-based File Upload in
       HTML_ , 11/07/1995. (Liczba stron - 13)
     *   RFC 1942 _E_ D. Raggett _HTML Tables_ 05/15/1996. (Liczba stron
       - 30)
     *   RFC 1980 _I_ J. Seidman _A Proposed Extension to HTML:
       Client-Side Image Maps_ 08/14/1996. (Liczba stron - 7)

  3.3 URL, URI

     *   RFC 1738 _PS_ T. Berners-Lee, L. Masinter, M. McCahill _Uniform
       Resource Locators (URL)_ 12/20/1994. (Liczba stron - 25)
     *   RFC 1808 _PS_ R. Fielding, _Relative Uniform Resource Locators_
       06/14/1995. (Liczba stron - 16)
     *   RFC 1700 _S_ J. Reynolds, J. Postel _ASSIGNED NUMBERS_
       10/20/1994. (Liczba stron - 230) (Uniewaznia RFC1340) (STD 2)
     *   RFC 1630 _I_ T. Berners-Lee, _Universal Resource Identifiers in
       WWW: A Unifying Syntax for the Expression of Names and Addresses
       of Objects on the Network as used in the World-Wide Web_
       06/09/1994. (Liczba stron - 28)
     *   RFC 2017 _PS_ N. Freed, K. Moore, A. Cargille, _Definition of
       the URL MIME External-Body Access-Type_ 10/14/1996. (Liczba stron
       - 5)

  3.4 HTTP

     *   RFC 2068 _PS_ R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T.
       Berners-Lee, _Hypertext Transfer Protocol -- HTTP/1.1_ 01/03/1997.
       (Liczba stron - 162)
     *   RFC 1945 _I_ T. Berners-Lee, R. Fielding, H. Nielsen, _Hypertext
       Transfer Protocol -- HTTP/1.0_ 05/17/1996. (Liczba stron - 60)

  3.5 MIME

     *
     * RFC 2077 _PS_ S. Nelson, C. Parks, Mitra, _The Model Primary
       Content Type for Multipurpose Internet Mail Extensions_ ,
       01/10/1997. (Liczba stron - 13)
     *   RFC 2045 _DS_ N. Freed, N. Borenstein _Multipurpose Internet
       Mail Extensions (MIME) Part One: Format of Internet Message Bodies_
       12/02/1996. (Liczba stron - 31) (Uniewaznia RFC1521)
     *   RFC 2046 _DS_ N. Freed, N. Borenstein, _Multipurpose Internet
       Mail Extensions (MIME) Part Two: Media Types_ 12/02/1996. (Liczba
       stron - 44) (Uniewaznia RFC1521)
     *   RFC 2047 _DS_ K. Moore, _MIME (Multipurpose Internet Mail
       Extensions) Part Three: Message Header Extensions for Non-ASCII
       Text_ 12/02/1996. (Liczba stron - 15) (Uniewaznia RFC1522)
     *   RFC 2048 _BC_ N. Freed, J. Klensin, J. Postel _Multipurpose
       Internet Mail Extensions (MIME) Part Four: Registration Procedures_
       01/28/1997. (Liczba stron - 21) (Uniewaznia RFC1590)
     *   RFC 2049 _DS_ N. Freed, N. Borenstein, _Multipurpose Internet
       Mail Extensions (MIME) Part Five: Conformance Criteria and
       Examples_ 12/02/1996. (Liczba stron - 24) (Uniewaznia RFC1521)
     *   RFC 2110 _PS_ J. Palme, A. Hopman, _MIME E-mail Encapsulation of
       Aggregate Documents, such as HTML (MHTML)_ , 03/12/1997.
       (Stron=19) (Format=.txt)
     *   RFC 2112 _PS_ E. Levinson, _The MIME Multipart/Related
       Content-type_ , 03/12/1997. (Stron=9) (Format=.txt) (Anuluje
       RFC1872)

  3.6 Gopher

     *   RFC 1436 _I_ F. Anklesaria, M. McCahill, P. Lindner, D. Johnson,
       D. John, D. Torrey, B. Alberti, _The Internet Gopher Protocol (a
       distributed document search and retrieval protocol)_ 03/18/1993.
       (Liczba stron - 16)

  3.7 VRML

     * VRML 1.0 - Specyfikacja
       <http://www.dcs.ed.ac.uk/home/mxr/gfx/3d/VRML.spec>
     * VRML 2.0 - Specyfikacja (vag.vrml.org)
       <http://vag.vrml.org/VRML2.0/FINAL/>

  3.8 Java

     * James Gosling, Bill Joy, Guy Stele _The Java Language
       Specification_ (ISBN 0-201063451-1)
     * Tim Lindholm, Frank Yellin, _The Java Virtual Machine
       Specification_ (ISBN 0-20163452-X)

  3.9 CGI

     * D.R.T.Robinson draft-robinson-www-interface-01.html
       <http://SunSite.ICM.edu.pl/pub/doc/internet-drafts/> _The WWW
       Common Gateway Interface Version 1.1_ (15.02.1996)

  3.10 UsenetNews i E-Mail

     *   RFC 822 _S_ D. Crocker, _Standard for the format of ARPA
       Internet text messages_ , 08/13/1982. (Pages=47) (Format=.txt)
       (Uniewaznia RFC0733) (STD 11) (Updated by RFC1327, RFC0987)
     *   RFC 822 _S_ J. Postel, _Simple Mail Transfer Protocol_ ,
       08/01/1982. (Pages=58) (Format=.txt) (Uniewaznia RFC0788) (STD 10)
     *   RFC 1123 _S_ R. Braden _Requirements for Internet hosts -
       application and support_ , 10/01/1989. (Pages=98) (Format=.txt)
       (STD 3)
     *   RFC 1036 __M. Horton, R. Adams, _Standard for interchange of
       USENET messages_ , 12/01/1987. (Pages=19) (Format=.txt)
       (Uniewaznia RFC0850)
     *   RFC 2076 _I_ J. Palme _Common Internet Message Headers_
       02/00/1997. (stron 26) (Format=.txt)

  3.11 Grafika

     * GIF - GRAPHICS INTERCHANGE FORMAT(sm) Version 89a
       <http://www.dcs.ed.ac.uk/home/mxr/gfx/>
     * JPEG Specification <http://www.dcs.ed.ac.uk/home/mxr/gfx/>
     *   RFC 2083 _I_ T. Boutell, _PNG (Portable Network Graphics)
       Specification Version 1.0_ , 01/16/1997. (Liczba stron - 102)

  3.12 Wielojezycznosc Sieci

     *   ISO 639:1988 <http://www.cm.spyglass.com/unicode/Languages.html>
       _Language Codes_
     *   ISO 3166:1993
       <http://www.cm.spyglass.com/unicode/Countries.html> _Country Codes_
     *   RFC 1766 _PS_ H. Alvestrand, _Tags for the Identification of
       Languages_ , 03/02/1995. (Pages=9) (Format=.txt)
     *   RFC 2070 _PS_ F. Yergeau, G. Nicol, G. Adams, M. Duerst,
       _Internationalization of the Hypertext Markup Language_
       01/06/1997. (Liczba stron - 43)
     *   RFC 1815 _I_ M. Ohta _Character Sets ISO-10646 and ISO-10646-J-1_
       08/01/1995. (Liczba stron - 6)

   _Patrz tez:_
     * The Official Documents Defining the Web
       <http://www.utoronto.ca/webdocs/Official/overview.html> Iana
       Grahama
     * IETF Working Groups <http://www.ics.uci.edu/pub/ietf/>
     _________________________________________________________________
Technical Details
Message-ID: <5qc7k3$pfo$1@sunsite.icm.edu.pl>
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!not-for-mail

Show Full Headers
Complete Article Headers
Path: mbox-mo1.pugleaf.net!news-archive.icm.edu.pl!pingwin.icm.edu.pl!news.icm.edu.pl!not-for-mail
From: Ziemek Borowski <ziembor@digilab.com.pl>
Newsgroups: pl.answers
Subject: pl.comp.www FAQ - 2/5 - definicje
Date: 14 Jul 1997 03:49:23 GMT
Organization: PSI DigiLab Sp. z o.o.
Lines: 971
Approved: rzm@adm.usenet.pl
Distribution: world
Message-ID: <5qc7k3$pfo$1@sunsite.icm.edu.pl>
Reply-To: Ziemek Borowski <ziembor@ziembor.waw.pl>
NNTP-Posting-Host: d01.digilab.com.pl
Mime-Version: 1.0
Keywords: FAQ, WWW, World Wide Web
X-Mailer: rpost z suck
Follow-up: poster
Expire: 29 Jul 1997 MET +0200
X-Posting-Frequency: Posted on 1th and 15th day of each month
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit