🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.answers
Article #152

pl.comp.www FAQ

#152
From: Ziemek Borowski
Date: Tue, 18 Mar 1997 00:00
2078 lines
60518 bytes
Posted-By: auto-faq 3.1.1.2
Archive-name: pl.comp.www


  pl.comp.www FAQ
  Ziemek Borowski

  WWW w Polsce i po polsku
(przepraszam za forme ;-)
od konca kwietnia FAQ beda znajaowac sie
adresem http://www.digilab.com.pl/pl.comp.www/

______________________________________________________________________

  Spis tre�ci:

  1.      Zasady, deklaracje

  1.1.    Dost�pno��

  1.2.    O tym dokumencie

  1.3.    Czy ta grupa ma swoje archiwum?

  1.4.    AID CDATA zasady-listserv

  1.5.    W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?

  1.5.1.  Zanim zadasz pytanie:

  1.5.2.  Gdy nie masz innego wyj�cia...

  1.6.    Co wywo�uje powszechny (i uzasadniony) gniew i irytacj�?

  2.      Definicje

  2.1.    Internet

  2.2.    Intranet

  2.3.    Infostrada

  2.4.    WWW

  2.5.    HTML

  2.6.    SGML

  2.7.    HTTP

  2.8.    Netscape-HTML i MS-HTML

  2.9.    URL

  2.10.   URI

  2.11.   CGI

  2.12.   VRML

  2.13.   Java

  2.14.   JavaScript

  2.15.   ActiveX

  2.16.   SSI

  2.17.   SSL

  2.18.   SHTTP

  2.19.   plug-in

  2.20.   ONE

  2.21.   PERL

  2.22.   HyperG

  2.23.   HyTime

  2.24.   DSSSL

  2.25.   XML

  2.26.   Broadway

  2.27.   LDAP

  2.28.   Unicode

  3.      Standardy, propozycje, informacje i podstawowa literatura

  3.1.    Podstawowa literatura

  3.2.    Standardy i informacje dla Internetu

  3.2.1.  HTML

  3.2.2.  URL, URI

  3.2.3.  HTTP

  3.2.4.  MIME

  3.2.5.  Gopher

  3.2.6.  VRML

  3.2.7.  Java

  3.2.8.  CGI

  3.2.9.  UsenetNews i E-Mail

  3.2.10. Grafika

  3.2.11. Wieloj�zyczno�� Sieci

  4.      Nawigacja

  4.1.    Paj�czarki

  4.1.1.  DOS

  4.1.2.  MS-Windows i OS/2

  4.1.3.  Unix

  4.2.    Poszukiwanie informacji

  4.2.1.  Katalogi tematyczne

  4.2.2.  Przeszukiwarki

  4.2.3.  Przypominacze, serwisy informacyjne

  4.3.    Wieloj�zyczno�� sieci - dlaczego widz� krzaczki?

  4.4.    Przy�pieszanie pracy (W3cache)

  4.5.    Praca off-line

  4.5.1.  Eksploracja cache dyskowego

  4.5.2.  Roboty gromadz�ce drzewo dokument�w

  4.5.3.  Wsp�lny W3cache

  4.6.    Niebezpiecze�stwa - wirusy i inne

  5.      Tworzenie og�lnie

  5.1.    Warunki publikowania

  5.2.    Prawa autorskie

  5.3.    Terminologia

  5.4.    Wieloj�czyna paj�czyna - polskie znaki diakrytyczne

  5.5.    Jakie formaty plik�w?

  5.6.    Dostawca us�ug internetowych

  6.      Tworzenie - HTML

  6.1.    Zasady sk�adni HTML

  6.2.    Najkr�tszy dokument

  6.3.    Podstawowe znaczniki

  6.4.    Przydatne wskaz�wki

  6.5.    Wsp�praca z przeszukiwarkami

  6.6.    Dlaczego standardy s� istotne?

  6.7.    Jak kontrolowa� poprawno�c kodu?

  6.8.    Ramki? Nie stosowa�!!!

  6.9.    Pytania r�ne

  6.9.1.  Czy mog� ukry� kod �r�d�owy dokumentu?

  6.10.   Narz�dzia

  6.10.1. DOS

  6.10.2. MS-Windows

  6.10.3. Unix

  6.11.   Pytania r�ne

  7.      Tworzenie - grafika

  7.1.    Istniej�ce formaty graficzne

  7.2.    Zasady umieszczania grafiki

  7.3.    Efekty specjalne

  7.3.1.  ,,Prze�roczyste grafiki''

  7.3.2.  Animacje

  7.4.    Pytania r�ne

  8.      Tworzenie - Java, JavaScript, CGI, SSI

  8.1.    Po co stosowa� programy w przekazie informacji

  8.2.    Statyczne - dynamiczne

  8.3.    Bazy danych

  8.4.    Przeszukiwanie

  8.5.    Lataj�ce spodki

  8.5.1.  W jaki spos�b mog� zainstalowa� licznik na stronie?

  9.      Serwery

  9.1.    Obs�uga b��d�w

  9.2.    Strona na has�o

  9.3.    Jakie serwery WWW (HTTP) s� dost�pne?

  9.4.    Jaki serwer wybra�  (i pod jakim systemem powinien pracowa�)?

  9.5.    Wirtualny serwer

  9.6.    Robot exlusion

  10.     Bezpiecze�stwo WWW

  10.1.   Java

  10.2.   CGI

  10.3.   Serwery

  11.     Podzi�kowania
  ______________________________________________________________________

  1.  Zasady, deklaracje

  1.1.

  Dokument ten jest osi�galny za pomoc� nast�puj�cych URLi: Dost�pno��

  �  <http://www.digilab.com.pl/pl.comp.www/> (w wersji ,,do
     przegl�dania'') <http://www.digilab.com.pl/pl.comp.www/> oraz
     wersja tekstowa (bez polskich liter):
     <http://www.digilab.com.pl/pl.comp.www/www.txt>

     Wersja skompresowana: www.tgz do dekompresji wymaga w DOSie
     programu UNTGZ (GNU):

  �  pe�na skompresowana wersja (ZIP) (148kb)

  �   name="dla uog�lninego DOSa"> (67kb)

  �  dla Windows z d�ugimi nazwami plik�w (76kb)

  �  dla IBM OS/2.

  �  dokumentacja do untgz

  1.2.  O tym dokumencie

  �  Je�li nie znalaz�e� tu odpowiedzi na swoje pytanie przepraszam... I
     mam pro�b�: jak znajdziesz, prze�lij uzupe�nienie do odpowiedzi na
     istniej�ce pytanie, b�d� napisz <maito:...@diglab.com.pl> (wraz
     z odpowiedzi�) nowe.

  �  B�d� dok�ada� stara� aby dokument ten by� w miar� systematycznie
     uzupe�niany i w miar� pojawiania si� nowych pyta� publikowane by�y
     jego kolejne wydania.

  �  Autorzy nie ponosz� �adnej odpowiedzialno�ci za efekty dzia�ania
     spowodowane stosowaniem si� do zalece� zawartych w dokumencie.

  �  Wszystkie zastrze�one znaki firmowe zosta�y u�yte jedynie w celach
     informacyjnych.

  �  Dokument nie ma �adnej mocy prawnej b�d� administracyjnej i
     powo�ywanie si� na udzielone w nim odpowiedzi oraz porady jest
     bezpodstawne.

  �  Dokument mo�e by� dowolnie u�ywany i rozpowszechniany, jednak w
     wypadku publikacji prosz� o poinformowanie o tym fakcie, a w
     wypadku zamieszczenia w Internecie, t�umacze� itp. prosz� ponadto o
     zobowi�zanie si� do systematycznego uaktualniania.

  �  Dokonywanie zmian bez zgody i wiedzy autora dokumentu jest
     niewskazane, cho� dopuszczalne, przy zachowaniu praw autoskich i
     zaznaczeniu jakie fragmenty uleg�y zmianie.

  �  Wi�kszo�� tekst�w jest autorstwa Ziemka Borowskiego, cho� bardzo
     cz�sto oparte s� na lekturze, np. artyku��w w grupie Je�li autorem
     danego fragmentu jest kto� inny, jest to zaznaczone przez podanie
     inicja��w autora tego fragmentu (*), lub uzupe�nienia (+*) poni�ej
     tre�ci.  Tym nie mniej Ziemek Borowski bierze na siebie
     odpowiedzialno�� za ca�o�� tekstu.

  �  Zawarto�� pl.comp.www FAQ opiera si� g��wnie na listach z grupy
     usenetowej <news:pl.comp.www> oraz ew.  <news:pl.comp.lang.java>
     <news:pl.listserv.polip> <news:pl.comp.ogonki>, je�li tylko maj�
     zwi�zek z tematem.

  1.3.  Czy ta grupa ma swoje archiwum?

  Nie... (ewentualnie mo�esz szuka� w DejaNews

  ;-) Ale trzeba uwa�a�: jest tam ustawiony nag��wek Pragma: NoCache i
  blokada dla robot�w (wi�c nie mo�na �ci�gn�� ca�ego archiwum ,,do
  domu'').

  1.4.  Czy mog� zaprenumerowa� t� grup� tak jak normaln� list�
  dyskusyjn�?

  Nie i bardzo dobrze... ;-) (sprz�enie z list� to tylko niepotrzebne
  k�opoty z polskimi literkami oraz g�upie pytania: jak si� wypisa�?
  ;-)

  1.5.  W jaki spos�b zadawa� pytania, aby uzyska� odpowied�?

  Daleki jestem od ods�dzania od czci wszystkich, kt�rzy zadaj� pytania
  nie konkretne, b�d� takie na kt�re odpowied� znajduje si� na drugiej
  stronie manuala, podr�cznika b�d� FAQ. Ale prosz�...

  1.5.1.  Zanim zadasz pytanie:

  �  zastan�w si�, czy to co ci� trapi jest rzeczywi�cie problemem. By�
     mo�e spotka�e� si� ju� z podobn� sytuacj� i tylko co� Ci na chwil�
     rozum za�mi�o :-)

  �  przejrzyj  dost�pn�  lokalnie  dokumentacj�... (pliki *.htm, *.hlp,
     i man * od posiadanych program�w, zawarto�� katalog�w /usr/doc na
     Unixach).  Po to si� j� tworzy.

  �  poszukaj FAQ (czyli zbioru najcz�ciej zadawanych pyta� wraz z
     odpowiedziami) zwi�zanego z nurtuj�cymi ci� problemami... w Polsce
     znajdziesz je pod adresem <http://sunsite.icm.edu.pl/pub/usenet/>

  �  Sprawd� archiwa: <http://web1.dejanews.com/forms/dnsetfilter.html>
     i tam wpis�c w filtrze grup�: pl.comp.www

  �  spytaj lokalnego administratora... chyba, �e ma Ci� ju� do��, b�d�
     sam nim jeste� :-)

  �  poszukaj przy pomocy katalogu ``tematycznego'' b�d�
     ``wyszukiwarki''.

  1.5.2.

  Gdy nie masz innego wyj�cia...

  to pytaj... Ale pami�taj, �e zadawanie pyta� te� jest sztuk�. Tutaj, w
  grupie <news:pl.comp.www> ograniczymy si� do wskaz�wek raczej
  technicznych.

  �  napisz dok�adnie: jaki masz problem... (np.  jakiego systemu
     operacyjnego u�ywaszi z jakim programem (i jak� jego wersj�) masz
     k�opoty ).  I nie my�l, �e istniej� jedynie M$ Windbloze (Lufciki
     ;-).

  �  je�li szukasz jakiego� narz�dzia, jakie wymagania ma spe�nia� i co
     najwa�niejsze w jakim systemie operacyjnym ma dzia�a�...

  �  nie zaszkodzi poda� gdzie szuka�e�, najwy�ej inni si� czego�
     naucz�.

  �  pomy�l, czy tematyka Twojego pytania jest dostosowana do tematyki
     grupy (np. nie pisz o jakim� zasobie nie zwi�zanym z TECHNOLOGI�
     World Wide Web tylko dlatego, �e znajduje si� on w Paj�czynie - od
     tego typu og�osze� s� inne grupy np.  <news:pl.internet.nowosci>,
     inna grupa bli�ej zwi�zana z tematyk� witryny, zasobu).

     I pami�taj: to, �e kto� Ci odpowie to tylko i wy��cznie jego dobra
     wola.  I nie obra�aj si�, jesli kto� Ci odpisze np.
     <http://zeus.pols.gliwice.pl/~bort/faq/> name="RTFM"> podaj�c
     jakiego� URLa, b�d� tyty� ;-).

  1.6.  Co wywo�uje powszechny (i uzasadniony) gniew i irytacj�?

  Wiele rzeczy.... Na przyk�ad:

  �  wysy�anie spamu <http://www.vixie.com/spam/>.

  �  wysy�anie plik�w binarnych (zw�aszcza wielkich i to takich kt�re
     mo�naby umie�ci� gdzie� w paj�czynie b�d� anonFTP i poda� URL)

  �  pytanie po raz n-ty jak zrobi� co� co jest opisane w ka�dym ``
     kursie HTMLa ''.

  �  pisanie, �e obowi�zuj�cym standardem kodowania polskich liter
     powinno by� ANSI CP-1250 (bo ,,tak jest pro�ciej'', i ,,dla
     ludzi'').

  �  skar�enie si� na jako�� darmowych us�ug i pytania ich dotycz�ce.

  �  ci�gle  pro�by  oce�cie  moj�  stron�  b�d�ce zakamuflowan� reklam�

   I m.in. dlatego pisz� to FAQ, aby unikn�� powtarzania zawsze tych
  samych, nie pos�waj�ch do przodu dyskusji, pyta�.

  2.  Definicje

  Co to jest:

  2.1.

  Internet

  RFC 1462 Internet zosta� zdefiniowany jako:

  �  sie� sieci komputerowych oparta na protoko�ach IP i TCP, UDP oraz
     ICMP (TCP/IP)

  �  zasoby dost�pne na komputerach po��czonych z sieci� (tzw. hostach)

  �  spo�eczno��, wsp�lnota (community) ludzi u�ywaj�cych i
     rozwijaj�cych t� sie�

  Nie jest to wi�c, jakby ludzie Microfotu chcieli ,,taka ikonka na
  pulpicie'' ani te� �adna z dominuj�cych w danej chwili us�ug
  sieciowych.

   Patrz te�:

  Internet Society <http://www.isoc.org/>

  Polska Spo�eczno�� Internetu <http://www.psi.org.pl/>

  InterNIC <http://www.internic.net/>

  Elementarz Internetu <http://www.cto.us.edu.pl/eleminte/ei.html>
  Macieja Uhliga

  Podstawowe us�ugi Internetu  <http://www.ict.pwr.wroc.pl/doc/iwpl/>
  Tomasza Surmacza

  R�ne po�yteczne dokumenty w/g AGH <http://www.agh.edu.pl/opisy.html>

  Wirtualna Akademia - Katedra Teleinformatyki
  <http://www.gumbeers.elka.pg.gda.pl/WA/KTI/>

  Narz�dzia sieciowe
  <http://www.immt.pwr.wroc.pl/export_hp/tool/tool.html> Wojciecha
  Myszki (jeden z lepszych TECHNICZNYCH przewodnik�w po sieci).

  wersja 3.1 EFFu Przewodnik po Internecie <ftp://www.eff.org/> jest te�
  wersja skompresowana <ftp://www.eff.org/>

  2.2.

  Intranet

  Jest pr�b� aplikacji technologii internetowych poziomu prezentacji i
  aplikacji do sieci lokalnych i firmowych. (Ma to zwi�zek koncepcj�
  odchudzenia stacji roboczych do wszechstronnie zorientowanego
  (przegl�darka, edytor, poczta) acz odchudzonego klienta i zwi�zanym z
  tym pomys�em na obni�anie koszt�w).

   Patrz te�:

  Panorama Intranetu (Projekt Winter)
  <http://winter.it.com.pl/intranet.htm>

  2.3.

  Infostrada

  Jest to jedna z nazw utopii nazywanej te� czasem spo�ecze�stwem
  informacyjnym, g�osz�cej �e podstawowym towarem staje si� wiedza i
  dost�p  do  niej.  W  tak  sformu�owany  program spo�eczny doskonale
  wpisuje si� Internet ``(w swej warstwie aplikacyjnej)''.

   Patrz te�:

  Michael Sullivan-Trainor    Infostrada ReadMe, IDGBooks,
  ProgramersPress: Warszawa 1995 (ISBN 83-85769-95-1)

  Ziemek Borowski Ideologia spo�ecze�stwa informacyjnego a Internet
  <http://www.QDnet.pl/~Ziembor/internet.htm> Warszawa 1996 (praca
  semestralna)

  2.4.

  WWW

  WWW (World Wide Web), zwana inaczej Paj�czyn�, Webem jest
  hipertekstowym, multimedialnym, sieciowym, opartym na TCP/IP systemem
  informacyjnym.

     hipertekstowym
        czyli takim gdzie istniej� zdefiniowane zale�no�ci miedzy
        poszczeg�lnymi dokumentami, mo�liwo�ci dowolnego przemieszczania
        si� pomi�dzy nimi, oraz zdefinowane znaczeniowo wyr�niki
        tekstu.
     multimedialnym
        czyli dopuszczaj�cym stosowanie r�nych �rodk�w przekazu:
        tradycyjnych tekst�w, d�wi�k�w, grafiki.

     sieciowym
        bo opartym na warstwie prezentacyjne/aplikacyjnej sieci
        rozleg�ej Internet, a wi�c o zasi�gu praktycznie globalnym.

   Patrz te�:

  World Wide Web Corporation <http://www.w3.org/>

  WWW FAQ Boutella <http://www.boutell.com/faq/>

  2.5.

  HTML

  HTML czyli  Hypertext Markup Language jest (a w�a�ciwie by�) napisanym
  w ``SGML'' hipertekstowym j�zykiem kodowania dokument�w. Od roku 1990
  (gdy zosta� zaprojektowany przez Toma Berners-Lee w CERN
  <http://www.cern.ch/>) przeszed� d�ug� i kr�t� drog� od prostego (w
  praktyce zawieraj�cego kilkana�cie wyra�e�)  j�zyka znakowania ZNACZE�
  dokument�w do j�zyka (a w�a�ciwie slangu ze wgl�du na zanik kluczowych
  elemnt�w gramatyki) opisu strony.

   Patrz te�:

  HTML at W3C <http://www.w3.org/pub/MarkUp/HTML/>

  The Web Design Group  <http://www.htmlhelp.com/>

  ``Sekcja: Tworzenie HTML''

  2.6.

  SGML

  SGML czyli Standard Generalized Markup Language jest metaj�zykiem
  (opisanym w standardzie mi�dzynarodowym (ISO 8879:1986)) s�u��cym do
  projektowania opisu dokument�w wed�ug okre�lonego zapotrzebowania
  informacyjnego z u�yciem dowolnie dobranego zestawu znacznik�w i
  gramatyki.

  Dokument SGML sk�ada si� z kilku cz�ci:

      deklaracji SGMLa
        gdzie opisuje si� klas� dokumentu, podstawowe paramenty jego
        budowy i przetwarzania: u�ywane zestawy znak�w, dopuszczalne
        d�ugo�ci litera��w (np. nazwy znacznik�w czy d�ugo�� atrybut�w),
        opcje minimalizacji (np. czy wymagane i w jakiej postacji
        pomijanie znacznik�w ko�cz�cych element).

      Definicja Typu Dokumentu
         (DTD, Document Type Definition) gdzie jest zakodowana
        hierarchia element�w wraz z dopuszczalnymi atrybutami, ich
        dopuszczalnymi i domy�lnymi warto�ciami mo�liw� zawatro�ci�. DTD
        jednoznacznie okre�la sk�adnie danego tyku dokumentu.

      zawarto�� dokumentu
        czyli tzw. DOCUMENT INSTANCE

  W wielu wypadkach deklaracj� stosuje si� domy�ln� a zamiast ca�ego DTD
  umieszcza si� Formal Public Indentifier (rozwi�zywany zwykle przez
  parsery na w�a�ciwie DTD przy pomocy pliku  catalog .  Przy czym ist
  nieje rozr�nienie na identyfikatory publiczne:
   <!DOCTYPE PUBLIC HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">  czyli zare
  jestrowane <> i systemowe np: <!doctype linuxdoc system>.

  Parser SGML (jak sama nazwa wskazuje) jst programem analizuj�cym
  sk�adni� dokumentu i to (je�li mowa o tzw.  validating parsers ) nie
  tylko sam� jednorazow� dawk� informacji ale r�wnie� deklaracj� SGML i
  DTD (wraz z jego sk�adni�). Wyj�cie z parsera (czyli
   ESIS, czyli Element Structure Information Set) mo�e stanowi� podstaw�
  konwersji czy jakiejkolwiek obr�bki dokumentu (��cznie z
  (re)formatowaniem, przy wykorzystaniu arkuszy stylistycznych
  ``DSSSL'').

  (GS + ZMB)

   Patrz te�:

  SGML HomePage <http://www.sil.org/sgml/>

  Getting Started with SGML
  <http://www.sgmlopen.org/sgml/docs/getstart.htm>

  SGML w Polsce <http://info.fuw.edu.pl/~ksiezyk/sgml.html>

  <mailto:M.O...@Literaae.com.pl>

  <news:comp.text.sgml>

  polskoj�zyczna lista dyskusyjna po�wi�cona zastosowaniom SGMLa
  <mailto:sgml-r...@camk.edu.pl>

  2.7.

  HTTP

  HTTP czyli HyperText Transfer Protocol jest protoko�em warstwy
  aplikacyjnej s�u��cym do pobierania (i przy u�yciu niekt�rych (w pe�ni
  realizuj�cych standard) serwer�w dostarczania) dokument�w
  hipertekstowych (najcz�ciej w postaci ``HTMLa''

   Patrz te�:

  ``Sekcja: Standardy: HTTP''

  ``Sekcja: Tworzenie: HTTP''

  WebCompare <http://webcompare.iworld.com>

  <http://www.w3.com/pub/WWW/Protocol/>

  2.8.

  Netscape-HTML i MS-HTML

  S� to dialekty (slangi) HTMLa cechuj�ce si� z jednej strony rozmaitymi
  rozszerzeniami (extensions) a z drugiej ignorowaniem proponowanych
  przez innych (np. cia�a standaryzacyjne, konkurencj�) nowych
  mo�liwo�ci np. proponowanych w szkicach dotycz�cych

  obs�ugi r�wna� matematycznych w HTML 3.0

  tabel w RFC 1942 Problem z tymi swoistymi rozszerzeniami polega na
  tym, �e przez tworzenie nieprzemy�lanych fakt�w blokuj� one rozw�j
  j�zyka (trudno zachowa� sp�jno�� logiczn� struktury dokumentu je�li w
  ka�dym jego miejscu mo�e wyst�pi� jakie� polecenie (w tym wypadku
  chodzi o nikomu w tej formie nie potrzebny znacznik <CENTER>).

   Patrz te�:

  Top 10 Things NOT to do <>

  2.9.

  URL

   Patrz te�:

  2.10.

  URI

   Patrz te�:

  2.11.

  CGI

   Patrz te�:

  2.12.

  VRML

   Patrz te�:

  2.13.

  Java

   Patrz te�:

  2.14.

  JavaScript

   Patrz te�:

  2.15.

  ActiveX

   Patrz te�:

  2.16.

  SSI

   Patrz te�:

  2.17.

  SSL

   Patrz te�:

  2.18.

  SHTTP

   Patrz te�:

  2.19.

  plug-in

   Patrz te�:

  2.20.

  ONE

   Patrz te�:

  2.21.

  PERL

   Patrz te�:

  2.22.

  HyperG

   Patrz te�:

  2.23.

  HyTime

   Patrz te�:

  2.24.

  DSSSL

   Patrz te�:

  2.25.

  XML

   Patrz te�:

  2.26.

  Broadway

   Patrz te�:

  2.27.

  LDAP

   Patrz te�:

  2.28.

  Unicode

   Patrz te�:

  3.

  Standardy, propozycje, informacje i podstawowa literatura

  3.1.

  Podstawowa literatura

   Patrz te�:

  3.2.

  Standardy i informacje dla Internetu

  �   RFC 2000 S J. Postel,
      "INTERNET OFFICIAL PROTOCOL STANDARDS", 02/24/1997.  (Liczba stron
     - 56)   (STD 1)

  �   RFC 1983 I G. Malkin, Internet Users' Glossary 08/16/1996. (Liczba
     stron - 62) (FYI 18) (Obsoletes RFC1392)

  �   RFC 1935 I J. Quarterman, S. Carl-Mitchell, What is the Internet,
     Anyway?, 04/10/1996. (Liczba stron - 11)

  �   RFC 1855 I S. Hambridge Netiquette Guidelines 10/20/1995. (Liczba
     stron - 21) (FYI 28)

  �   RFC 2028 BC R. Hovey, S. Bradner, The Organizations Involved in
     the IETF Standards Process 10/29/1996.  (Liczba stron - 7)

  �   RFC 2027 BC J. Galvin, IAB and IESG Selection, Confirmation, and
     Recall Process:  Operation of the Nominating and Recall Committees
     10/29/1996.  (Liczba stron - 11)

  �   RFC 2026 BC S. Bradner, The Internet Standards Process -- Revision
     3 10/29/1996.  (Liczba stron - 36) (Updates RFC1602) (Obsoletes
     RFC1602)

  3.2.1.

  HTML

  �   HTML 3.2 Reference Specification
     <http://www.w3.org/pub/WWW/TR/REC-html32.html> W3C Recommendation
     14-Jan-1997 Dave Raggett  <mailto:d...@w3.org>

  �   RFC 1866 PS T. Berners-Lee, D. Connolly, Hypertext Markup Language
     - 2.0, 11/03/1995.  (Liczba stron - 77)

  �   RFC 1867 E E. Nebel, L. Masinter, Form-based File Upload in HTML,
     11/07/1995.  (Liczba stron - 13)

  �   RFC 1942 E D. Raggett HTML Tables 05/15/1996.  (Liczba stron - 30)

  �   RFC 1980 I J. Seidman A Proposed Extension to HTML: Client-Side
     Image Maps 08/14/1996.  (Liczba stron - 7)

  3.2.2.

  URL, URI

  �   RFC 1738 PS T. Berners-Lee, L. Masinter, M. McCahill Uniform
     Resource Locators (URL) 12/20/1994.  (Liczba stron - 25)

  �   RFC 1808 PS R. Fielding, Relative Uniform Resource Locators
     06/14/1995.  (Liczba stron - 16)

  �   RFC 1700 S J. Reynolds, J. Postel ASSIGNED NUMBERS 10/20/1994.
     (Liczba stron - 230) (Obsoletes RFC1340) (STD 2)

  �   RFC 1630 I T. Berners-Lee, Universal Resource Identifiers in WWW:
     A Unifying Syntax for the Expression of Names and Addresses of
     Objects on the Network as used in the World-Wide Web 06/09/1994.
     (Liczba stron - 28)

  �   RFC 2017 PS N. Freed, K. Moore, A. Cargille, Definition of the URL
     MIME External-Body Access-Type 10/14/1996.  (Liczba stron - 5)

  3.2.3.

  HTTP

  �   RFC 2068 PS R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T.
     Berners-Lee, Hypertext Transfer Protocol -- HTTP/1.1 01/03/1997.
     (Liczba stron - 162)

  �   RFC 1945 I T. Berners-Lee, R. Fielding, H. Nielsen,
      Hypertext Transfer Protocol -- HTTP/1.0 05/17/1996.  (Liczba stron
     - 60)

  3.2.4.  MIME

  �

  �  RFC 2077 PS S. Nelson, C. Parks, Mitra, The Model Primary Content
     Type for Multipurpose Internet Mail Extensions, 01/10/1997.
     (Liczba stron - 13)

  �

     RFC 2045 DS N. Freed, N. Borenstein Multipurpose Internet Mail
     Extensions (MIME) Part One:  Format of Internet Message Bodies
     12/02/1996.  (Liczba stron - 31) (Obsoletes RFC1521)

  �   RFC 2046 DS N. Freed, N. Borenstein, Multipurpose Internet Mail
     Extensions (MIME) Part Two:  Media Types 12/02/1996.  (Liczba stron
     - 44) (Obsoletes RFC1521)

  �   RFC 2047 DSK. Moore, MIME (Multipurpose Internet Mail Extensions)
     Part Three: Message Header Extensions for Non-ASCII Text
     12/02/1996.  (Liczba stron - 15) (Obsoletes RFC1522)

  �   RFC 2048 BC N. Freed, J. Klensin, J. Postel Multipurpose Internet
     Mail Extensions (MIME) Part Four:  Registration Procedures
     01/28/1997.  (Liczba stron - 21) (Obsoletes RFC1590)

  �   RFC 2049 DS N. Freed, N. Borenstein, Multipurpose Internet Mail
     Extensions (MIME) Part Five:  Conformance Criteria and Examples
     12/02/1996.  (Liczba stron - 24) (Obsoletes RFC1521)

  3.2.5.

  Gopher

  �   RFC 1436 I F. Anklesaria, M. McCahill, P. Lindner, D. Johnson, D.
     John, D.  Torrey, B. Alberti, The Internet Gopher Protocol (a
     distributed  document search and retrieval protocol) 03/18/1993.
     (Liczba stron - 16)

  3.2.6.

  VRML

  �

  3.2.7.

  Java

  �

  3.2.8.

  CGI

  �

  3.2.9.

  UsenetNews i E-Mail

  �

  3.2.10.

  Grafika

  �   RFC 2083 I T. Boutell, PNG (Portable Network Graphics)
     Specification  Version 1.0, 01/16/1997.  (Liczba stron - 102)

  3.2.11.

  Wieloj�zyczno�� Sieci

  �   RFC 2070 PS F. Yergeau, G. Nicol, G. Adams, M. Duerst,
     Internationalization of the Hypertext Markup Language 01/06/1997.
     (Liczba stron - 43)

  �   RFC 1815 I M. Ohta Character Sets ISO-10646 and ISO-10646-J-1
     08/01/1995.  (Liczba stron - 6)

   Patrz te�:

  4.

  Nawigacja

  4.1.

  Paj�czarki

  4.1.1.

  DOS

  Wbrew temu co mog�oby si� wydawa� jest ca�kiem du�o przegl�darek
  dzi�aj�cych w ,,go�ym'' DOSie (przypominam �e poza MS-DOSem istniej� i
  inne systemy dzia�aj�ce w tym trybie, np.  Caldera OpenDOS (nb.
  nied�ugo ma by� wyposa�ony nie tylko w klienta NewWare ale i w stos
  TCP/IP)).  Wyminione zosta�y pod adresem
  <http://www.fdisk.com/doslynx/>.

   Patrz te�:

  4.1.2.

  MS-Windows i OS/2

  Najprostsz� form� zaopatrzenia si� w przegl�dark� jest zajrzenie do
  jednego z archiw�w oprogramowania Winsock:

  The Ultimate Collection of Winsock Software <http://www.tucows.com/>
  albo Tucows na SunSite <http://sunsite.icm.edu.pl/pub/tucows/> Tucows
  na PW <http://alfa2.it.pw.edu.pl/tucows/>

  The CWSApps List Indeks Aplikacji Sieciowych dla Windows

  Papa's Anonymous FTP i tam mo�na znale�� tak Netscape Navigatora, MS
  IExplorera, jak i NSCA Mosaics i wiele, wiele innych.

   Patrz te�:

  4.1.3.

  Unix

  O ile UNIX i pochodne do tej pory dominuj� na rynku serwer�w, to
  systemem przegl�darek sta� si� MS Windows <http://www.micr0s0ft.com/>.
  Tym nie mniej jest kilka warto�ciowych produkt�w. Takich jak:

  �  Arena (W3C)

  �  Amayara (W3C)

  �  Netscape Navigator

  �  niezast�piony Lynx

  �  NSCA Mosaic

  �  Chimera

  �  MNEMONIC Multilithic, Non-dependant, Extensible, Modular,
     Objective, Network-aware, Internet Client : w trakcie powstawania.

     W Polsce podstawowym archiwum jest ,,sansajt''

   Patrz te�:

  <http://sunsite.unc.edu/pub/Linux/Documentation/HOWTO/WWW-HOWTO.html>

  4.2.

  Poszukiwanie informacji

  4.2.1.

  Katalogi tematyczne

  �  Wirtualna Polska <http://wp.cnt.pl/>

  �  WOW!  <http://www.waw.wow.pl/>

  �  Onet  <http://www.optimusnet.pl/>

  �  PolishWorld <http://www.polishworld.com/>

  �  NASK  <http://www.nask.pl/resoces/>

  �  oficjalna Polska Strona <http://www.polska.pl/>

  �  Oficjalna Polska Strona po angielsku <http://www.poland.pl/>

  �  <http://info.fuw.edu.pl/PolandHomepage.html>

     i �wiatowe

  �  Yahoo <http://www.yahoo.com/>

  �  WWW Virtual Library
     <http://www.w3.org/hypertext/DataSources/bySubject/Overview.html>

  �  Maggellan <http://www.mackinley.com/>

  �  Galaxy EINET <http://www.einet.net/galaxy>

   Patrz te�:

  Yahoo <http://www.yahoo.com/>

  4.2.2.

  Przeszukiwarki

  �  ICMowy serwer archie <http://archie.icm.edu.pl/>

  �  InfoSeek na ICM <http://infoseek.icm.edu.pl:8000>

  �  AltaVista w TPnet <http://www.altavista.tpnet.pl>

  �  Sieciowid  <http://sieciowid.pol.pl> Polski OnLine

  �  Netoscop <http://www.chip.pl> istniej�cy w ramach serwisu
     sieciowego CHiPa <http://www.chip.pl/>

  �  DEC Alta Vista <http://www.altavista.digital.com/>

  �  Lycos <http://fuzine.mt.cs.cmu.edu/mlm/lycos-home.html>

  �  WebCrawler <http://webcrawler.com/>

  �  World Wide Web Worm
     <http://www.cs.colorado.edu/home/mcbryan/WWWW.html>

  �  InfoSeek <http://www2.infoseek.com/>

  �  OpenText <http://www.opentext.com/>

  �  HotBot <http://www.HotBot.com/search.html>

  �  i inne ... :-) wi�kszo�� dostawc�w us�ug Iternetowych dostarcza
     odp.  formularzy do wyszukiwania na najpopularniejszych
     przeszukiwarkach.

   Patrz te�:

  Panorama wyszukiwania w Internecie
  <http://winter.it.com.pl/wyszukiwanie.htm> w Projekcie Winter

  4.2.3.

  Przypominacze, serwisy informacyjne

  Istnieje ju� kilkana�cie r�nych specjalizowanych w wyszukiwaniu i
  �ledzeniu informacji serwis�w. Cz�sto s� one dost�pne za darmo (czyli
  za przeczytanie za��czonych reklam ;-). Nale�� do nich np.:

  �  <http://www.pointcast.com/>

  �  <http://www.urlminder.com/>

   Patrz te�:

  <http://www.yahoo.com>

  4.3.

  Wieloj�zyczno�� sieci - dlaczego widz� krzaczki?

  Dlaczego cz�sto widz� ,,krzaczki'' zamiast polskich liter?

  Jest kilka mo�liwo�ci rozwi�zania tego problemu:

  �  Masz niew�a�ciw� przegl�dark�, tj. nie obs�uguj�c� polskich liter w
     standardzie ISO-8859-2. W miar� mo�liwo�ci wymie� j� na co� innego
     lub sprawd� czy nie mo�na tego jako� poprawi�:
     <http://www.agh.edu.pl/ogonki/>.

  �  Twoja przegl�darka obs�uguje polskie literki, ale ty nic o tym nie
     wiesz. Np. nie ustawi�e� w Netscape Navigatorze 3.0 opcji:
     Options|Document Ecoding|Central European (ISO-8859-2) i
     odpowiedniej czcionki w Options|General_Preferences|Fonts|Latin-2

  �  Wina le�y po stronie autora strony:

  �  ani w nag��wku http: "text/html charset=8859-2"   html htm w pliku
     mime.types

  �  ani w nag��wku strony przy pomocy komendy
      <meta http-equiv="content-type" content="text/html;
     charset=iso-8859-2"> oraz atrybutu LANG=PL nie zadeklarowa�
     polsko�ci dokumentu, ani nawet u�ywanej strony kodowej

  �  Wina le�y po stronie autora strony: u�ywa CP 1250 :-(

   Patrz te�:

  ``Tworzenie wieloj�zyczno��''

  Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/>

  W jaki spos�b poprawnie serwowa� polskie dokumenty?
  <http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html> Paw�a Wi�cka

  4.4.

  Przy�pieszanie pracy (W3cache)

   Co to jest i dlaczego nale�y u�ywa� W3cache-proxy?

  Dlaczego? Przecie� to oczywiste... ;-) Jednym ze skutk�w coraz
  gwa�towniejszego rozwoju us�ug WWW jest saturacja ��cz sieci
  rozleg�ych. O ile przepustowo�ci ��cz sieci lokalnych i miejskich s�
  zwykle nadmiarowe, to ��cza mi�dzynarodowe (znacznie bardziej
  kosztowne) stanowi� zazwyczaj w�skie gard�a Internetu.  Szybko��
  wzrostu zapotrzebowania na pasmo znacznie przekracza wszelkie
  mo�liwo�ci inwestycyjne. Analiza ruchu wskazuje przy tym, �e
  procentowo coraz wi�kszy udzia� stanowi� w nim transmisje WWW.
  Polska, jako jeden z pierwszych kraj�w zbudowa�a struktur� tzw. cache
  WWW, kt�ra pozwala na lokalne buforowanie najcz�ciej ��danych
  dokument�w WWW, a tym samym:

  �  zmniejszenie obci��enia ��cz mi�dzynarodowych,

  �  skr�cenie �redniego czasu dost�pu do informacji,

  �  zoptymalizowanie wykorzystania ��cz krajowych.

  Hierarchia W3cache <http://w3cache.icm.edu.pl/sites_pl.html/> obejmuje
  wszystkie wa�niejsze sieci miejskie oraz dzia�a w bezpo�redniej
  wsp�pracy z podobnymi projektami poza Polsk�. W3cache wymienia tak�e
  informacje z pojedynczymi serwerami cache tam, gdzie nie istniej�
  jeszcze struktury og�lnokrajowe.  Przy czym u�ytkownicy takich
  og�lnopolskich sieci jak TPnet, lub Telebank powinni ustawi� parametry
  swojego proxy cache na lokalny cache, a je�li nie ma (a nie ma) to na
  w3cache.icm.edu.pl:8080 jako najbli�szy sieciowo ich sieciom, nie za�
  na cache np. krakowskie. (cho� ostatnio w zwi�zku z zaistnieniem
  <http://w3cache.icm.edu.pl> w TPnecie, powstawaniem ,,lokalnych''
  po�acze� TPnetu z NASKnetem (np. w Krakowie) sytuacja si� zmienia).

  (WojSyl+ZMB)

   Patrz te�:

  Replication <http://www.w3.org/>

  <http://w3cache.icm.edu.pl/>

  4.5.

  Praca off-line

  4.5.1.  Eksploracja cache dyskowego

  4.5.2.  Roboty gromadz�ce drzewo dokument�w

  4.5.3.

  Wsp�lny W3cache

   Patrz te�:

  4.6.

  Niebezpiecze�stwa - wirusy i inne

  Czy u�ywaj�c WWW mog� narazi� si� na zniszecznie zawarto�ci dysku,
  b�d� inn� form� destabilizacji pracy komputera?

  Oczywi�cie :-(.  A powa�nie: o ile masz wy��czon� JAVA, JavaScript,
  ActiveX i nie �adujesz plik�w z danymi zawieraj�cymi makroinstrukcje,
  PostScript oraz wykonywalnych - nie mo�esz. W pozosta�ych wypadkach:

  �  pliki MS Worda, MS Excella (i innych program�w mog�cych zawiera�
     makroinstrukcje) i wykonywalne - wiadomo - mog� by� zaka�one i to
     nie zale�y od medium przesy�owego.

  �  w Javie i JavaScript  znaleziono (w niekt�rych wersjach
     implementacjach np.: Netscape Navigatorze 2.0.0) jakie� usterki na
     tyle powa�ne, �e pono� zagra�aj�ce bezpiecze�stwu system�w.

  �  PostScript, TeX i inne programy/dokumenty - mog� zawiera�
     niebezpieczne operacje, kt�re pewne przegl�darki mog� pr�bowa�
     wykona�: kasowanie plik�w albo ustawienie/zmiana has�a drukarki.

  �  W wypadku Lynxa istnieje co� takiego (tzw. trusted hosts) co
     pozwala wykonywa� polecenia wydawane ze zdalnego komputera na
     lokalnym.

   Patrz te�:

  CERT NASKu <http://www.nask.pl/CERT/>

  5.

  Tworzenie og�lnie

  5.1.

  Warunki publikowania

  Aby m�c publikowa� potrzeba odpowiedniego typu konta: najlepiej na
  komputerze gdzie jest zainstalowany serwer httpd.  W wypadku dostawc�w
  komercyjnych nale�y wykupi� odpowiedni rodzaj konta. Na wi�kszo�ci
  uczelni istnieje mo�liwo�� za�o�enia w�asnej strony w ramach
  normalnego konta, i to cz�sto nawet bez ingerencji administratora
  (zazwyczaj nale�y za�o�y� w swoim katalogu domowym katalogu
  public_html lub .home . Istnieje tak�e kilka serwer�w komercyjnych
  umo�liwiaj�cych publikowanie materia��w niekomercyjnych bez wnoszenia
  op�at. Istniej� te� serwery umo�liwiaj�ce ,,darmowe'' us�ugi: e-mail i
  niekomercyjne publikowanie na WWW.  Darmowe tzn. nie p�acisz firmie,
  ale za to firma mo�e udost�pnia� (lub w inny spos�b wykorzystywa�)
  Tw�j adres innym (co powoduje zalew �mieciem reklamowym).

  <http://free.polbox.pl>

  <http://www.pocketpress.com.pl/free/>

  <http://www.hotmail.com/>

  <http://www.geocities.com/> i na troch� innych zasadach: QDnet
  <http://www.QDnet.pl/>

   Patrz te�:

  Darmowe us�ugi w/g Paw�a Wi�cka
  <http://la.ists.pwr.wroc.pl/~coven/tech/freenet.html.po>

  5.2.

  Prawa autorskie

  Nale�y przyj��, �e (przynajmniej w wypadku polskich stron) obowi�zuj�
  przepisy Ustawy o prawie autorskim i prawach pokrewnych z 04.02.1995
  <http://www.pocketpres.com/> Przy czym (na podstawie art. 1 punkt 1 i
  punkt 2 ustawy), o ile autor nie zaznaczy� inaczej wszystkie strony s�
  domy�lnie oznaczone jako � b�d� (C) i mo�na podawa� do nich
  odniesienie, nie mo�na natomiast ich wykorzystywa� we w�asnej pracy
  (tj. tre�ci powi�zanej z form�, poniewa� czystej informacji to ju� nie
  dotyczy) bez zgody (najlepiej pisemnej) autora (w�a�ciciela (C)).
  Ochronie podlegaj� r�wnie� znaki firmowe (lecz mo�na ich u�y� w celach
  informacyjnych).

  Nie mo�na jednak popada� w przesad�: ze wgl�du na rodzaj medium nie
  mo�na domaga� si� pe�nej integralno�ci i nienaruszalno�ci dzie�a.

  �  Nie mo�na zakaza� kopiowania dokumentu w jakiejkolwiek formie.
     (wystarczy �e przegl�darka musi �ci�gn�� dokument na komputer
     lokalny)

  �  Nie mo�na domaga� si� by dokument zachowa� sw� integralno�� i
     identyczno�� graficzn� (bo nie mo�emy wymaga� by� przegl�dany w
     zadanych ustawieniach przegl�darki je�li np. zosta� przeskanowany
     przez ``robota'', albo jest interpretowany przez przegl�dark� dla
     niewidomych (np. z syntezatorem mowy).
   Patrz te�:

  �wiat Wiedzy 9/96

  5.3.

  Terminologia

      WWW
        Marek Car:  Wszechnica Wiedzy Wszelakiej ,
         paj�czyna ,

      site
        Microsoft:  miejsce w Internecie PC Magazine PL:  o�rodek w
        Webie w�ze� sieci,  serwer

      link
        odno�nik, odwo�anie

      service
         us�uga

      download
         za�aduj ,  �ci�gnij ,  zapami�taj

      upload
         za�aduj na serwer

      serwer
         serwer ,  sztafarz

      browser
         przegl�darka ,  paj�czarka

      applet
        ?

      bookmark
         zak�adka

   Patrz te�:

  ???

  5.4.

  Wieloj�czyna paj�czyna - polskie znaki diakrytyczne

   W jaki spos�b mog� tworzy� poprawne strony z polskimi znakami
  diakrytycznymi?

  Przede wszystkim nale�y u�ywa� kodowania w ISO-8859-2. Poza tym je�li
  nie jeste� administratorem i nie mo�esz spowodowa�, �eby serwer
  dodawa� do nag��wka stron z polskimi literami deklaracji typu
  dokumentu:

  text/html; charset=iso-8859-2

  nale�y doda� w nag��wku strony (pomi�dzy <HEAD> i </HEAD>, a przed
  <TITLE> ) nast�puj�c� instrukcj�: <META HTTP-EQUIV="content-type" CON
  TENT="text/html; charset=iso-8859-2"> nie jest to rozwi�zanie
  najbardziej eleganckie: powoduje (na niekt�rych serwerach i z
  niekt�rymi przegl�darkami (np. Netscape Navigator) dwukrotne interpre
  towanie zawarto�ci dokumentu, nie jest w pe�ni uwzgl�dnione w specy
  fikacji HTML. Tym nie mniej dop�ki nie doczekamy si� (b�d�, sami nie
  przyczynimy si� ;-) do uznania przez grona normalizacyjne i produ
  cent�w oprogramowania faktu, �e w WWW stosuje si� i inne, poza
  anglosaskim zestawy znak�w, pozostaje nam stosowanie p�rodk�w.

   Patrz te�:

  ``standardy''

  Internationalization of the Hypertext Markup Language
  <http://ds.internic.net/rfc/rfc2070.txt>

  Polska Strona Ogonkowa <http://www.agh.edu.pl/ogonki/>

  Wieloj�zyczny serwer
  <http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html>

  5.5.

  Czy mog� w Paj�czynie umieszcza� dokumenty w innym formacie ni� HTML?
  Jakie formaty plik�w?

  Tak. Ale trzeba pami�ta� o tym, aby nie by�y ograniczone tylko do
  jednej platformy sprz�towej/systemowej. I dlatego nie nale�y u�ywa�
  surowych plik�w MS Worda czy QuattroPro. Warto je prze�o�y� na jaki�
  powszechnie uznany standard taki jak PostScript, RichTextFormat, CVS,
  PDF, HTML.

  Je�li nie jest to mo�liwe?  W takim razie nale�y doda� odpowiednie
  deklaracje MIME types serwera.  Oznaczenia typ�w plik�w znajduj� si� w
  comp.mail.mime FAQ
  <http://sunsite.icm.edu.pl/pub/usenet/comp.mail.mime/>

  5.6.

  Dostawca us�ug internetowych

  6.

  Tworzenie - HTML

  6.1.

  Zasady sk�adni HTML

  HTML jest aplikacj� ``SGMLa''.  Sk�adnia dokumentu HTML jest
  definiowana przez kombinacj� deklaracji SGML (definuj�cej m.in. zakres
  dopuszczalnych znak�w) oraz DTD. Wyra�enia znakuj�ce sk�adaj� si� z
  cz�ciej otwieraj�cej  a zamykaj�cej.  W pierwszej cz�ci jest to
  sekwencja

  <znacznik>

  za� w drugiej jest to

  </znacznik>

  (< to znak mniejszo�ci za� > to znak wi�kszo�ci i s� to HTML (i w
  wi�kszo�ci j�zyk�w opartych na SGMLu) znaki zastrze�one do znakowa
  nia).  Po w�a�ciwym poleceniu mog� nast�powa� jego atrybuty (wraz z
  warto�ciami)

  <znacznik> atrybut=wartosc

  Nie s� istotne typowe elementy staruj�ce: spacje, tabulatory, znaki
  ko�ca linii (og�lnie znaki o kodzie ASCII poni�ej 32).  W niekt�rych
  przypadkach nie jest wymagane zamki�cie polecenia znakuj�cego.(np.<P>,
  <LI>) cho� czasem mo�e si� to nieciekawie sko�czy� (zw�aszcza nie-
  ko�czenie polece� ,,wymieniaj�cych'' takich jak <UL>, <OL>).

  Cz�� przydatnych na codzie� znak�w u�ywanych przez polecenia
  znakuj�ce zosta�a zast�piona przez tzw. entries rozpoczynaj�cych si�
  od znaczka & (Ampersand):

  �  < - &lt;      - znak mniejszo�ci

  �  > - &gt;      - znak wi�kszo�ci

  �  " - &quot; - znak cala (stosowany powszechnie jako cudzys��w)

  �  &160; - &nbsp;  - znak kr�tkiej spacji

  �  & - &amp;

     W parametrach atrybut�w mog� (bez uj�cia w " lub ') wyst�powa�
     jedynie znaki z zakresu a-Z, poza tym kropki, znak my�lnika
     (przeniesienia).  (wyst�puj� przy tym problemy zwi�zane z literk� �
     w atrybutach np.  <IMG SRC="foo" ALT="���">). Istotna jest
     kolejno��  zagnie�dze� znacznik�w (ew. patrz przegl�d sk�adni
     Coguara <http://www.digilab.com.pl/pl.comp.www/html/DTD-HOME.html>
     by� mo�e rozwnin� z tego kurs HTMLa ;-)

   Patrz te�:

  6.2.

  Najkr�tszy dokument

  Wed�ug specyfikacji HTML 3.2 najkr�tszy dokument wygl�da w tak:

  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
  <TITLE>Tytu� dokumentu</TITLE>

  cho� zwykle stosuje si�:

  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
  <HTML>
  <HEAD>
  <META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=ISO-88592">
  <TITLE>Tytu� dukumentu</TITLE>
  </HEAD>
  <BODY>
  zawarto�c dokumentu
  </BODY>
  </HTML>

   Patrz te�:

  6.3.  Podstawowe znaczniki

      <HTML>
        oznaczenie pocz�tku dokumentu HTML

      <HEAD>
        sekcja nag��wkowa (definicje dotycz�ce ca�ego dokumentu, miejsce
        na wsadzenie informacji o stosowanych stylach, relacjach mi�dzy
        dokumentami itd).

      <BODY>
        sekcja g��wna dokumentu (ca�a reszta ;-)

      <TITLE>
        tytu� dokumentu

      <A>
        (od ANCHOR) wymaga co najmniej jednego z dw�ch atrybut�w:
        HREF="``URL''" lub NAME="punkt" oraz zako�czenia (to co znajduje
        si� pomi�dzy pocz�tkiem a ko�cem wyra�enia stanowi obszar
        aktywny po��czenia (czyli trzeba klikn�� myszk� na tek�cie z
        wyra�enia aby uruchomi� odno�nik i przenie�� si� do innego
        dokumentu).

      <LINK>
        pozwala na zdefiniowanie zale�no�ci mi�dzy dokumentami.

      <META>
        wnosi dodatkowe informacje na temat dokumentu.

      <STONG>
        wyr�nienie

      <EM>
        wyr�nienie

      <H1>
        nag��wek 1 stopnia

   Patrz te�:

  ``rekomendacja dla HTML 3.2''

  ``RFC 1886''

  opis Wilbura czyli HTML 3.2
  <http://www.htmlhelp.com/reference/wilbur/> a tak�e wersja offline
  <http://www.htmlhelp.com/reference/wilbur/wilbur.zip>

  WWW FAQ Thomasa Boutella <http://www.boutell.com/faq/>

  Kurs HTML Paw�a Wimmera z Wydawnictwa Lupus
  <http://www.polbox.com.pl/lupus/html/>

  Panorama HTML <http://winter.it.com.pl/html/> z Projektu Winter
  WWWhowto - Jak zrobi� swoja strone WWW? Tomasza Pi�ata
  <http:://ajax.umcs.lublin.pl/~poncjusz/WWWhowto/> (jest tam te�
  dzia�aj�cy on-line validating parser HTML Wilbur SWAT
  <http:://ajax.umcs.lublin.pl/~poncjusz/SWAT/>

  Jak stworzy� w�asn� stron� WWW (Grzegorza W�jcika)
  <http://www.ia.pw.edu.pl/pl-iso/homepage-info.html>

  Jak zrobi� w�asn� stron� WWW <http://www.pk.edu.pl/sysdocs/howto.html>
  (wskaz�wki dla u�ytkownik�w z PK) (Szymona Soko�a i Grzegorza Muchy)

  Opis polece� j�zyka HTML  z przyk�adami
  <http://www.wibro.agh.edu.pl/info/www/html/reference/>  Roberta Paj�ka

  KROTKI KURS HTML <http://panda.bg.univ.gda.pl:80/~krabek/kurs.html>

  Jak zrobi� swoja w�asn� HomePage ?
  <http://zeus.polsl.gliwice.pl/~bort/local/how-to.html>

  Opis HTML autostwa ,,Statoma''
  <http://www.polsl.gliwice.pl/~statom/HTML/HTML.html> czyli Tomasza
  Stankiewicza

  The Bare Bones Guide to HTML <http://werbach.com/barebones/> kr�tki
  (15kb) spis wszystkich komend HTML wraz z netscapizmami (zaznaczonymi)

  6.4.

  Przydatne wskaz�wki

  gdy tworzysz wi�kszy zestaw dokument�w warto najpierw stworzy� projekt
  (w tym graficzny), szablon dokumentu.

  staraj si� tworzy� dokumenty ,,znaczeniowe'' a ,,wygl�dowe''

   Patrz te�:

  6.5.

  Wsp�praca z przeszukiwarkami

  Warto dostosowa� swoje dokumenty do istnienia przeszukiwarek i innych
  robot�w przez zdefiniowanie dodatkowej informacji o dokumencie:

      kr�tki opis
        <META NAME="Description" CONTENT=" To jest kr�tki opis ">

      s�owa kluczowe
        <META NAME="Keywords" CONTENT=" WWW, FAQ ">

      informacja o prawch autorskich
        <META NAME="CopyRight" CONTENT=" Ziemek Borowski (GNU v.2.0) ">

      informacja o autorze
        <META NAME="Author" CONTENT=" Ziemek Borowski ">

      informacja o adresie pocztowym autora
        <LINK REV="MADE" HREF="mailto:zie...@digilab.com.pl">

      data powstania dokument�w
        <META NAME="Create" CONTENT=" Sat  15 Mar 1997  19:26:58 ">

      data ostatniej modyfikacji dokumentu
        <META NAME="Modification" CONTENT="Sat 15 Mar 1997 19:26:58 ">

   Patrz te�:

  Opis META <>

  6.6.

  Dlaczego standardy s� istotne?

  Netscapizmami zwie si� popularnie te rozszerzenia akceptowane tylko i
  wy��cznie przez przegl�darki firmy Netscape Communications Corporation
  , i ostatnio przez MS Internet Explorer, nie zarejestrowane w
  oficjalnej specyfikacji (b�d� jej propozycji) j�zyka HTML.  Nie nale�y
  ich u�ywa� poniewa�:

  �  nie ma mo�liwo�ci sensownego sprawdzenia parserem/validatorem SGML
     takiego dokumentu (zazwyczaj brak jest oficjalnych DTD (i nawet
     nieoficjalnych, np. dla IE 3.0, lub NN 3.0) dla takich rozszerze�)

  �  dokumenty te nie zawsze mog� by� poprawnie wy�wietlane w
     przegl�darkach innych producent�w. A HTML b�d�cy (zw�aszcza w
     wersjach 2.0 i Wilbur) bardzo ubogim znaczeniowo zastosowaniem
     SGML-a, zosta� stworzony po to, by istnia�a wsp�lna, niezale�na od
     sprz�tu i systemu platforma informacyjna.

  �  niekt�re rozszerzenia nie mieszcz� si� w �aden spos�b w sk�adni
     istniej�cych DTD HTMLowych ;-) np. te zwi�zane z ramkami...
     (FRAMES)

   Patrz te�:

  6.7.

  Jak kontrolowa� poprawno�c kodu?

  Dlaczego: to chyba oczywiste ka�dy chyba chce �eby rzeczywisty efekt
  pokrywa� si� z planowanym, tak treraz jak i w przysz�o�ci, gdy
  przegl�darki b�d� np. �ci�lej trzyma� si� standardu.  Powszechnie
  stosowan� metod� jest ,,r�czne'' sprawdzanie za pomoc� wybranej
  dowolnie ,,przegl�darki testowej'' takiej jak np. Lynx, Netscape, lub
  MS IE. Jest to dzia�anie co najmniej w�tpliwe: przegl�darka powinna
  wy�wietla� wszystkie (nawet z b��dami sk�adniowymi) strony poprawnie,
  cho� niekoniecznie zgodnie z intencjami jej autor�w. Poprawn� form�
  sprawdzania strony jest raczej u�ycie parsera/validatora SGML takiego
  jak na przyk�ad SP <http://www.jclark.com/sp/> Jamesa Clarka (dost�pny
  tak dla DOS (32-ext.) Win32, jak i UNIXa wraz z odpowiednim DTD dla
  stosowanego dialektu HTMLa <http://www.w3.org/pub/WWW/MarkUp/html-
  pubtext/> W wyniku kontroli (np.

  nsgmls -m /usr/lib/pubtext/catalog -f nazwa.err -o nazwa.out nazwa.htm

  powstaje lista b��d�w (przez skierowanie potoku b��d�w do pliku) na
  podstawie, kt�rej nale�y ,,r�cznie'' poprawi� dokument. Dopiero potem
  warto sprawdzi� w przegl�dace, czy przypadkiem czego� istotnego nie
  przeoczyli�my...

   Patrz te�:

  Validation-HTML
  <http://sunsite.icm.edu.pl/pub/Linux/Documentation/HOWTO/mini/Validation-
  HTML>

  6.8.

  Ramki? Nie stosowa�!!!

  Dlaczego?

  �  nie odpowiedniego DTD,

  �  nadal bardzo trudno umie�ci� jak�� stron� w zak�adkach,

  �  starsze przegl�darki nie akceptuj�,

  �  �atwo zapomnie� o poleceniu <NOFAMES>

  6.9.

  Pytania r�ne

  6.9.1.  Czy mog� ukry� kod �r�d�owy dokumentu?

  Nie. I bardzo dobrze. Po prostu kod �r�d�owy dokumentu w HTML musi by�
  zakodowany bez �adnych ogranicze�, aby mo�na by�o czyta� dokumenty nie
  do ko�ca sprowadzone na lokalny komputer.

  6.10.

  Narz�dzia

  Gdy mowa o narz�dziach s�u��cych do kreowania dokument�w w HTMLu
  cz�sto trudno doj�� do porozumienia. Cz�� ludzi twierdzi, �e
  najlepszym narz�dziem jest... Windowsowy Notatnik.  Inni twierdz�, �e
  ma za ma�e mo�liwo�ci wyszukiwania i zamiany wi�c zalecaj� Vi;-) S� to
  zwolennicy edytor�w poziomu ,,r�cznego''. S� tacy kt�rzy chcieli by
  jednak mie� jak�� form� spomagania tworzenia dokument�w przez
  pod�wietlanie sk�adni i mo�liwo�c wybrania z listy dobranych
  znacznik�w. Ci s� zwolennikami ,,edytor�w niskiego poziomu''. S�
  jednak te� zwolennicy edytor�w graficznych tzw. WYSYG czyli
  ,,wysokiego poziomu''. Lecz bardzo cz�sto zapomina si� o innego typu
  narz�dziach np. konwerterach z innych format�w (w tym SGMLowych)
  rozmaitych preprocesorach u�atwiaj�ch tworzenie du�ych o�rodk�w.

   Patrz te�:

  6.10.1.

  DOS

   Patrz te�:

  6.10.2.

  MS-Windows

   Patrz te�:

  <http://www.tucows.com/window95.html> Tucows na SunSite
  <http://sunsite.icm.edu.pl/pub/tucows/> Tucows na PW
  <http://alfa2.it.pw.edu.pl/tucows/>

  <http://www.tucows.com/windows3.html> The CWSApps List
  <http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html> Indeks
  Aplikacji Sieciowych dla Windows

  Papa's Anonymous FTP <ftp://ftp.man.poznan.pl/pub/winsock-l/>

  Windows95 shareware and freeware <http://www.windows95.com/>

  6.10.3.

  Unix

  Wbrew temu co niekt�rzy m�wi�  dla Unixie jest mn�stwo cennych
  narz�dzi do edycji HTML (i generalnie  SGMLa). Poczynaj�c od
  spreparowanych pod k�tem HTML plik�w startowych Vi, ViMa
  <http://www.math.fu-berlin.de/~guckes/vim/>, joe, Emacsa
  <http://www.santafe.edu/~nelson/tools/> i XEmacsa
  <http://www.XEmacs.org/> dochodz�c do dedykowanych HTMLowi asWedita
  <http://SunSite.icm.edu.pl/pub/www/asWedit/> i edytorowi z Ayamayi
  (W3C) <http://www.w3.org/> Istotne s� te� liczne narz�dzia skryptowe
  takie jak na przyk�ad WebLint, Latex2HTML, SGML-Tools
  <http://web.inter.nl.net/users/C.deGroot/sgmltools/>, perlSGML
  <http://www.oac.uci.edu/indiv/ehood/perlSGML.html> sdc
  <ftp://ftp.inria.fr/INRIA/Projects/icsla/Implementations> oraz
  preprocesory takie jak Orb
  <http://www.cinenet.net/users/cberry/orbinfo.html>.

  6.11.

  Pytania r�ne

   Patrz te�:

  7.

  Dopuszczalnymi formatami grafik dla WWW s�: GIF, JPEG, i PNG, oraz
  XBM, XPM.  Nie nale�y, bez ostrze�enia kierowa� do stron zawieraj�cych
  du�e (tj.  powy�ej 20 kb) grafiki.

  Tworzenie - grafika

  7.1.

  Dopuszczalnymi formatami grafik dla WWW s�: GIF, JPEG, i PNG, oraz
  XBM, XPM.  Istniej�ce formaty graficzne

  Istnieje kilka uznanych format�w grafiki s�u��cych do prezentacji w
  paj�czynie:

  �  GIF

  �  JPEG

  �  PNG

  �  nieoficjalnie

   Patrz te�:

  7.2.

  Zasady umieszczania grafiki

  �  Pami�taj o tym by nie zamieszcza� na stronie startowej wielkich
     (tj. razem powy�ej 20 kb) element�w graficznych.  Mo�esz tym
     odstraszy� (wolne/prze�nione ��cza)

  �  Pami�taj o atrybucie ALT poleczenia IMG

  �  Niech grafiki stanowi� drobne urozaicenie tekstu, immanetn� ca�o��
     jako ilustracje  a nie jako�� sam� w sobie: Patrzcie co potrafi�
     zrobi� PhotoShopem

  �  Staraj si� nie robi� element�w zawieraj�cych napisy jako grafik�.
     A nu� kto� to b�dzie chcia� obejrze� na monitorze 21 calowym ;-)
     Pomijaj�c fakt, �e to uniemo�liwia normalne indeksowanie takich
     napis�w (niekt�re roboty nie czytuj� tego co jest zamieszczone jako
     ALT).

   Patrz te�:

  7.3.

  Efekty specjalne

  7.3.1.  ,,Prze�roczyste grafiki''

  Aby przygotowa� prze�roczyste grafiki, tj. w kolorze dowolnie
  definiowanego t�a lub podk�adu, nale�y zapami�ta� je w formacie GIF
  89a przy pomocy np.  LView Pro  1.0 dla Windows
  <http://world.std.com/~mmedia/lviewp.html> (lub z mirrora:
  <http://alfa2.ia.pw.edu.pl/tucows/>) albo giftrans dla DOSa
  <http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.exe> i/lub
  UNIX <http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.1.gz>

  7.3.2.

  Do tworzenia animowanych rysunk�w mog� s�u�y�: Gif Construction Set
  dla Windows <ftp://ftp.dtp.std.com/ftp/vendors/mmedia/gifcon.exe> Web
  Paint - shareware dla W95 <http://www.barentsnett.no/webpaint/>
  GifMerge dla UNIXa <http://www.iis.ee.ethz.ch/~kiwi/GIFMerge/>

  Animacje

   Patrz te�:

  7.4.

  Pytania r�ne

   Patrz te�:

  8.

  Tworzenie - Java, JavaScript, CGI, SSI

  8.1.

  Po co stosowa� programy w przekazie informacji

  Czasem trzeba. I to nie po to by
   uatrakcyjny� statyczne strony Web a po to by

  �  zapewni� dost�p do danych z bazy

  �  umo�liwi� wyszukiwanie

  �  zapewni� informacj� zwrotn�

  �  u�atwi� autentyfikacj�

   Patrz te�:

  8.2.

  Statyczne - dynamiczne

  Nie wiem czemu wszelkie pisma m�wi�c o Paj�czynie i Javie pisz� o
  statycznych dokumentach HTML i wnoszeniu  ruchu do nich...  Uwa�am za
  haniebn� praktyk� lataj�cych ramek, spodk�w i napis�w.  Uwa�am, �e
  wszelkie stosowanie oprogramowania powinno dotyczy� systuacji gdy dane
  s� po prostu oprawiane w form� HTMLow�.

   Patrz te�:

  8.3.

  Bazy danych

  Jakie s� dost�pne bazy danych mo�liwe do stosowania w Paj�czynie?
  Odpowied� brzmni pewnie:  wszystkie . Ale trzeba wybra� jeden produkt.
  Ja osobi�cie poleca�bym Postgres <http://www.postgresql.org/> na
  Unixie (a zw�aszcza Linuxie <http://www.Linux.org.pl/>). Dlaczego?

  �  d�uga historia (10 lat - pocz�tek prac na zlecenia DARPA i NSF)

  �  relacyjna

  �  rozszerzalna

  �  cechy obiektowe

  �  dost�p przy pomocy podzbioru SQL

  �  istnieje interface do WWW

     Poza tym niekt�rzy zalecaj� mSQL <http://hunges.com.au/> (cho� baza
     ta dost�pna jest za darmo jedynie dla instytucji edukacyjnych),
     dost�pny teoretycznie za darmo cho� na dziwnych zasadach
     MICRO/CDS/ISIS <http://www.medianet.com.pl/~cc/> rodem z UNESCO.

   Patrz te�:

  8.4.

  Przeszukiwanie

  SWISH <http://www.eit.com/software/swish/> GlimpseHTTPd
  <http://glimpse.cs.arizona.edu/ghttp/>

  8.5.

  Lataj�ce spodki

   Patrz te�:

  8.5.1.

  W jaki spos�b mog� zainstalowa� licznik na stronie?

  Nie nale�y tego robi� poniewa�, zazwyczaj, liczniki k�ami�, nie
  uwzgl�dniaj�c odwo�a� do strony przez Proxy-Cache, powoduje
  niepotrzebne obci��enie serwera (graficzne), i jest przejawem
  niepotrzebnego efekciarstwa. Je�li jednak te argumenty s�
  nieprzekonuj�ce polecam:

  <http://www.webtools.org/counter/>

  <http://www.w4.nl/software/counter/>
  <ftp://ftp.ibspan.waw.pl/pub/unix/html-counter/>

  albo skorzystaj z opisu Tomasza Pi�ata (sprawdzony jedynie z NSCA
  HTTPd 1.4. i dzia�aj�cy na bazie  Server Side Include ): nale�y
  za�o�y� w katalogu gdzie mamy strone, do kt�rej chcemy liczy� dost�py
  plik .htaccess

  AddType text/x-server-parsed-html index.html
  AddType application/x-httpd-cgi count.cgi

  - gdzie index.html to nazwa tej strony, a count.cgi nazwa pliku pro
  gramu licznika (obie liniki powinny by� zako�czone Enterem). Oto
  zawarto�� tego drugiego:

  #!/usr/bin/perl
  open (COUNT,"count") ;
  $counter =<COUNT>;
  close (COUNT) ;
  open (COUNT, ">count") ;
  print COUNT +($counter+1) ;
  close (COUNT) ;
  print $counter;
  exit(0) ;

  mo�e zaistnie� potrzeba zmiany �cie�ki do PERLa (to jest
  #!/usr/bin/perl).  Naj�atwiej sprawdzi�, gdzie jest PERL pisz�c:
  whereis perl lub which perl Wykonujemy co nast�puje:

  touch count
  chmod 777 count
  chmod 505 .htaccess
  chmod 505 count.cgi

  W pliku count znajdowa� si� b�dzie liczba odwiedzin.  Umieszczamy na
  stronie cos takiego:

  Te strone odwiedzilo juz
  <!-#exec cmd="/usr/bin/perl count.cgi"->
  gosci!

  Uwaga cenzora: powinno by�:

  Te strone pobrano juz <!-#exec cmd="/usr/bin/perl count.cgi"-> razy od dnia
  zainstalowania licznika lub jego resetowania.

  (TP)

  9.

  Serwery

  9.1.

  Obs�uga b��d�w

   Patrz te�:

  9.2.

  Strona na has�o

   Patrz te�:

  9.3.  Jakie serwery WWW (HTTP) s� dost�pne?

  9.4.  Jaki serwer wybra�  (i pod jakim systemem powinien pracowa�)?

  Pytanie rzeka... najlepiej spojrze� na stron� WebCompare
  <http://webcompare.iworld.com/> gdzie szczeg�owo opisano (i
  por�wnano) wi�kszo�� dost�pnych serwer�w WWW.

  Ja osobi�cie u�ywam boa <http://www.boa.org/> - ma�ego, taniego (GNU)
  i chdz�cego jako nobody nie za� jako root.

  Inni preferuj� Apache 1.2 <http://sunsite.icm.edu.pl/pub/www/apache/>
  i wcale si� im nie dziwi� - pot�ne narz�dzie, z do�� �atw� integracj�
  z bazami danych, opcjami takimi jak: virtualny serwer i u�ywane na
  tyle powszechnie (podobnie jest z sendmailem), �e skutecznie
  przetestowane (Netcraft <http://www.netcraft.com/> donosi �e Apache
  stanowi 40% wszystkich u�ywanych serwer�w HTTPd.

   Patrz te�:

  9.5.

  Wirtualny serwer

   Patrz te�:

  9.6.  Robot exlusion

  10.

  Bezpiecze�stwo WWW

  10.1.

  Java

   Patrz te�:

  10.2.

  CGI

   Patrz te�:

  10.3.

  Serwery

   Patrz te�:

  -->

  11.  Podzi�kowania

  �  Rafa� Maszkowski

  �  Marek B�czek

  �  Grzegorz Staniak

  �  Piotr T�czy�ski

  �  Wojciech Myszka

  �  Pawe� Wi�cek

  �  Wojtek Sylwestrzak

  �  Jerzy Pankiewicz

  �  Tomasz Pi�at

  �  Marcin Cie�lak

  �  Bogus�aw Fries

  �  Jaros�aw Zieli�ski

  �  inni, kt�rzy zg�osz� swoj� ofert� pomocy :-)

  �  wszyscy pisuj�cy na <news:pl.comp.www>

  �  Linus Torvalds  :), tw�rca Linuxa

  �  Free Software Foundation i GNU Public Licence (GPL) v. 2.0

  �  James GlodFarb

  �  Tim Berners-Lee

  �  Tees A. de Groot Ulrich Windl Tom Gordon Matt Welsh Greg Hankins i
     inni kt�rzy wnie�li sw�j wk�ad w stworzenie pakietu SGML-Tools

  �  Bram Moolenaar inni przyk�adaj�c sie do ViMa a zw�aszcza wersji
     4.x.

  �  Jim Clark tworz�c SP.

  �  Tillmann Steinbrecher tworz�c UNTGZ


-- 
Rafal Maszkowski r...@torun.pdi.net           http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID: <pl.comp.www-1-858711415@torun.pdi.net>
Path: mbox-mo1.pugleaf.net!unknown!not-for-mail

Show Full Headers
Complete Article Headers
From: Ziemek Borowski <zie...@qdnet.pl>
Subject: pl.comp.www FAQ
Date: 1997/03/18
Message-ID: <pl.comp.www-1-858711415@torun.pdi.net>
X-Deja-AN: 226717661
Distribution: world
Sender: r...@rymunda.torun.pdi.net
Supersedes: <pl.comp.www...@torun.pdi.net>
X-Posting-Frequency: Posted on 1st and 15th day of each month
Followup-To: poster
Organization: Rafal Maszkowski
Keywords: WWW World Wide Web
Reply-To: zie...@qdnet.pl (Ziemek Borowski)
Newsgroups: pl.comp.www,pl.answers
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit