🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: pl.answers
Article #145

pl.comp.www FAQ

#145
From: Ziemek Borowski
Date: Sat, 01 Mar 1997 00:00
2458 lines
61867 bytes
Posted-By: auto-faq 3.1.1.2
Archive-name: pl.comp.www

  Wersja 0.7.0.2 z dnia 04.02.1997 godzina 23:59:59.99
  pl.comp.www FAQ & A
  Ziemek Borowski & inni.

  Dokument ten jest proba opisania (w formie ,,Czesto Zadawanych Pytan
  wraz z Odpowiedziami -CZPiO) zagadnien zwiazanych z technologia

  World Wide Web ,,w Polsce i po polsku''

  1.  Autorzy, deklaracje, kwestie porzadkowe.

  1.1.

  Dostepne:

  <http://www.QDnet.pl/~Ziembor/pl.comp.www/>

  oraz wersja tekstowa (bez polskich liter):

  <http://www.QDnet.pl/~Ziembor/wwwfaqpl.txt>

  Wersja skompresowana:

  <http://www.QDnet.pl/~Ziembor/www.tgz>

  do dekompresji wymaga w DOSie programu UNTGZ

  (GNU) <http://www.QDnet.pl/~Ziembor/untgz.zip>.  Dostepnosc

  1.2.  Koordynator i (w charakterze sklejacza) autor :-)

  Ziemek Borowski  (ZMB)

  <mailto:zie...@QDnet.pl>

  <http://www.QDnet.pl/~Ziembor/>

  1.3.  za co serdecznie dziekuje

  (kolejnosc quasi-losowa ;-) i wedlug chronologii): Komentuja, poma
  gaja, podrzucaja pomysly:

  1.3.1.  Bezposrednio

  �  Rafal Maszkowski (RM)

     <mailto:r...@torun.pdi.net>

     <http://www.torun.pdi.net/~rzm/>

  �  Marek Baczek (MGB)

     <mailto:m...@QDnet.pl>

     <http://www.QDnet.pl/~mgb/>

  �  Grzegorz Staniak (GS)

     <mailto:gsta...@golem.umcs.lublin.pl>
  �  Piotr Teczynski (PT)

     <mailto:pte...@hum.amu.edu.pl>

     <http://hum.amu.edu.pl/~pteczyn/>

  �  Wojciech Myszka (WM)

     <mailto:W.My...@immt.pwr.wroc.pl>

  �  Pawel Wiecek (cov)

     <mailto:co...@pwr.wroc.pl>

     <http://www.ists.pwr.wroc.pl/~coven/>

  �  Wojtek Sylwestrzak (WojSyl)

     <mailto:woj...@icm.edu.pl>

  �  Jerzy Pankiewicz (JP)

     <mailto:panki...@pwr.wroc.pl>

  �  Tomasz Pilat (TP)

     <mailto:ponc...@ajax.umcs.lublin.pl>

     <http://ajax.umcs.lublin.pl/~poncjusz/>

  �  Marcin Cieslak (Saper)

     <mailto:sa...@sgh.waw.pl>

  �  Boguslaw Fries  <mailto:fr...@digilab.com.pl>

  �  inni, ktorzy zglosza swoja oferte pomocy :-)

  �  wszyscy pisujacy na  <news:pl.comp.www>

  1.3.2.  Tworzac oprogramowanie

  W co najmniej takim samym stopniu do powstania tego dokumentu

  przyczynili sie:

  �  Linus Torvalds :), tworca Linuxa,

     <mailto:li...@linux.helsinki.fi>

  �  Free Software Foundation i GNU Licence

  �  Tom Gordon, Matt Welsh, Greg Hankins i inni ktorzy wniesli swoj
     wklad w stworzenie pakietu SGML-Tools

  �  Bram Moolenaar  <mailto:mo...@oce.nl> i inni:  ViM a zwlaszcza
     wersje 4.2.

  �  Jim Clark  <mailto:jcl...@jclark.com> i SP.

  �  Tillmann Steinbrecher  <t...@pizza.omnilink.net>

     i UNTGZ  <http://privat.schlund.de/tst/untgz.htm>.

     za co dziekuja im rownie goraco.

  1.4.  Deklaracje

  �  Dokument ten (jeszcze nie teraz) bedzie podlegal ochronie

     na podstawie GPL v 2.0. Tym niemniej juz teraz mozna do niego
     stosowac

     postanowienia licencji GNU.

  �  Jesli nie znalazles tu odpowiedzi na swoje pytanie przepraszam... I

     mam prosbe: jak znajdziesz, przeslij uzupelnienie do odpowiedzi na

     istniejace pytanie, badz napisz (wraz z odpowiedzia) nowe.

  �  Dokument ten

     bedzie wysylany do grup  <news:pl.comp.www> oraz  <pl.anwsers> raz
     na dwa tygodnie,

     pierwszego i pietnastego dnia kazdego miesiaca.

  �  Bede dokladal staran aby dokument ten byl systematycznie
     uzupelniany i w miare pojawiania

     sie nowych pytan publikowane byly jego kolejne wydania.

  �  Autorzy nie ponosza zadnej odpowiedzialnosci za efekty dzialania

     spowodowane stosowaniem sie do zalecen zawartych w dokumencie.

  �  Wszystkie zastrzezone znaki firmowe zostaly uzyte jedynie w celach

     informacyjnych.

  �  Dokument nie ma zadnej mocy prawnej badz administracyjnej i

     powolywanie sie na udzielone w nim odpowiedzi oraz porady jest

     bezpodstawne.

  �  Dokument moze byc dowolnie uzywany i rozpowszechniany, jednak w

     wypadku publikacji prosze o poinformowanie o tym fakcie, a w
     wypadku

     zamieszczenia w Internecie prosze ponadto o zobowiazanie sie do

     systematycznego uaktualniania.

  �  Dokonywanie zmian bez zgody i wiedzy autora dokumentu jest

     niewskazane, choc dopuszczalne, przy zachowaniu praw autoskich i

     zaznaczeniu jakie fragmenty ulegly zmianie.

  �  Wiekszosc tekstow jest autorstwa Ziemka Borowskiego, choc bardzo

     czesto oparte sa na lekturze, np. artykulow w grupie

     <news:pl.comp.www>.

     Jesli autorem danego fragmentu jest ktos inny, jest to zaznaczone
     przez podanie inicjalow autora tego fragmentu (*), lub uzupelnienia

     (+*) ponizej tresci.

     Tym nie mniej Ziemek Borowski bierze na siebie odpowiedzialnosc

     za calosc tekstu.

  �  Zawartosc  <news:pl.comp.www> FAQ opiera sie glownie na

     listach z grupy

     usenetowej  <news:pl.comp.www> oraz ew.

     <pl.comp.lang.java>,

     <pl.listserv.polip>,

     <pl.comp.ogonki>, jesli tylko maja zwiazek z tematem.

   Kwestie porzadkowe

  1.5.  Czy ta grupa ma swoje archiwum?

  Nie... (ewentualnie mozesz szukac w DejaNews

  <http://www.DejaNews.com/forms/dns.html> ;-) Ale trzeba uwazac:

  jest tam ustawiony naglowek  Pragma: NoCache , i blokada dla robotow

  (wiec

  nie mozna sciagnac calego archiwum ,,do domu'').

  1.6.  Czy moge zaprenumerowac te grupe tak jak normalna liste
  dyskusyjna?

  Nie i bardzo dobrze... ;-) (sprzezenie z lista to tylko niepotrzebne

  klopoty z polskimi literkami oraz glupie pytania:  jak sie wypisac? .

  ;-)

  1.7.  W jaki sposob zadawac pytania, aby uzyskac odpowiedz?

  Daleki jestem od odsadzania od czci wszystkich, ktorzy zadaja pytania

  nie konkretne, badz takie na ktore odpowiedz znajduje sie na drugiej

  stronie manuala, podrecznika badz FAQ. Ale prosze...

  1.7.1.  Zanim zadasz pytanie:

  �  zastanow sie, czy to co cie trapi jest rzeczywiscie problemem. Byc

     moze spotkales sie juz z podobna sytuacja i tylko cos Ci na chwile

     rozum zacmilo :-)

  �  przejrzyj dostepna lokalnie dokumentacje... Po to sie ja tworzy.

  �  poszukaj FAQ (czyli zbioru najczesciej zadawanych pytan wraz z

     odpowiedziami) zwiazanego z nurtujacymi cie problemami... w Polsce

     znajdziesz je pod adresem

     <http://sunsite.icm.edu.pl/pub/usenet/>

  �  Sprawdz archiwa:

     <http://www.dejanews.com/forms/dnq.html>

     i tam wpisz grupe: pl.comp.www w filtrze.

  �  spytaj lokalnego administratora... chyba, ze ma Cie juz dosc, badz
     sam

     nim jestes :-)

  �  poszukaj przy pomocy katalogu tematycznego badz wyszukiwarki

  1.7.2.  Gdy nie masz innego wyjscia...

  to pytaj... Ale pamietaj, ze zadawanie pytan

  tez jest sztuka. Tutaj, w grupie  <news:pl.comp.www>

  ograniczymy sie do wskazowek

  raczej technicznych.

  �  napisz dokladnie: jaki masz problem... (np.

     jakiego systemu operacyjnego uzywasz i z

     jakim programem (i jaka jego wersja) masz klopoty ).

     I nie mysl ze istnieje jedynie M$ Windbloze.

  �  jesli szukasz jakiegos programu, napisz jak sie nazywa, jakie

     wymagania ma spelniac i co najwazniejsze w jakim systemie
     operacyjnym

     ma dzialac...

  �  nie zaszkodzi podac gdzie szukales, najwyzej inni sie czegos
     naucza.

  �  pomysl, czy tematyka Twojego pytania jest dostosowana do tematyki

     grupy (np. nie pisz o jakims zasobie nie zwiazanym z TECHNOLOGIA
     World Wide Web

     tylko dlatego, ze znajduje sie on w Pajeczynie - od tego typu
     ogloszen sa inne

     grupy np.  <pl.internet.nowosci>, inna grupa blizej zwiazana z
     tematyka

     witryny, zasobu).

      I pamietaj: to, ze ktos Ci odpowie to tylko i wylacznie jego dobra
     wola.

     I nie obrazaj sie, jesli ktos Ci odpisze np. RTFM podajac jakiegos
     URLa,

     badz tytyl ;-).

  1.8.  Co wywoluje powszechny (i uzasadniony) gniew i irytacje?

  Wiele rzeczy.... Na przyklad:

  �  wysylanie spamu.

  �  wysylanie plikow binarnych (zwlaszcza wielkich i to takich ktore
     moznaby

     umiescic gdzies w pajeczynie badz anonFTP i podac URL)

  �  pytanie po raz nt. jak zrobic cos co jest opisane w kazdym kursie
     HTMLa.

  �  pisanie, ze obowiazujacym standardem kodowania polskich liter
     powinno byc ANSI CP-1250 (bo ,,tak jest prosciej'', i ,,dla
     ludzi'').

     I m.in. dlatego pisze to FAQ, aby uniknac powtarzania zawsze tych
     samych, nie posowajach do przodu dyskusji, pytan.

  2.  Co to jest WWW i inne definicje.

  Ponizej przedstawiam ogolne informacje dotyczace World Wide Web.

  2.1.  Co to jest Internet?

  W RFC 1462, lub FYI 20 Internet zostal zdefiniowany jako:

  �  siec komputerowa oparta na protokolach TCP i IP (TCP/IP)

  �  zasoby dostepne na komputerach polaczonych z siecia (tzw. hostach)

  �  spolecznosc, wspolnota (community) ludzi uzywajacych i
     rozwijajacych

     te siec

  2.2.  Co to jest Web, WWW?

  WWW (World Wide Web), zwana inaczej Pajeczyna , Webem jest

  hipertekstowym, multimedialnym, sieciowym, opartym na TCP/IP systemem

  informacyjnym.

     hipertekstowym
        czyli takim gdzie istnieja zdefiniowane zaleznosci miedzy

        poszczegolnymi dokumentami, i mozliwosci dowolnego
        przemieszczania sie

        pomiedzy nimi.

     multimedialnym
        czyli dopuszczajacym stosowanie roznych srodkow przekazu:
        tradycyjnych

        tekstow, dzwiekow, grafiki.

     sieciowym
        opartym na sieci rozleglej Internet, a wiec o zasiegu
        praktycznie

        globalnym.

  2.3.  Kto wyznacza standardy dla Internetu i WWW???

  Ostateczna instancja zatwierdzajaca dana propozycje standardu jest

  Internet Engineering Task Force czyli w skrocie IETF.

  <http://www.ietf.org/>

  Swoje propozycje w zakresie WWW przedstawia mu The World Wide Web

  Consortium (W3C) bedaca organizacja skupiajaca producentow
  oprogramowania.

  (propozycje standardow Internetu sa przedstawiane w RFC

  ( Request For Comments  - kategoria  Standard Track )

  2.4.  Co to jest SGML i HTML? I jakie sa ich wzajemne zwiazki?

   Standard Generalized Markup Language  oraz

   HyperText Markup Language

  :-)

  SGML to metajezyk tworzenia jezykow oznaczen.

  HTML i inne podobne jezyki (takie jak np. LinuxDOC)

  opisane w roznych

   Document Type Declaration  (identyfikowanych przy pomocy

   Public Identiters Declaration )

  sa jego zastosowaniem, aplikacja. Kazdy dokument

  SGML w sklada sie z trzech czesci:

  �  deklaracja SGML, opisujaca zestawy znakow, mechanizmy skladniowe i
     pewne
     poczatkowe wartosci stosowane w dokumentach danego typu;

     (np. <!DOCTYPE HTML system >

  �  DTD czyli definicja typu dokumentu opisujaca strukture jezyka
     oznaczen

     czyli zestaw elementow, model zawartosci kazdego z nich,
     dopuszczalne i

     domyslne wartosci atrybutow ;

  �  sam dokument, czyli document instance , np. konkretna strona HTML.

     W przypadku aplikacji zorientowanej na jeden tylko typ dokumentu,

     deklaracja skladni moze byc stosowana domyslnie (+ opcje zmiany)
     lub wszyta

     w kod, do wariantow DTD nastepuje odwolanie przez deklarowanie typu

     dokumentu (DOCTYPE) z publicznym identyfikatorem, po czym idzie juz
     sam

     dokument. Tak powinno byc tez w przegladarkach HTMLa, ale jak
     wiadomo

     znajomosc SGMLa wsrod ich autorow jest nikla,

     wiec deklaracja SGML jest po prostu

     ignorowana, w najlepszym razie stosowana na oko. Edytory HTMLa
     (zazwyczaj

     operujace rozmaitymi rozszerzeniami HTML dla ktorych nie ma - oby
     jeszcze -

     odpowiednich DTD) wstawiaja deklaracje DOCTYPE w zasadzie tylko w
     celu

     wywarcia wrazenia na klientach.

  Blizej SGML zostal opisany np. w artykule Wlodka Wypycha i Jacka
  Staszelisa:

   Po tagach poznacie  w:  PCkurier  20/96 oraz rzecz jasna na

  <http://www.sil.org/sgml/sgml.html>

  (GS+ZMB)

  2.5.  Co to jest HTML?

  HTML jest, a wlasciwie powinien byc, konkretna aplikacja

  (zastosowaniem) SGML opisana w odpowiednim dla danego dialektu HTMLa
  DTD.

  Niestety najczesciej jest

  to (w praktyce) oddzielny jezyk (nie posiadajacy uregulowanej przez

  DTD struktury), majacy tylko pewne elementy zgodne ze standardem
  opisanym w

  postaci DTD.

  Rozwijany przede wszystkim przez The World Wide Web Consortium

  (W3C) ( <http://www.w3.org/> -

  tam tez mozna znalezc specyfikacje i odsylacze do podrecznikow) oraz

  przez producentow pajeczarek: Netscape Communication  oraz Microsft

  (tworcy kolejnych wersji Mosaica (po odejsciu Andersena i powstaniu
  NC)

  - z NSCA tez swoje dolozyli).

  2.6.  Co to jest URL?

   Uniform Resource Locator  Wyglada mniej wiecej tak

  <http://www.cos.tam.pl:80/jakis/katalog/jakis.plik.html>

  I jest zlozony z nazwy uslugi:

  �  file://... - odnosnik do zasobow lokalnych komputera (nie nalezy
     chyba

     uzywac w sieci :-)

  �  ftp://...

     - odnosnik do zasobow dostepnych za pomoca protokolu FTP, z

     wariantem ftp://uzytkownik@...

     , lub ftp://uzytkownik:haslo@... (choc tej ostatniej wersji nie
     polecam)

  �  gopher://... - odnosnik do zasobow Gopher`a

  �  http://...

     - zbior obslugiwany bezposednio przez serwer httpd

     (WWW)

  �  maito:... - odnosnik powodujacy wyslanie listu pod podany adres
     (bez

     // po dwukropku!!!)

  �  news:... - odnosnik powodujacy uruchomienie przegladarki USENETU

     (news) uzywajac domyslnego serwera, i podanej grupy

  �  telnet:... - odnosnik do zdalnego komputera, zazwyczaj uzywajac

     terminala VT100 (bez // po dwukropku!!!)

  �  tn3270:... - odnosnik do zdalnego komputera IBM (np. 3090 na

     plearn.edu.pl) terminala IBM-3270 (bez // po dwukropku!!!)
  �  wais: - odwolanie do systemu wyszukiwawczego WAIS:

     <http://www.ict.pwr.wroc.pl/cgi-bin/tswais>

  �  newsrc:... - Odnosnik do okreslonego pliku newsrc

  �  nntp://... - Okresla inny niz domyslnie uzywany serwer newsow

     oraz:

  �  adresu (moze byc IP lub slowny typu www.my.computer)

  �  numeru portu pod ktorym jest dostepna dana usluga - o ile
     standardowy

     (tj. wg. RFC 1738 ) niepotrzebny.

  �  sciezki dostepu do pliku ((zakonczonej - choc nie jest to
     bezwzgledny

     (tj. wg. specyfikacji) wymog) znaczkiem / o ile nie jest to pelna

     sciezka, a tylko nazwa katalogu) Jesli podajemy jedynie katalog na

     serwerze wyswietlany jest jedynie plik zdefiniowany w ustawieniach

     serwera jako domyslny. Zazwyczaj jest to  index.html ,

      index.htm  lub  default.htm .

  �  nazwy pliku

  (+PT)

  2.7.  Co to jest CGI?

  Common Gateway Interface jest specyfikacja umozliwiajaca komunikacje

  przegladarki z programami uruchamianymi przez serwer.

  Opisana zostala na powszechnie znanym serwerze

  W3C:

  <http://www.w3.org/pub/WWW/Daemon/User/CGI/Overview.html>,

  <http://hoohoo.ncsa.uiuc.edu/cgi/>

  a takze

  <http://www.vservers.com/reference/cgi.html>

  i

  http://www.best.com/~hedlund/cgi-faq/

  <http://www.best.com/~hedlund/cgi-faq/>

  - CGI Programmer`s Reference   (FAQ).

  i grupa  <comp.infosystems.www.authoring.cgi>
  2.8.  Co to jest VRML?

  Vitual Reality Modeling Language jest to,

  wykorzystujacy niektore mechanizmy WWW

  (takie jak httpd,

  czy URL), jezyk opisu scen trojwymiarowych oparty na

  formacie Open Inventor stworzonym przez Silicon Graphics.

  <http://www.vrml.org/>

  Istnieje juz wersja 2.0 specyfikacji:

  <http://vag.vrml.org/VRML2.0/FINAL/>.

  Poza tym warto zajrzec do grupy  <news:comp.lang.vrml>.

  2.9.  Co to jest Java i JavaScript?

  JAVA ma byc w zalozeniach obiektowym jezykiem programowania
  niezaleznym

  od systemu operacyjnego i sprzetu stworzonym przez Sun Microsystems
  INC.

  JavaScript nie jest jego uproszczona wersja. Jest to stosunkowo prosty

  jezyk stworzony przez Netscape Communication Corporation o kodowej
  nazwie

   MOCHA  (ew. LiveScript) do pisania apletow w kodzie HTMLa.

  Podstawym zrodlem informacji od  JAVA`ie  jest:

  <http://java.sun.com/> oraz grupy Usenetowe

  <news:pl.comp.lang.java>

  <news:comp.lang.java>.

  2.10.  Co to jest plug-in?

   Plug-in`em nazwano programy wspomagajace przegladarki WWW,

  umozliwiajace np. czytanie niestandardowych dla pajeczyny i Internetu

  formatow plikow w przegladarce WWW.

  Zalecanie ich stosowania jest przy tworzeniu serwisu WWW wskazane
  jedynie w sytuacji gdy w zaden sposob nie

  miescimy sie w ramach wytyczonych przez standardy... (a to zwykle
  znaczy, ze

  nie bylismy zbyt pomyslowi ;-). Oczywiscie czesc ,,wtyczek'' zastepuje
  programy zewnetrzne integrujac je w jeden ,,interface uzytkownika''
  odbierajac elastycznosc dedykowanych aplikacji.

  2.11.  Co to jest ActiveX?

  ActiveX jest technologia opracowana przez NetManage, i promowana przez

  Micosoft oraz przewidziana w Broadway, umozliwiajaca

  wstawianie obiektow OLE w strony WWW. Moim zdaniem nie nalezy stosowac
  tej

  technologii, chyba, ze nie chcemy, zeby wiekszosc uzytkownikow WWW to

  zobaczyla.

  2.12.  Co to jest Broadway?

  ,,Uniwersalny dostep za posrednictwem Pajeczyny do interaktywnych

  aplikacji'' -- taki jest slogan reklamowy. Ze znaczkiem X na masce,

  rzecz jasna.

  <http://www.x.org/consortium/broadway.html> Wiecej szczegolow:

  Piotr Teczynski Premiera na Broadwayu.

   UNIXForum , 4/1996 s.13-15.

  Obecna nazwa: X11R6.3. Juz dostepny!!! Podobno (wg X Consortium) daje

  sie przekompilowac pod Linuxa 2.x. Mirror na:

  <http://sunsite.icm.edu.pl/pub/X11/R6.3/>

  2.13.  Co to jest SSI?

   Server-Side Include

  umozliwiajacy wlaczanie do dokumentow pewnych stalych elementow  i
  efektow

  pracy uruchamianych programow.

  2.14.  Co to jest SSL?

   Secure Socket Layer  mechanizm ,,bezpiecznych transakcji w sieci...''

  2.15.  Co to jest ONE?

   One Network Environment

  <http://developer.netscape.com/library/one/>

  jest to pomysl stworzenia jednolitego sieciowego srodowiska

  progamistycznego.

  2.16.  Kto uzywa WWW i Internetu?

  W swiecie powszechnie uznawany jest GVU Survey
  <http://www.cc.gatech.edu/gvu/user_surveys/User_Survey_Home.html>

  Natomiast w

  Polsce... Prowadzi sie roznego rodzaju badania ankietowe:

  �  np. PolishWorld

     <http://www.polishworld.com/polnet96/scorespol.htm>

  �  opis najrozmaitszych badan wykonany Jarka Zielinskiego

     <http://winter.it.com.pl/inetpl.htm>

  3.  Jakich narzedzi uzywac do wedrowania po pajeczynie.

  Na razie wskazuje zrodla pozyskania pajeczarek jedynie dla

  dominujacych rodzin systemow operacyjnych. Pozniej obiecuje to
  rozszerzyc o

  inne takie jak: IBM OS/2, Amige, i co tam jeszcze Boutell wymienia :-)

  I zalecam zajrzenie do iWorld

  <http://browserwatch.iworld.com/>

  do przegladu pajeczarek...

  3.1.  Jakie przegladarki sa dostepne dla DOSa?

  Nietety niewiele... Jest  Lynx  w dwoch odmianach:

  �  rozwojowa dawnego DOSLynxa

     <http://www.fdisk.com/doslynx/>

  �  adaptowany do DOSa i DJGPP/MSDOS Lynx 2.6

     <http://www.delorie.com/web/lynx/>

     (niestey wymaga stalego lacza do sieci - nie dziala jak ten
     priewszy przez PPP)

     Sa jakies przegladarki plikow tekstowych

     uwgledniajace i HTML:

     <ftp://ftp.pwr.wroc.pl/pub/pc/sac/utiltext/view114.zip>

     Jest takze kombajnik pod nazwa Minuet.

  3.2.  Jakie przegladarki sa dostepne dla MS Windows 3.x i MS Windows
  95/NT?

  Niestety multum :-). I nie sposob ich wszystkich wymienic w tym
  krotkim

  przegladzie. Na razie ogranicze sie do wskazania glownych archiwow:

  �  Netscape Communications Corporation - czesciowy mirror:

     <http://sunsite.icm.edu.pl/www/netscape/>

  �  Microsoft. - mirror wersji ,,gotowych'' w Lupusie:

     <ftp://ftp.polbox.com.pl/library/!lupus/>

  �  Tucows - The Ultimate Collection of Winsock Software

     <http://alfa2.it.pw.edu.pl/tucows/>

     <http://sunsite.icm.edu.pl/pub/tucows/>

  �  The CWSApps List - Indeks Aplikacji Sieciowych dla Windows

     <http://www.man.poznan.pl/hypertext/cwsa/cwsapps.html>

  �   Papa's Anonymous FTP

     <ftp://ftp.man.poznan.pl/pub/winsock-l/>

     i tam mozna znalezc tak Netscape Navigatora, MS IExplorera, jak i
     NSCA Mosaics i wiele, wiele innych.

  3.3.  Jakie sa dostepne przegladarki dla UNIXa?

  O ile UNIX i pochodne do tej pory dominuja na rynku serwerow, to

  systemem przegladarek stal sie MS Windows. Tym nie mniej jest kilka

  wartosciowych produktow. Takich jak:

  �  Arena

  �  Netscape Navigator

     <http://sunsite.icm.edu.pl/pub/netscape/navigator/3.0/unix/>

  �  niezastapiony Lynx

     <ftp://ftp.pwr.wroc.pl/pub/infosystems/www/lynx/>,

  �  NSCA Mosaic  <http://sunsite.icm.edu.pl/pub/www/Mosaic/>

  �  Chimera  <http://www.unlv.edu/chimera/>

  �  Amayara (W3C)

     W Polsce podstawowym archiwum jest ,,sansajt''

     <http://sunsite.icm.edu.pl/pub/www/>.

  4.  Wedrowanie po pajeczynie.

  Ponizej opisze istotne aspekty uzytkowania WWW.

  4.1.  Czy jest jakis katalog tematyczny WWW?

  Mnostwo. Np. polskie:

  �  Wirtualna Polska:

     <http://wp.cnt.pl/>

  �  WOW!:

     <http://www.waw.wow.pl/>

  �  OptimusNET:

     <http://www.optimusnet.pl/>

  �  PolishWorld:

     <http://www.polishworld.com/>

  �  NASK

     <http://www.nask.pl/>

     i swiatowe

  �  Yahoo:

     <http://www.yahoo.com/>

  �  WWW Virtual Library:

     <http://www.w3.org/hypertext/DataSources/bySubject/Overview.html>

  �  Galaxy EINET:

     <http://www.einet.net/galaxy>

  4.2.  Jak moge znalezc jakis tekst na stronie umieszczonej w
  pajeczynie?

  Nalezy zadac pytanie w ktorejs z publicznie dostepnych baz danych

  indeksujacych strony WWW.

  �  Z tego co zrozumialem to (w Polsce) dobrym rozwiazaniem jest uzycie

     ICMowego serwera archie:

     <http://archie.icm.edu.pl/>

  �  Sieciowid  <http://sieciowid.pol.pl> Polski OnLine

  �  Netoscopu  <http://www.chip.pl> istniejacego w ramach serwisu

     sieciowego CHiPa

  �  DEC Alta Vista:

     <http://www.altavista.digital.com/>

  �  Lycos:

     <http://fuzine.mt.cs.cmu.edu/mlm/lycos-home.html>

  �  WebCrawler:

     <http://webcrawler.com/>

  �  World Wide Web Worm:

     <http://www.cs.colorado.edu/home/mcbryan/WWWW.html>

  �  InfoSeek:

     <http://www2.infoseek.com/>

  �  OpenText:

     <http://www.opentext.com>

  �  HotBot:

     <http://www.HotBot.com/search.html>

  �  i inne ... :-) wiekszosc dostawcow uslug Iternetowych dostarcza
     odp.

     formularzy do wyszukiwania na najpopularniejszych przeszukiwarkach.

  4.3.  Dlaczego czesto widze ,,krzaczki'' zamiast polskich liter?

  Jest kilka mozliwosci rozwiazania tego problemu:

  �  Masz niewlasciwa przegladarke, tj. nie obslugujaca polskich liter w

     standardzie ISO-8859-2. W miare mozliwosci wymien ja na cos innego

     (lub sprawdz czy nie mozna tego jakos poprawic:

     <http://www.agh.edu.pl/ogonki/>)

  �  Twoja przegladarka obsluguje polskie literki, ale ty nic o tym nie

     wiesz. np. nie ustawiles w Netscape Navigatorze 3.0 opcji:

     Options|Document Ecoding|Central European (ISO-8859-2) i
     odpowiedniej

     czcionki w  Options|General_Preferences|Fonts|Latin-2

  �  Wina lezy po stronie autora strony: Ani w naglowku http,

     (  "text/html

     charset=8859-2"   html htm  w pliku mime.types) ani w naglowku

     strony (przy pomocy komendy

      <meta http-equiv="content-type"

     content="text/html;

     charset=iso-8859-2"> ) nie zadeklarowal polskosci dokumentu, ani
     nawet

     uzywanej strony kodowej

  �  Wina lezy po stronie autora strony: uzywa CP 1250 :-(

  4.4.  Czy uzywajac WWW mozna zlapac wirusa?

  Oczywiscie :-) Zwlaszcza wirusa glupoty. A powaznie: o ile masz

  wylaczona JAVA, JavaScript, ActiveX,

  i nie ladujesz plikow z danymi zawierajacymi makroinstrukcje,

  PostScript oraz wykonywalnych - nie mozesz. W pozostalych wypadkach:

  �  Pliki Worda i wykonywalne - wiadomo - moga byc zakazone i to nie

     zalezy od medium.

  �  w Javie, i JavaScript znaleziono

     (np. w niektorych wersjach

     Netscape Navigatora 2.0.0.)

     jakies usterki na tyle powazne, ze ponoc zagrazajace bezpieczenstwu

     systemow.

  �  PostScript - moze zawierac niebezpieczne operacje, ktore pewne

     przegladarki moga probowac wykonac: kasowanie plikow albo

     ustawienie/zmiana hasla drukarki.

  �  W wypadku Lynxa istnieje cos takiego (tzw. trusted hosts) co
     pozwala

     wykonywac polecenia wydawane ze zdalnego komputera na lokalnym.

  (ZMB+WM)

  4.5.  W jaki sposob nawigowac po Pajeczynie ?

  Jak najmniej chaotycznie :-0. Najlepiej uzywajac do poszukiwan

  katalogow zasobow i przeszukiwarek, i odznaczajac ciekawe miejsca w

  ,,zakladkach'', ,,bookmark`ach''. (przy czym jesli juz cos ciekawego
  znalazles

  nie musisz tego obwieszczac calemu swiatu.

  4.6.  Jak jest z prawami autorskimi w Internecie?

  Nalezy przyjac, ze (przynajmniej w wypadku polskich stron) obowiazuja

  przepisy Ustawy o prawie autorskim i prawach pokrewnych z 04.02.1995
  <http://www.pocketpres.com/>.

  Przy czym (na podstawie art. 1 punkt 1 i punkt 2 ustawy), o ile autor
  nie

  zaznaczyl inaczej wszystkie strony sa domyslnie oznaczone jako � badz
  (C) i

  mozna podawac do nich odniesienie, nie mozna natomiast ich
  wykorzystywac we

  wlasnej pracy (tj. tresci powiazanej z forma, poniewaz czystej
  informacji

  to juz nie dotyczy) bez zgody (najlepiej pisemnej) autora (wlasciciela

  (C)). Ochronie podlegaja rowniez znaki firmowe (lecz mozna ich uzyc w

  celach informacyjnych).

  4.7.  W jaki sposob pracowac z WWW bez bezposredniego polaczenia?

  Tak zupelnie bez polaczenia sie nie da...

  Ale mozna sciagnac potrzebne strony (uzywajac tzw. robota, albo

  normalnej przegladarki z wlaczonym cache dyskowym, lub zainstalowanym

  serwerem proxy cache) a nastepnie je lokalnie przegladac.

  Wiekszosc dostepnych w tej chwili przegladarek dziala bez polaczenia z

  siecia. Poza tym istnieje bardzo ladnie dzialajacy viewer: view114.zip

  pozwalajacy m.in. ogladac pliki MS Word, HTML, i innych...

  <ftp://ftp.pwr.wroc.pl/pub/pc/sac/utiltext/view114.zip>

  Mozna tez uzyc uslugi nazywanej www2mail. W Polsce taki serwer

  uruchomil Jaroslaw Strzalkowski. Wystarczy wyslac pod adresem:

  www2...@arrow.uci.agh.edu.pl list zawierajacy ,,w ciele''

  URLe zadanych

  dokumentow.

  (ZMB+WM)

  4.8.  Co to jest i dlaczego nalezy uzywac W3cache-proxy?

  Dlaczego? Przeciez to oczywiste... ;-)

  Jednym ze skutkow coraz gwaltowniejszego rozwoju uslug WWW jest

  saturacja lacz sieci rozleglych. O ile przepustowosci lacz sieci
  lokalnych

  i miejskich sa zwykle nadmiarowe, to lacza miedzynarodowe (znacznie

  bardziej kosztowne) stanowia zazwyczaj waskie gardla Internetu.
  Szybkosc wzrostu zapotrzebowania na pasmo znacznie przekracza wszelkie

  mozliwosci inwestycyjne. Analiza ruchu wskazuje przy tym, ze
  procentowo

  coraz wiekszy udzial stanowia w nim transmisje WWW.

  Polska, jako jeden z pierwszych krajow zbudowala strukture tzw. cache

  WWW, ktora pozwala na lokalne buforowanie najczesciej zadanych
  dokumentow

  WWW, a tym samym:

  �  zmniejszenie obciazenia lacz miedzynarodowych,

  �  skrocenie sredniego czasu dostepu do informacji,

  �  zoptymalizowanie wykorzystania lacz krajowych.

     Hierarchia W3cache

     <http://w3cache.icm.edu.pl/sites_pl.html/>

     obejmuje

     wszystkie wazniejsze sieci miejskie oraz dziala w bezposredniej
     wspolpracy

     z podobnymi projektami poza Polska. W3cache wymienia takze
     informacje z

     pojedynczymi serwerami cache tam, gdzie nie istnieja jeszcze
     struktury

     ogolnokrajowe.

     Przy czym uzytkownicy takich ogolnopolskich sieci jak TPnet, lub

     Telebank powinni ustawic parametry swojego proxy cache na lokalny
     cache, a

     jesli nie ma (a nie ma) to na w3cache.icm.edu.pl:8080 jako
     najblizszy

     sieciowo ich sieciom, nie zas na cache np. krakowskie. (choc
     ostatnio w

     zwiazku z zaistnieniem w3cache.icm.edu.pl w TPnecie, powstawaniem
     ,,lokalnych''

     polaczen TPnetu z NASKnetem (np. w Krakowie) sytuacja sie zmienia).

  (WojSyl+ZMB)

  5.  Tworzenie - ogolne.

  Tworzenie stron i prezentacji WWW to nie tylko kodowanie w HTML, ale

  takze przygotowywanie grafik, dbalosc o poprawnosc skladniowa kodu
  HTML i
  mnostwo innych zagadnien.

  5.1.  Jak moge publikowac w WWW?

  Aby moc publikowac potrzeba odpowiedniego typu konta: najlepiej na

  komputerze gdzie jest zainstalowany serwer httpd.

  W wypadku dostawcow

  komercyjnych nalezy wykupic odpowiedni rodzaj konta. Na wiekszosci
  uczelni

  istnieje mozliwosc zalozenia wlasnej strony w ramach normalnego konta,
  i to

  czesto nawet bez ingerencji administratora (zazwyczaj nalezy zalozyc w

  swoim katalogu domowym katalogu public_html lub .home . Istnieje takze

  kilka serwerow komercyjnych umozliwiajacych publikowanie materialow

  niekomercyjnych bez wnoszenia oplat. Np. Marek Baczek zlozyl
  deklaracje, ze

  jest gotow przyjac strony na nastepujacych warunkach:

  �  strona musi byc niekomercyjna.

  �  strona musi byc co najmniej ciekawa.

  �  strona musi byc robiona w ISO-8859-2 lub CP1250; (w zadnym wypadku
     bez

     ogonkow, moze byc po angielsku).

  �  strony nie powinny przekroczyc 10 MB i nie powinny zawierac zbyt
     duzo

     plikow do zaladowania.

  �  URL do tej strony bylby taki:

     <http://www.QDnet.pl/~jakasnazwa/>

  �  Prosze przyslac kilka stron dla przykladu e-mail na adres (Marek

     Baczek

     <mailto:m...@QDnet.pl>

     (do 500kB)).

     W poza tym w swiecie istnieje kilka serwerow oferujacych podbne
     uslugi: np.

     Geocites  <http://www.geocites.com>, ponoc i

     PocketPress  <http://www.pocketpres.com> i

     Polbox  <http://www.free.polbox.pl>  (ew. patrz:

     <http://la.ists.pwr.wroc.pl/~coven/tech/freenet.html>)
  5.2.  Czy moge w Pajeczynie umieszczac dokumenty w innym formacie niz
  HTML?

  Tak. Ale trzeba pamietac o tym, aby nie byly ograniczone tylko do

  jednej platformy sprzetowej/systemowej. I dlatego nie nalezy uzywac

  surowych plikow MS Word`a czy QuattroPro.

  Warto je przelozyc na jakis

  powszechnie uznany standard taki jak PostScript,

  RichTextFormat, CVS, TeX, lub HTML.

  Jesli nie jest to mozliwe?

  W takim razie nalezy dodac odpowiednie deklaracje MIME types serwera.

  Oznaczenia typow plikow znajduja sie w comp.mail.mime FAQ

  <http://sunsite.icm.edu.pl/pub/usenet/comp.mail.mime/>

  5.3.  Jakich polskich terminow uzywac przy tworzeniu stron?

  Temat jest problematyczny... **** Mysle, ze zamiast

  link

  powinien pojawic

  sie

  odnosnik,

  odwolanie, zas zamiast Microsoftowego

  miejsca w Internecie

  lub

  site`a:

  serwer swiatowej Pajeczyny

  - choc i ten, serwer brzmi

  nie-po-polsku .

  Zamiast:

  service usluga.

  6.  HTML

  6.1.  Jak wyglada dokument WWW?

  Wiekszosc polecen jest dwuczesciowa: czesc otwierajaca <XXX> i

  zamykajaca </XXX> . Czesc polecen nie wymaga zamkniecia. Oto jest kod

  najprostszego dokumentu w HTML

  <HTML> <HEAD> <TITLE> Tytul dokumentu </TITLE>

  </HEAD> <BODY> Zawartosc

  dokumentu </BODY> </HTML>

  A teraz opis:

  <HTML> deklaracja, ze jest to poczatek dokumentu  w HTML

  <HEAD> naglowek (zawierajacy definicje dla calego dokumentu)

  <TITLE> tytul dokumentu

  <BODY> wlasciwa tresc dokumentu.

  Znaki specjalne pozwalaja wstawic graficzny obraz znakow bedacych
  czescia

  polecen: wiekszosci ( <- &lt; ) i mniejszosc (> - &gt; ),

  cudzyslowu (" - &quot; )

  oraz spacji (&160;; - &nbsp; ), i stanowiacy skladnik tych poprzednich

  ampersand ( & - &amp; ). Przy czym wobec pominiecia deklaracji typu

  dokumentu nie powinnismy stosowac niczego poza najprostszym
  ,,poziomem''

  HTML. W przeciwnym wypadku na poczatku dokumentu powinno sie

  zalezc na przyklad cos

  takiego:

  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">

  Wiecej informacji mozna znalezc w dostepnych w sieci i realnym swiecie

  kursach i podrecznikach HTML.

  6.2.  Co jest standardem w HTMLu?

   (uwaga: ostatnio okazala sie W3C Recommendation (14.01.1997)

  rekomendacja - jeszcze nie RFC i nie standard dla HTML 3.2

  <http://www.w3.org/pub/WWW/TR/REC-html32.html>)

  Aktualnie obowiazujacy standard HTML zostal zdefiniowany w dokumencie

  IETF: RFC 1866 autorstwa T. Berners-Lee i D. Connolly

  Hypertext Markup Language - 2.0

  z listopada 1995 r. oraz RFC 1867 E. Nebela i L. Masinter

  Form-based File Upload in HTML . Poza tym w dyskusji znajduje sie

  propozycja standardu HTML 3.2. Jedna z propozycji nosi nazwe Wilbur a

  druga, powracajaca w czesci do rzeczy porzuconych w Wilburze

  <http://www.w3.org/hypertext/WWW/MarkUp/Wilbur/>

  nazywa sie

   Cougar

  <http://www.w3.org/hypertext/WWW/MarkUp/Cougar/HTML.dtd>.

  Poza istnieja rozmaite ,,rozszerzenia'' roznych firm.

  Pawel Wiecek zaproponowal (w tekscie umieszczonym pod adresem

  <http://la.ists.pwr.wroc.pl/~coven/tech/mbc.html>

  ) program  MuliBrowser Compatibility :

  (ZMB, cov, PT)

  6.3.  Jakie narzedzia wspomagajace tworzenie dokumentow WWW sa
  dostepne dla DOSa/Win i MS Windows 95/NT?

  Z powodu ogromnej dynamiki powstawania nowych programow moge jedynie

  wskazac dostepne archiwa oprogramowania:

  �  Tucows - The Ultimate Collection of Winsock Software

     <http://alfa2.it.pw.edu.pl/tucows/>

     coraz lepsze: zawiera wiekszosc oprogramowania dla Intenetowego

     stosowania MS Windows, zwiezle recenzje i archiwa bezposrednio na

     Politechnice Warszawskiej

  �   The CWSApps List  - Indeks Aplikacji Sieciowych dla Windows

     <http://www.man.poznan.pl/hypertext/cwsa/cwsapps.>>

     zawiera wiekszosc oprogramowania dla Intenetowego stosowania MS

     Windows, recenzje. Archiwa prowadza niestety w swiat, choc mozna po

     wynotowaniu nazw programow, sciagnac je z Papa AFTP.

  �  Papa's Anonymous FTP

     <ftp://ftp.man.poznan.pl/pub/winsock-l/>

     jedno z lepiej wyposazonych archiwow na FTP.

  6.4.  Jakie narzedzia wspomagajace tworzenie dokumentow WWW sa
  dostepne dla UNIXa?

  Jest to dla mnie niewygodne pytanie: dopiero zaczynam uzywac Linuxa.

  Ale jest cos takiego jak asWedit

  <ftp://sunsite.icm.edu.pl/pub/www/asWedit/>, sa tryby HTML dla ViMa

  <http://www.math.fu-berlin.de/~guckes/vim/>,

  i Emacsa

  <http://www.santafe.edu/~nelson/tools/>. Sa tez

  (skryptowe) narzedzia do weryfikacji odniesien, sprawdzania
  poprawnosci

  kodu itp. Sa wreszcie narzedzia pozwalajace na konwersje popularnych w

  Unixie (uogolnionych) formatow: LaTeX, SGMLtools (QWERTZ)

  <ftp://ftp.cc.gatech.edu/pub/people/gregh/sgml-tools/sgml-
  tools-0.99.0.tar.gz>

  (przy pomocy ktorego jest robione to FAQ).

  na HTML. Wiekszosc ze wspomnianych

  narzedzi mozna znalezc na ,,sansjacie''

  <http://sunsite.icm.edu.pl/pub/www/>

  6.5.  Co to sa netscapizmy oraz inne rozszerzenia? I dlaczego nie
  nalezy ich stosowac?

   Netscapizmami  zwie sie popularnie te rozszerzenia akceptowane tylko
  i

  wylacznie przez przegladarki firmy Netscape Communications Corporation
  , i

  ostatnio przez MS Internet Explorer, nie zarejestrowane w oficjalnej

  specyfikacji (badz jej propozycji) jezyka HTML.

  Nie nalezy ich uzywac poniewaz:

  �  nie ma mozliwosci sensownego sprawdzenia parserem/validatorem

     SGML takiego

     dokumentu (zazwyczaj brak jest oficjalnych DTD (i nawet

     nieoficjalnych, np. dla IE 3.0, lub NN 3.0) dla takich rozszerzen)

  �  dokumenty te nie zawsze moga byc poprawnie

     wyswietlane w przegladarkach innych

     producentow. A HTML bedacy (zwlaszcza w wersjach 2.0 i Wilbur)
     bardzo

     ubogim znaczeniowo zastosowaniem SGML-a, zostal stworzony po to, by

     istniala wspolna, niezalezna od sprzetu i systemu platforma

     informacyjna.

  �  niektore rozszerzenia nie mieszcza sie w zaden sposob w skladni

     istniejacych DTD HTMLowych

     ;-) np. te zwiazane z ramkami... (FRAMES)

  6.6.  W jaki sposob moge tworzyc poprawne strony z polskimi znakami
  diakrytycznymi?

  Przede wszystkim nalezy uzywac kodowania w ISO-8859-2. Poza tym jesli

  nie jestes administratorem i nie mozesz spowodowac, zeby serwer
  dodawal do

  naglowka stron z polskimi literami deklaracji typu dokumentu:

   text/html; charset=iso-8859-2

  nalezy dodac w naglowku strony (pomiedzy <HEAD> i

  </HEAD> , a i raczej przed <TITLE> ) nastepujaca instrukcje:

  <META

  HTTP-EQUIV="content-type"

  CONTENT="text/html; charset=iso-8859-2">

  nie jest

  to rozwiazanie najbardziej eleganckie: powoduje (na niektorych serwer
  ach)

  dwukrotne interpretowanie zawartosci dokumentu, nie jest w pelni

  uwzglednione w specyfikacji HTML. Tym nie mniej dopoki nie doczekamy
  sie

  (badz, sami nie przyczynimy sie ;-) do uznania przez grona normaliza
  cyjne i

  producentow oprogramowania faktu, ze w WWW stosuje sie i inne, poza

  anglosaskim zestawy znakow, pozostaje nam stosowanie polsrodkow.

  6.7.  Dlaczego i w jaki sposob sprawdzac poprawnosc skladniowa doku
  mentow?

  Dlaczego: to chyba oczywiste kazdy chyba chce zeby rzeczywisty efekt

  pokrywal sie z planowanym, tak treraz jak i w przyszlosci, gdy
  przegladarki

  beda np. scislej trzymac sie standardu.

  Powszechnie stosowana metoda jest ,,reczne'' sprawdzanie za pomoca

  wybranej dowolnie ,,przegladarki testowej'' takiej jak np. Lynx,
  Netscape,

  lub MS IE. Jest to dzialanie co najmniej watpliwe: przegladarka
  powinna

  wyswietlac wszystkie (nawet z bledami skladniowymi) strony poprawnie,
  choc

  niekoniecznie zgodnie z intencjami jej autorow. Poprawna forma
  sprawdzania

  strony jest raczej uzycie parsera/validatora SGML takiego jak na

  przyklad

  SP Jamesa Clarka (dostepny tak dla DOS (32-ext.) Win32,

  jak i UNIXa)

  <http://www.jclark.com/sp/>

  wraz z odpowiednim DTD dla stosowanego dialektu HTMLa.

  <http://www.w3.org/pub/WWW/MarkUp/html-pubtext/>

  W wyniku kontroli powstaje lista bledow (przez skierowanie potoku
  bledow do

  pliku) na podstawie, ktorej nalezy ,,recznie'' poprawic dokument.
  Dopiero

  potem mozna sprawdzic w przegladace, czy przypadkiem czegos istotnego
  nie

  przeoczylismy...

  6.8.  Czy moge ukryc kod zrodlowy dokumentu?

  Nie. I bardzo dobrze. Po prostu kod zrodlowy dokumentu w HTML musi

  byc zakodowany bez zadnych ograniczen, aby mozna bylo czytac dokumenty
  nie do

  konca sprowadzone na lokalny komputer.

  7.  Grafika na stronach WWW.

  Dopuszczalnymi formatami grafik dla WWW sa: GIF, JPEG, i PNG, oraz
  XBM, XPM.

  Nie nalezy, bez ostrzezenia kierowac do stron zawierajacych duze (tj.

  powyzej 20 kb) grafiki.

  Aby przygotowac przezroczyste grafiki, tj. w kolorze dowolnie

  definiowanego tla lub podkladu, nalezy zapamietac je w formacie GIF
  89a

  przy pomocy np.

  LView Pro 1.0 dla Windows,

  <http://world.std.com/~mmedia/lviewp.html>

  lub z

  mirrora:

  <http://alfa2.ia.pw.edu.pl/tucows/>

  albo

  giftrans dla DOSa

  <http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.exe>

  i/lub UNIX.

  <http://sunsite.icm.edu.pl/pub/www/tools/giftrans/giftrans.1.gz>

  Do tworzenia animowanych rysunkow moze sluzyc program

  Gif Construction Set dla

  Windows

  <ftp://ftp.dtp.std.com/ftp/vendors/mmedia/gifcon.exe>

  WebPaint - shareware dla W95

  <http://www.barentsnett.no/webpaint/>

  GifMerge dla UNIXa

  <http://www.iis.ee.ethz.ch/~kiwi/GIFMerge/>

  Wiecej informacji zawieraja nastepujace strony:

  <http://www.best.com/~adamb/GIFpage.html>

  <http://dragon.jpl.nasa.gov/~adam/transparent.html>

  <http://www.boutell.com/faq/tinter.htm>

  Standard formatu graficznego GIF 89a jest opisany pod adresem

  <http://members.aol.com/royalef/gifanim.htm>

  8.  CGI i programowanie w WWW.

  8.1.  W jaki sposob moge zainstalowac licznik na stronie?

  Nie nalezy tego robic poniewaz, zazwyczaj, liczniki klamia, nie

  uwzgledniajac odwolan do strony przez Proxy-Cache, powoduje
  niepotrzebne

  obciazenie serwera (graficzne), i jest przejawem niepotrzebnego

  efekciarstwa. Jesli jednak te argumenty sa nieprzekonujace polecam

  <http://www.webtools.org/counter/>
  <http://www.w4.nl/software/counter/>

  lub

  Yahoo  <http://www.yahoo.com/>,

  czy wreszcie

  <ftp://ftp.ibspan.waw.pl/pub/unix/html-counter/>

  albo skorzystaj z opisu Tomasza Pilata (sprawdzony jedynie z

  NSCA HTTPd

  1.4. i dzialajacy na bazie  Server Side Include ):

  nalezy zalozyc w katalogu

  gdzie mamy strone, do ktorej chcemy liczyc dostepy

  plik .htaccess

  AddType text/x-server-parsed-html index.html

  AddType application/x-httpd-cgi count.cgi

  - gdzie index.html to nazwa tej strony, a count.cgi nazwa pliku pro
  gramu

  licznika (obie liniki powinny byc zakonczone Enterem). Oto zawartosc
  tego

  drugiego:

  #!/usr/bin/perl

  open (COUNT,"count") ;

  $counter =<COUNT>;

  close (COUNT) ;

  open (COUNT, ">count") ;

  print COUNT +($counter+1) ;

  close (COUNT) ;

  print $counter;

  exit(0) ;

  moze zaistniec potrzeba zmiany sciezki do PERLa (to jest
  #!/usr/bin/perl).

  Najlatwiej sprawdzic, gdzie jest PERL piszac: whereis perl lub which
  perl
  Wykonujemy co nastepuje:

  touch count

  chmod 777 count

  chmod 505 <tt/.htaccess/

  chmod 505 count.cgi

  W pliku count znajdowac sie bedzie liczba odwiedzin.

  Umieszczamy na stronie cos takiego: Ta strone odwiedzilo juz

  <!-#exec cmd="/usr/bin/perl count.cgi"->

  Uwaga cenzora: powinno byc:

  Te strone pobrano juz <!-#exec cmd="/usr/bin/perl count.cgi"-> razy od
  dnia

  zainstalowania licznika lub jego resetowania.

  (TP)

  9.  Serwery WWW

  9.1.

  systemem powinien pracowac)?  Jakie serwery WWW (HTTP) sa dostepne i
  ktory wybrac (i pod jakim

  Pytanie rzeka... najlepiej spojrzec na strone Web Compare

  <http://webcompare.iworld.com/>

  gdzie szczegolowo opisano (i porownano)

  wiekszosc dostepnych serwerow WWW.

  9.2.  Gdzie moge znalezc opis protokolu serwera WWW (HTTP)?

  Aktualnie obowiazujacy standard (realizowany w calosci przez wiekszosc

  dostepnych serwerow) zostal opisany w RFC 1945

  9.3.  W jaki sposob moge na moim serwerze obslugiwac jego bledy?

  Przede wszystkim zajrzyj do dokumentacji swojego serwera. Zazwyczaj w

  dostarczanych zbiorach konfiguracyjnych serwerow dostepne sa
  odpowiednie
  opcje (choc zwykle skomentowane , aby je uaktywnic wystarczy skasowac
  znak

  komentarza). Opis bledow znajduje sie w specyfikacji http.

  9.4.  W jaki sposob poprawnie serwowac polskie dokumenty?

  na podstawie:

  <http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html>

  Nalezy wykorzystac mozliwosci serwera Apache-Httpd,

  a mianowicie

  technologie MultiViews. Dzieki temu wykorzystywane sa preferencje

  jezykowe

  uzytkownika.

  Generuje to nastepujace rozszerzenia dla wersji jezykowych dokumentow:

  Charset                  HTML      HTML z SSI     CGI uzytkownika

  Jedyna:                 .html      .shtml          .cgi

  Polska bez diakrytyki:  .html.pn   .shtml.pn;      .cgi.pn

  Polska  ISO 8859-2:     .html.po   .shtml.po;      .cgi.po

  Angielska:              .html.en   .shtml.en;      .cgi.en

  Dla skryptow CGI umieszczonych w katalogu /cgi-bin/ warto stosowac

  nazwy takie jak dla CGI uzytkownika (rozpoznawanych po rozszerzeniu).

  Aby moc skorzystac z tej technologii nalezy w kazdym katalogu umiescic

  plik .htaccess o np. nastepujacej zawartosci (dyrektywy te moga sie
  tez

  znalezc w plikach konfiguracyjnych serwera - access.conf i srm.conf):

  Options All MultiViews

  AddLanguage   pl .po

  AddLanguage   pn .pn

  AddLanguage   pw .pw

  LanguagePriority   pl pn pw en

  DirectoryIndex   index.shtml index.html

  Dyrektywa deklarujaca rozszerzenie .en znajduje sie domyslnie w pliku

  srm.conf.

  Powyzszy plik .htaccess wlacza MultiViews, aby mozna bylo korzystac z

  tej technologii, definiuje rozszerzenia jezykowe uzywane przez nia,
  ustala

  domyslne preferencje jezykowe i pozwala uzywac plikow index z

  Server-Side Includes.

  Do automatycznego tworzenia na podstawie dokumentow z polskimi lit
  erami

  w standardzie ISO 8859-2 wersji bez polskich znakow i ewentualnie CP
  1250 z

  zachowaniem wymogow tej technologii mozna uzyc programu HtmlConv
  (patrz

  nizej).

  Przygotowywanie dokumentow pod DOS-em Z wlasnego doswiadczenia wiem,
  ze

  przygotowywanie dokumentow HTML-owych pod DOS-em jest dosc popularne.

  Jednakze napotykamy tam na drobny problem - DOS-owy limit dlugosci
  nazw

  plikow, a dokladniej limit dlugosci rozszerzenia do trzech znakow.

  Sugeruje uzywanie nastepujacych rozszerzen zastepczych:

     UNIX       DOS

   *.html      *.htm

   *.ihtml     *.iht

   *.whtml     *.wht

   *.ehtml     *.eht

   *.shtml     *.sht

   *.html.po   *.htp

   *.html.pn   *.htn

   *.html.en   *.hte

   *.shtml.po  *.shp

   *.shtml.pn  *.shn

   *.shtml.en  *.she

  Dodatkowo plik .htaccess powinien pod DOS-em nosic nazwe _htacces.

  Tlumaczenia nazw plikow z wersji DOS-owych na wersje UNIX-owe (obie

  technologie) wykonuje program Reh (ten i inne opisane

  w tej odpowiedzi programy opisane sa na stronie:

  <http://la.ists.pwr.wroc.pl/~coven/tech/langtech.html>).

  (cov)

  9.5.  Jak stworzyc strone na haslo?

  W UNIXie, na Apache,

  badz NSCA nalezy zalozyc w katalogu w ktorym ma

  sie znajdowac chroniony zasob plik .htaccess w ktorym nalezy wpisac

  klauzule (podobna do wystepujacej w zbiorze  access.conf )

  AuthUserFile /home/dir/foo/public_html/.htpasswd

  AuthGoupFile /home/dir/foo/public_html/.htgroup

  i wymienionych zbiorach nazwy uzytkownikow i hasla.

  Pod NT tez jest to mozliwe pod warunkiem, ze korzysta sie z NTFS.

  Nadaje sie na katalog lub konkretny plik odpowiednie uprawnienia do

  czytania (jednemu lub grupie uzytkownikow), po czym odbiera sie

  uprawnienia pozostalym.

  9.6.  W jaki sposob moge udostepnic przeszukiwanie mojego serwera?

  Unix - tutaj spraw jest prosta: istnieje kilka systemow

  umozliwiajacych przeszukiwanie np.

   SWISH

  <http://www.eit.com/software/swish/> albo

   GlimpseHTTPd

  <http://glimpse.cs.arizona.edu/ghttp/>

   MS Windows NT  Nie wiem, przypuszczam, ze:

  �  mozna, za ciezkie pieniadze, kupic

  �  mozna na biezaco wczytywac wszystkie strony z wlasnego serwera

     do bazy danych i udostepniac ja jako forme pzeszukiwania.

  9.7.  Jak mozna udostepniac baze danych przez WWW?

   Unix  -

  Jest cos takiego, do WWW nadaje sie doskonale, daje tylko podzbior SQL

  - i to wszystko za darmo (choc jedynie dla uniwersytetow i organizacji

  non-profit). Nazywa sie miniSQL (ostatnia wersja - 1.0.13).
  Dokumentacje do

  niego znajduje sie pod adresem

  <http://www.sgh.waw.pl/guides/db/mSQL/>

  Tam

  tez jest link do sciagniecia ktorejs z wersji przez FTP.

  Innym rozwiazaniem jest Apache z CGI / modulem PHP/FI i mSQL.

  (CS+Saper+PT)

  Inna ewentualnoscia jest uzycie (dostepnego w postaci zrodlowej)

   Postgess95   <http://www.postgress.org>

  <http://sunsite.icm.edu.pl/pub/Linux/sunsite/apps/Database/progress/>

  realizujacego obszerny podzbior SQL, zawieajacy moduly konwersji do
  HTML.

  (na dniach ma sie ukazac Postgress 6.0

  MS Windows NT

  Tutaj (o ile uzywa sie MS Internet information Serwer) czesc

  narzedzi dostarczana jest z serwerem (potrzebne jest jeszcze MS SQL),

  lub mozna uzyc innych

  (zazwyczaj drogich) narzedzi oferowanych np. przez Netscape
  Communication

  (LiveWare), Microsoft (dbWeb),

  Oracle (WebSerwer 2.0 + Designer2000)

  10.  Standardy - dostepne w roznych miejscach

  �  <ftp://ftp.nask.pl/pub/rfc/>

  �  <ftp://ftp.icm.edu.pl/pub/rfc/>

  �  <ftp://ftp.cyf-kr.edu.pl/pub/mirror/rfc/>

  �  <ftp://ftp.man.lodz.pl/pub/doc/>

  �  <ftp://ftp.pwr.wroc.pl/pub/doc/rfc/>

  �  <ftp://ds.internic.net/rfc/>

  �  <ftp://nic.nordu.net/>

  �  <ftp://ftp.nis.garr.it/>

     HTML

  �  RFC 1590 - The text/html Internet Media type

  �  RFC 1866 - Official Specification of HTML 2.0

  �  RFC 1867 - FORM-based file uploads (Experimental)

  �  RFC 1942 - dotyczacy tabel w HTML

     HTTP

  �  RFC 1945 - Official Specification of HTTP

     1.0

     E-Mail and MIME

  �  RFC 822 - Standard for Internet E-mail

  �  RFC 1123 - Update to RFC 822

  �  RFC 1521 - MIME Mail standard (1/1) - message format

  �  RFC 1522 - MIME Mail standard (2/2) - extended header field data

  �  RFC 1590 - The text/html Internet Media type

     USEnet News

  �  RFC 1036 - USENET news messages protocol

     Uniform Resource Locators

  �  RFC 1738 - Uniform Resource Locators

  �  RFC 1808 - Relative Uniform Resource Locators

  �  RFC 1630 - Overview of Resource Naming Schemes for the Internet

  �  RFC 1700 - Assigned Numbers - numery portow w sieciach opartych
     TCP/IP

     Language and Country Specifications

  �  RFC 1766 - Language Tags for use on the Internet

  �  ISO 639 - Language Codes

     <http://www.ics.uci.edu/pub/ietf/http/related/iso639.txt>

  �  ISO 3166 - Country Codes

     <http://www.ics.uci.edu/pub/ietf/http/related/iso3166.txt>

  11.  Ogolne wprowadzenia do sieci.

  Jakoze WWW jest dla wielu podstawowa usluga Internetu, a na pewno
  wielu

  ludzi zaczyna swoj kontakt z siecia od niego, pozwalam sobie zamiescic

  odniesienia do podstawowych przewodnikow po Sieci.

  �  Elementarz Internetu Macieja Uhliga

     <http://www.cto.us.edu.pl/eleminte/ei.html>

  �  Podstawowe uslugi Internetu Tomasza Surmacza

     <http://www.ict.pwr.wroc.pl/doc/iwpl/>

  �  Rozne pozyteczne dokumenty w/g AGH

     <http://www.agh.edu.pl/opisy.html>

  �  Wirtualna Akademia - Katedra Teleinformatyki

     <http://www.gumbeers.elka.pg.gda.pl/WA/KTI/>

  �   Narzedzia sieciowe

     Wojciecha Myszki (jeden z lepszych TECHNICZNYCH

     przewodnikow po sieci.

     <http://www.immt.pwr.wroc.pl/export_hp/tool/tool.html>

  �   EFFu Przewodnik po Internecie  , wersja 3.1

     <ftp://www.peryt.waw.pl/pub/doc/netguide-ascii-polish.eff>

     Jest tez

     wersja skompresowana

     <ftp://www.peryt.waw.pl/pub/doc/netguipl.zip>

  12.  Zrodla dotyczace HTML.

  O HTML mozna dlugo pisac (i o zrodlach jego tyczacych tez ;-).

  Postaram sie jednak przedstawic przede wszystkim

  polskie (tj. tak polsko-jezyczne, jak i tylko sie w Polsce znajdujace)

  zasoby.

  12.1.  Zrodla HTML po polsku w sieci.

  Mam nadzieje, ze ponizsza lista jest w miare pelna...

  Prosze o sprostowania :-)

  �  Kurs HTML Pawla Wimmera

     <http://www.polbox.com.pl/html/glowny.htm>

     Jest

     tez wersja offline

     <ftp://polbox.com.pl/library/!lupus/html.zip>

  �  Kurs HTML Jaroslawa Zielinskiego

     <http://winter.it.com.pl/html/>

  �  WWWhowto - Jak zrobic swoja strone WWW? Tomasza Pilata

     <http:://ajax.umcs.lublin.pl/~poncjusz/WWWhowto/>

     (jest tam tez dzialajacy on-line validating parser SGML/HTML Wilbur

     SWAT:

     <http:://ajax.umcs.lublin.pl/~poncjusz/SWAT/>

  �  Jak stworzyc wlasna strone WWW (Grzegorza Wojcika)

     <http://www.ia.pw.edu.pl/pl-iso/homepage-info.html>

  �  Jak zrobic wlasna strone WWW (wskazowki dla uzytkownikow z PK)

     (Szymona Sokola i Grzegorza Muchy)

     <http://www.pk.edu.pl/sysdocs/howto.html>

     )

  �  Opis polecen jezyka  HTML  z przykladami Roberta Pajaka

     <http://www.wibro.agh.edu.pl/info/www/html/reference/>

  �  KROTKI KURS  HTML

     <http://panda.bg.univ.gda.pl:80/~krabek/kurs.html>

  �  Jak zrobic swoja wlasna HomePage ?

     <http://zeus.polsl.gliwice.pl/~bort/local/how-to.html>

  �  Opis HTML autostwa ,,Statoma'' czyli ***

     <http://www.polsl.gliwice.pl/~statom/HTML/HTML.html>

  12.2.  Drukowane zrodla dotyczace HTMLa, VRML i Javy po polsku

  �  Wlodzimierz Macewicz

     HTML. Jezyk opisu dokumentu hipertekstowego HTML

     Warszawa 1996; Zaklad Nauczania Informatyki MIKOM (kiedys w I

     wyd.(1995) nazywalo sie to Jezyk skladu dokumentu hipertekstowego
     HTML

     i HTML + ) Sciaga; dosc porzadnie opisuje HTML.

     Pisze o polskich literach.

     Dobre zestawienie znakow (lacznie z nie obslugiwanymi jeszcze

     sekwencjami matematycznymi) i notacja co do, jakiej przegladarki (a

     zwlaszcza specyfikacji jezyka) nalezy. Jedyne czego brakuje (jako

     sciadze, nie tylko podrecznikowi) to odeslan do standardow (RFC) i

     stwierdzenia dlaczego nalezy uzywac HTML 2.0 aby byc powszechnie

     zrozumianym. Stosunkowo tania: 182 strony za 10 zl.

  �  Elisabeth Castro  Po prostu HTML

     Gliwice 1996; Helion, Peachpit Press

     Ksiazka kucharska. Wyglada na warta swej ceny :-) Bardzo

     rozbudowany spis tresci + przyklady graficzne obok konkretnych

     konstrukcji jezyka. (choc ja i tak wole ksiazke Macewicza :-) cena
     cos

     kolo 19 zl.

  �   Jezyk HTML. Tworzenie wlasnych dokumentow WWW

     w: CHIP Special.

     Internet dla kazdego. s. 50-80 Wroclaw 1996; Vogel Publishing

     maj-czerwiec 1996

     jest tez CD-ROM ze FAQ i RFC (do RFC 1814, 60 Mb) i jakimis dwoma

     kursami: Sunila Gupty i dostepnym w sieci (Wroclaw)

      A Beginner's Guide to HTML  . Cena 20 zl. (uwazam, ze dla
     widziarzy (zwlaszcza tych 3.1)

     warto)

  �  Piotr Teczynski (1996).  HTML - uniwersalny jezyk Pajakow?

     w:

     Informacja Profesjonalna,  ISSN 1233-0329.

  �  Asha Dornfest  Tworzenie stron WWW za pomoca Worda  ; Gliwice 1996;

     Helion

  �  Dave Taylor  Tworzenie stron WWW. HTML Warszawa 1996; IDG Books,
     ReadME

  �  Artur van Hoff, Sami Shaio, Orca Starbuck  JAVA

     ; Gliwice 1996; Helion

     (2 dyskietki z przykladami)

  �  Piotr Gawrysiak VRML.  Wirtualna rzeczywistosc w Internecie

     Warszawa

     1995, 1996; Zaklad Nauczania Informatyki MIKOM

     Wyglada przyzwoicie - przy czym raczej jako podreczna sciagawka

     przy pisaniu skryptow (z dyskietka)

  �   Wlasny osrodek Web   w:  PC Magazine

     nr 11(45)/1996

  12.3.  Zrodla HTML po angielsku w sieci

  �  Yahoo

     <http://www.yahoo.com/Computers/World_Wide_Web/HTML/>

  �   A Beginner's Guide to HTML  (na Politechnice Wroclawskiej)

     <http://www.immt.pwr.wroc.pl/export_hp/html-primer-080693.html>

  �   Introduction to HTML  Iana S. Grahama (Peryt - Warszawa)

     <http://whisky.peryt.waw.pl/tools/webdoc/<tt/HTML/docs/New<tt/HTML//htmlin
dex.html>

     i na Uniwersytecie Gdanskim

     <http://www.univ.gda.pl/owner/ktem/newhtml/html_intro.html>

  �   HTML Documentation  Iana S. Grahama (Politechnika Krakowska)

     <http://www.pk.edu.pl/sysdocs/jezyk_html/>

  �   Interaktywny kurs HTML  (w oryginale autorstwa Yuriko Ienaga

     zmodyfikowany przez Jana Peszko  <mailto:jp...@ip.krakow.pl>)

     <http://www.ip.krakow.pl/~jpesz/html/html.html>

  �  The other HTML FAQ - Galactusa

     <http://www.stack.urc.tue.nl/~galactus/html/other-faq.html>

  �  World Wide Web FAQ Thomasa Boutella (w poznanskim MANie).

     <http://www.put.Poznan.pl/hypertext/Internet/faq/www/www_faq.html>

     Jest tez wersja offline WWW-FAQ.

  �  HTML 3.0 Specification

     Instytut Fizyki UJ - Krakow

     <http://www.if.uj.edu.pl/UJ/IF/PTO/<tt/HTML/_3.0/Contents.html>

     Trojmiejska Akademicka Siec Komputerowa

     <http://www.task.gda.pl/help/<tt/HTML/_3.0/Contents.html>

      Introduction to HTML 3.0  (UCI AGH Krakow)

     <http://rexio.uci.agh.edu.pl/~dot/man/1.html>

  �  Welcome to HotJAVA SGGW Warszawa

     <http://alpha.sggw.waw.pl/java/>

  �  Dokumentacja do NCSA Mosaic we Wroclawiu

     http:://www.immt.pwr.wroc.pl/mosaic-docs/

  12.4.  Zrodla HTML po angielsku drukowane

  �  Ian S. Graham  HTML Documentation and Style Guide

     Torontto 1994

  13.  Zrodla dotyczace innych, zwiazanych z WWW jezykow programowania

  �  VRML w Polsce

     <http://andante.iss.uw.edu.pl/obuz/vrmlp/index.html>

  �  AMU-NET's VRML Repository (Administrator: Klaudiusz Modrzewski)

     dla Win 3.x:

     <http://math.amu.edu.pl/ftp/windows/vrml/00_index.html>

     i dla Win95

     <http://math.amu.edu.pl/ftp/windows/win95/vrlm/00.html>.

  �  JAVA na UCI AH

     <http://arrow.uci.agh.edu.pl/~java/index-p.html>

  �  JAVA na SunSite ICM UW

     <http://sunsite.icm.edu.pl/java/>

  14.  Dokumenty dotyczace tworzenia (ogolne) WWW.

  14.1.  Dokumenty dotyczace tworzenia (ogolne) WWW po polsku.

  �  Polska Strona Ogonkowa

     <http://www.agh.edu.pl/ogonki/>

  �  Strony testowe ISO-8859-? Wojciecha Myszki

     <http://www.immt.pwr.wroc.pl/export_hp/test/>

  �  Instalacja i konfiguracja serwera WWW

     <http://info.fuw.edu.pl/tech-doc/serwery.html>

  �  test polskich liter

     <http://www.ch.uj.edu.pl/pl/testpl.html>

  �  Winter Jaroslawa Zielinskiego

     <http://winter.it.com.pl/>

     ciekawy serwis semi-komercyjny, zawierajacy sporo ciekawych, choc

     jeszcze czesto ogolnikowych materialow na temat HTMLa i Lotus
     Notes.

  14.2.  Dokumenty dotyczace tworzenia WWW w polskiej sieci.

  �  Przewodniki po WWW na SGH w Warszawie

     <http://www.sgh.waw.pl/guides/>

  �  NSCA Tutorial

     <http://www.lublin.pl/docs-1.4/tutorials/index.html>

  �  Running A WWW Service Briana Kelly (Gliwice)

     <http://www.polsl.gliwice.pl/e-books/HTML/handbook.html>

  14.3.  Dokumenty dotyczace WWW w swiatowej sieci

  I znow bedzie to jedynie moj subiektywny wybor:

  �  The World Wide Web Consortium (W3C)

     <http://www.w3.org/>

     serwer

     organizacji proponujacej standardy dla WWW.

     tam miedzy innymi Style Guide for Online Hypertext

     <http://www.w3.org/pub/WWW/Provider/Style/>
  �
      Gallacusowy opis Wilbura

     <http://www.htmlhelp.com/reference/wilbur/>

     a takze wersja offline

     <http://www.htmlhelp.com/reference/wilbur/wilbur.zip>

  �  The WDVL: The Virtual Library of WWW Development

     <http://WWW.Stars.com/Vlib/>

  �  Top 10 Things NOT to do

  �  The Multilingual World Wide Web

     <http://www.ebt.com:8080/docs/multilingual-www.html>

  �  Lynx Optimized Pages!

     <http://www.nyu.edu/pages/wsn/subir/lynx.html>

  �  WWW Viewer Test Page

     <http://www-dsed.llnl.gov/documents/WWWtest.html>

  �  Yale C/AIM WWW Style Manual

     <http://info.med.yale.edu/caim/StyleManual_Top.<tt/HTML/>

  �  WWW Authoring Information

     <http://www.netspace.org/~dwb/www-authoring.html>

  �  HTML resouces in WWW by SQ

     <http://www.sq.com/htmlsgml/html/h-sites.htm>

  �  The Bare Bones Guide to HTML

     <http://werbach.com/barebones/>

     krotki

     (15kb) spis wszystkich komend HTML wraz z netscapizmami
     (zaznaczonymi)


-- 
Rafal Maszkowski r...@torun.pdi.net           http://www.torun.pdi.net/~rzm
Opinia publiczna powinna byc zaalarmowana swoim nieistnieniem - St. J. Lec
Technical Details
Message-ID: <pl.comp.www-1-857186568@torun.pdi.net>
Path: mbox-mo1.pugleaf.net!unknown!not-for-mail

Show Full Headers
Complete Article Headers
From: Ziemek Borowski <zie...@qdnet.pl>
Subject: pl.comp.www FAQ
Date: 1997/03/01
Message-ID: <pl.comp.www-1-857186568@torun.pdi.net>
X-Deja-AN: 222235710
Distribution: world
Sender: r...@rymunda.torun.pdi.net
Supersedes: <pl.comp.www...@torun.pdi.net>
X-Posting-Frequency: Posted on 1st and 15th day of each month
Followup-To: poster
Organization: Rafal Maszkowski
Keywords: WWW World Wide Web
Reply-To: zie...@qdnet.pl (Ziemek Borowski)
Newsgroups: pl.comp.www,pl.answers
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit